Ubuntu

Realtek ALC272 not working in 9.04 but its working under 8.10

Reported by Antonio Sánchez on 2009-06-18
This bug report is a duplicate of:  Bug #438318: [karmic] no sound on toshiba nb205. Edit Remove
90
This bug affects 12 people
Affects Status Importance Assigned to Milestone
ALSA driver
Unknown
Unknown
Linux
New
Undecided
Unassigned
linux (Ubuntu)
High
Daniel T Chen
Nominated for Karmic by Mychal
Nominated for Lucid by Mychal

Bug Description

Hardware: Toshiba NB200 netbook (EU), same as Toshiba NB205 (USA) and Toshiba Dynabook UX (JP)

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
 Subsystem: Toshiba America Info Systems Device ff6e
 Flags: bus master, fast devsel, latency 0, IRQ 22
 Memory at f0440000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
 Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
 Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
 Capabilities: [100] Virtual Channel <?>
 Capabilities: [130] Root Complex Link <?>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Under Ubuntu 8.10 sound works without doing nothing.
Under Ubuntu 9.04 sound doesn't work by default. With alsamixer we can see that chip is Realtek ALC272.

description: updated
description: updated
tags: added: toshiba
affects: ubuntu → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Daniel T Chen (crimsun) wrote :

Please use "ubuntu-bug alsa-base".

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
status: Confirmed → Incomplete
Daniel T Chen (crimsun) wrote :

Sorry, I meant use "apport-collect -p alsa-base 389040".

AplayDevices:
 **** Lista de PLAYBACK Dispositivos Hardware ****
 tarjeta 0: Intel [HDA Intel], dispositivo 0: ALC272 Analog [ALC272 Analog]
   Subdispositivos: 1/1
   Subdispositivo #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** Lista de CAPTURE Dispositivos Hardware ****
 tarjeta 0: Intel [HDA Intel], dispositivo 0: ALC272 Analog [ALC272 Analog]
   Subdispositivos: 1/1
   Subdispositivo #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: usuario 2968 F.... pulseaudio
                      usuario 3167 F.... mixer_applet2
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0440000 irq 22'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,1179ff6e,00100001'
   Controls : 15
   Simple ctrls : 10
DistroRelease: Ubuntu 9.04
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
Uname: Linux 2.6.28-13-generic i686
UserGroups:

Tao.Li (tao-li) wrote :

Hi Guys:

Some member in Canonical U.S.A named Andres Salomon and Bill Filler may help you.
They help Toshiba NB200 notebook work well at UNR 1.01.
I remember familiar issue happend in UNR 1.01

I remember one guy from Canonical with a Dynabook UX or NB200 in the last UDS at Barcelona. I'll try to contact with them.

Thanks Tao.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bit 3188 f.... mixer_applet2
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0440000 irq 22'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,1179ff6e,00100001'
   Controls : 15
   Simple ctrls : 10
DistroRelease: Ubuntu 9.04
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.UTF-8
Tags: ubuntu-unr
Uname: Linux 2.6.28-13-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

ultim8fury (ultim8fury) wrote :
ultim8fury (ultim8fury) wrote :
ultim8fury (ultim8fury) wrote :
ultim8fury (ultim8fury) wrote :
ultim8fury (ultim8fury) wrote :
ultim8fury (ultim8fury) wrote :
ultim8fury (ultim8fury) wrote :

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jwb 3338 F.... mixer_applet2
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0440000 irq 22'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,1179ff6e,00100001'
   Controls : 15
   Simple ctrls : 10
DistroRelease: Ubuntu 9.04
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_CTYPE=en_US.UTF-8
Uname: Linux 2.6.28-13-generic i686
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare

description: updated

AplayDevices:
 **** PLAYBACK硬件设备列表 ****
 卡 0: Intel [HDA Intel], 设备 0: ALC272 Analog [ALC272 Analog]
   子设备: 1/1
   子设备:#0: subdevice #0
Architecture: i386
ArecordDevices:
 **** CAPTURE硬件设备列表 ****
 卡 0: Intel [HDA Intel], 设备 0: ALC272 Analog [ALC272 Analog]
   子设备: 1/1
   子设备:#0: subdevice #0
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/dsp', '/dev/snd/controlC0', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D0c', '/dev/snd/seq', '/dev/snd/timer', '/dev/sequencer', '/dev/sequencer2'] failed with exit code 1:
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0440000 irq 22'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,1179ff6e,00100001'
   Controls : 15
   Simple ctrls : 10
DistroRelease: Ubuntu 9.04
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=zh_CN.UTF-8
Tags: ubuntu-unr
Uname: Linux 2.6.28-13-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

York (yorkzhangsir) wrote :
York (yorkzhangsir) wrote :
York (yorkzhangsir) wrote :
York (yorkzhangsir) wrote :
York (yorkzhangsir) wrote :
York (yorkzhangsir) wrote :
York (yorkzhangsir) wrote :

I Have the same issue, I found one someone else blog (http://tjmcgrew.blogspot.com/2009/07/toshiba-nb205-part-2.html) that adding the following line to /etc/modprobe.d/alsa-base.conf give sound thru the headphones jack (nothing from the speaker) :

options snd-hda-intel model=asus-mode4

Maybe this can help fix this issue.

The modprobe options suggested by Emmanuel by way of that blog seem to have worked for me. No sound out of the speakers, but via headphones it seems to be working well.

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: phil 5389 F.... pulseaudio
                      phil 5627 F.... mixer_applet2
                      phil 6198 F.... explorer.exe
                      phil 6323 F.... SwMessenger.exe
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0440000 irq 22'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,1179ff6e,00100001'
   Controls : 15
   Simple ctrls : 10
DistroRelease: Ubuntu 9.04
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Uname: Linux 2.6.28-15-generic i686
UserGroups:

Jaykar (philip-webb) wrote :
Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
tags: added: regression-release
joshspy (joshspy) on 2009-10-30
tags: added: apport-collected
214 comments hidden view all 290 comments

AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access /dev/snd/: No such file or directory
AplayDevices: aplay: device_list:223: no soundcards found...
Architecture: i386
ArecordDevices: arecord: device_list:223: no soundcards found...
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-18.55-generic
Tags: ubuntu-unr
Uname: Linux 2.6.31-18-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

7 comments hidden view all 290 comments

Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3382 F.... knotify4
                      ubuntu 3403 F.... pulseaudio
                      ubuntu 3411 F.... kmix
 /dev/snd/seq: timidity 2237 F.... timidity
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0440000 irq 22'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,1179ff6e,00100001'
   Controls : 16
   Simple ctrls : 8
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.31-20.57-generic
Uname: Linux 2.6.31-20-generic i686
UserGroups:

9 comments hidden view all 290 comments

Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: deivymg 1461 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0440000 irq 22'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,1179ff6e,00100001'
   Controls : 17
   Simple ctrls : 9
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091028.4)
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
Tags: ubuntu-unr
Uname: Linux 2.6.31-20-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

9 comments hidden view all 290 comments

AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access /dev/snd/: No such file or directory
AplayDevices: aplay: device_list:223: no soundcards found...
Architecture: i386
ArecordDevices: arecord: device_list:223: no soundcards found...
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Displaying first 40 and last 40 comments. View all 290 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.