Ubuntu

[Dell Latitude D430, iwl3945] Wireless can't be activated after disabling kill switch

Reported by Martin Pitt on 2009-09-16
220
This bug affects 44 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Nominated for Jaunty by Rajesh Verma
Nominated for Lucid by Rajesh Verma
Karmic
High
Tim Gardner

Bug Description

It seems that this problem keeps reappearing. This is exactly the same as bug 193970, but opening a new bug since the first one is very big and noisy already.

Summary: If I boot with the kill switch off (i. e. wifi enabled), the kill switch works just fine. But if I boot with kill switch on (i. e. wifi disabled), changing the kill switch doesn't do anything and network-manager keeps insisting that the network is disabled.

ProblemType: Bug
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: martin 2634 F.... pulseaudio
 /dev/snd/controlC0: martin 2634 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xefebc000 irq 21'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:83847690,10280201,00102201'
   Controls : 7
   Simple ctrls : 5
Card1.Amixer.info:
 Card hw:1 'Headset'/'Logitech Logitech USB Headset at usb-0000:00:1d.7-8.3.4, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0a01'
   Controls : 6
   Simple ctrls : 2
CheckboxSubmission: 526c13623eeda7bcc3936c7be57b2d29
CheckboxSystem: c8e8edcc4d15e0d55af04774be77e330
Date: Wed Sep 16 17:49:06 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=5df2daed-eb83-4d60-a87c-9b71ff6b703f
MachineType: Dell Inc. Latitude D430
Package: linux-image-2.6.31-10-generic 2.6.31-10.32lp429241apw2
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-10-generic root=UUID=e43b0104-23d3-4bb8-9710-effa762ca2f6 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.32lp429241apw2-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-10-generic N/A
 linux-firmware 1.18
SourcePackage: linux
Uname: Linux 2.6.31-10-generic i686
dmi.bios.date: 05/21/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: 0HU754
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd05/21/2007:svnDellInc.:pnLatitudeD430:pvr:rvnDellInc.:rn0HU754:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D430
dmi.sys.vendor: Dell Inc.

Martin Pitt (pitti) wrote :
tags: added: regression-proposed
Martin Pitt (pitti) wrote :

Ah, this sheds some light:

superm1| pitti, mjg59 needs to write a patch that inserts an input filter to intercept a keypress of XF86WLAN in
dell-laptop kernel module to be able to update dell-laptop's rfkill status
superm1| pitti, dell-laptop was introduced in karmicish kernels
superm1| it's not worked perfectly since introduced because of this deficiency
superm1| any other problems with <karmic were different

Changed in linux (Ubuntu):
importance: Undecided → High
status: New → Triaged
tags: added: regression-potential
removed: regression-proposed

I can confirm this bug on a Dell E6400.

Ryan (ubuntu-draziw) wrote :

Looks like patches were offered up by Matthew Garrett two months ago:

http://patchwork.kernel.org/patch/38437/

http://patchwork.kernel.org/patch/38439/

But there are still dell-laptop rfkill patches that went in just a couple weeks ago:
http://patchwork.kernel.org/patch/48601/

Hopefully it gets merged into a ubuntu kernel soon... maybe cherry pick before the beta?

Mario Limonciello (superm1) wrote :

That first one and last one are already in the Ubuntu kernel.

The second is the one that would be fixing this problem, but requires patches to the input subsystem too I believe.

Isi (isaiasmy) wrote :

I have a similar problem, it happened me when I updated from Jaunty to Karmic Alpha 6. The point is that if i boot with the live cd the wifi works perfectly. Therefore the problem is related with the upgrade :( I'm waiting for the bug fix.

Robert Collins (lifeless) wrote :

My observations:
 - boot with network permitted
 - hit switch, network is disabled fine
 - restore switch, network is not enabled again; /sys/devices/virtual/rfkill/rfkill1/state == 2

echoing 1 to that file permits the network to work again

For anyone interested, I've built a test kernel with the following patches applied:

http://patchwork.kernel.org/patch/38440/
http://patchwork.kernel.org/patch/38439/
 (this depends on the first)

Please test and let us know your results.

http://people.canonical.com/~ogasawara/lp430809/

Leann Ogasawara [2009-10-07 0:57 -0000]:
> For anyone interested, I've built a test kernel with the following
> patches applied:
> http://people.canonical.com/~ogasawara/lp430809/

Thanks! Any chance we can get an amd64 build as well?

Martin Pitt (pitti) wrote :

> Any chance we can get an amd64 build as well?

Great, it's there now.

Martin Pitt (pitti) wrote :

I confirm that with this kernel, the kill switch works perfectly. I tested it with both booting when it's off and when it's on, and then switching several times.

Killswitch on -> off:

Oct 7 10:49:57 tick kernel: [ 73.147216] [drm] TV-16: set mode NTSC 480i 0
Oct 7 10:49:57 tick kernel: [ 178.012263] iwl3945 0000:0c:00.0: firmware: requesting iwlwifi-394
Oct 7 10:49:57 tick kernel: [ 178.093611] iwl3945 0000:0c:00.0: loaded firmware version 15.32.2.
Oct 7 10:49:57 tick kernel: [ 178.160297] Registered led device: iwl-phy0::radio
Oct 7 10:49:57 tick kernel: [ 178.160399] Registered led device: iwl-phy0::assoc
Oct 7 10:49:57 tick kernel: [ 178.160439] Registered led device: iwl-phy0::RX
Oct 7 10:49:57 tick kernel: [ 178.160479] Registered led device: iwl-phy0::TX
Oct 7 10:49:57 tick kernel: [ 178.221304] ADDRCONF(NETDEV_UP): wlan0: link is not ready

and NM picks it up and connects to my wifi.

Killswitch off -> on:
Oct 7 10:50:27 tick kernel: [ 178.677389] cfg80211: Found new beacon on frequency: 2472 MHz (Ch 13) on phy0
Oct 7 10:50:27 tick kernel: [ 188.800551] wlan0: authenticate with AP 00:1a:2b:30:75:1c
Oct 7 10:50:27 tick kernel: [ 188.802961] wlan0: authenticated
Oct 7 10:50:27 tick kernel: [ 188.802968] wlan0: associate with AP 00:1a:2b:30:75:1c
Oct 7 10:50:27 tick kernel: [ 188.805712] wlan0: RX AssocResp from 00:1a:2b:30:75:1c (capab=0x411 status=0 aid=1)
Oct 7 10:50:27 tick kernel: [ 188.805719] wlan0: associated
Oct 7 10:50:27 tick kernel: [ 188.807686] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Oct 7 10:50:27 tick kernel: [ 199.412666] wlan0: no IPv6 routers present
Oct 7 10:50:27 tick kernel: [ 208.980169] wlan0: deauthenticating by local choice (reason=3)

and NM disconnects again and says "disabled".

Thanks so much!

Isi (isaiasmy) wrote :

Hello,

I have a dell e4300 with a wifi 5300 AGN CARD. After upgrading from Jaunty to Karmic Alpha6 my wifi card starts always disabled because although my hardware switch is enabled, rfkill does not detect it and it disables the wifi by software (if i do a fresh install of Karmic Alpha 6 works !!!).

I have tested the patched kernel and now the problem with the rfkill is solved but the interface is not detected as a wireless one:

iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 no wireless extensions.

vboxnet0 no wireless extensions.

pan0 no wireless extensions.

Therefore, there is some cross-relation isssue among your patch and mi wifi card. I have to go to the original kernel to have wifi support although i have to enable the wifi manually with rfkill.

Isi (isaiasmy) wrote :

Hello again,

just a clarification, this morning was an update from kernel 2.6.31-11 to kernel 2.6.31-12, so the problem about not detecting the wireless extensions of my wifi interface is related with it. Therefore, it seems that the patch solves my problem with rfkill, but probably some days would be need it to confirm it.

Ryan (ubuntu-draziw) wrote :

Leann Ogasawara: Confirmed your kernel works great here - thanks! ... Now if I could just boot with my external (USB) mouse and keyboard and not have to unplug and replug them to work - I'd be set. :)

 Booted with killswitch, then toggled - all happy!

$ uname -a
Linux lt 2.6.31-12-generic #39+lp430809v1 SMP Tue Oct 6 22:07:52 UTC 2009 i686 GNU/Linux

[ 100.818516] iwl3945 0000:0c:00.0: firmware: requesting iwlwifi-3945-2.ucode
[ 101.060977] iwl3945 0000:0c:00.0: loaded firmware version 15.32.2.9
[ 101.142112] Registered led device: iwl-phy0::radio
[ 101.142137] Registered led device: iwl-phy0::assoc
[ 101.142197] Registered led device: iwl-phy0::RX
[ 101.142217] Registered led device: iwl-phy0::TX
[ 101.164935] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 101.963970] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
[ 110.014615] wlan0: authenticate with AP *snip*
*snip*
[ 110.019644] wlan0: associated
[ 110.029783] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 110.572077] wlan0: deauthenticating by local choice (reason=3)
[ 110.636059] iwl3945 0000:0c:00.0: MAC is in deep sleep!. CSR_GP_CNTRL = 0x040003DD

ii linux-headers-2.6.31-12 2.6.31-12.39+lp430809v1 Header files related to Linux kernel version
ii linux-headers-2.6.31-12-generic 2.6.31-12.39+lp430809v1 Linux kernel headers for version 2.6.31 on x
ii linux-image-2.6.31-12-generic 2.6.31-12.39+lp430809v1 Linux kernel image for version 2.6.31 on x86

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Karmic):
assignee: nobody → Leann Ogasawara (leannogasawara)
status: Triaged → Fix Committed
Jerone Young (jerone) wrote :

The rfkill works to kill the wifi & blutooth.

Though on machines like the Inspiron 15n their appears to be an issue with it bringing the bluetooth & wirless device back.

You have to press the key 4 - 5 times to bring both back correctly. So their appear to still be some issues here.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-13.42

---------------
linux (2.6.31-13.42) karmic; urgency=low

  [ Leann Ogasawara ]

  * SAUCE: (drop after 2.6.31) input: Add support for filtering input
    events
    - LP: #430809
  * SAUCE: (drop after 2.6.31) dell-laptop: Trigger rfkill updates on wifi
    toggle switch press
    - LP: #430809

  [ Tim Gardner ]

  * SAUCE: Raise the default console 'quiet' level to 2
    This supresses all but critical and emergency level messages.
    https://lists.ubuntu.com/archives/kernel-team/2009-October/007476.html

  [ Upstream Kernel Changes ]

  * TTY: fix typos
  * Linux 2.6.31.3
  * V4L/DVB (12439): cx88: add support for WinFast DTV2000H rev. J
    - LP: #433904

 -- Tim Gardner <email address hidden> Thu, 08 Oct 2009 10:42:07 -0600

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Jerone Young (jerone) wrote :

Looks like the Inspiron 15n is an isolated to the machine. The XPS 13 is not showing this issue and working fine, as well as other Dell laptops.

Boban Aleksov (aleksovboban) wrote :

After new kernel update sadly it still doesnt work. Here are situations that i tested and results.

Ryan (ubuntu-draziw) wrote :

Works perfect on my D620 now. Thanks!

Mario Limonciello (superm1) wrote :

I've got a patch that i'd like to propose that should hopefully help the other Dell laptops that are failing. It will need some testing on both the failing and functional machines though. I've tested it on a machine of mine that still failed (Studio 1537) and it appears to fix the functionality.

Changed in linux (Ubuntu Karmic):
status: Fix Released → Confirmed

I've built additional test kernels with Mario's patch applied (ie comment #21). Please test and let us know your results. Thanks!

http://people.canonical.com/~ogasawara/lp430809v2/

Felix Geyer (debfx) wrote :

Still doesn't work for me (Dell Vostro 1320).
On my laptop the dell-wifi killswitch seems to be useless as the physical killswitch state is correctly represented by phy0.

2.6.31-12.41:
% rfkill list
0: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
2: dell-wifi: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes

2.6.31-13.44 and 2.6.31-13.44+lp430809v2:
% rfkill list
0: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
2: dell-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: yes

Mario Limonciello (superm1) wrote :

@Boban & @Felix:

What state were you starting the computer up in? HW killswitch enabled or disabled?

I've confirmed that my patch didn't work with it starting up in the disabled state, and fixed that in this next patch.

I've still got to test with an Intel wireless card as the Broadcom card i'm using now doesn't create a phy0 rfkill device, but just relies on the dell-wifi device.

Mario et al, I'll put together a new test kernel with the latest patch applied (ie comment #25). Will post a comment here when it's ready. Thanks!

Boban Aleksov (aleksovboban) wrote :

Patch didnt work with HW switch put only to BT in bios and i was booting with switch ON.
Can you tell me all info you need, for example all situations you want me to create and make logs so you can fix this nasty bug?

Felix Geyer (debfx) wrote :

Mario:
The bug only occurs when booting with the killswitch enabled (wlan off).
Before updating the Vostro 1320 BIOS to A03 the bug also occured with the killswitch disabled at boot.

Here's the test kernel with Mario's latest patch from comment #25:

http://people.canonical.com/~ogasawara/lp430809v3/

Felix Geyer (debfx) wrote :

Still doesn't work with lp430809v3

Mario Limonciello (superm1) wrote :

Hi Felix:

There are no more references to setting the soft block, so I can only think of one more place this is changing. Here's a 4th revision of the patch. I'll also add a DKMS package of it so it's easier to test again with rather than having to rebuild another kernel.

I've got access to a lot more Dell HW tomorrow, so I should be able to reproduce any regressions people still see with this 4th version.

Mario Limonciello (superm1) wrote :
Boban Aleksov (aleksovboban) wrote :

With DKMS driver v4 it still doesn't work.

For me (Dell Latitude D630, IWL3945) kernel #lp430809v3 + DKMS v4 package works almost perfectly, but there remains a bug in the switching logic:

Now the killswitch acts on both bluetooth and wlan although I have set in BIOS for it to only act on bluetooth.
Apart from that BT/WLAN are now perfectly and correctly switchable by hardware and software.

Felix Geyer (debfx) wrote :

The DKMS packages works for me, thanks!

Boban Aleksov (aleksovboban) wrote :

@Felix Geyer: What laptop do you have?

Felix Geyer (debfx) wrote :

Dell Vostro 1320 with Intel WiFi 5100

Daniel Cardin (daniel-cardin) wrote :

Dell Vostro 1720 with #lp430809v3 + DKMS v4. I can feel it's getting close... Now wireless works properly IF and only IF I boot with the killswitch off. So this is progress for me, but it falls into the bug 441161 now.

When I boot with the killswitch on, the logic seems reversed meaning that the swithing to the OFF position triggers the wireless availability, nm-applet shows the available networks. But obviously, the hardware is turned off and it doesn't work. Reverting to the ON position, nm-applet is notified that the wireless is now disabled.

Mario Limonciello (superm1) wrote :

OK Guys thanks for the feedback. There's a few issues at hand here. Hopefully this should address everyone's concerns up this point.

1) As raised by Janne: this ignored the logic the BIOS had in place to make the HW switch only affect certain devices.
2) As raised by Daniel: the value getting read isn't reliably correct on business client machines. I looked more into this (with a Latitude 2100) and found that the wrong data was getting read for everyone. It was just dumb luck to work sometimes. I've added a second check in here.
*----*
I'm attaching a new deb. Lets call this "v5".
So in this deb there are 3 new patches:
only_my_switch.patch : addresses Janne's concern
check_hw_sw_supported.patch: address Daniel's concern
debug_support.patch: for in case someone else is still broke
*----*
If you are still having troubles, please do this:
1) Cold boot. Take note of whether the switch is flipped to block wifi/bt/wwan or to not block
2) Flip the switch on once
3) Count to 5
4) Flip the switch off once
5) Save "dmesg" output
6) Repeat 1-5 with the switch starting in the opposite state from cold boot

I've tested this series of patches on the following machines with success:
* Latitude 2100
* Studio XPS 1340
* Inspiron 1545
* Studio 1537
* Latitude D630

Boban Aleksov (aleksovboban) wrote :

Yesss!!! Dell Insipron 1525, i think problem is solved! Will tryout
everything in morning!

Felix Geyer (debfx) wrote :

dell-laptop-dkms 0.2 still works on Vostro 1320.

Boban Aleksov (aleksovboban) wrote :

Dell Inspiron 1525 Bios rev A16, everything is ok! Thank you for fixing this!

Not yet working correctly with Dell Latitude D630:

Previous bugs were fixed, but a new one introduced:
Killswitch is off, I switch bluetooth off via bluetooth-applet, and now WLAN ("phy0: Wireless LAN") gets turned hard off. When I flip the killswitch on and back off, WLAN turns on again.

Moreover, when I turn off bluetooth by software only, the BT indicator light on the laptop stays on which is slightly irritating (and was not the case in dell-laptop-dkms 0.1).

I'm running kernel #44+lp430809v3 + dell-laptop-dkms 0.1

Forgot to mention: BIOS setting is still "BT only"

dmesg output directly after turning bluetooth off via applet, having had killswitch off (so WLAN and BT on):

[ 1108.968678] dell_rfkill_query called for radio 1.
[ 1108.969569] Query returned the following raw data:
[ 1108.969572] 00000000 00000001 00000011 00011111
[ 1108.970026] Second query returned the following raw data:
[ 1108.970029] 00000000 00000000 00000001 00000010
[ 1108.970079] HW switch status is set to following raw data:
[ 1108.970081] 00000000 00000000 00000000 00000010
[ 1108.970132] Setting HW state to 0.
[ 1108.970138] dell_rfkill_set called for radio 1, to set 1
[ 1109.117246] wlan0: deauthenticating by local choice (reason=3)
[ 1109.199337] iwl3945 0000:0c:00.0: MAC is in deep sleep!. CSR_GP_CNTRL = 0x040003DD

Daniel Cardin (daniel-cardin) wrote :

This it not yet working with Vostro 1720 either using #44+lp430809v3 + dell-laptop-dkms 0.2

Mario, I can give you both dmesg outputs booting on or off if you want. But what strikes me as the first difference
is that rfkill lists a device hci0 if booting with the switch in the on position.

1: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: yes
2: dell-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no
3: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no

When booting in the off position, i only have dell-wifi and dell-bluetooth which are both unblocked.

Mario Limonciello (superm1) wrote :

Daniel.
I need dmesg output from both scenarios.

On 10/13/2009, Daniel Cardin <email address hidden> wrote:
> This it not yet working with Vostro 1720 either using #44+lp430809v3 +
> dell-laptop-dkms 0.2
>
> Mario, I can give you both dmesg outputs booting on or off if you want. But
> what strikes me as the first difference
> is that rfkill lists a device hci0 if booting with the switch in the on
> position.
>
> 1: dell-wifi: Wireless LAN
> Soft blocked: no
> Hard blocked: yes
> 2: dell-bluetooth: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 3: hci0: Bluetooth
> Soft blocked: no
> Hard blocked: no
>
> When booting in the off position, i only have dell-wifi and dell-
> bluetooth which are both unblocked.
>
> --
> [Dell Latitude D430, iwl3945] Wireless can't be activated after disabling
> kill switch
> https://bugs.launchpad.net/bugs/430809
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Sent from my mobile device

Mario Limonciello
<email address hidden>

Mario Limonciello (superm1) wrote :

Janne:

It sounds like I flipped one of the bits looking at that dmesg output. Can you try this deb instead?

Daniel Cardin (daniel-cardin) wrote :

Mario: I know this build was targetting Janne, but I tested it. Still exhibits the same problem.

On another note, is the new build 2.6.31-13.45 really including the lp430809v3 patch? I would assume so from the description, but I want to make absolutely sure for the next tests.

Mario Limonciello (superm1) wrote :

Daniel:

That's to be expected, the changes were only relevant to that particular
problem Janne had. I'll need your dmesg from both scenarios to help debug
what's happening with you.

On Tue, Oct 13, 2009 at 12:43, Daniel Cardin <email address hidden>wrote:

> Mario: I know this build was targetting Janne, but I tested it. Still
> exhibits the same problem.
>
> On another note, is the new build 2.6.31-13.45 really including the
> lp430809v3 patch? I would assume so from the description, but I want to
> make absolutely sure for the next tests.
>
> --
> [Dell Latitude D430, iwl3945] Wireless can't be activated after disabling
> kill switch
> https://bugs.launchpad.net/bugs/430809
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Mario Limonciello
<email address hidden>

Daniel Cardin (daniel-cardin) wrote :

I sent them to your gmail address... I am reluctant to pollute the bug here. But if that's what you want, I will.

Mario Limonciello (superm1) wrote :

Please post them to this bug. If others are seeing the same problems, they can indicate if their dmesg is identical. (And I don't see them in my gmail, even in my spam bucket)

Daniel Cardin (daniel-cardin) wrote :
Daniel Cardin (daniel-cardin) wrote :
Daniel Cardin (daniel-cardin) wrote :

The dmesg outputs are done on kernel 2.6.31-13 #45 with dell-laptop-dkms 0.3

Mario Limonciello (superm1) wrote :

Daniel:

The return of the query of the HW switch status isn't returning anything
different in any of these scenarios:
00000000 00000010 00000011 00001101

Bit 16 indicates the status of the HW switch.

It's looking like there is 1 of two things going on here:

1) A bios bug w/ your laptop. Not much we can do from dell-laptop's
perspective
2) A return flag is failing that we're not checking for.

To rule out two, please run this command and provide the output, while the
switch is turned off:

sudo smbios-wireless-ctl --info

On Tue, Oct 13, 2009 at 13:35, Daniel Cardin <email address hidden>wrote:

> The dmesg outputs are done on kernel 2.6.31-13 #45 with dell-laptop-dkms
> 0.3
>
> --
> [Dell Latitude D430, iwl3945] Wireless can't be activated after disabling
> kill switch
> https://bugs.launchpad.net/bugs/430809
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Mario Limonciello
<email address hidden>
Sent from Manchester, New Hampshire, United States

Daniel Cardin (daniel-cardin) wrote :

Libsmbios version : 2.2.13
smbios-wireless-ctl version : 2.2.13
Wireless Info:
 Hardware switch supported
 Hardware switch is Off
 WiFi Locator not supported
 Wireless Keyboard not supported
 NVRAM Size: 256 bytes
 NVRAM format version: 1

Radio Status for WLAN:
 WLAN enabled at boot
 WLAN supported
 WLAN disabled
 WLAN installed
 WLAN boot-time wireless switch setting not present
 WLAN runtime switch control currently enabled
 Status Code: 1

Radio Status for Bluetooth:
 Bluetooth enabled at boot
 Bluetooth supported
 Bluetooth enabled
 Bluetooth installed
 Bluetooth boot-time wireless switch setting not present
 Bluetooth runtime switch control currently disabled
 Status Code: 0

Radio Status for WWAN:
Traceback (most recent call last):
  File "/usr/sbin/smbios-wireless-ctl", line 369, in <module>
    sys.exit( main() )
  File "/usr/sbin/smbios-wireless-ctl", line 334, in main
    wirelessInfo(radios[i])
  File "/usr/sbin/smbios-wireless-ctl", line 222, in wirelessInfo
    print onOff(tokenTable[radio["radioEnable"]].isActive(), _("\t%s enabled at boot"), _("\t%s disabled at boot")) % radio["name"]
  File "<libsmbios_c._peak_util_decorators.rewrap wrapping libsmbios_c.token.__getitem__ at 0x09894A3C>", line 3, in __getitem__
  File "/usr/lib/python2.5/site-packages/libsmbios_c/trace_decorator.py", line 98, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.5/site-packages/libsmbios_c/token.py", line 155, in __getitem__
    raise exceptions.IndexError( _("ID 0x%04x not found") % id )
IndexError: ID 0x017c not found

Daniel Cardin (daniel-cardin) wrote :

I wonder though why would the switch work perfectly if I boot in the off position first.

The situation is as follows :

boot with switch in the off position:
 -- wireless and bluetooth follow the switch state

boot with switch in the on position :
  -- bluetooth follows the switch state
  -- wifi's logic is reversed. Off tries to activate the wireless, On disables

Mario thanks a lot for debugging and fixing this. Everything mostly works now, just a small nitpick remaning:

I start w/ killswitch off (0), then switch BT off by software (1), the BT indicator LED turns off. Then I turn killswitch on (2) and off again (3); now the BT indicator turns on again although BT is disabled by software.

Below the output of dmesg corresponding to the numbers in parentheses above:

(1)
[ 988.413286] dell_rfkill_query called for radio 2.
[ 988.414263] Query returned the following raw data:
[ 988.414267] 00000000 00000001 00000011 00011111
[ 988.414692] Second query returned the following raw data:
[ 988.414695] 00000000 00000000 00000001 00000010
[ 988.414746] HW switch status is set to following raw data:
[ 988.414749] 00000000 00000000 00000000 00000010
[ 988.414799] Setting HW state to 0.
[ 988.414806] dell_rfkill_set called for radio 2, to set 1
[ 988.449141] usb 3-2: USB disconnect, address 13
[ 988.449310] btusb_intr_complete: hci0 urb f22c5c00 failed to resubmit (19)
[ 988.449329] btusb_bulk_complete: hci0 urb f22c5f00 failed to resubmit (19)
[ 988.450317] btusb_bulk_complete: hci0 urb f22c5000 failed to resubmit (19)

(2)
[ 1037.678566] dell_rfkill_update called.
[ 1037.678575] Toggling HW state for bt

(3)
[ 1066.386140] dell_rfkill_update called.
[ 1066.386149] Toggling HW state for bt
[ 1066.897077] usb 3-2: new full speed USB device using uhci_hcd and address 14
[ 1067.083438] usb 3-2: configuration #1 chosen from 1 choice

Also the corresponding 'rfkill list' outputs:

(0)
0: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: dell-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no
2: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
16: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no

(1)
0: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: dell-bluetooth: Bluetooth
 Soft blocked: yes
 Hard blocked: no
2: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

(2)
0: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: dell-bluetooth: Bluetooth
 Soft blocked: yes
 Hard blocked: yes
2: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

(3)
$ rfkill list
0: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: dell-bluetooth: Bluetooth
 Soft blocked: yes
 Hard blocked: no
2: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
17: hci0: Bluetooth
 Soft blocked: yes
 Hard blocked: no

Download full text (3.6 KiB)

Hello,

I have been having problems with my wifi-card and rfkill, I opened bug 435141.
Maybe, this bug is related so I have tried the patch, I have a dell e4300 with
an interl 53000 AGN.

I attach the results of testing the patch with hardware switch on and off. In
both cases the result is the same:

If hardware switch on:

rfkill list
1: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
2: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no

If hardware switch off:

 rfkill list

1: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes

My wifi is always disabled by software, I have to enable it manually. However,
with a fresh install of Karmic Alpha 6 it worked perfectly. I would appreciate
some feedback if it would be possible, I don't want to introduce noise in a
bug not related with me. Maybe is with something related with rfkill but not
rfkill itself. Let me know if you need more info.

Regards,

Isaías

--
Isaias Martinez Yelmo

On Tuesday 13 October 2009 22:53:19 Janne Hyötylä wrote:
> Mario thanks a lot for debugging and fixing this. Everything mostly
> works now, just a small nitpick remaning:
>
> I start w/ killswitch off (0), then switch BT off by software (1), the
> BT indicator LED turns off. Then I turn killswitch on (2) and off again
> (3); now the BT indicator turns on again although BT is disabled by
> software.
>
> Below the output of dmesg corresponding to the numbers in parentheses
> above:
>
> (1)
> [ 988.413286] dell_rfkill_query called for radio 2.
> [ 988.414263] Query returned the following raw data:
> [ 988.414267] 00000000 00000001 00000011 00011111
> [ 988.414692] Second query returned the following raw data:
> [ 988.414695] 00000000 00000000 00000001 00000010
> [ 988.414746] HW switch status is set to following raw data:
> [ 988.414749] 00000000 00000000 00000000 00000010
> [ 988.414799] Setting HW state to 0.
> [ 988.414806] dell_rfkill_set called for radio 2, to set 1
> [ 988.449141] usb 3-2: USB disconnect, address 13
> [ 988.449310] btusb_intr_complete: hci0 urb f22c5c00 failed to resubmit
> (19) [ 988.449329] btusb_bulk_complete: hci0 urb f22c5f00 failed to
> resubmit (19) [ 988.450317] btusb_bulk_complete: hci0 urb f22c5000 failed
> to resubmit (19)
>
>
> (2)
> [ 1037.678566] dell_rfkill_update called.
> [ 1037.678575] Toggling HW state for bt
>
> (3)
> [ 1066.386140] dell_rfkill_update called.
> [ 1066.386149] Toggling HW state for bt
> [ 1066.897077] usb 3-2: new full speed USB device using uhci_hcd and
> address 14 [ 1067.083438] usb 3-2: configuration #1 chosen from 1 choice
>
>
> Also the corresponding 'rfkill list' outputs:
>
> (0)
> 0: dell-wifi: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 1: dell-bluetooth: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 2: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 16: hci0: Bluetooth
> Soft blocked: no
> Hard blocked: no
>
> (1)
> 0: dell-wifi: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 1: dell-bluetooth: Bluetooth
> Soft blocked: yes
> Hard blocked: no
> 2: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: n...

Read more...

Daniel:

With the HW switch flipped on, do you get the same output from the top
section:

" Hardware switch supported
       Hardware switch is Off
"

On Tue, Oct 13, 2009 at 15:01, Daniel Cardin <email address hidden>wrote:

> Libsmbios version : 2.2.13
> smbios-wireless-ctl version : 2.2.13
> Wireless Info:
> Hardware switch supported
> Hardware switch is Off
> WiFi Locator not supported
> Wireless Keyboard not supported
> NVRAM Size: 256 bytes
> NVRAM format version: 1
>
> Radio Status for WLAN:
> WLAN enabled at boot
> WLAN supported
> WLAN disabled
> WLAN installed
> WLAN boot-time wireless switch setting not present
> WLAN runtime switch control currently enabled
> Status Code: 1
>
> Radio Status for Bluetooth:
> Bluetooth enabled at boot
> Bluetooth supported
> Bluetooth enabled
> Bluetooth installed
> Bluetooth boot-time wireless switch setting not present
> Bluetooth runtime switch control currently disabled
> Status Code: 0
>
> Radio Status for WWAN:
> Traceback (most recent call last):
> File "/usr/sbin/smbios-wireless-ctl", line 369, in <module>
> sys.exit( main() )
> File "/usr/sbin/smbios-wireless-ctl", line 334, in main
> wirelessInfo(radios[i])
> File "/usr/sbin/smbios-wireless-ctl", line 222, in wirelessInfo
> print onOff(tokenTable[radio["radioEnable"]].isActive(), _("\t%s enabled
> at boot"), _("\t%s disabled at boot")) % radio["name"]
> File "<libsmbios_c._peak_util_decorators.rewrap wrapping
> libsmbios_c.token.__getitem__ at 0x09894A3C>", line 3, in __getitem__
> File "/usr/lib/python2.5/site-packages/libsmbios_c/trace_decorator.py",
> line 98, in trace
> result = func(*args, **kw)
> File "/usr/lib/python2.5/site-packages/libsmbios_c/token.py", line 155, in
> __getitem__
> raise exceptions.IndexError( _("ID 0x%04x not found") % id )
> IndexError: ID 0x017c not found
>
> --
> [Dell Latitude D430, iwl3945] Wireless can't be activated after disabling
> kill switch
> https://bugs.launchpad.net/bugs/430809
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Mario Limonciello
<email address hidden>
Sent from Austin, Texas, United States

Daniel Cardin (daniel-cardin) wrote :

Yup... same thing.

Wireless Info:
 Hardware switch supported
 Hardware switch is Off
 WiFi Locator not supported
 Wireless Keyboard not supported
 NVRAM Size: 256 bytes
 NVRAM format version: 1

This is booting with the switch off, and then turning it on. it works. the hardware is on, nm-applet works, I'm currently using it to post this.

rfkill :
0: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: dell-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no
2: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no

sudo dellWirelessCtl --st_wlan

Radio Status for WLAN:
 WLAN enabled at boot
 WLAN supported
 WLAN disabled
 WLAN installed
 WLAN boot-time wireless switch setting not present
 WLAN runtime switch control currently enabled
 Status Code: 1

Something's fishy...

Boot-time vs runtime switch?

Mario Limonciello (superm1) wrote :

Daniel:

Sorry to say, but it looks like you've got a BIOS bug. Every Dell laptop that is working with this can read the HW switch setting properly and key off that (bit 16 of the query 1 raw outputs if you're keeping track of dmesg's).

I don't think we'll be able to work around your bug. Check for BIOS updates in case this got addressed. If this was a machine that shipped with Ubuntu, please raise this on the linux-desktops Dell mailing list.

Mario Limonciello (superm1) wrote :

Janne:

OK, hopefully this should address what you're looking for, so no more nitpicking :)

Mario Limonciello (superm1) wrote :

Isaías:

You're looking at a different bug, because your machine doesn't even support dell-laptop it looks like.

Daniel Cardin (daniel-cardin) wrote :

Mario: What is different if I boot with the switch off then ? How does nm-applet and the rest make it work ? What's different?
another way to put it, how was it working in hal in jaunty prior to v4 IIRC ?

There has to be something... Otherwise I wouldn't be online at the moment through nm-applet :)

Daniel Cardin (daniel-cardin) wrote :

Is it because nm-applet uses rfkill's underlying mechanism ? rfkill reports

with switch on :
0: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: dell-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no
2: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no

with switch off:
0: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: yes
1: dell-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no

So rfkill definitely can read the status bit...

Mario Limonciello (superm1) wrote :

Daniel:

The actual switching is happening in the BIOS when you press the key. The
BIOS spits out the keycode and dell-laptop says "OK sure, lets change our
internal status now" So that would explain how the information works
reverted. Dell-laptop also has support to send the toggle itself, but it
needs to know the starting status to accurately do that.

On Tue, Oct 13, 2009 at 17:51, Daniel Cardin <email address hidden>wrote:

> Mario: What is different if I boot with the switch off then ? How does
> nm-applet and the rest make it work ? What's different?
> another way to put it, how was it working in hal in jaunty prior to v4 IIRC
> ?
>
> There has to be something... Otherwise I wouldn't be online at the
> moment through nm-applet :)
>
> --
> [Dell Latitude D430, iwl3945] Wireless can't be activated after disabling
> kill switch
> https://bugs.launchpad.net/bugs/430809
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Mario Limonciello
<email address hidden>
Sent from Austin, Texas, United States

Mario: dkms v0.4 works.

Daniel Cardin (daniel-cardin) wrote :

Mario:

Ok let's assume there is a BIOS bug. I would still have one last request for you. I suggest we pick the lesser of two evils and always have the driver respond the wireless is available. it _will_ cause problems if Karmic is released with a default mode of operation which prevents users from using the wireless network.

I prefer having nm-applet think the network is present even when the hardware is off than having no way to activate it.

What do you think?

Andy Whitcroft (apw) on 2009-10-14
Changed in linux (Ubuntu Karmic):
milestone: none → karmic-updates
Mario Limonciello (superm1) wrote :

Here's the final version that fixes this bug.

It adds a blacklist for Daniel's Vostro due to the BIOS bug. Also blacklists the mini family which don't support smbios via dell-laptop, but instead use compal-laptop. Everything else is identical to v 0.4.

http://kernel.ubuntu.com/git?p=mariol/ubuntu-karmic/.git;a=commit;h=f3c51aae2c14588931b1d19a43ce8fe6669d15a3
http://kernel.ubuntu.com/git?p=mariol/ubuntu-karmic/.git;a=commit;h=3344bb3d92e0e1557e0bd39a83a6379350f9a7c8

Daniel Cardin (daniel-cardin) wrote :

Mario:

Thanks for the time you spent fixing this. It is very important IMHO that dell is well supported at release time. It was a crippling bug without a workaround. Good job!

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Karmic):
assignee: Leann Ogasawara (leannogasawara) → Tim Gardner (timg-tpi)
milestone: karmic-updates → none
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-14.47

---------------
linux (2.6.31-14.47) karmic; urgency=low

  [ Mario Limonciello ]

  * SAUCE: dell-laptop: Store the HW switch status internally rather than
    requerying every time
    - LP: #430809
  * SAUCE: dell-laptop: Blacklist machines not supporting dell-laptop
    - LP: #430809

 -- Tim Gardner <email address hidden> Wed, 14 Oct 2009 15:05:39 -0600

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Gaute (gaute-div) wrote :

Sorry guys, but I seem to be having this exact problem in the released Karmic.

Dell vostro 1520.

Starting with hw switch off works fine.

Exactly same crash of smbios-wireless-ctl as in comment #56
( posted as Bug #464449 )

Perhaps just need to blacklist vostro 1520 ?
Haven't looked into how that works yet.

Download full text (3.2 KiB)

Have you tried to upgrade your bios?
Latest version, for your notebook, is A04, as you can see on Dell
support site, while in your log i see that you have A00 version.
For my laptop, Vostro 1320, bios upgrade worked fine.

Federico

On Fri, Oct 30, 2009 at 10:28 AM, Gaute <email address hidden> wrote:
> Sorry guys, but I seem to be having this exact problem in the released
> Karmic.
>
> Dell vostro 1520.
>
> Starting with hw switch off works fine.
>
> Exactly same crash of smbios-wireless-ctl  as in comment #56
> ( posted as Bug #464449 )
>
> Perhaps just need to blacklist vostro 1520 ?
> Haven't looked into how that works yet.
>
> --
> [Dell Latitude D430, iwl3945] Wireless can't be activated after disabling kill switch
> https://bugs.launchpad.net/bugs/430809
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “linux” package in Ubuntu: Fix Released
> Status in linux in Ubuntu Karmic: Fix Released
>
> Bug description:
> It seems that this problem keeps reappearing. This is exactly the same as bug 193970, but opening a new bug since the first one is very big and noisy already.
>
> Summary: If I boot with the kill switch off (i. e. wifi enabled), the kill switch works just fine. But if I boot with kill switch on (i. e. wifi disabled), changing the kill switch doesn't do anything and network-manager keeps insisting that the network is disabled.
>
> ProblemType: Bug
> Architecture: i386
> AudioDevicesInUse:
>  USER        PID ACCESS COMMAND
>  /dev/snd/controlC1:  martin     2634 F.... pulseaudio
>  /dev/snd/controlC0:  martin     2634 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
>  Card hw:0 'Intel'/'HDA Intel at 0xefebc000 irq 21'
>   Mixer name   : 'SigmaTel STAC9200'
>   Components   : 'HDA:83847690,10280201,00102201'
>   Controls      : 7
>   Simple ctrls  : 5
> Card1.Amixer.info:
>  Card hw:1 'Headset'/'Logitech Logitech USB Headset at usb-0000:00:1d.7-8.3.4, full speed'
>   Mixer name   : 'USB Mixer'
>   Components   : 'USB046d:0a01'
>   Controls      : 6
>   Simple ctrls  : 2
> CheckboxSubmission: 526c13623eeda7bcc3936c7be57b2d29
> CheckboxSystem: c8e8edcc4d15e0d55af04774be77e330
> Date: Wed Sep 16 17:49:06 2009
> DistroRelease: Ubuntu 9.10
> HibernationDevice: RESUME=UUID=5df2daed-eb83-4d60-a87c-9b71ff6b703f
> MachineType: Dell Inc. Latitude D430
> Package: linux-image-2.6.31-10-generic 2.6.31-10.32lp429241apw2
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-10-generic root=UUID=e43b0104-23d3-4bb8-9710-effa762ca2f6 ro quiet splash
> ProcEnviron:
>  PATH=(custom, user)
>  LANG=de_DE.UTF-8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-10.32lp429241apw2-generic
> RelatedPackageVersions:
>  linux-backports-modules-2.6.31-10-generic N/A
>  linux-firmware 1.18
> SourcePackage: linux
> Uname: Linux 2.6.31-10-generic i686
> dmi.bios.date: 05/21/2007
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: A00
> dmi.board.name: 0HU754
> dmi.board.vendor: Dell Inc.
> dmi.chassis.type: 8
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias: dmi:bvnDellInc.:bvrA00:bd05/21/2007:svnDellInc.:pnLatitudeD430:pvr:rvnDellInc.:rn0HU754:rvr:cvnDellInc.:ct8:cvr:
> dmi....

Read more...

Gaute (gaute-div) wrote :

Just what I was doing, and it seems to have solved the problem.

Found it mentioned in Bug# 441768
V1520A04-32_64.exe did the trick.

Thanks for the quick response anyway :)

Just updated to the latest bios (20091201) on my Latitude E6400 and booting with the kill switch off (wifi and bluetooth on) gives me disabled wifi and the only way to fix this seems to use "sudo rmmod dell-laptop".

network card: Intel Corporation PRO/Wireless 5300 AGN [Shiloh]

Upgraded the bios of my Vostro 1320.
Now everything works as a breeze.
Thank you.

mabawsa (mabawsa) wrote :

I have this issue still with 2.6.31-18-generic on my XPS M1330 with an Intel 4965 card.
BIOS set to toggle Bluetooth only with the killswitch.
If switch is off or on no wireless on coldboot.
If switch is toggled then wireless starts.
If I blacklist dell-laptop then the switch behaves as expected. Is it OK to run without DELL-Laptop on my machine.

mabawsa (mabawsa) wrote :

Oh I have the latest BIOS as well.

emilio (emiliomaggio) wrote :

On dell e4300 fix + update to the latest bios (A14) solves the problem

Rajesh Verma (verma-r-kumar) wrote :

Hi All,

I have Dell Inspiron 1420 with BIOS version A10. I was using Ubuntu 9.04 64-bit and had no issue with Intel 3945ABG wireless card.
Recently, I have installed Ubuntu 10.04 64-bit (fresh install) and this created the problem with wireless saying "Wireless disabled". I had the similar problem with Ubuntu 9.10 therefore shifted back to 9.04.

After googling, found some similar issues which were telling to remove network-manager and install wicd.

http://ubuntuforums.org/showthread.php?t=1420053

But still, WICD was not able to detect wireless and could able to scan the network only when network-manager was also present. One more weird thing was, wicd able to scan and detect wireless connections only when I connected the system with eth0 cable. After detection, I was unplug the ethernet cable and could start using wlan0 connection.

Also tried by doing:
sudo rmmod -f iwl3945
sudo modprobe iwl3945 disable_hw_scan=1

But it also not worked for me.

After removing "dell-laptop" module and blacklisting the same, network-manager starts detecting the wireless connections. wicd also able to detect but starts asking authentication for startup (don't know why). My system is running with default kernel (v2.6.32) came with ubuntu 10.04.

Could you please let me know, is there any patch available for this issue for ubuntu 10.04. Also, what could be the side-effects of removing dell-laptop module.

Thanks.

Rajesh Verma (verma-r-kumar) wrote :

Removing Jaunty from nominations.

Rajesh Verma (verma-r-kumar) wrote :

Ubuntu 10.04 has "wireless disabled" issue.

Changed in linux (Ubuntu Karmic):
status: Fix Released → Incomplete
Martin Pitt (pitti) wrote :

Please file a new bug about your issue with "ubuntu-bug linux".

Changed in linux (Ubuntu Karmic):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions