3G sierra wireless card cannot connect. Driver Loads but unable to dial.

Bug #379593 reported by BeJay on 2009-05-23
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
network-manager (Ubuntu)
Undecided
Unassigned
ppp (Ubuntu)
Undecided
Unassigned

Bug Description

I have a sierra wireless 880E Express Card (Blue Telstra thing for Australia) and it works perfectly under 8.10, but not under 9.04. It finds the card ok, I setup the wizard for "telstra next g card" and it dials but then reboots the card. In other words when I connect to the 3G profile in network manager it tries, but I see the power lights cycle and the modem reboots then it says it's disconnected.

Code:

[ 3090.248118] usb 5-2: USB disconnect, address 13
[ 3090.251453] sierra 5-2:1.0: device disconnected
[ 3090.744068] usb 5-2: new full speed USB device using uhci_hcd and address 14
[ 3090.908198] usb 5-2: configuration #1 chosen from 1 choice
[ 3090.910739] sierra 5-2:1.0: Sierra USB modem converter detected
[ 3090.912780] usb 5-2: Sierra USB modem converter now attached to ttyUSB0
[ 3090.912836] usb 5-2: Sierra USB modem converter now attached to ttyUSB1
[ 3090.912870] usb 5-2: Sierra USB modem converter now attached to ttyUSB2

This is what happens when you dial it:

[ 3091.304330] sierra ttyUSB3: Sierra USB modem converter now disconnected from ttyUSB3
[ 3091.304367] sierra ttyUSB4: Sierra USB modem converter now disconnected from ttyUSB4
[ 3091.304398] sierra ttyUSB5: Sierra USB modem converter now disconnected from ttyUSB5

I've updated to the latest drivers 1.7.0, But I don't think this is a driver issue as the older version works fine under 8.10.

Ubuntu ships with version: v.1.3.2

Here is the current Driver info:

modinfo sierra
filename: /lib/modules/2.6.28-11-generic/kernel/drivers/usb/serial/sierra.ko
license: GPL
version: v.1.7.0
description: USB Driver for Sierra Wireless USB modems
author: Kevin Lloyd, Elina Pasheva, Matthew Safar, Rory Filer
srcversion: 12B80B20F6FCBF818657666
alias: usb:v1199p68A3d*dc*dsc*dp*ic*isc*ip*
alias: usb:v0F3Dp0112d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0112d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6892d*dc*dsc*dp*icFFiscFFipFF*
alias: usb:v1199p6891d*dc*dsc*dp*icFFiscFFipFF*
alias: usb:v1199p6890d*dc*dsc*dp*icFFiscFFipFF*
alias: usb:v1199p6880d*dc*dsc*dp*icFFiscFFipFF*
alias: usb:v1199p685Ad*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6859d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6856d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6855d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6853d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6852d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6851d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6850d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p683Ed*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p683Dd*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p683Cd*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p683Bd*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p683Ad*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6833d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6832d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6821d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6820d*dc*dsc*dp*ic*isc*ip*
alias: usb:v03F0p1E1Dd*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6815d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6813d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6812d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6803d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6804d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p6802d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0028d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0027d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0026d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0025d*dc*dsc*dp*icFFiscFFipFF*
alias: usb:v1199p0023d*dc*dsc*dp*icFFiscFFipFF*
alias: usb:v1199p0120d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0021d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0019d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0220d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0024d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0020d*dc*dsc*dp*ic*isc*ip*
alias: usb:v03F0p1B1Dd*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0218d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0018d*dc*dsc*dp*ic*isc*ip*
alias: usb:v1199p0017d*dc*dsc*dp*ic*isc*ip*
depends:
vermagic: 2.6.28-11-generic SMP mod_unload modversions 586
parm: nmea:NMEA streaming (bool)
parm: debug:Debug messages (bool)
parm: suspend_support:Selective Suspend support (bool)

I think it's a network manager / kernel issue but what else can I test for?

Thanks

Bj

BeJay (bjdag79) wrote :

FIXED!!!!!

I updated the firmware to "AC880E_Telstra_F1_0_0_19ap" using a windows XP laptop and now it works with version 1.7.0 driver for sierra 880E under Ubuntu It won't however work with the driver that ships with 9.04.

I got the formware form here: http://www.sierrawireless.com/support/

Hope it helps someone.

BeJay (bjdag79) wrote :

Driver update and firmware update fixed this problem. Updated driver in 9.04 to 1.7.0 to resolve.

Changed in ubuntu:
status: New → Confirmed
Bruce Wolfe (wolfedu) wrote :

Hi Bejay, et. al.

I have a Fujitsu T2010 that has a built in Sierra MC8780 3G modem. Like you worked fine in earlier versions now in 9.04 it doesn't.

Connects, logs in and then gets reset/closed.

I updated the Driver - but this did not resolve the NM issue. It did however let me manually use pppd to connect. When comparing the logs for NM vs. direct I noticed that direct uses /dev/ttyUSB0 for comms whilst NM appears to be trying to use /dev/ttyUSB2 for comms. It would appear that NM is trying to talk across the wrong device in my case, but at this time I am not sure how to change NM's behaviour.

Can anybody help with this??????

As a result - there appears to be a bug in the NM environment in choosing the correct device.

I don't know if I actually needed to upgrade the driver, although the Sierra site certainly implies it is necessary.

Stewart Baillie (sqbaillie) wrote :

To my great frustration these problems persist in Lucid. Fortunately BeJay's solution above works on this platform also.

Just make and install the appropriate sierra driver source tar from their website and all is now good for my AC880U using networkmanager.

affects: ubuntu → linux (Ubuntu)
darkraven (jasminr) wrote :
Download full text (4.4 KiB)

something to do with maverick. Stay with 9.10 or 10.04.

i seem to have the best like with my usb 305 lightning here.

The issue is NOT dialing for me. I can dial. It took some diagnoses and a pppd script to get some info.
You can start by copying the /etc/ppp folder to your normal mounted drive from the live cd. CHmod it 777 for now. (I dont feel like messing with groups)

That said. I tried it three ways.

1) Throught the wifi menu on top of gnome...flat out fails and disconnects.
2) sudo pppd call gsm (with some slight modifications) ...get strange error saying ppp headers turned on and disconnecting...

3) gnome-ppp ...this works until after it dials, when it needs pppd to work.

I've tried copying pppd and the libs and the config files all from the live 10.04 disc, which works.
I get the same place.

on 10.04, I added in the driver from sierra wireless and it seems to work ok. apparently the kernel only provides half the driver on 10.04.

ls usb:

Bus 001 Device 007: ID 1199:68a3 Sierra Wireless, Inc.

see here is my problem. this worked before.

I had two out of three of these buggers from different vendors working with 'sudo pppd call <script>' before with the help of the bit-flipper someone put together.

the app switches from cd mode to usb modem mode. I dont need it with the 305, thankfully. Im sick of the one-shot dialouts.

The error is on header compression, not BSD compression, which worked fine before maverick. ATT will disconnect you with compressed IP headers. This is why people have been getting segfaults on the GUI mode.

Now WHO CHANGED the DRIVER??? Linux programmers are notroiously breaking KNOW WORKING DRIVERS. This is the second time I have had HW issues due to this. The first was with the PS2(game console) headset, which was working for skype. I had to get a new one from logitech due to this.

Please keep in mind.......USB modems (and contracts) have STIFF PENALTIES for disconnects.
Not everybody will go through this much headache. Im glad I always keep a retro disc around when I update ubuntu, that way I have a fallback point.

If yall are going to put this product out on the market...quite frankly... you should have less bugs than my coffe os, WRITTEN with FPC. I have (7) SEVEN bugs and a .65 or so kernel. I bet the people at kernel.org cant even compete.Im ONE programmer guys...C'mon. Its called BETA testing for a reason folks.....either WAIT and TEST it or dont release the product.

Linux is getting notorious for BREAKING things lately. i really dont know where is issue is. These kernels are STABLE. With 'kernelcheck' package anyone can optimize or update thier kernel without hell of locking themselves out. The issue here IS NOT the kernel file as some have made reference to elsewhere. It obviously works or i wouldn't be dialing at all.

here is the dialing output from the terminal:
--------------------------------------------

Setting the abort string

Initializing modem

Setting APN

Dialing...
Script /usr/sbin/chat -v -f /etc/ppp/peers/gsm_chat finished (pid 3312), status = 0x0
Serial connection established.
using channel 5
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB0
sent [LCP ConfReq id=0x1 <async...

Read more...

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Thomas Hood (jdthood) wrote :

@BeJay: Can you please explain the status of this bug in Ubuntu 12.04? Is it "fixed"?

Changed in network-manager (Ubuntu):
status: New → Incomplete
Changed in ppp (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for ppp (Ubuntu) because there has been no activity for 60 days.]

Changed in ppp (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for network-manager (Ubuntu) because there has been no activity for 60 days.]

Changed in network-manager (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers