Comment 5 for bug 379593

darkraven (jasminr) wrote :

something to do with maverick. Stay with 9.10 or 10.04.

i seem to have the best like with my usb 305 lightning here.

The issue is NOT dialing for me. I can dial. It took some diagnoses and a pppd script to get some info.
You can start by copying the /etc/ppp folder to your normal mounted drive from the live cd. CHmod it 777 for now. (I dont feel like messing with groups)

That said. I tried it three ways.

1) Throught the wifi menu on top of gnome...flat out fails and disconnects.
2) sudo pppd call gsm (with some slight modifications) ...get strange error saying ppp headers turned on and disconnecting...

3) gnome-ppp ...this works until after it dials, when it needs pppd to work.

I've tried copying pppd and the libs and the config files all from the live 10.04 disc, which works.
I get the same place.

on 10.04, I added in the driver from sierra wireless and it seems to work ok. apparently the kernel only provides half the driver on 10.04.

ls usb:

Bus 001 Device 007: ID 1199:68a3 Sierra Wireless, Inc.

see here is my problem. this worked before.

I had two out of three of these buggers from different vendors working with 'sudo pppd call <script>' before with the help of the bit-flipper someone put together.

the app switches from cd mode to usb modem mode. I dont need it with the 305, thankfully. Im sick of the one-shot dialouts.

The error is on header compression, not BSD compression, which worked fine before maverick. ATT will disconnect you with compressed IP headers. This is why people have been getting segfaults on the GUI mode.

Now WHO CHANGED the DRIVER??? Linux programmers are notroiously breaking KNOW WORKING DRIVERS. This is the second time I have had HW issues due to this. The first was with the PS2(game console) headset, which was working for skype. I had to get a new one from logitech due to this.

Please keep in mind.......USB modems (and contracts) have STIFF PENALTIES for disconnects.
Not everybody will go through this much headache. Im glad I always keep a retro disc around when I update ubuntu, that way I have a fallback point.

If yall are going to put this product out on the market...quite frankly... you should have less bugs than my coffe os, WRITTEN with FPC. I have (7) SEVEN bugs and a .65 or so kernel. I bet the people at kernel.org cant even compete.Im ONE programmer guys...C'mon. Its called BETA testing for a reason folks.....either WAIT and TEST it or dont release the product.

Linux is getting notorious for BREAKING things lately. i really dont know where is issue is. These kernels are STABLE. With 'kernelcheck' package anyone can optimize or update thier kernel without hell of locking themselves out. The issue here IS NOT the kernel file as some have made reference to elsewhere. It obviously works or i wouldn't be dialing at all.

here is the dialing output from the terminal:
--------------------------------------------

Setting the abort string

Initializing modem

Setting APN

Dialing...
Script /usr/sbin/chat -v -f /etc/ppp/peers/gsm_chat finished (pid 3312), status = 0x0
Serial connection established.
using channel 5
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x104da6f5> <pcomp> <accomp>]

rcvd [LCP ProtRej id=0x0 00 0d ba dd c0 de 85 85 85 85 ac fa fc a8 78 fc fc a8 01 05 00 00 88 c0 36 a8 00 00 05 00 20 06 ...]

rcvd [LCP ConfReq id=0x1 <mru 1600> <auth pap> <magic 0xa3f518d5> <asyncmap 0x0> <pcomp> <accomp>]
sent [LCP ConfAck id=0x1 <mru 1600> <auth pap> <magic 0xa3f518d5> <asyncmap 0x0> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x104da6f5> <pcomp> <accomp>]
sent [LCP EchoReq id=0x0 magic=0x104da6f5]
sent [PAP AuthReq id=0x1 <email address hidden>" password=<hidden>]
rcvd [LCP EchoRep id=0x0 magic=0xa3f518d5]
rcvd [PAP AuthAck id=0x1 "TTP Com PPP - Password Verified OK"]

Remote message: TTP Com PPP - Password Verified OK
PAP authentication succeeded
sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 192.168.1.2> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]

rcvd [LCP ProtRej id=0x1 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 03 2f 32]

Protocol-Reject for 'Compression Control Protocol' (0x80fd) received ******* I specifically turned this off! *****

rcvd [LCP TermReq id=0x0 "0021: Normal Termination by NCP"]
LCP terminated by peer (0021: Normal Termination by NCP)
sent [LCP TermAck id=0x0]

Modem hangup
Connection terminated.