Ubuntu

acer_wmi in Jaunty on Aspire One exposes non-functional (always disabled) rfkill device

Reported by Max Bowsher on 2009-01-21
172
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
Ubuntu Netbook Remix
Undecided
Unassigned
linux (Fedora)
Confirmed
Unknown
linux (Ubuntu)
Medium
Andy Whitcroft
Jaunty
Medium
Andy Whitcroft

Bug Description

Upgrading to Jaunty, I found that network-manager would no longer let me make any wireless connections - it turned out that it thought that a killswitch was triggered (in /var/log/daemon.log). However, "iwlist wlan0 scan" could see networks. Toggling the killswitch apparently did turn the radio off and on, as evidenced by the response of "iwlist wlan0 scan", but network-manager remained convinced that radio was killed throughout.

I discovered that the acer_wmi rfkill device in sysfs was reporting state="0" regardless what state the killswitch was actually in. Investigating the modules website at http://code.google.com/p/aceracpi/wiki/SupportedHardware revealed the comment that the WMI implementation on the Aspire One does not do anything. Based on that assertion, I did "rmmod acer_wmi", and network-manager sprang into life and happily connected my network.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: linux-image-2.6.27-11-generic 2.6.27-11.24
ProcCmdLine: root=UUID=4564f896-7a91-482d-b4fd-ad60ba162fce ro quiet splash
ProcEnviron:
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.27-11.24-generic
SourcePackage: linux
UnreportableReason: This is not a genuine Ubuntu package

Max Bowsher (maxb) wrote :
Max Bowsher (maxb) wrote :

Huh? Why does apport think my kernel isn't a genuine Ubuntu package? It _is_.

Connor Imes (rocket2dmn) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please include the following additional information as separate attachments.
   uname -a > uname-a.log
   lsb_release -rd > lsb_release-rd.log
   cat /proc/version_signature > proc_version_signature.log
   sudo lspci -vvnn > lspci-vvnn.log
   dmesg > dmesg.log
as well as
   /var/log/daemon.log

Before removing the acer_wmi module, please also attach
   lsmod > lsmod.log

For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies

Thanks in advance!

Changed in linux:
importance: Undecided → Medium
status: New → Incomplete
Connor Imes (rocket2dmn) wrote :

Heh, forgot this was an apport bug, sorry. You don't need to attach those first 5 again. daemon.log and lsmod would still be nice. Cheers.

Max Bowsher (maxb) wrote :

OK, here is lsmod output. I did also do lsmod after rmmod, but I'm not attaching it because it showed only the obvious change (i.e. acer_wmi being removed:
@@ -11 +10,0 @@
-acer_wmi 23104 0
@@ -39 +38 @@
-led_class 12036 2 acer_wmi,ath5k
+led_class 12036 1 ath5k

Max Bowsher (maxb) wrote :

Here is daemon.log, clipped to a single bootup, and annotated with:
   ### Bootup
   ### Login to X
   ### rmmod acer_wmi

Changed in linux:
status: Incomplete → New
Connor Imes (rocket2dmn) wrote :

Max,
Can you also please attach
   lshal > lshal.txt
Thanks again.

Changed in linux:
status: New → Incomplete
Connor Imes (rocket2dmn) wrote :

One more thing, can you please run
   lshal -m
and toggle your killswitch while the acer_wmi module is still loaded. Post the output back to this bug report. Then repeat after you have unloaded that module when your wireless is working.
Thanks.

Max Bowsher (maxb) wrote :
Max Bowsher (maxb) wrote :

lshal.txt attached.

lshal -m outputs the following on killswitch toggle:
  platform_i8042_i8042_KBD_port_logicaldev_input condition ButtonPressed = wlan
(Yes, it's exactly the same output regardless of whether the state is being toggled on, or toggled off)

Changed in linux:
status: Incomplete → New
Connor Imes (rocket2dmn) wrote :

Thank you for supplying that information, Max. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as Triaged and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in linux:
status: New → Triaged
Conrad Knauer (atheoi) wrote :

> I did "rmmod acer_wmi", and network-manager sprang into life and happily connected my network.

Indeed, that solves the problem on my Acer Aspire One (110)
http://ubuntuforums.org/showthread.php?t=1042075

Steve Beattie (sbeattie) wrote :

Assigning to the kernel team.

Changed in linux:
assignee: nobody → canonical-kernel-team
Max Bowsher (maxb) wrote :

Nominated for Jaunty as "All Acer Aspire One's refuse to connect to wifi using NetworkManager" is a notable regression.

I'm not runnin Ubuntu at the moment however I saw a similar bug occur with ArchLinux on an Acer Aspire One AOA150. The network connection is made but found that after a period of heavy data traffic the network card stops working and thus requires a hard reset of the device. I disable the acer_wmi module and now the issue doesn't appear again.

Btw, this is using 2.6.28.7 kernel - so issues are appearing even outside the Ubuntu world so one can assume that this isn't a distro specific issue.

To be perfectly honest, I don't know what acer_wmi does but maybe its best if it is disabled atleast on all the Acer Aspire One models.

michele (mikj) wrote :

I have an acer aspire 1524 wlmi and a linksys wpc300n ath9k ar5814 ... and always the same (bug/problem ..
I will waiting full of hoping ;)
mikj

Kenneth Mokkelbost (kmokk) wrote :

Has there been any progress on this one?

Personally I've just blacklisted acer_wmi, but for some of my friends who will upgrade to 9.04 when it is released will probably say "I have to do what?" if I tell them to blacklist the acer_wmi module.

Will a blacklisting of acer_wmi negatively affect those who are not using an Aspire One?

i have the same issue with an aspire one and an intel wifi link 5300. Issue occurs for all kernels > 2.6.27

Timo Jyrinki (timo-jyrinki) wrote :

If someone has time to recompile kernel, could this simple double free problem cause this problem? :

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=013d67fd4f0da8f6af60a376f1a254266ab658ef

(the driver is drivers/misc/acer-wmi.c in 2.6.28, though)

Max Bowsher (maxb) wrote :

Timo:

Any reason to suspect it in particular? The Aspire One doesn't have bluetooth hardware, so there's a fair chance that codepath isn't being touched anyway.

Timo Jyrinki (timo-jyrinki) wrote :

Not really besides if the wireless data would be somehow incorrectly freed and the state would be lost somehow / reset to 0 because of that, but I really don't know the code in question so no idea... anyway, it's the only change that has been done recently, but of course the chances are the bug has no fix anywhere at the moment.

Meanwhile I also blacklisted acer_wmi as a workaround, which works.

This is an upstream linux bug; It's not specific to the ubuntu "sauce". http://kernel.ubuntu.com/~kernel-ppa/mainline/ and Feodra Rawhide are all affected.

Andy Whitcroft (apw) on 2009-03-20
Changed in linux:
assignee: canonical-kernel-team → apw
status: Triaged → In Progress

Hello,

I also have Acer Aspire One 120gb. This is my travel netbook installed Jaunty up to date.
I dont have any important data within this computer.
I can test any software to help developers.
If any help needed you can contact with me.

Stefan Bader (smb) wrote :

This is the dmidecode information for the AA1 in case acer-wmi should be selectively disabled.

Oupamster (oupamster) wrote :

hi
I'm also running aceraspireone 150BGw model wt AR2425 & had similar issues with the wireless connection on my home lan. after reading the posts here and running "rmmod acer_wmi"as mentioned, i could connect to my wireless lan. I also running Jaunty 9.04 unr on my acer netbook up-to-date.

thankx

Andy Whitcroft (apw) wrote :

After a number of rounds of debugging with Stefan (thanks for your patience) I think I have a workable patch for this issue. Basically it appears that the Aspire One has hardware rfkill support and layering the software rfkill support over this simply disables the radio permenantly. The patch adds a new quirk type for having hardware rfkill and enabled that for the Aspire One. Could those of you with this hardware test the Jaunty kernels below and report back. If you have swrfkill enabled it should be announced in the dmesg. Please test with the acer-wmi module loaded (which it should automatically), please indicate whether the wireless works at all in this state and whether the rfkill switch works too. Kernels are at the URL below:

    http://people.ubuntu.com/~apw/lp319825-jaunty/

Andy Whitcroft (apw) on 2009-03-25
Changed in linux:
status: In Progress → Incomplete
Stéphane Marguet (stemp) wrote :

Work for me. AAO 110.

stemp@stemp-aa1:~$ uname -a
Linux stemp-aa1 2.6.28-11-generic #38~lp319825apw1 SMP Wed Mar 25 19:34:44 UTC 2009 i686 GNU/Linux
stemp@stemp-aa1:~$ lsmod | grep acer
acerhdf 15152 0
acer_wmi 23876 0
led_class 12036 2 acer_wmi,ath5k

stemp@stemp-aa1:~$ dmesg | grep kill
stemp@stemp-aa1:~$

Can you please add some instructions how to install these files.
.deb files ok. Downloaded them and run with package manager.
But no idea with .patch files

Stéphane Marguet (stemp) wrote :

@Attila : the .patch files are the source code of the modifications. You don't need them.
Just install the deb files, remove acer_wmi from blacklist and reboot.

Changed in linux (Ubuntu Jaunty):
status: Incomplete → In Progress
Bart Rose (jbrose3) wrote :

Linux AAO-Lin 2.6.28-11-generic #38~lp319825apw1 SMP Wed Mar 25 19:34:44 UTC 2009 i686 GNU/Linux

Did not work for me on my AAO 150

Bart Rose (jbrose3) wrote :

Also, no mention of swrfkill in dmesg.

Max Bowsher (maxb) wrote :

It's perhaps worth noting that there must be some way for the software to discover the rfkill state, as the Linpus Lite that ships preinstalled has on-screen popups and LED-state setting indicating state when you toggle the rfkill switch.

Unfortunately, it looks like they are using some customized madwifi-derivative for which I can't find the source.

@Attila : the .patch files are the source code of the modifications. You don't need them.
Just install the deb files, remove acer_wmi from blacklist and reboot.

I installed all 3 .deb kernel files.
No success.
How to remove acer_vmi from blacklist

LarryGrover (lgrover) wrote :

The patched kernel works on my Aspire One.

Model: AOA 110 - 1295

grover@stingray:~$ uname -a
Linux stingray 2.6.28-11-generic #38~lp319825apw1 SMP Wed Mar 25 19:34:44 UTC 2009 i686 GNU/Linux

grover@stingray:~$ lsmod | grep acer
acer_wmi 23876 0
led_class 12036 2 acer_wmi,ath5k

grover@stingray:~$ dmesg | grep kill
grover@stingray:~$

Not working with my AAO A150 120gb hdd version.
all outputs are same like above.

attila@attila-laptop:~$ uname -a
Linux attila-laptop 2.6.28-11-generic #38~lp319825apw1 SMP Wed Mar 25 19:34:44 UTC 2009 i686 GNU/Linux
attila@attila-laptop:~$ lsmod |grep acer
acer_wmi 23876 0
led_class 12036 2 ath5k,acer_wmi
attila@attila-laptop:~$ dmesg |grep kill
attila@attila-laptop:~$

Until now 2 AAO 110 works and 2 AAO 150 dont work.

Jeremy Bicha (jbicha) wrote :

Isn't this a problem?

From 0001-acer-rfkill-disable-quirk-for-ACER-Aspire-One.patch
+ .matches = {
+ DMI_MATCH(DMI_SYS_VENDOR, "Acer"),
+ DMI_MATCH(DMI_PRODUCT_NAME, "AOA110"),

Why don't you add the 150 model to this patch, and not just the 110?

Jeremy Bicha (jbicha) wrote :

AOA150

Andy Whitcroft (apw) wrote :

@Jeremy -- I can now that I am aware that there is more than one name for this thing.

@maxb -- interesting but without that elusive source are somewhat limited in our approach here. As the functionality does work without this support at least we are in a better place.

Here is lshw output of my Acer Aspire One A150 netbook.

@Andy: A small patch for the patch - changing an instance of rkfill to rfkill.

@Andy: Your latest kernel works on my AOA150:

nkbj@hafnium:~$ uname -a
Linux hafnium 2.6.28-11-generic #38~lp319825apw2 SMP Fri Mar 27 11:46:14 UTC 2009 i686 GNU/Linux
nkbj@hafnium:~$ lsmod | grep acer
acer_wmi 24260 0
led_class 12036 2 ath5k,acer_wmi

Jeremy Bicha (jbicha) wrote :

Andy, The apw2 kernel worked for me until I rebooted. Now eth1 is disabled again.

Andy,

Can not install and test your kernel.
Package installer says:
Error: A later version is already installed.
The problem happened after the last updates on 27-March updates.

Leon Nardella (leon.nardella) wrote :

Attila,

You can install the kernel package from the command line:
$ sudo dpkg -i nameofthepackage

Bart Rose (jbrose3) wrote :

Wireless and kill switch both work for me on my AAO150. Thanks for hard work!

Leon Nardella (leon.nardella) wrote :

Yeah.. I can confirm too that Andy's kernel solves the problem.
Wireless is working as expected with free Atheros driver and so is the kill switch.

Not sure if they should, but the wifi leds aren't working.

Bart Rose (jbrose3) wrote :

LEDs work with linux-backports-modules-jaunty version of ath5k.

@Leon Thanks for the help. :)

@Andy Thank you also for this job wireless working. "Computer AAO150"
   Seems that kill switch not working properly.
   Wifi led is ok with me. I installed backports-modules-jaunty earlier.

One more Question: 3 linux updates are on the update manager. (linux-headers/ linux-headers-generic/ linux-image-generic all 2,6.28-11)
Should we make these updates or not??

Leon Nardella (leon.nardella) wrote :

I managed to get LEDs to work by doing the following:

1- Doing all updates ( I have Proposed enabled ) which overrides Andy's kernel, breaking wireless again.
2- Reinstall linux-backports-modules-jaunty
3- Reinstall Andy's kernel.

I'm not sure whether it's really needed, but I reboot after each step.

@Attila
From my experience, the latest kernel ( which I guess comes from Proposed ) still breaks wifi for me.

@Andy
When can we expect your fixes to be uploaded to Proposed?

@Andy

I had been meaning to do something like this patch for a while, though I wasn't aware that the Aspire One's broken/ lack of WMI support broke things so badly for NetworkManager. A few things though:

1. You may want to update the patch details though - the bug here is that the Aspire One's ACPI-WMI interface just provides empty, useless methods that do nothing - calling into them doesn't return any result, but there's no way yet to distinguish it from a working Acer ACPI-WMI interface without blacklisting, since it advertises all the GUIDs that acer-wmi can drive.

2. Consider changing the DMI matching string - DMI can match on partial strings, so matching on 'AOA1' should be enough to catch all the Aspire One models with one DMI entry (in case there are more than just the 110 and 150 out there).

Other than that, if this patch is ready to go (and it looks good to me so far), I can add my sign-off to it and we can get it merged upstream.

Andy Whitcroft (apw) wrote :

@Carlos -- i am happy that the patch achieves what we wanted here. Getting the Aspire Ones we had seen in the wild working for wireless. However, if the real issue is that the whole module is useless on that hardware then it would make more sense for the patch to just blacklist the whole module. On expanding the DMI decode match, my personal preference is to be conservative; to only match those we know about. I am loath to blacklist something for a later model and find it does work there and that we are overruling it. I do however note you are the maintainer so I am happy to go whichever way you deem correct. Let me know and I'll get you a clean patch in e-mail for merging.

Max Bowsher (maxb) wrote :

I think AOA110 and AOA150 should probably cover all existing models (the 110 is the SSD version, the 150 the HD version)

Andy Whitcroft (apw) wrote :

In preparation for pushing this upstream I have cleaned the patch up and pushed new kernel with this clean version applied. If you have a chance could you test this kernel and report back. Should support all known Aspire Ones. Kernels are here:

    http://people.ubuntu.com/~apw/lp319825-jaunty/

@Andy: The apw3 kernel works fine on my AOA150.

Stefan Bader (smb) wrote :

Downloaded the latest kernel and it (still) works for the A0A100

Andy Whitcroft (apw) wrote :

@Niels, @Stefan -- thanks will push the current patch to Carlo for merging and to the kernel-team.

Last kernel is ok with my AOA150 too.

For interest, the model name of the new 10.1" Acer Aspire One (windows) appears to be AOD150

see
http://portablemonkey.com/article/acer-aspire-8.9-aoa150-vs-10.1-aod150-comparison/

There is more information about the names of these models at
http://en.wikipedia.org/wiki/Acer_Aspire_One

Not sure when they'll hit the shops or how reliable this information is.

Matt Zimmerman (mdz) wrote :

Is the fix queued for Jaunty to land before kernel freeze?

@Andy

Then perhaps the following might be better to just blacklist acer-wmi completely for the Aspire One (I've given this a cursory test on my Aspire 5020, so it at least doesn't break anything).

(I've left your cleanup changes out for now, as they should probably go into a separate patch).

@richard mullens

Thanks. Although, given how crazy the DMI naming for the Aspire One's is (compared to every other Acer laptop, which is at least reasonably sane in this respect), it's probably better to adopt a wait-and-see on those models.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-11.39

---------------
linux (2.6.28-11.39) jaunty; urgency=low

  [ Alan Tull ]

  * SAUCE: mx51: fix to1.1 in mxc_iomux_set_input
    - LP: #348333

  [ Andy Whitcroft ]

  * SAUCE: acer: rfkill disable quirk for ACER Aspire One
    - LP: #319825

  [ Brad Figg ]

  * ARM: Increase CONFIG_BLK_DEV_RAM_SIZE for imx51 flavour.
    - LP: #349842
  * ARM: Enable rtl8187 for imx51
    - LP: #349526
  * ARM: Unset CONFIG_USB_STORAGE_DEBUG for imx51
    - LP: #348504

  [ Bryan Wu ]

  * build CRAMFS into kernel to support mounting CRAMFS initrd on iop32x
    machine
    - LP: #349104

  [ Michael Casadevall ]

  * [lpia] Change ATA, SCSI, SD, ext2-4 modules into compiled-in components
    - LP: #347458

  [ Rob Herring ]

  * SAUCE: imx51: fec: fix cache operations for receive
    - LP: #348333

  [ Sam Yang ]

  * SAUCE: Revert ENGR00103870 FEC reopening causes network wdog timeout
    - LP: #348333
  * SAUCE: imx51: fec cache flush functions are incorrect
    - LP: #348333

  [ Upstream Kernel Changes ]

  * Bluetooth: Add fine grained mem_flags usage to btusb driver
    - LP: #268502
  * Bluetooth: Handle bulk URBs in btusb driver from notify callback
    - LP: #268502
  * Bluetooth: Submit bulk URBs along with interrupt URBs
    - LP: #268502

 -- Tim Gardner <email address hidden> Wed, 01 Apr 2009 17:37:32 -0600

Changed in linux (Ubuntu Jaunty):
status: In Progress → Fix Released
michele (mikj) wrote :

On my acer 1524 wmli, it does not works !
I must shut down acer_wmi module (sudo rmmod -v acer_wmi), to un-freeze NM ...
I've just upgraded my linux box ....
I've the standard kernel (no ricompilation)
----------
:~$ uname -a
Linux gigiottopoli64 2.6.28-11-generic #40-Ubuntu SMP Fri Apr 3 17:39:41 UTC 2009 x86_64 GNU/Linux
-------------

mikj

Matt Zimmerman (mdz) wrote :

@michele: since the fix has been confirmed to work for some others, it is possible that your problem is slightly different. Please file it as a new bug and refer to this one in the report.

I updated today to 2.6.28-11.41-generic and my aspire one wifi no longer work at all:

ath5k phy0: gain calibration timeout
ath5k phy0: can't reset hardware (-11)

I removed acer_wmi.ko and same result.

Kenneth Mokkelbost (kmokk) wrote :

@laurent: try power off, remove battery and power cord and wait a bit (30 sec for instance). That has helped me earlier with similar, but not the same, error messages.

Kenneth, thanks for the advice, a cold boot did restore wifi on my aspire one.

Now the bug is still around :)

Timo Jyrinki (timo-jyrinki) wrote :

The calibration timeout thing is a different bug, please search for a more proper bug report or file a new bug.

(yes it has occurred to me as well at times when resuming from suspend, using wireless-compat drivers now so haven't checked lately)

Robert Hooker (sarvatt) wrote :

There are clones of the AOA150 also affected by this bug. I have confirmed it kills wifi access using both packard bell and gateway AOA150 bioses. Gateway's AOA150 has subvendor ID 1025 subsystem ID 015B and Vendor string "Gateway", and Packard Bell's SVID/SSID is 1631/0193 with vendor string "Packard Bell". The bioses for all these systems are interchangable and a bunch of people with earlier model Acer AOA150's are using the other ones in order to have more backlight brightness levels. It's not that big of a deal because the module does not automatically load on these bioses but it is still affected by the bug if manually loaded for some reason. The gateway clone is sold in the US under the LT model series name. As a side note, this causes all kinds of havoc to hal keymaps :D

Example from the Gateway bios dmidecode-
Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
 Vendor: Gateway
 Version: v0.3103
 Release Date: 12/09/2008
 ROM Size: 1024 kB
 Characteristics:
  PCI is supported
  BIOS is upgradeable
  BIOS shadowing is allowed
  Boot from CD is supported
  Selectable boot is supported
  BIOS ROM is socketed
  EDD is supported
  Japanese floppy for NEC 9800 1.2 MB is supported (int 13h)
  Japanese floppy for Toshiba 1.2 MB is supported (int 13h)
  5.25"/360 kB floppy services are supported (int 13h)
  5.25"/1.2 MB floppy services are supported (int 13h)
  3.5"/720 kB floppy services are supported (int 13h)
  3.5"/2.88 MB floppy services are supported (int 13h)
  8042 keyboard services are supported (int 9h)
  CGA/mono video services are supported (int 10h)
  ACPI is supported
  USB legacy is supported
  Targeted content distribution is supported

Handle 0x0001, DMI type 1, 27 bytes
System Information
 Manufacturer: Gateway
 Product Name: AOA150
 Version: LU.S050B.111
 Serial Number: xxxxxxx
 UUID: xxxxxxx
 Wake-up Type: Power Switch
 SKU Number: Napa_Fab5
 Family: Intel_Mobile

solidus0079` (solidus0079) wrote :

Problem does not exist any more for me with BIOS update 3309. Wifi worked out of the gate on a fresh install without having to make manual blacklist edits.

jokerejoker (jokerejoker) wrote :

This problem also appeared on my old Acer Aspire 3610.
For me it seems like a general problem for acer laptop.

The command "sudo rmmod acer_wmi" fixed the problem for me to :)

Erki Hallingu (erkiha) wrote :

I had the same problem before, but I installed netbook remix 9.04 (final) on my AOA110 and wifi works "out of box". Installing linux-backports-modules-jaunty even made the led to work. Though before installing I upgraded bios to latest version (3309 at the moment).

Kevin Lipe (kevin-lipe) wrote :

I'm having the same exact problem on a Thinkpad X60 tablet: the Network Manager shows me no wireless networks and says the wireless is disabled, even though I can scan for networks using iwconfig from the console. All kinds of modprobing and rmmod-ing hasn't helped anything, and I'm not even using an Atheros wireless card. This particular Thinkpad has an Intel wireless card, using the iwl3945 module. It does, however, have an RF kill switch, and the Bluetooth and WiFi are both completely dead as a result of this bug.

Weird.

Max Bowsher (maxb) wrote :

Kevin,

This bug concerns the acer_wmi module. If your problem is not resolved by rmmoding the acer_wmi module, you are not having the same problem, but a different problem with similar symptoms. Please file a separate bug. Thanks!

Max Bowsher (maxb) wrote :

UNR uses Ubuntu kernels, so if it's fixed in one it's fixed in the other...

Changed in netbook-remix:
status: New → Fix Released
Changed in linux (Fedora):
importance: Undecided → Unknown
status: New → Unknown
Changed in linux (Fedora):
status: Unknown → Confirmed
tags: added: iso-testing
MacRules (macrules) wrote :

i have issues on 11.04 with acerhk package, which may be fixed by acer_wmi.
but is not in 11.04?

This issue still occurs, even in Ubuntu 13.10.

Here is an example:

https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/240287

Workaround solution was to blacklist the acer_wmi module.

To post a comment you must log in.