Ubuntu

rt61pci wireless card not working after suspend

Reported by Stephen G on 2008-11-05
70
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Natty by Juan Luis

Bug Description

In Ubuntu 8.10, Gigabyte EP35-DS3P with E8400. 2.6.27-7-generic

I have a D-link DWA-510 wireless PCI card in my desktop computer. It works correctly until I suspend the machine. Before the GUI flashes back up I see some console errors. I have found the following in dmesg which may be the messages I see (it happens very quickly):

[ 703.888068] phy0 -> rt61pci_mcu_request: Error - mcu request error. Request 0x50 failed for token 0xff.
[ 703.888071] phy0 -> rt61pci_mcu_request: Error - mcu request error. Request 0x50 failed for token 0xff.

After this wlan0 is no longer present in ifconfig. I can work around this by doing the following:
sudo modprobe -r rt61pci
sudo modprobe rt61pci

Then network manager automatically reconnects my wireless. However this only works once. The next time I do this the process 'events/0' starts taking 100% CPU and the system starts misbehaving. Shutting down does not work, I just get a lot of hung task messages.

I have now also just tried removing/replacing the module twice without suspending, and the events/0 issue occurs on the second insert here as well. Perhaps this is two different issues, or perhaps my workaround is just bad practice. (First bug report, be kind)

Stephen G (stephen.g) wrote :

Today I can't reproduce the events/0 issue. The work around restores the connection every time. If I remove the module before suspending there are no error messages. I have installed some updates today, the log of what has been installed is attached.

I do have the same bug.

I tried the backports-package (linux-backports-generic), but it is broken at the moment.

See attached file. It shows the backport-bug.

So at the moment suspending seems to be unusable here.

Christian

Download full text (4.3 KiB)

And here the dmesg output with standard linux-image-generic after doing the resume, rmmod and modprobe again (I have done both _after_ resume):

[ 878.964468] ------------[ cut here ]------------
[ 878.964469] WARNING: at /build/buildd/linux-2.6.27/kernel/power/main.c:176 suspend_test_finish+0x75/0x80()
[ 878.964471] Modules linked in: cbc aes_x86_64 aes_generic ecryptfs af_packet binfmt_misc rfcomm sco bnep l2cap bluetooth ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 xt_state nf_conntrack ipt_REJECT xt_tcpudp bridge stp kvm_intel kvm iscsi_trgt crc32c libcrc32c ppdev ipv6 acpi_cpufreq cpufreq_userspace cpufreq_stats cpufreq_powersave cpufreq_conservative cpufreq_ondemand freq_table sbs wmi video output pci_slot sbshc container battery iptable_filter ip_tables x_tables ac w83627ehf hwmon_vid sbp2 parport_pc lp parport mt352 saa7134_dvb videobuf_dvb dvb_core saa7134_alsa mt20xx tea5767 tda9887 tda8290 tuner snd_hda_intel snd_pcm_oss snd_mixer_oss arc4 snd_pcm ecb crypto_blkcipher snd_seq_dummy saa7134 snd_seq_oss rt61pci crc_itu_t snd_seq_midi rt2x00pci rt2x00lib ir_common snd_rawmidi compat_ioctl32 rfkill snd_seq_midi_event snd_seq videodev v4l1_compat snd_timer led_class evdev dm_multipath snd_seq_device v4l2_common scsi_dh mac80211 pcspkr snd videobuf_dma_sg nvidia(P) videobuf_core tveeprom iTCO_wdt iTCO_vendor_support cfg80211 soundcore i2c_core eeprom_93cx6 button snd_page_alloc shpchp pci_hotplug ext3 jbd mbcache pata_acpi sr_mod sd_mod crc_t10dif cdrom usbhid hid sg pata_marvell ata_generic ohci1394 ahci ieee1394 skge sky2 libata scsi_mod dock ehci_hcd uhci_hcd usbcore raid10 raid456 async_xor async_memcpy async_tx xor raid1 raid0 multipath linear md_mod dm_mirror dm_log dm_snapshot dm_mod thermal processor fan fbcon tileblit font bitblit softcursor fuse compcache lzo_decompress lzo_compress tlsf
[ 878.964528] Pid: 8168, comm: pm-suspend Tainted: P 2.6.27-7-generic #1
[ 878.964529]
[ 878.964529] Call Trace:
[ 878.964533] [<ffffffff8024e9b4>] warn_on_slowpath+0x64/0x90
[ 878.964536] [<ffffffff804fffa6>] ? printk+0x6c/0x6e
[ 878.964538] [<ffffffff803a3fb7>] ? kobject_put+0x27/0x60
[ 878.964540] [<ffffffff80501049>] ? mutex_unlock+0x9/0x20
[ 878.964542] [<ffffffff80434e4a>] ? dpm_complete+0x18a/0x1a0
[ 878.964544] [<ffffffff8027e1a5>] suspend_test_finish+0x75/0x80
[ 878.964546] [<ffffffff8027e2b4>] suspend_devices_and_enter+0x104/0x1b0
[ 878.964547] [<ffffffff8027e571>] enter_state+0xe1/0x110
[ 878.964549] [<ffffffff8027e65a>] state_store+0xba/0x100
[ 878.964550] [<ffffffff803a3e57>] kobj_attr_store+0x17/0x20
[ 878.964552] [<ffffffff803495fa>] sysfs_write_file+0xca/0x140
[ 878.964555] [<ffffffff802e9e9b>] vfs_write+0xcb/0x130
[ 878.964556] [<ffffffff802e9ff5>] sys_write+0x55/0x90
[ 878.964559] [<ffffffff8021285a>] system_call_fastpath+0x16/0x1b
[ 878.964560]
[ 878.964560] ---[ end trace 3edda6dc2afa118b ]---
[ 878.964664] PM: Finishing wakeup.
[ 878.964665] Restarting tasks ... done.
[ 880.299660] skge eth0: enabling interface
[ 880.303425] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 880.310442] sky2 eth1: enabling interface
[ 880.314414] ADDRCONF(NETDEV_UP): eth1: link is not...

Read more...

Just confirming this bug. This happens also with my RT61 card.

lokster (lokiisyourmaster) wrote :

This is happening on my MSI M670 notebook too. I have to reload rt61pci module manually after suspend/resume.

Care to test and confirm if this issue remains with the most recent pre-release of Jaunty 9.04 (currently Alpha4) - http://cdimage.ubuntu.com/releases/jaunty/ . It contains a newer 2.6.28 based kernel. You should be able to test suspend via a LiveCD. Please let us know your results. Thanks.

Changed in linux:
status: New → Incomplete

> Care to test and confirm if this issue remains with the most recent pre-
> release of Jaunty 9.04 (currently Alpha4) -
> http://cdimage.ubuntu.com/releases/jaunty/ . It contains a newer 2.6.28
> based kernel. You should be able to test suspend via a LiveCD. Please
> let us know your results. Thanks.

It does _not_ work here. I am already on jaunty. After resume, I need to
rmmod modprobe the rt61pci module.

After resume the module _seems_ to be ok, because NetworkManager lists
several nets, but it is impossible to connect to a network. Even
disabeling wlan and reactivating it does not solve it. Needs module
reloading.

Thanks Christian,

Can you also attach your lspci -vnvn information:

sudo lspci -vnvn > lspci-vnvn.log

Changed in linux:
importance: Undecided → Medium
status: Incomplete → Triaged
Dan Bishop (danbishop) wrote :

I have the same problem and have attached the requested output.

Dan Bishop (danbishop) wrote :

MIght also be worth mentioning that this problem occurs with hibernation as well as suspend... Oh and I'm on jaunty :)

Dan Bishop (danbishop) wrote :

For anyone desperate for a fix i've found that using ndiswrapper with this driver: http://download1.msi.com.tw/files/downloads/dvr_exe/Ralink_6833B_xp32_NB.zip

Works perfectly :D

lokster (lokiisyourmaster) wrote :

@Dan Bishop, this is the same driver that I use under WinXP with my notebook. Unfortunately, it seems that when using it with ndiswrapper, I can't connect to my wpa encrypted network.
My accesspoint info:
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK

:(

Dan Bishop (danbishop) wrote :

@lockster I can confirm it connects to my wpa network when used under jaunty... perhaps jaunty has a newer ndiswrapper version?

Stephen G (stephen.g) wrote :

Was hoping this would be fixed in jaunty but no luck :(
My current workaround is by adding a file containing

SUSPEND_MODULES="rt61pci"

to /etc/pm/config.d/
this automates the unloading and reloading of the module.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete

Working fine for me in Karmic.
Resumes from both Suspend and Hibernate without any problems.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released

Yes, I also haven't had this problem for quite some time in Karmic. Hibernate works fine. Haven't tried suspend.

davidetkarine (saveurlinux) wrote :

Dear you,
I've got the same problem with an
Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)
and this modules:
iwlagn 115220 0
iwlcore 116521 1 iwlagn
mac80211 225267 2 iwlagn,iwlcore
compat_firmware_class 6554 1 iwlagn
cfg80211 144778 3 iwlagn,iwlcore,mac80211
I've got a thinkpad R61 and after suspend to ram, If i turn off the wifi switch the wifi led turn off, If I turn on the wifi switch the light goes up but the wifi doesn't work.

davidetkarine (saveurlinux) wrote :

I forgot to say that i'm running Lucid and the work around
SUSPEND_MODULES="iwlagn"
works for me, thanks

Juan Luis (ntrrgc) wrote :

Still present on Maverick

Yes, present on Maverick. Sad.....

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers