Comment 6 for bug 294058

Care to test and confirm if this issue remains with the most recent pre-release of Jaunty 9.04 (currently Alpha4) - http://cdimage.ubuntu.com/releases/jaunty/ . It contains a newer 2.6.28 based kernel. You should be able to test suspend via a LiveCD. Please let us know your results. Thanks.