module rt61pci needs to be removed before suspending

Bug #300792 reported by bikeridercz on 2008-11-21
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

my old Toshiba TECRA8100 notebook was suspending well on HARDY, but after upgrade to INTREPID it never gone to suspend state. Always CAPSLOCK starts to blink and machine freeze. I'm completely lost and waste lot of time trying to solve it.

Please help.

bikeridercz (rmkk) wrote :
bikeridercz (rmkk) wrote :
bikeridercz (rmkk) wrote :
bikeridercz (rmkk) wrote :
bikeridercz (rmkk) wrote :

unfortunately /var/log/kern.log is empty and /var/log/kern.log.0 contains very old messages

A blinking capslock light usually means a kernel panic - which is bad. Dmesg would probably help, but if the machine is frozen, I dunno how you would go about getting that. Maybe look at your suspend scripts?

bikeridercz (rmkk) wrote :

unfortunately pm-suspend.log does not help ...

bikeridercz (rmkk) wrote :

Finally I tried to make hibernation, it failed with the same result - blinking capslock - except visible error messages on display, please see attachement.

Any help is appreciated.

bikeridercz (rmkk) wrote :

rt61pci seems to be driver for my wireless card, if the card driver makes a problem is it possible to add it do blacklisted hardware, will it work better ?

bikeridercz (rmkk) wrote :

Is anybody there ? I'm trying to make Ubuntu better :-)

Florian Diesch (diesch) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. :-)
Sometimes it just takes some time before somebody answers a bug report.

You can try to remove the rt61pci driver bevor suspending:
Open a terminal window and execute
  sudo modprobe -r rt61pci
To check if the driver really is removed excute
  lsmod | grep rt61pci
This should give you *no* output.

Then use
 sudo pm-suspend
to suspend. Does it work now? If not, do you get any messages?

bikeridercz (rmkk) wrote :

Surprisingly it worked, I tried it twice. In a few seconds my laptop was down, I'm indludng a log file. Unfortunately It returned back with black screen and blinking cursor, so hard reset was needed to be done.

So, what to do with rt61pci driver to remove it automatically before suspend ?
What to do with resume ?

Thanks.

Florian Diesch (diesch) wrote :

Most likely the black screen is not related to the rt61pci, maybe it's the graphic card.

Let's first find a workaround for the rt61pci bug.

If you don't have a backup of your system it may be a good idea to get one as you may need some more hard resets and chances are that the file system get damaged by that.

To get the rt61pci driver automatically removed when suspending execute
  echo 'SUSPEND_MODULES=rt61pci' | sudo tee /etc/pm/config.d/00rt61pci.local
on the command line. That creates a file etc/pm/config.d/00rt61pci.local that contains one line:
  SUSPEND_MODULES=rt61pci
The .local suffix should make sure it doesn't conflict with any file provided by a package.

Now log out, than switch to the text console using Ctrl-Alt-F1, log in there and execute
  sudo /etc/init.d/gdm stop
This shuts down the grafics system which should reduce the risk that the system hangs after resuming.

Then check that the rt61pci driver is still loaded:
  lsmod | grep rt61pci
should output at least one line containing 'rt61pci'

Now suspend using
 sudo pm-suspend
and try to resume. If it works you get the text console back and can start the graphics system using
 sudo /etc/init.d/gdm start
and check if the network is working.

If resuming still doesn't work please check if /var/log/messages contains anything useful.
Logging after resume should start with something like
 Nov 25 14:34:46 scenic kernel: [15485.432019] ACPI: Waking up from system sleep state S4

Also please attache the output of
 lsmod

bikeridercz (rmkk) wrote :

I did what You said, laptop gone down quickly with no problem.

But, resume is very strange, lcd panel backlight is turned on, usb mouse lights on, but then cursor start to blink and for next 30 seconds nothing happens, then quickly some screen with errors appeared, then it is exchanged for the original screen with pm-suspend command. It is not the end, then every 5seconds messages appearing reporting some troubles, then once again, once again, ...

Unforunately messages.log contains nothing useful. Message "...ACPI: Waiking ..." I fond in kern.log.0, but this log wasn't populated since 2.11.2008, and kern.log is completely empty.

So I take a pictures, sorry for that.

bikeridercz (rmkk) wrote :
bikeridercz (rmkk) wrote :
bikeridercz (rmkk) wrote :

Latest update: I realized that there is PCMCIA CF card adapter with 512MB CF inserted, it is used for regular backups of chosen files. After ejecting card reader, resume suddenly start to work even with started GDM.

Seems that it solves the problem, but I would like still to continue solving the isssues, because It is a good way how to backup files, so I prefer to have card reader inserted.

I have two questions:
1. it is ok for You to continue solving the resume issue caused by CF card reader ?
2. 00rt61pci.local file was a workaround of some bug ? So will somebody try to solve problem with rt61pci driver ?

Thanks for Your time.

Florian Diesch (diesch) wrote :

For the card reader issue please file a new bug. I changed the title of this one to a more catchy one.

I don't know if someone is working on the rt61pci driver (but I hope so). Maybe you can keep an eye on this issue and add a comment if the bug is still there in a few weeks or test the jaunty beta when it is out.

Changed in linux:
status: New → Confirmed
Florian Diesch (diesch) wrote :

The workaround above worked for bug #298623 too.

Frank Niedermann (fbn) wrote :

Hi,

the workaround only worked for me to suspend the computer, but while resuming it hangs and I have to reset it.

Any updates for the rt61pci driver? Is there a way to find out who's working on it to give them some more information?

Thanks,
  Frank

Hi bikeridercz,

Care to test the latest pre-release of Jaunty 9.04 (currently Alpha4) - http://cdimage.ubuntu.com/releases/jaunty/ . It contains an updated 2.6.28 based kernel. It would be good to know if this issue remains. You should be able to test suspend via a LiveCD. Please let us know your results and if any of the workarounds you tried previously are still valid. Thanks.

Changed in linux:
status: Confirmed → Incomplete
Frank Niedermann (fbn) wrote :

Hi,

I'm now on Jaunty 9.04 and it is slightly better: After resume from suspend there is no WLAN connection available, disabling and enabling wireless with network manager does not do anything. But if I unload the module rt61pci and load it again I get a network connection.

So the problem on Jaunty is that rt61pci has to manually be removed and loaded after resume.

Frank

drberg1000 (drberg1000) wrote :

I'm running an up-to-date Jaunty and am experiencing similar problems. After hibernating, wireless is not functional.

Running sudo modprobe -r rt61pci && sudo modprobe rt61pci restores the wireless.

Adding MODULES="rt61pci" to /etc/default/acpi-support does not seem to help in anyway.

--Dave

Hi Guys,

Just want to keep this up to date. Care to confirm this remains with the latest Karmic Alpha?
ISO CD images are available from http://cdimage.ubuntu.com/releases/karmic . Thanks.

I'm also going to mark this as a duplicate to bug 294058. Please provide your feedback there. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers