ipw2200 driver no longer works with wpa2 network

Bug #264104 reported by Ryan Lackey on 2008-09-02
36
This bug affects 2 people
Affects Status Importance Assigned to Milestone
module-init-tools
Invalid
Undecided
Unassigned
linux (Ubuntu)
Medium
Stefan Bader
Nominated for Jaunty by Oliver Joos
Intrepid
Medium
Stefan Bader

Bug Description

Binary package hint: wpasupplicant

I've recently upgraded from a custom kernel 2.6.24 on Hardy to 2.6.27-2 generic with Intepid Alpha.

Everything works great, except now I can't use WPA2 wireless networks reliably with my ipw2200/ipw2915abg card. (thinkpad t43p).

I can connect sometimes initially, but then it drops during a re-scan; reconnects, or eventually connects to a non-wpa network.

[ 165.482912] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.
 are the error messages I see, also periodically:

[ 213.389333] ipw2200: Firmware error detected. Restarting.

I'm really not sure which package is at fault; I've tried various permutations of ap-scan, hwcrypto, etc. in the driver and in wpa_supplicant.

Description: Ubuntu intrepid (development branch)
Release: 8.10

wpasupplicant:
  Installed: 0.6.4-1
  Candidate: 0.6.4-1
  Version table:
 *** 0.6.4-1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

linux:
  Installed: 2.6.27.2.2
  Candidate: 2.6.27.2.2
  Version table:
 *** 2.6.27.2.2 0
        500 http://archive.ubuntu.com intrepid/restricted Packages
        100 /var/lib/dpkg/status

network-manager:
  Installed: 0.7~~svn20080818t061112+eni0-0ubuntu1
  Candidate: 0.7~~svn20080818t061112+eni0-0ubuntu1
  Version table:
 *** 0.7~~svn20080818t061112+eni0-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

Ryan Lackey (ryan.lackey) wrote :

It appears the problem was the driver was trying to scan for networks constantly, as well as Network Manager doing so, and the probes tripping each other up in the driver.

Adding:
options ipw2200 hwcrypto=1 associate=0 debug=0x43fff
(relevant part being associate=0)
to /etc/modprobe.d/ipw2200

seems to have fixed it.

Reinhard Tartler (siretart) wrote :

seems rather like a driver problem, not something we could fix in wpasupplicant. I'm reassinging to the kernel therefore.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Kevin L. Nault (prof-morbius) wrote :

I am also having this issue, except it appears to apply to ALL 802.11 networks, not just WPA. Some dumps:

klaatu@it-knault:~$ dmesg | grep ipw2200
[ 31.284166] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[ 31.284174] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[ 31.285673] ipw2200 0000:02:04.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[ 31.320230] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[ 31.320329] firmware: requesting ipw2200-bss.fw
[ 33.239407] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11achannels)
[ 280.107466] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.
[ 2649.459624] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.
[ 3513.792563] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.
[ 3516.857455] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.

klaatu@it-knault:~$ lspci | grep 2200
02:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)

Please feel free to ask for any more information. I installed Kubuntu Intrepid off the Alpha 4 CD, and am fully up to date as of 4 Sept '08 through apt-get upgrade and dist-upgrade (required once).

Kevin L. Nault (prof-morbius) wrote :

Just tried creating an /etc/modprobe.d/ipw2200 with the line "option ipw2200 associate=0". I no longer get the "Failed to send SYSTEM_CONFIG" errors, but neither does it connect (to anything).

The hardware I'm using, incidentally, is an HP/Compaq nc8230, and the wireless radio status light doesn't work, though the button toggle the radio on/off does. (Just FYI)

Actually now I'm back to having problem regardless of the options in the
ipw2200 driver. (I'm seriously considering just getting another minipci
card; I've never really loved the ipw2200; maybe atheros is better?)

I've been experimenting with various options of:
options ipw2200 hwcrypto=1 antenna=2 auto_create=0 cmdlog=1 associate=0

Quoting Kevin L. Nault <email address hidden>:
> Just tried creating an /etc/modprobe.d/ipw2200 with the line "option
> ipw2200 associate=0". I no longer get the "Failed to send
> SYSTEM_CONFIG" errors, but neither does it connect (to anything).
>
> The hardware I'm using, incidentally, is an HP/Compaq nc8230, and the
> wireless radio status light doesn't work, though the button toggle the
> radio on/off does. (Just FYI)
>
> --
> ipw2200 driver no longer works with wpa2 network
> https://bugs.launchpad.net/bugs/264104
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” source package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: wpasupplicant
>
> I've recently upgraded from a custom kernel 2.6.24 on Hardy to 2.6.27-2 generic with Intepid Alpha.
>
> Everything works great, except now I can't use WPA2 wireless networks reliably with my ipw2200/ipw2915abg card. (thinkpad t43p).
>
> I can connect sometimes initially, but then it drops during a re-scan; reconnects, or eventually connects to a non-wpa network.
>
> [ 165.482912] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.
> are the error messages I see, also periodically:
>
> [ 213.389333] ipw2200: Firmware error detected. Restarting.
>
> I'm really not sure which package is at fault; I've tried various permutations of ap-scan, hwcrypto, etc. in the driver and in wpa_supplicant.
>
> Description: Ubuntu intrepid (development branch)
> Release: 8.10
>
> wpasupplicant:
> Installed: 0.6.4-1
> Candidate: 0.6.4-1
> Version table:
> *** 0.6.4-1 0
> 500 http://archive.ubuntu.com intrepid/main Packages
> 100 /var/lib/dpkg/status
>
> linux:
> Installed: 2.6.27.2.2
> Candidate: 2.6.27.2.2
> Version table:
> *** 2.6.27.2.2 0
> 500 http://archive.ubuntu.com intrepid/restricted Packages
> 100 /var/lib/dpkg/status
>
> network-manager:
> Installed: 0.7~~svn20080818t061112+eni0-0ubuntu1
> Candidate: 0.7~~svn20080818t061112+eni0-0ubuntu1
> Version table:
> *** 0.7~~svn20080818t061112+eni0-0ubuntu1 0
> 500 http://archive.ubuntu.com intrepid/main Packages
> 100 /var/lib/dpkg/status
>

--
Ryan Lackey [RL960-RIPE AS24812] <email address hidden> +1 206 569 4575
OpenPGP DH 4096: B8B8 3D95 F940 9760 C64B DE90 07AD BE07 D2E0 301F

Kevin L. Nault (prof-morbius) wrote :

A further followup: trying to join WEP & unencrypted networks via command-line (sudo iwconfig eth1 ...) also does not work, so this is not (just) a problem with knetworkmanager but with ipw2200 and/or the kernel.

Unless I'm talking out of my [censored].

I'm seeing the same error in dmesg with a non-encrypted network. I'm connecting using NetworkManager and its vpnc plugin.

The first time I boot up, it connects fine to both and I'm able to use the connection for a few minutes. Then the message:

 ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.

appears 5-6 times in dmesg and the connection drops. NetworkManager still shows that I'm connected to both the wifi network and the VPN, but I'm unable to communicate on the network.

If I disconnect and reconnect to the VPN in NetworkManager, it works fine and doesn't seem to drop out anymore.

I had a similar problem in Fedora 9 (messages from ipw2200 and dropped wifi/VPN connections with no obvious error), so it definitely could be something with the driver.

Ken Arnold (kenneth-arnold) wrote :

I had been using the Interpid kernel for a while, and it worked okay with ipw2200. Problems coming back from hibernation, and NetworkManager would have some issues, but it worked at least some of the time. Now the card still seems to work, but I get this message a /lot/ (600 times in about 30 minutes).

Greg Taylor (gtaylor) wrote :

I'm getting this on a formerly Canonical issued Toshiba Tecra A4 PTA40E.

Jamie Strandboge (jdstrand) wrote :

I just started seeing this after upgrading intrepid packages from the last few days. After login, network-manager tries to connect to my WPA2 network. I can get things to work again if I uncheck 'Enable wireless' in network-manager, and then do 'rmmod ipw2200'. It takes a few seconds to be removed. Then I can 'modprobe ipw2200' and check 'Enable wireless' and everything is fine.

As a stab in the dark, I looked for updates that jumped out at me from the last seven days (find /var/cache/apt/archives -mtime -7):
/var/cache/apt/archives/acpid_1.0.6-9ubuntu4_i386.deb
/var/cache/apt/archives/acpi-support_0.112_i386.deb
/var/cache/apt/archives/hal_0.5.11-3~ubuntu9_i386.deb
/var/cache/apt/archives/libc6_2.8~20080505-0ubuntu7_i386.deb
/var/cache/apt/archives/network-manager_0.7~~svn20080908t183521+eni0-0ubuntu4_i386.deb
/var/cache/apt/archives/upstart_0.3.9-8_i386.deb

$ dmesg | grep ipw2200
[ 22.398699] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[ 22.398703] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[ 22.398790] ipw2200 0000:02:02.0: PCI INT A -> Link[LNKC] -> GSI 11 (level, low) -> IRQ 11
[ 22.437643] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[ 22.437696] firmware: requesting ipw2200-bss.fw
[ 24.064139] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)
[ 63.882779] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.
[ 64.818557] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.
[ 65.099348] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.
[ 70.564266] ipw2200: Failed to send ASSOCIATE: Already sending a command.
[ 189.567881] ipw2200: Firmware error detected. Restarting.
[ 189.569852] ipw2200: Failed to up device
[ 189.852190] ipw2200 0000:02:02.0: PCI INT A disabled

Alexander Sack (asac) wrote :

please confirm that associate=0 is the option needed to fix this.

assigning to rtg. If associate=0 fixes this for everyone we should definitly consider to change our default.

Changed in linux:
assignee: ubuntu-kernel-team → timg-tpi
Alexander Sack (asac) wrote :

milestoning.

Changed in linux:
milestone: none → ubuntu-8.10
Jamie Strandboge (jdstrand) wrote :

Seems associate is on be default:
$ modinfo ipw2200
...
parm: associate:auto associate when scanning (default on) (int)
...

I confirmed the default state of 'associate' by performing:
$ cat /sys/module/ipw2200/parameters/associate
1

Creating /etc/modprobe.d/foo with:
options ipw2200 associate=0

and rebooting gets rid of all of my posted 'Failed' messages above. I confirmed the new state of 'associate' by performing:

$ cat /sys/module/ipw2200/parameters/associate
0

With associate=0, I am able to associate with my WPA2 network, as well as public networks. I'll keep rebooting to make sure this fixed it, as having associate=1 would only sometimes cause the above problem.

Jamie Strandboge (jdstrand) wrote :

After 7 reboots there were no problems with associate=0. 2 out of 7 attempts had the problem with associate=1.

Ryan Lackey (ryan.lackey) wrote :

associate=0 helps for me; I still have a weird race condition when I first
boot up since the wpa2 and non-wpa networks are both visible, and it
initially connects to the wpa2 net, then drops for the unencrypted net,
then tries wpa2, then drops, then tries again. Changing freq on the wpa2
net helped with that, but not 100%.

I think associate=0 being the default should fix the problem for most users.

Quoting Alexander Sack <email address hidden>:
> milestoning.
>
> ** Changed in: linux (Ubuntu Intrepid)
> Target: None => ubuntu-8.10
>
> --
> ipw2200 driver no longer works with wpa2 network
> https://bugs.launchpad.net/bugs/264104
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” source package in Ubuntu: Triaged
> Status in linux in Ubuntu Intrepid: Triaged
>
> Bug description:
> Binary package hint: wpasupplicant
>
> I've recently upgraded from a custom kernel 2.6.24 on Hardy to 2.6.27-2 generic with Intepid Alpha.
>
> Everything works great, except now I can't use WPA2 wireless networks reliably with my ipw2200/ipw2915abg card. (thinkpad t43p).
>
> I can connect sometimes initially, but then it drops during a re-scan; reconnects, or eventually connects to a non-wpa network.
>
> [ 165.482912] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.
> are the error messages I see, also periodically:
>
> [ 213.389333] ipw2200: Firmware error detected. Restarting.
>
> I'm really not sure which package is at fault; I've tried various permutations of ap-scan, hwcrypto, etc. in the driver and in wpa_supplicant.
>
> Description: Ubuntu intrepid (development branch)
> Release: 8.10
>
> wpasupplicant:
> Installed: 0.6.4-1
> Candidate: 0.6.4-1
> Version table:
> *** 0.6.4-1 0
> 500 http://archive.ubuntu.com intrepid/main Packages
> 100 /var/lib/dpkg/status
>
> linux:
> Installed: 2.6.27.2.2
> Candidate: 2.6.27.2.2
> Version table:
> *** 2.6.27.2.2 0
> 500 http://archive.ubuntu.com intrepid/restricted Packages
> 100 /var/lib/dpkg/status
>
> network-manager:
> Installed: 0.7~~svn20080818t061112+eni0-0ubuntu1
> Candidate: 0.7~~svn20080818t061112+eni0-0ubuntu1
> Version table:
> *** 0.7~~svn20080818t061112+eni0-0ubuntu1 0
> 500 http://archive.ubuntu.com intrepid/main Packages
> 100 /var/lib/dpkg/status
>

--
Ryan Lackey <email address hidden> +1 206 569 4575
B8B8 3D95 F940 9760 C64B DE90 07AD BE07 D2E0 301F

Tim Gardner (timg-tpi) wrote :

module-init-tools_3.3-pre11-4ubuntu15

Changed in linux:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.27-7.11

---------------
linux (2.6.27-7.11) intrepid; urgency=low

  [ Amit Kucheria ]

  * STABLE queue: mac80211: fix two issues in debugfs
    - LP: #275227
  * SAUCE: Adds support for COMPAL JHL90 webcam

  [ Ben Collins ]

  * SAUCE: (no-up) x86: Quiet "Kernel alive" messages
    - LP: #39985
  * SAUCE: (no-up) Modularize vesafb
  * build/config: Enable vesafb module
  * build: Switch to vesafb as preferred.

  [ Leann Ogasawara ]

  * Add Dell Dimension 9200 reboot quirk
    - LP: #271370

  [ Michael Haas ]

  * SAUCE: Revert aufs changes from AppArmor merge

  [ Tim Gardner ]

  * fix virtio udeb layout
    - LP: #257739
  * Enabled CONFIG_EXT4DEV_FS=m
  * Changed default TCP congestion algorithm to 'cubic'
    - LP: #278801
  * SAUCE: ipw2200: change default policy for auto-associate
    - LP: #264104

  [ Upstream Kernel Changes ]

  * x86, early_ioremap: fix fencepost error
    - LP: #263543

 -- Tim Gardner <email address hidden> Sat, 11 Oct 2008 08:07:42 -0600

Changed in linux:
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: module-init-tools has a superfluous option for ipw2200.

Patch Description: removed extra/modprobe.d/options:'options ipw2200 associate=0'

Tim Gardner (timg-tpi) wrote :

Uploaded module-init-tools_3.3-pre11-4ubuntu17

Changed in module-init-tools:
assignee: nobody → timg-tpi
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Tim, does it actually have any adverse effect to have the extra option? If it's just "superfluous", but not "harmful", then I don't see the justification for doing an SRU of module-init-tools?

Tim Gardner (timg-tpi) wrote :

No, its not harmful. I had an email exchange with Scott Remnant wherein he convinced me that I should change the driver source instead of putting options in a modprobe file. Therefore, I reasoned that I should remove the modprobe option once the driver is propagated. Won't this also reduce the number of differences that we carry from version to version?

Martin Pitt (pitti) wrote :

Tim Gardner [2008-11-05 0:31 -0000]:

> No, its not harmful.

OK, thanks. Then let's skip that for intrepid-updates.

> Won't this also reduce the number of differences that we carry from
> version to version?

Yes, and that's why we should absolutely do it in Jaunty.

Christoph Langner (chrissss) wrote :

I posted a similar bug under bug #291711 Is this a duplicate?

Eugen Pyvovarov (bsn.dev) wrote :

My wifi card in Toshiva a105-s2712 broked started from 8.10 alhpa5, and works only with
"options ipw2200 hwcrypto=1 associate=0 debug=0x43fff" line in /etc/modprobe.d/ipw2200.

But it seems that now i have a lot debug messages in syslog, like:

Dec 1 14:00:22 bsn-laptop kernel: [ 1045.122852] ipw2200: I ipw_rx_notification type = 25 (4 bytes)
Dec 1 14:00:22 bsn-laptop kernel: [ 1045.225242] ipw2200: I ipw_rx_notification type = 25 (4 bytes)
Dec 1 14:00:23 bsn-laptop kernel: [ 1045.327625] ipw2200: I ipw_rx_notification type = 25 (4 bytes)
Dec 1 14:00:23 bsn-laptop kernel: [ 1045.430032] ipw2200: I ipw_rx_notification type = 25 (4 bytes)
Dec 1 14:00:23 bsn-laptop kernel: [ 1045.532431] ipw2200: I ipw_rx_notification type = 25 (4 bytes)
Dec 1 14:00:23 bsn-laptop kernel: [ 1045.634851] ipw2200: I ipw_rx_notification type = 25 (4 bytes)
Dec 1 14:00:23 bsn-laptop kernel: [ 1045.737236] ipw2200: I ipw_rx_notification type = 25 (4 bytes)
Dec 1 14:00:23 bsn-laptop kernel: [ 1045.839668] ipw2200: I ipw_rx_notification type = 25 (4 bytes)
Dec 1 14:00:23 bsn-laptop kernel: [ 1045.942028] ipw2200: I ipw_rx_notification type = 25 (4 bytes)
Dec 1 14:00:23 bsn-laptop kernel: [ 1046.044445] ipw2200: I ipw_rx_notification type = 25 (4 bytes)
Dec 1 14:00:23 bsn-laptop kernel: [ 1046.146854] ipw2200: I ipw_rx_notification type = 25 (4 bytes)
Dec 1 14:00:23 bsn-laptop kernel: [ 1046.249237] ipw2200: I ipw_rx_notification type = 25 (4 bytes)
Dec 1 14:00:24 bsn-laptop kernel: [ 1046.351646] ipw2200: I ipw_rx_notification type = 25 (4 bytes)

django (dino-vliet) wrote :

Hi folks,

On my shiny new ubuntu 8.10 installation, I had this error as well on a Toshiba Satellite laptop SA50-432.

Adding:
options ipw2200 hwcrypto=1 associate=0 debug=0x43fff

to /etc/modprobe.d/ipw2200

fixed it. This file, didn't exist, so I had to create it first.

I could not connect to no wep or wpa enabled wireless network.

When will this be fixed in the driver? And is it safe to keep that setting over there in the file /etc/modprobe.d/ipw2200 file?

Alexander Sack (asac) wrote :

On Mon, Dec 01, 2008 at 12:02:04PM -0000, Eugene Pyvovarov wrote:
> My wifi card in Toshiva a105-s2712 broked started from 8.10 alhpa5, and works only with
> "options ipw2200 hwcrypto=1 associate=0 debug=0x43fff" line in /etc/modprobe.d/ipw2200.

Hmmm ... so we need hwcrypto too here? or is the debug= parameter what helps?

 - Alexander

Eugen Pyvovarov (bsn.dev) wrote :

In my own situation if I remove debug parameter - nothing works and wifi device shows like "unmanaged", but with debug parameter wifi works but i have about 20mb syslog each day because of debug messages from wifi card.

Greg Taylor (gtaylor) wrote :

This is all I need on my Toshiba Tecra A4 PTA40E:

options ipw2200 associate=0

Recent kernels have improved wireless to the point where it can actually be used for extended period of times before dropping, rather than every other minute.

Alexander Sack (asac) wrote :

On Thu, Dec 04, 2008 at 01:22:43PM -0000, Eugene Pyvovarov wrote:
> In my own situation if I remove debug parameter - nothing works and wifi
> device shows like "unmanaged", but with debug parameter wifi works but i
> have about 20mb syslog each day because of debug messages from wifi
> card.
>

this sounds like a race. the debug stuff slows down your operation and
somehow the driver works better.

Just associate=0 didnt work? e.g. I think that hwcrypto isnt really
what you want. Why would you add that parameter?

 - Alexander

Alexander Sack (asac) wrote :

On Thu, Dec 04, 2008 at 01:50:36PM -0000, Greg Taylor wrote:
> This is all I need on my Toshiba Tecra A4 PTA40E:
>
> options ipw2200 associate=0
>

This should be the default for ipw2200 since intrepid. Is that on
hardy?

 - Alexander

Eugen Pyvovarov (bsn.dev) wrote :

 Alexander Sack, I tried to remove each parameter and check what happens. I saw that complete line with hwcrypto on this page earlier and just copypaste it. However, without hwcrypto wifi works as well, but when I removed debug option - device became unmanaged again :-\

so now my working config is:
options ipw2200 associate=0 debug=0x43fff

Alexander Sack (asac) wrote :

On Sun, Dec 07, 2008 at 12:25:20PM -0000, Eugene Pyvovarov wrote:
> Alexander Sack, I tried to remove each parameter and check what
> happens. I saw that complete line with hwcrypto on this page earlier and
> just copypaste it. However, without hwcrypto wifi works as well, but
> when I removed debug option - device became unmanaged again :-\
>
> so now my working config is:
> options ipw2200 associate=0 debug=0x43fff
>

tim, could you please look into this?

eugene, can you paste your complete syslog output you get when
connecting using debug?

 - Alexander

Eugen Pyvovarov (bsn.dev) wrote :
Download full text (28.4 KiB)

Hi Alexander,

sure I can post the syslog.
I typed tail -f /var/log/syslog, turned off wireless and turned it on again. There is the result from syslog

Dec 15 17:26:09 bsn-laptop kernel: [20963.045139] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:09 bsn-laptop kernel: [20963.548742] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:10 bsn-laptop kernel: [20964.053770] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:11 bsn-laptop kernel: [20964.556707] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:11 bsn-laptop kernel: [20965.060726] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:12 bsn-laptop kernel: [20965.564801] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:12 bsn-laptop kernel: [20966.068734] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:13 bsn-laptop kernel: [20966.573287] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:13 bsn-laptop kernel: [20967.077291] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:14 bsn-laptop kernel: [20967.581246] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:14 bsn-laptop kernel: [20968.085294] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:15 bsn-laptop kernel: [20968.589275] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:15 bsn-laptop kernel: [20969.093229] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:16 bsn-laptop kernel: [20969.597495] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:16 bsn-laptop kernel: [20970.096993] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:17 bsn-laptop kernel: [20970.601233] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:17 bsn-laptop kernel: [20971.104856] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:18 bsn-laptop kernel: [20971.609218] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:18 bsn-laptop kernel: [20972.112750] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:19 bsn-laptop kernel: [20972.616734] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:19 bsn-laptop pulseaudio[6155]: core-util.c: Failed to open configuration file '/home/bsn/.pulse/volume-restore.table': Permission denied
Dec 15 17:26:19 bsn-laptop pulseaudio[6155]: module-volume-restore.c: Failed to open file '(null)': No such file or directory
Dec 15 17:26:19 bsn-laptop kernel: [20973.121230] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:20 bsn-laptop kernel: [20973.625353] ipw2200: U ipw_wx_get_name Name: unassociated
Dec 15 17:26:20 bsn-laptop NetworkManager: <WARN> nm_device_wifi_set_enabled(): not in expected unavailable state!
Dec 15 17:26:20 bsn-laptop NetworkManager: <info> (eth2): bringing up device.
Dec 15 17:26:20 bsn-laptop kernel: [20973.975500] ipw2200: U ipw_net_open dev->open
Dec 15 17:26:20 bsn-laptop kernel: [20973.976899] ADDRCONF(NETDEV_UP): eth2: link is not ready
Dec 15 17:26:20 bsn-laptop kernel: [20973.977905] ipw2200: U ipw_wx_get_range GET Range
Dec 15 17:26:20 bsn-laptop NetworkManager: <info> (eth2): device state change: 2 -> 3
Dec 15 17:26:20 bsn-laptop kernel: [20973.981604] ipw2200: U ipw_wx_set_mode Set MODE: 2
Dec 15 17:26:20 b...

Oliver Joos (oliver-joos) wrote :

@Tim: sorry for my "Nominated for Jaunty"! It was a mistake! I am only affected by this bug, but not involved in fixing or releasing.

The workarounds (associate=0 and/or debug=0x43fff) do not work for me.

The symptoms here are very similar: WPA2 generates frequent "Firmware error detected. Restarting." particularly when transferring much data. With Intrepid it occurs very often. In Hardy I did also see it, but much less often. One strange observation which might help: in Intrepid the time between "Firmware error detected. Restarting." is always an exact multiple of 30 seconds!

I think there are 3 duplicates to this bug report:
https://bugs.launchpad.net/bugs/295414
https://bugs.launchpad.net/bugs/293426
https://bugs.launchpad.net/bugs/289276 (slightly different symptoms)

Tim Gardner (timg-tpi) wrote :

I just uploaded the latest wireless-testing bits in linux-backports-modules-intrepid last week. Give that a try. I'm also re-assigning this issue to Stefan.

Changed in linux:
assignee: timg-tpi → stefan-bader-canonical
Changed in module-init-tools:
assignee: timg-tpi → nobody
status: Fix Committed → Invalid
Changed in linux:
assignee: timg-tpi → stefan-bader-canonical

urns out my bug report here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/303802 is a duplicate of this one. None of the proposed fixes or workarounds in this report solve the issue in my situation. Is anyone else from this report still following the situation (or still having problems)?

Oliver Joos (oliver-joos) wrote :

Since Jaunty final it is solved for me.

I was able to circumvent this issue by removing network-manager and installing wicd. Could it be that network-manager really is the culprit? This would coincide with findings at the beginning of the comments on this report that network-manager and the driver are "tripping each other up".

Still, it would be nice if this could be pinned down and fixed (if it is indeed still an issue - it could be a configuration issue or something on my end, too). I like network-manager better than wicd...but I need the wireless to function, too.

I actually was connected to a WPA2 network a few weeks ago with no issues,
though I didn't think about it until I saw this e-mail.

I'm using Kubuntu Jaunty, up-to-date, with the Network Manager widget as the
front end for networkmanager.

On Sun, Jul 12, 2009 at 12:19 AM, Alsandair Sneachta <
<email address hidden>> wrote:

> I was able to circumvent this issue by removing network-manager and
> installing wicd. Could it be that network-manager really is the
> culprit? This would coincide with findings at the beginning of the
> comments on this report that network-manager and the driver are
> "tripping each other up".
>
> Still, it would be nice if this could be pinned down and fixed (if it is
> indeed still an issue - it could be a configuration issue or something
> on my end, too). I like network-manager better than wicd...but I need
> the wireless to function, too.
>
> --
> ipw2200 driver no longer works with wpa2 network
> https://bugs.launchpad.net/bugs/264104
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Religion, or the duty which we owe our Creator, and the manner of
discharging it, can be directed only by reason and conviction, not by force
and violence; and therefore all men are equally entitled to the free
exercise of religion, according to the dictates of conscience.
 -- James Madison

Stian Jordet (stian-web) wrote :

I'm also seeing this after the upgrade to Jaunty, it seems. It works perfectly with 2.6.27-11-generic, but fails with 2.6.28-13-generic (I have also tried 2.6.30 from http://kernel.ubuntu.com/~kernel-ppa)

As an additional datapoint, it works when I replaced Network-Manager with Wicd. I really prefer NM, so it's a rather poor workaround for me. It also affects non-encrypted networks for me.

It only happens when transferring data at high data rates (like, faster than my internet connection). For instance when transferring iso-images over NFS (or scp...)

While I have found a workaround, it's pretty annoying not to be able to use NM, because I have a HDSPA card as well.

Stefan Bader (smb) wrote :

Just to make sure this does not miss some information, was the Intrepid installation using the backports modules version or the in-kernel one? This can be found out with "modinfo ipw2200". Both drivers would also be using different firmware.

Stian Jordet (stian-web) wrote :

Not sure what you need from modinfo, but does this help?

version: 1.2.2kmprq
vermagic: 2.6.27-11-generic SMP mod_unload modversions 586

I don't think I had intrepid-backports, but I was probably using intrepid-updates...

Thanks :)

westbywest (westbywest) wrote :

I am curious if anyone who was experiencing this problem with the ipw2200 module has noticed a relationship between CPU temp and driver stability. (For laptops, that is. Probably no effect on desktops.)

I had been intermittently experiencing the problems described in this thread, i.e. wifi connection drops out with repeated "Failed to send SYSTEM_CONFIG: Already sending a command." errors in dmesg, regardless of whether the signal is encrypted.

Several days ago I discovered my HP nw8240 notebook was running quite hot, circa 100C CPU temperature peaks, likely due to degraded thermal junction between the chipsets and fansink.

I've since turned on aggressive CPU frequency throttling to keep the motherboard from melting down until I can get new thermal paste, but I notice now that the wifi seems more stable. No drop-outs yet.

Stian Jordet (stian-web) wrote :

Well, while my computer is pretty hot (It's a fanless Fujitsu-Siemens P7120), I don't it's related.

stianj@chrysler:~$ cat /proc/acpi/thermal_zone/TZ00/temperature
temperature: 40 C

As I wrote earlier, I only have this problem when using Network Manager with kernel 2.6.28 and later. Using Wicd with those kernels works fine, using NM with 2.6.27 or earlier works. Pretty weird.

My laptop is currently having other technical issues (video card is bad), but I'll attempt to give as much info as I can.

I started having this issue with kernel 2.6.27-7, and no kernel version since has worked properly for me. See my bug report (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/303802) for additional logs and whatnot. So far, the kernel versions I have tried this with have been:

Ubuntu 2.6.27-7.15-generic
Ubuntu 2.6.27-7.16-generic
Ubuntu 2.6.27-9.19-generic
Ubuntu 2.6.27-11.22-generic
Various Ubuntu 2.6.28 iterations in Jaunty
2.6.28.10-amaterasu (my own custom build, with the config files copied from the prepackaged Ubuntu builds and slightly modified)

The 2.6.27 kernels were tested with BOTH the in-kernel *and* backports modules, both with no resolution. I apologize for not keeping track of the exact versions of 2.6.28 that I had issues with...but I know I was using the in-kernel modules. I also tried removing the modules, and downloading them manually from the ipw2200 website and setting them up manually. The setup worked, but the problem still persisted.

As for a relationship between heat and all of this, I doubt it has a bearing on it. My laptop's processor runs fairly hot (around the 52C area when I'm doing intensive graphics stuff...or playing flash videos), but I have noticed no correlation between that and my card working better/worse.

As I said in my previous comment, using Wicd has been my personal workaround, just like Stian has found. Using NetworkManager honestly appears to be the problem, or part of the problem, after Ubuntu kernel version 2.6.27. It's important to note that the problem occurs with the Ubuntu packages, because I have used Debian with their kernel and NM packages and had no problems. Unfortunately, I do not have any logs or additional information from my Debian install, so I do not know what versions of those packages I tried.

Also, I've found quite a lot of other bugs that may or may not be related to this one. If anyone wants to sift through additional information in those bugs, they may or may not find something useful.

https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.22/+bug/177295
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/179698
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/187306
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/293426
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/303802
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/352150

Lastly, in bug 303802, Bryan Wu has asked if everyone can test the latest versions of Karmic to see if the bug is still present. I cannot test, as my laptop is not currently in my possession, however I hope others can. Images for testing are available at http://cdimage.ubuntu.com/daily-live/current/. If the bug is present, please run "apport-collect -p linux <bug #>" to gather and attach updated bug information.

Stian Jordet (stian-web) wrote :

Hmm. I've upgraded to karmic tonight (using dist-upgrade, did not do a fresh install). That actually just made it worse. Now it's not usable with network-manager even with my good, old 2.6.27-11-kernel. Or the new 2.6.31-5. Wicd still works fine with any kernel I've tried, so I can still use my computer :) (at least when I find out why I can't mount nfs-shares anymore after the upgrade...)

Stefan Bader (smb) wrote :

As there has been a relationship to the modules options before, can one of you
add the output of "grep . /sys/module/ipw2200/parameters/*" (with the module
loaded)?

Stian Jordet (stian-web) wrote :

Here's mine:

/sys/module/ipw2200/parameters/antenna:0
/sys/module/ipw2200/parameters/associate:0
/sys/module/ipw2200/parameters/auto_create:1
/sys/module/ipw2200/parameters/bt_coexist:0
/sys/module/ipw2200/parameters/burst_duration_CCK:0
/sys/module/ipw2200/parameters/burst_duration_OFDM:0
/sys/module/ipw2200/parameters/channel:0
/sys/module/ipw2200/parameters/cmdlog:0
/sys/module/ipw2200/parameters/debug:0
/sys/module/ipw2200/parameters/disable:0
/sys/module/ipw2200/parameters/hwcrypto:0
/sys/module/ipw2200/parameters/led:0
/sys/module/ipw2200/parameters/mode:0
/sys/module/ipw2200/parameters/qos_burst_enable:0
/sys/module/ipw2200/parameters/qos_enable:0
/sys/module/ipw2200/parameters/qos_no_ack_mask:0
/sys/module/ipw2200/parameters/roaming:1
/sys/module/ipw2200/parameters/rtap_iface:0

:)

Stefan Bader (smb) wrote :

Stian Jordet wrote:
> Here's mine:
>
> /sys/module/ipw2200/parameters/associate:0
> /sys/module/ipw2200/parameters/auto_create:1
> /sys/module/ipw2200/parameters/roaming:1

Alexander, you mentioned that roaming probably should also be turned off, righ?
Stian, you might try to add "options ipw2200 roaming=0" in that case.

Alexander Sack (asac) wrote :

On Mon, Aug 31, 2009 at 04:30:17PM +0200, Stefan Bader wrote:
> Stian Jordet wrote:
> >Here's mine:
> >
> >/sys/module/ipw2200/parameters/associate:0
> >/sys/module/ipw2200/parameters/auto_create:1
> >/sys/module/ipw2200/parameters/roaming:1
>
> Alexander, you mentioned that roaming probably should also be turned off, righ?
> Stian, you might try to add "options ipw2200 roaming=0" in that case.
>
>

Yes, atm all that magic is done by wpasupplicanta alone. So try to
make drivers as much dumb as possible. If there is a automagic
"roaming" feature it should be turned off for wpasupp/nm use.

 - Alexander

Stian Jordet (stian-web) wrote :

Sorry for the very late reply. Changing the module's roaming option didn't change anything - I'm still resorted to using wicd (with no 3g support...)

-Stian

Elliot (elliot-orwells) wrote :

I am also experiencing this bug after upgrading from 10.04 to 11.10.

In 10.04 (fresh install) I did not had any problems, it started right after upgrading. Tried all configs above, (and associate=0 was already the default). Perhaps most people here upgraded their laptops and this became quiet?

dmesg:
[ 482.839845] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.
(...)
[ 2726.480032] eth1: no IPv6 routers present
(...)
[ 3812.489364] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.
(...)
[ 4006.536026] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
[ 4006.537293] render error detected, EIR: 0x00000010
[ 4006.537297] page table error
[ 4006.537299] PGTBL_ER: 0x00000100
[ 4006.537305] [drm:i915_report_and_clear_eir] *ERROR* EIR stuck: 0x00000010, masking
[ 4006.537315] render error detected, EIR: 0x00000010
[ 4006.537318] page table error
[ 4006.537320] PGTBL_ER: 0x00000100
[ 4044.647465] ipw2200: Failed to send SYSTEM_CONFIG: Already sending a command.

$grep . /sys/module/ipw2200/parameters/*

/sys/module/ipw2200/parameters/antenna:0
/sys/module/ipw2200/parameters/associate:0
/sys/module/ipw2200/parameters/auto_create:1
/sys/module/ipw2200/parameters/bt_coexist:0
/sys/module/ipw2200/parameters/burst_duration_CCK:0
/sys/module/ipw2200/parameters/burst_duration_OFDM:0
/sys/module/ipw2200/parameters/channel:0
/sys/module/ipw2200/parameters/cmdlog:0
/sys/module/ipw2200/parameters/debug:0
/sys/module/ipw2200/parameters/disable:0
/sys/module/ipw2200/parameters/hwcrypto:0
/sys/module/ipw2200/parameters/led:1
/sys/module/ipw2200/parameters/mode:0
/sys/module/ipw2200/parameters/qos_burst_enable:0
/sys/module/ipw2200/parameters/qos_enable:0
/sys/module/ipw2200/parameters/qos_no_ack_mask:0
/sys/module/ipw2200/parameters/roaming:1
/sys/module/ipw2200/parameters/rtap_iface:0

Changed to:
/sys/module/ipw2200/parameters/antenna:0
/sys/module/ipw2200/parameters/associate:0
/sys/module/ipw2200/parameters/auto_create:1
/sys/module/ipw2200/parameters/bt_coexist:0
/sys/module/ipw2200/parameters/burst_duration_CCK:0
/sys/module/ipw2200/parameters/burst_duration_OFDM:0
/sys/module/ipw2200/parameters/channel:0
/sys/module/ipw2200/parameters/cmdlog:0
/sys/module/ipw2200/parameters/debug:278527
/sys/module/ipw2200/parameters/disable:0
/sys/module/ipw2200/parameters/hwcrypto:1
/sys/module/ipw2200/parameters/led:1
/sys/module/ipw2200/parameters/mode:0
/sys/module/ipw2200/parameters/qos_burst_enable:0
/sys/module/ipw2200/parameters/qos_enable:0
/sys/module/ipw2200/parameters/qos_no_ack_mask:0
/sys/module/ipw2200/parameters/roaming:1
/sys/module/ipw2200/parameters/rtap_iface:0

and couldn't even associate.

$lspci -v

04:02.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
 Subsystem: Intel Corporation IBM ThinkPad R50e
 Flags: bus master, medium devsel, latency 64, IRQ 21
 Memory at a0202000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [dc] Power Management version 2
 Kernel driver in use: ipw2200
 Kernel modules: ipw2200

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers