Low network performance of ipw2200

Bug #187306 reported by Christoph Langner on 2008-01-30
20
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I think the WLAN performance of the ipw2200 kernel module isn't as good as is should be. I'm running a FSC Lifebook S-6120D here with Intel PRO/Wireless 2200BG chipset. Right now i'm using the latest hardy kernel within Ubuntu Gutsy Gibbon.

<snip>
$ uname -r
2.6.24-5-generic

$ lspci | grep Net
01:0d.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)

$ lsmod | grep ipw
ipw2200 146120 0
ieee80211 35528 1 ipw2200
</snip>

I'm using WLAN at two different locations. At home within ~5m distance from the AP and at my university. At home WLAN works good. But at the university it's troublesome. I'm sitting here in between a number of people with laptops inside our shiny new 24/7 library. I'm sure there are some people with similar notebooks like the one i've got, most of them use Windows, some MacOS X. I'm one of the few Linux users. All these guys have decent WLAN reception, except me. I can see our WLAN, and the reception is not bad. But i can't transmit data without a lot of packet losses.

<snip>
iwlist scan
...
eth1 Scan completed :
          Cell 01 - Address: 0A:0F:A3:A9:18:B4
                    ESSID:"VPN/WEB"
                    Protocol:IEEE 802.11bg
                    Mode:Master
                    Frequency:2.462 GHz (Channel 11)
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Quality=39/100 Signal level=-77 dBm
                    Extra: Last beacon: 1560ms ago
</snip>

But when i try to start vpnc it usually fails. The reason: paket loss. When i ping my DNS server, i get over 50% packet loss.

<snip>
$ ping -c 100 129.13.64.5
PING 129.13.64.5 (129.13.64.5) 56(84) bytes of data.

--- 129.13.64.5 ping statistics ---
100 packets transmitted, 45 received, 55% packet loss, time 99043ms
rtt min/avg/max/mdev = 1.327/3.949/21.601/4.593 ms
</snip>

When i watch /var/log/messages while connecting to our network i see messages like this

<snip>
$ tail -f -n 0 /var/log/messages
Jan 30 14:20:25 stein kernel: [ 2479.061629] ADDRCONF(NETDEV_UP): eth1: link is not ready
Jan 30 14:20:26 stein kernel: [ 2479.538324] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Jan 30 14:20:49 stein dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.host_name
Jan 30 14:20:50 stein dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.nis_domain
Jan 30 14:20:50 stein dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.nis_servers
Jan 30 14:20:58 stein kernel: [ 2511.367516] tun0: Disabled Privacy Extensions
</snip>

I even noticed

<snip>
Jan 30 13:51:19 stein kernel: [ 732.956386] ipw2200: Firmware error detected. Restarting.
</snip>

When I boot into WinXP WLAN works much better. In other words: Same place, same WLAN, same computer, same time: WLAN under Windows works, WLAN under Linux doesn't work as it should.

Hi Christoph,

Per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux:
status: New → Incomplete
Christoph Langner (chrissss) wrote :
Christoph Langner (chrissss) wrote :
Christoph Langner (chrissss) wrote :
Changed in linux:
status: Incomplete → New
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
boskicinek (boski-cinek) wrote :

I have similar problem. I got ton of this:
[17850.977781] ipw2200: Firmware error detected. Restarting.
[17928.125610] ipw2200: Firmware error detected. Restarting.
[18013.535665] ipw2200: Firmware error detected. Restarting.
[18231.611602] ipw2200: Firmware error detected. Restarting.
[18243.717162] ipw2200: Firmware error detected. Restarting.
[18248.590127] ipw2200: Firmware error detected. Restarting.
[18270.834660] ipw2200: Firmware error detected. Restarting.
[18311.263507] ipw2200: Firmware error detected. Restarting.
[18349.463382] ipw2200: Firmware error detected. Restarting.
[18391.082067] ipw2200: Firmware error detected. Restarting.
[18402.126980] ipw2200: Firmware error detected. Restarting.

Even more weird, my screen goes blank (like xset dpms force off) after I press kill switch on my HP NX6110! It also hurts performance of my desktop.
$ uname -r
2.6.24-5-386

Eric Amundson (sewmyheadon) wrote :

Hi Folks,

I've been having problems with my ipw2200 wireless on an Inspiron 9300 laptop since upgrading to Hardy. Have searched forums and Launchpad and can't seem to locate one, clear answer.

Right now, I'm running Hardy with the latest updates using Wicd. I have another laptop running the same that uses a Broadcom card and it's working perfectly.

I can connect using the IPW2200, but it's really slow.

eric@poe:~$ dmesg | grep ipw
[ 13.991491] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[ 13.991496] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[ 14.037007] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[ 16.411152] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)
[ 515.241242] ipw2200: Firmware error detected. Restarting.

Seems like there's a firmware issue. I'll attach my log files as requested by the Kernel Team.

Eric Amundson (sewmyheadon) wrote :
Eric Amundson (sewmyheadon) wrote :
Eric Amundson (sewmyheadon) wrote :

My ipw2200 was working "fine" - with the occasional packet reset, but with some recent upgrade performance has dropped to non-functional.

It has only since I switched back to a wired network have I realised how slow the ipw2200 had become.

I'm sitting here with two laptops in front of me -

Dell Inspiron 8600 - ipw2200 - won't work any more ( ~60% packet loss )
Dell Lattitude 430 - iwl3945 - works a treat

Both trying to go to the same access point.

~> cat /proc/version_signature
Ubuntu 2.6.24-19.36-generic

dmesg attached..

lspci gives :

02:03.0 Network controller [0280]: Intel Corporation PRO/Wireless 2200BG Network Connection [8086:4220] (rev 05)
        Subsystem: Intel Corporation Dell Latitude D600 [8086:2722]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (750ns min, 6000ns max), Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 7
        Region 0: Memory at faffc000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=1 PME-

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Christoph Langner (chrissss) wrote :

Just installing linux-image-2.6.27-* doesn't work. I installed

$ dpkg -l *2.6.27*
[...]
un linux-doc-2.6.27 <keine> (keine Beschreibung vorhanden)
ii linux-image-2.6.27-2-gen 2.6.27-2.3 Linux kernel image for version 2.6.27 on x86/x86_64
ii linux-restricted-modules 2.6.27-2.2 Non-free Linux kernel modules for version 2.6.27 on x86/x86_64
un linux-source-2.6.27 <keine> (keine Beschreibung vorhanden)

but the firmware can't be found

$ dmesg | grep ipw2200
[ 27.204146] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[ 27.204151] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[ 27.294100] ipw2200 0000:01:0d.0: PCI INT A -> Link[LNKC] -> GSI 11 (level, low) -> IRQ 11
[ 27.294226] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[ 27.294286] firmware: requesting ipw2200-bss.fw
[ 28.507315] ipw2200: ipw2200-bss.fw request_firmware failed: Reason -2
[ 28.507326] ipw2200: Unable to load firmware: -2
[ 28.507330] ipw2200: failed to register network device
[ 28.507428] ipw2200 0000:01:0d.0: PCI INT A disabled
[ 28.507455] ipw2200: probe of 0000:01:0d.0 failed with error -5

I'll wait for intrepid alpha-5

Christoph Langner (chrissss) wrote :
Download full text (3.3 KiB)

I booted my FSC Lifebook S-6120 with ipw2200 chipset with Ubuntu Intrepid Ibex 8.10 Alpha5. Again i'm sitting here inside our shiny still new 24/7 library. First I made some tests while I'm connected via cable to our university lan.

=== Intrepid Ibex Alpha5, LAN ===
$ sudo vpnc
VPNC started in background (pid: 9353)...

$ time wget http://cachefly.cachefly.net/10mb.test
--2008-09-06 18:05:22-- http://cachefly.cachefly.net/10mb.test
Resolving cachefly.cachefly.net... 205.234.175.175
Connecting to cachefly.cachefly.net|205.234.175.175|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10485760 (10M) [application/octet-stream]
Saving to: `10mb.test'

100%[======================================>] 10,485,760 8.48M/s in 1.2s

2008-09-06 18:05:23 (8.48 MB/s) - `10mb.test' saved [10485760/10485760]

real 0m1.245s
user 0m0.016s
sys 0m0.168s

$ ping -q -c 100 www.google.de
PING www.l.google.com (209.85.129.99) 56(84) bytes of data.

--- www.l.google.com ping statistics ---
100 packets transmitted, 100 received, 0% packet loss, time 99396ms
rtt min/avg/max/mdev = 3.951/4.727/10.506/0.699 ms
=== /Intrepid Ibex Alpha5, LAN ===

Now i'm switching to WLAN.

=== Intrepid Ibex Alpha5, WLAN ===
$ sudo vpnc
VPNC started in background (pid: 9353)...

$ time wget http://cachefly.cachefly.net/10mb.test
--2008-09-06 17:58:18-- http://cachefly.cachefly.net/10mb.test
Resolving cachefly.cachefly.net... 205.234.175.175
Connecting to cachefly.cachefly.net|205.234.175.175|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10485760 (10M) [application/octet-stream]
Saving to: `10mb.test'

100%[======================================>] 10,485,760 142K/s in 74s

2008-09-06 17:59:32 (139 KB/s) - `10mb.test' saved [10485760/10485760]

real 1m13.712s
user 0m0.084s
sys 0m0.448s

$ ping -q -c 100 www.google.de
PING www.l.google.com (209.85.129.147) 56(84) bytes of data.

--- www.l.google.com ping statistics ---
100 packets transmitted, 99 received, 1% packet loss, time 99394ms
rtt min/avg/max/mdev = 6.523/13.569/93.803/12.430 ms
=== /Intrepid Ibex Alpha5, WLAN ===

Back in Ubuntu Hardy Heron i repeat those tests

=== Hardy Heron 8.04, 2.6.24-19-generic, WLAN ===
$ sudo vpnc
vpnc: no response from target

$ time wget http://cachefly.cachefly.net/10mb.test
--20:20:15-- http://cachefly.cachefly.net/10mb.test
           => `10mb.test'
Auflösen des Hostnamen »cachefly.cachefly.net«.... 205.234.175.175
Verbindungsaufbau zu cachefly.cachefly.net|205.234.175.175|:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 10.485.760 (10M) [application/octet-stream]

100%[====================================>] 10.485.760 51.73K/s ETA 00:00

20:21:50 (107.61 KB/s) - »10mb.test« gespeichert [10485760/10485760]

real 1m35.216s
user 0m0.104s
sys 0m0.320s

$ ping -q -c 100 www.google.de
PING www.l.google.com (209.85.129.104) 56(84) bytes of data.

--- www.l.google.com ping statistics ---
100 packets transmitted, 99 received, 1% packet loss, time 99005ms
rtt min/avg/max/mdev = 4.998/16.177/67.245/9.824 ms
=== /Hardy Heron 8.04, 2.6.24-19-generic, WLAN ===

My experience with Kernel 2.6...

Read more...

Setting this to "Fix Released" based on the decision to stick with the 2.6.27 kernel for Intrepid - https://lists.ubuntu.com/archives/kernel-team/2008-September/003107.html

Changed in linux:
status: Triaged → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Steven Harms (sharms) wrote :

Consolidating this to #352150 - it is not fixed with Intrepid kernel nor Jaunty.

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers