(Intrepid, Hardy) Intel 4965 wlan stops working

Bug #179698 reported by Ing0R on 2008-01-01
34
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Unknown
High
linux (Ubuntu)
Medium
Unassigned

Bug Description

The wireless nic of my thinkpad R61 (Intel 4965 a/g/n WLAN) stops to work after some minutes to many houres of uptime.
When this had happened, I removed the iwl4965 kernel module and reinserted it. The nic did not do anything but /var/log/syslog shows about ten messages per second
> Jan 1 17:10:53 tp kernel: [52384.933004] iwl4965: HARDWARE GONE?? INTA == 0x000000000000000000000000000000000000000000000000000000000000000000000000ffffffff

This may have something to do with http://<email address hidden>/msg29760.html

Ing0R (ing0r) wrote :

The nic continues to 'disappear' after today's kernel update.

$uname -r
2.6.24-2-generic

Ing0R (ing0r) wrote :

I disabled bluetooth and my wlan nic does no longer disappear.

Ing0R (ing0r) wrote :

2.6.24-5-generic in the amd64 version is also affected.

Hi Ing0R,

Just curious if the issue still exists in the latest kernel release (2.6.24-8)? Also, the iwlwifi drivers are now in the kernel, version 1.1.17. I believe linux-ubuntu-modules has an update version of the iwlwifi drviers, version 1.2.0. Just curious what happens if you run the 1.1.17 version. Also, could you attach your entire dmesg output which captures these messages? Thanks.

Changed in linux-ubuntu-modules-2.6.24:
status: New → Incomplete
Ing0R (ing0r) wrote :

I have seen it once with 2.6.24-8-generic (x86_64) shortly after 2.6.24-8-generic was released in the hardy repo. Btw bluetooth was disabled so please ignore my post from 2008-01-21.

Ing0R (ing0r) wrote :

My laptop has now an uptime of more than 6 days. I think the issue is gone. In the past I had never more than three days without my wlan disappearing. Maybe I had not rebootet into the new kernel an I remembered faultly on 2008-02-19.

Hi Ing0R,

Thanks for the update. I'm going to go ahead and close this report. Seems like things are resolved. Feel free to reopen if you see any regressions.. Thanks!

Changed in linux-ubuntu-modules-2.6.24:
status: Incomplete → Fix Released
Ing0R (ing0r) wrote :

After circa 40 minutes uptime I experienced it again :(

Changed in linux-ubuntu-modules-2.6.24:
status: Fix Released → New
Ing0R (ing0r) wrote :

seen in 2.6.24-11-generic

Ing0R (ing0r) wrote :

2.6.24-12-generic is as bad as 2.6.24-11-generic: less than 30 minutes until wlan stops. (opposed to 8 days with 2.6.24-10-generic)

Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged

Hi IngOR,

An updated version of the iwlwifi drivers (version 1.2.25) was recently added to the linux-backports-modules-2.6.24 package. It would be good if you could retest once lbm with the update is published and available. Thanks.

Ing0R (ing0r) wrote :

Today my nic stopped working. I have linux-backports-modules-2.6.24-15-generic installed.
The nic did not disappear after kernel module un- and reload. The log files are not spammed.

Btw: I now have a "wlan1". I will try to reinstall hardy because I lost overview with my networking stuff for virtual machines (I tried VirtualBox and this new integrated VM host)

I am also still experiencing this problem. I'm attaching a dmesg from right after it happened. I am on 64-bit Hardy. Let me know if I can provide anything else of use to you.

Ing0R (ing0r) wrote :

Seen in 2.6.24-17 from hardy proposed.

Ing0R (ing0r) wrote :

Seen in 2.6.26-3 (intrepid)

Ing0R (ing0r) wrote :
Ing0R (ing0r) wrote :

and again in 2.6.26-4-generic

Btw this happens when wlan0 is in this strange state.
ingo@R61:/var/log$ sudo ifconfig wlan0 down
ingo@R61:/var/log$ sudo ifconfig wlan0 up
SIOCSIFFLAGS: Input/output error

There is no linux-ubuntu-modules-2.6.26 module installed on my system. So I wonder which is the correct package to file this bug against.

Hi Ing0R,

Thanks for testing Intrepid and the feedback, it's much appreciated. As you noticed there is no linux-ubuntu-modules for Intrepid. Beginning with the Intrepid development cycle the linux-ubuntu-modules package was merged into the linux kernel source package. I'm going to go ahead and move this bug forward to the "linux" kernel source package. Thanks.

Murray Cumming (murrayc) wrote :

Is there any chance of a fix for this going into Hardy?

Hi Murray,

I'm going to try to escalate this issue to the Intel contacts I have. We'll want to try to get a patch against Intrepid first and then see what can be done in terms of backporting to Hardy. I feel this sort of issue would qualify for a Stable Release Update - http://wiki.ubuntu.com/StableReleaseUpdates but we'll need to isolate the fix first. I know that doesn't help much with an immediate solution so thanks for you patience.

Ing0R (ing0r) wrote :

I stumbled upon this bug http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1700 which looks very similar to this here. Is it the same issue?

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Ing0R (ing0r) wrote :

Seen in 2.6.27-2-generic.

Yingying Zhao (yingying-zhao) wrote :

Is vPRO/AMT enabled on this machine?

Ing0R (ing0r) wrote :

I think it's not enabled. I searched for vPRO in the bios setup but could not find it. I think there was such a setting in a previous version of the bios of this machine.
Is there a way to find out from the OS environment?

Ing0R (ing0r) wrote :

seen in 2.6.27-3-generic.

WLAN does not work at all on an Acer TravelMate 6292 with an Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61). Maybe this is due to the fact that the additional key for switching on / switching off WLAN is currently not supported. Does this report belong here, or is this a separate bug?

PS This relates to Ubuntu 8.10 64-Bit Alpha with all updates.

Ing0R (ing0r) wrote :

oss_test_launchpad: This bug is about a wifi card which initially works and and stops after a random period of time. I think your bug is something separate.

Btw after looking through some other kernel related bugs I think this bug also deserves "high" importance.

Ing0R (ing0r) wrote :

2.6.27-4-generic shows the "hardware gone" in dmesg:

[18754.621720] iwlagn: HARDWARE GONE?? INTA == 0x000000000000000000000000000000000000000000000000000000000000000000000000ffffffff
[18754.623958] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
[18760.440088] wlan0: No ProbeResp from current AP 00:13:49:08:55:05 - assume out of range
[18761.068075] iwlagn: Error sending REPLY_SCAN_CMD: time out after 500ms.
[18761.568082] iwlagn: Error sending REPLY_SCAN_ABORT_CMD: time out after 500ms.
[18761.568161] iwlagn: TX Power requested while scanning!
[18762.068083] iwlagn: Error sending REPLY_RXON: time out after 500ms.
[18762.068099] iwlagn: Error setting new RXON (-110)
[18762.068112] wlan0: authenticate with AP 00:13:49:08:55:05
[18762.269076] wlan0: authenticate with AP 00:13:49:08:55:05
[18762.469082] wlan0: authenticate with AP 00:13:49:08:55:05
[18762.668091] wlan0: authentication with AP 00:13:49:08:55:05 timed out
[18775.985096] iwlagn: Error sending REPLY_SCAN_ABORT_CMD: time out after 500ms.
[18775.985128] iwlagn: Aborted scan still in progress after 100ms
[18775.985134] wlan0: Failed to config new SSID to the low-level driver

Hipopo (hipopo) wrote :

Hello,

I have the same problem with the same Wireless card : Intel pro/wireless 4965 on Ubuntu Hardy Heron.
I don't have any problem with a non-encrypted connection, but the connection with a wpa/TTLS/TKIP/PAP network with a certificate work during between five minutes and one hour.
Ing0R : have you find a solution at this problem?
have you got any problem with Ubuntu Intrepid Ibex?

Thank you,

Ing0R (ing0r) wrote :

@Hipopo:
The only solution is to buy another nic. I have tried debian and fedora and experienced the same bug.
As the title of this bug says, it is also in Intrepid Ibex.

Ing0R (ing0r) wrote :

Seen in 2.6.27-5-generic (just as someone unplugged my ac adapter)

Ing0R (ing0r) wrote :

Seen in 2.6.27-7-generic.

ariendj (ariendj) wrote :

Seen in 2.6.27-7-generic with all packets up to date on a vPro/Centrino Duo MSI PR620 Laptop with 4965AGN rev=0x4.

Since some 8.10 update, WLAN now works on an Acer TravelMate 6292 (see above).

corigo (damon-corigo) wrote :

I just upgraded my Lenovo T61 with Intel 4965 a/g/n to Intrepid.
1. Network Manager wouldn't save my WEP info (wouldn't store my authentication type as ASCII)
2. May have caused some kernel storms
3. Network Manager crashed
4. Launching Network Manager from the Applications menu launched a legay version that didn't recognize the Linux distro and asked to confirm the distro. Intrepid was not in the list.

Installed linux-modules-backport-intrepid
1. Network Manager crashed every time I tried to display the Advanced settings for the WEP connection.

No connection yet... (obviously)

This bug may be related somehow (or may actually be the same thing):

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/229611

tonyw (tony-whyman) wrote :

I think I am just about ready to give up on Intrepid for now and re-install Hardy on my Laptop. Even with every update, proposed update and backport installed neither the Intel 4965 AGN Wireless or the Realtek AC883 sounds works. They worked fine under Hardy. The Laptop hangs every time it boots. It can see Wireless networks but not connect to them (even after changing the useless (US) default to EU).

I would not recommend anyone with an Intel chipset upgrading to Intrepid. You only have to google to find out how many problems people are having. It has the feel of an "alpha" about it.

My 4965 is working fine on Wireless G networks. Are you talking about on
N? Maybe your problem is stemming from proposed and/or backports being
enabled, although I do have the linux modules backports package installed.

On Tue, Nov 18, 2008 at 5:40 AM, tonyw <email address hidden>wrote:

> I think I am just about ready to give up on Intrepid for now and re-
> install Hardy on my Laptop. Even with every update, proposed update and
> backport installed neither the Intel 4965 AGN Wireless or the Realtek
> AC883 sounds works. They worked fine under Hardy. The Laptop hangs every
> time it boots. It can see Wireless networks but not connect to them
> (even after changing the useless (US) default to EU).
>
> I would not recommend anyone with an Intel chipset upgrading to
> Intrepid. You only have to google to find out how many problems people
> are having. It has the feel of an "alpha" about it.
>
> --
> (Intrepid, Hardy) Intel 4965 wlan stops working
> https://bugs.launchpad.net/bugs/179698
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "linux" source package in Ubuntu: Triaged
>
> Bug description:
> The wireless nic of my thinkpad R61 (Intel 4965 a/g/n WLAN) stops to work
> after some minutes to many houres of uptime.
> When this had happened, I removed the iwl4965 kernel module and reinserted
> it. The nic did not do anything but /var/log/syslog shows about ten
> messages per second
> > Jan 1 17:10:53 tp kernel: [52384.933004] iwl4965: HARDWARE GONE?? INTA
> ==
> 0x000000000000000000000000000000000000000000000000000000000000000000000000ffffffff
>
> This may have something to do with
> http://<email address hidden>/msg29760.html
>

Ing0R (ing0r) wrote :

> My 4965 is working fine on Wireless G networks.
Mine not. Neither with Hardy, nor with Intrepid, nor with Jaunty.

I am talking about G networks. I cannot remember any N network on which I have access.
I have linux-backport-modules-2.6.27-intrepid installed.
The problem occures at home (802.11g tkip-encryption), (802.11g WEP), at university with 802.11a access points available but only g access points are used(?) (http://www.rz.fhtw-berlin.de/de/internet_notebook/wireless_lan/linux_bsd/manuell/index.html).
I have not tried unencrypted networks for a long time but I will if requested.

tonyw (tony-whyman) wrote :

>My 4965 is working fine on Wireless G networks. Are you talking about on
N? Maybe your problem is stemming from proposed and/or backports being
enabled, although I do have the linux modules backports package installed

I am trying to use it with a 'G' network on channel 13. This needs an extra modprobe option lbm_cwcfg80211 ieee80211_regdom='EU' before it will even see it - but still won't connect. (An aside: why the silly default as it's the base station and not the AP that needs to worry about the allowable channels)

I started with a vanilla upgrade of Hardy to Intrepid and have then incrementally added the proposed updates and finally the backports - but to no avail. No sound or Wifi and a 2 min hang on every boot. I wish I had applied the if it ain't broke don't fix it maxim as my Laptop worked fine under Hardy.

If you look around the forums, you will find lots of people reporting problems. Intrepid should never have been released with such a flaky driver.

Mediazinmann (mk-klenk) wrote :

Hi,

having a T61p:
  Model: "Intel Lenovo ThinkPad T61"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x4230 "PRO/Wireless 4965 AG or AGN Network Connection"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x1111 "Lenovo ThinkPad T61"
  Revision: 0x61
  Driver: "iwlagn"

Kernel: 2.6.27-8-generic

I started on this NB with a new installation of Intrepid Kubuntu 64bit. I also had problems configuring encrypted Network with KNetworkmanager. I could not change these settings properly with Knetworkmanager (neither several keys for encryption nor without encryption),

 As I deleted all Network configuration from KNetwork Manager and started from Scratch (no encrypted wlan) I've set up a working configuration immediately. After that I encrypted my wlan with WPA2 CCMP. It seems, that KNetworkmanager somehow couldn't manage my first configuration properly.

My WLAN works well.... until I try to disable it with "soft-key" (fn + F5). This soft-switch switches bluetooth + wlan. Switching too fast affects a non-working wlan module. But I can reset WLAN by switching off and on with hardware-switch.

Maybe this bug is also related to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/247489
To which I reported additional infos from Logs on switching on and off my wlan.

tonyw (tony-whyman) wrote :

Having spent many unhappy hours trying to get Intrepid to work on my Laptop, I finally gave up, backed-up the important files and prepared to re-install Hardy on my Laptop. But before I did so, I thought I would do a clean install of Intrepid and see if it made a difference - it did. Everything now works! The Wireless works fine as does the sound. The only observation is that the WiFi reg domain is set to the US default and needs a syscntl change to set it to Europe (Why isn't this a locale setting?).

It seems that the problem is in the upgrade from Hardy to Intrepid and not Intrepid itself, and a clue to the reason may be found in another problem.

I also use Bluetooth with my Nokia phone for mobile internet access. This worked fine after the upgrade from Hardy to Intrepid, but did not work on the Intrepid clean install. That is until I changed the OTT security policy to permit me to use a modem to access the internet. The permissions on pppd seemed to have changed to stop world execute - although on the upgrade version these permissions remained unchanged.

My guess is that the upgrade problem is the policy manager. Many permissions have changed and these are not being correctly reflected in the upgrade.

Ing0R (ing0r) wrote :

Running kernel 2.6.28-2-generic my laptop occasionally crashes after some minutes of wifi activity.
I think it relates to this bug because it happens on the same machine under the same circumstances and seems to be related to the kernel.

Ing0R (ing0r) wrote :

Same observation on a amd64 ubuntu 2.6.28-2-generic.

Ing0R (ing0r) wrote :

Seen the
iwlagn: Error sending REPLY_RXON: time out after 500ms.
in jaunty i386.

Ing0R (ing0r) wrote :

Leann, you have set this bug to triaged on 14 Mar 08 23:19. Is anyone still working on it?

http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1700 is NOT related to this bug. Please remove the reference and create a new to http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1855 which I have just opened.

Hi IngOR,

You may want to try installing the linux-backports-modules-intrepid package that is currently in intrepid-proposed as it contains an even newer compat-wireless stack. See https://edge.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.27 - "Updated to wireless-testing master-2008-11-17" . To enable intrepid-proposed do the following:

1) cd /etc/apt/sources.list.d
2) create a file "intrepid-proposed.list" which contains the following two lines (sudo vim intrepid-proposed.list):

deb http://archive.ubuntu.com/ubuntu/ intrepid-proposed main
deb-src http://archive.ubuntu.com/ubuntu/ intrepid-proposed main

3) sudo apt-get update
4) sudo apt-get install linux-backports-modules-intrepid
5) sudo rm /etc/apt/sources.list.d/intrepid-proposed.list
6) sudo apt-get update

Steps 5 and 6 basically undo the enabling of intrepid-proposed. Of course you'll finally need to reboot to test.

Additionally since you also have an upstream bug report open, I'd also suggest testing the latest compat-wireless stack - http://linuxwireless.org/en/users/Download - and let upstream know your results. Thanks.

Changed in linux:
status: Unknown → Confirmed
Ing0R (ing0r) wrote :

linux-backports-modules-2.6.27-10-generic (2.6.27-10.8) is affected. (only tested i386)

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Changed in linux:
status: Confirmed → In Progress
Changed in linux:
status: In Progress → Invalid
Changed in linux:
status: Invalid → Confirmed
Changed in linux:
status: Confirmed → In Progress
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Ing0R (ing0r) on 2010-03-21
Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) on 2010-12-03
tags: added: acpi-bad-address
Charlie Kravetz (charlie-tca) wrote :

Setting this back to triaged. Upstream has a patch that appears to be waiting for something.

Thanks for being so patient.

Changed in linux (Ubuntu):
status: New → Triaged
Changed in linux:
importance: Unknown → High
status: In Progress → Unknown
Brad Figg (brad-figg) on 2011-05-06
tags: added: b73a1py79

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.