initramfs error/problem ubuntu 8.04

Bug #222176 reported by azurehi on 2008-04-25
42
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I cannot install HH ubuntu 8.04 (not kubuntu 8.04) because of an initramfs error/problem. I have downloaded images from several different mirrors, including the alternate version and burned each on new discs at the slowest speed and Always get the screen with BusyBox v1.1.3(Debian 1:1.1.3-5ubuntuiz) built-in shell (ash)
initramfs. I have tried changing BIOS setting from IDE to RAID and at F6 adding pci-nomsi. Nothing works.

I have used ubuntu successfully since 6.06. Could this be related to the kernel 2.6.24?

rathel (rathel) wrote :

Same thing happens for me, except that the live cd for the x86 boots and installs fine but when I try to boot into the installed OS the problem occurs, and I can't even get into the AMD64 live cd version when I know my processor supports it.

dalesyk (dale-czexan) wrote :

same issue here with both x32 and x64 8.04 desktop cd verified cd on another system. Install option or verify cd option both drop into busybox shell after a few seconds. This is an older amd x64 system that works well with many other Linux distros. More info available by request.

Bert Massop (bert-massop) wrote :

Try to Wubi-install the Alternate CD and then boot HH with the pci=nomsi option. I have HH running that way (well, it's certainly not quite elegant, but half-working is better than non-working).

I have not tested x86 yet, but I can confirm this bug applies to AMD64.

Bert Massop (bert-massop) wrote :

For me, pci=nomsi also works with the normal Desktop AMD64 cd. With this option, I can install and run HH without any problems.

The problem seems to be an incompatibility with certain IDE/RAID/SATA chips (when BusyBox pops up, it is most likely that the boot process failed because it couldn't find the CD-ROM you're booting from). Before loading busybox, it tries to read from my floppy drive (with no disk in it, ofcourse). After loading the kernel ("Kernel Alive") there is no activity on the harddisks nor on the cd drive, and then busybox pops up. Are you experiencing the same symptoms? I did this with 100% MD5 verified media, burned at 4,0x.

I am using a MSI K9A Platinum with ATI SB600 IDE/RAID/SATA controller (southbridge). I'm using a Pioneer IDE DVD-burner to boot the cd.

Please reply: what kind of motherboard and IDE/RAID/SATA controller are you using? Are you using a IDE or SATA cd/dvd device? It might be a specific chipset or hardware problem.

dalesyk (dale-czexan) wrote :

My hardware is MSI K8N Neo2 Platinum (nvidia nforce3 ultra chipset). pressing F6 and adding a space and pci=nomsi doesn't change anything. I'm more familiar with redhat based distros, so if I'm doing this wrong, let me know. I haven't downloaded the alternate cd yet. I did remove the quiet and splash boot option to see more info. Now the last thing I see are messages about sda and sdb my sata disks. I may try booting from an external cdrom to bypass the sata controller, but I don't have the time today.

rathel (rathel) wrote :

Chipset: P35/G33 (Bearlake) Processor to I/O Controller
SouthBridge: 82801IR (ICH9R) LPC Interface Controller
DVD Writer: TSSTcorp DVD+-RW TS-H653B ATA ATAPI
Hope this helps, I haven't tried the pc=nomsi yet. Will try in a little bit.

Alan Fung (fccaa33) wrote :

I have the same problem!

The configuration of my PC is
Motherboard: Asus A8N-VM CSM
HDD: 2 WD HDs (both of them are ATA)
and the DVD writer is also ATA
No sata device

At first, I upgrade my system from 7.10. But I found that, after the upgrade, the DVD writer cannot read almost all CD-R, while those discs can be read properly under Windows. So, I can sure that those CD-R are readable. Also, if I mount the CD-Rs manually, say
sudo mount /dev/cdrom1 /media/cdrom0 -t iso9660
it reported that I used a wrong type to mount.

After, I try to format the partition and install 8.04 from the live CD. However, whenever I booted from the live CD, the system stopped at "busybox".

I guess these two problem are related, just like what bertm suggested, it seemed that the system cannot found the live cd.

Bert Massop (bert-massop) wrote :

Alright, I notice that a lot of different chipsets/setups are causing the same problem (and more).

When I read the note of Alan, I immediately think of kernel (module) updates causing the problem, instead of a faulty bootdisk. I'm on holidays the next two weeks, so I can't try this, but maybe someone else could:

1- install Gutsy
2- check if everything works fine
3- update the kernel to the version included in Hardy
4- check if everything still works fine
5- update some other important stuff
6- check
7- repeat from 5...

Also, looking at the last kernel output when booting could reveal something interesting (like dalesyk did: boot without splash and quiet option, and note what displays last). Maybe it's possible to do a dmesg in the BusyBox prompt?

Good luck, I'll be back.

azurehi (azurehi) wrote :

Here is my equipment:
1.80 gigahertz AMD Athlon 64
Board: MSI MS-6702E 1.0
Bus Clock: 200 megahertz
BIOS: American Megatrends Inc. 080011 06/08/2005
Standard floppy disk controller
Primary IDE Channel [Controller] (2x)
Secondary IDE Channel [Controller] (2x)
Standard Dual Channel PCI IDE Controller
VIA Bus Master IDE Controller
VIA Rev 5 or later USB Universal Host Controller (4x)
VIA USB Enhanced Host Controller
NVIDIA GeForce4 MX 4000 (Microsoft Corporation) [Display adapter]
DELL P992 [Monitor] (17.7"vis, s/n 8D4662BN41J2, November 2002)
Hitachi 160GBHD...not sure of the particulars

I have tried every suggestions posted in ubuntu forums (http://ubuntuforums.org/showthread.php?t=765195 and http://ubuntuforums.org/showthread.php?p=4805822#post4805822) to no avail. I am basically a Linus Noob and rather lost at this point. I had hope HH would be as easy as 7.10 and earlier releases. Any comments/suggestions are appreciated.

azurehi (azurehi) wrote :

Following the suggestion of Jong http://ubuntuforums.org/showthread.php?t=765195&page=7 I was able to boot from ubuntu 8.04 HH live CD desktop. After selecting language, install, F6 I entered:

all_generic_ide floppy=off irqpoll

The image booted from cd-rom and the installation proceeded without problem. I am hopeful others will have the same success.

Alan Fung (fccaa33) wrote :

Hi all,

azurehi, thank you for your reference!

for my pc, I only need to add the option "all_generic_ide" to fix the problem.

it also fixes the problem on reading CD-R in 8.04...

Thank You!

Joshua (development-caddgeek) wrote :

Same problem here with a MSI K9A Platinum. Seems like a possible kernel bug or new feature to me. Here's my steps

- Originally had Gusty installed and working... No issues
- Attempted install of Hardy with without splash and quiet options. Shows errors that SATA device loses connection and then attempts to re-establish it (about 3 or 4 times). Finally it pops up BusyBox (initramfs).
- Tried another SATA drive to rule out drive issues.
- Tried another mobo (same make and model) to rule out mobo issues.
- Rebooted to Gusty and preformed Hardy upgrade. Upon reboot into kernel 2.6.24-16, I found myself back in BusyBox. Reboot back to kernel 2.6.22-14 and it booted back to my old desktop with minimal issues (considering it still had all the new packages installed).
- Disconnected SATA drive and plugged in an PATA. It booted to the installer and I could partition and install to that drive.

I haven't yet tried to specify any kernel parameters upon boot. Will try that when I get some time later.

SideShow Bob (sideshowbob) wrote :

I'm having the same problem with my ASUS M2N-VM DVI motherboard. I initially setup my system on a the primery EIDE device, which when it's the only disk comes up as sda*.

Once I got that setup to my satisfaction with HH 8.04, I moved the six SATA drives from my old box to the new ubuntu box, and as long as the drives are connected, neither the installed Ubuntu, Debian latest unstable, or the Ubuntu 8.04 live CD are able to boot. Not sure what Debian does, but both version of Ubuntus go to the busybox initramfs prompt.

Using the Ubuntu 8.04 live CD I can use F6 to remove the spash and quiet, but pci=nomsi doesn't appear to help. Because I have 6 SATA drives, I don't think it'd help to run all_generic_ide. It also doesn't appear to make any difference whether the BIOS has the SATA drives setup as JBOD or RAID. Obviously I'd like to get it working with RAID5.

There have been a few times where I was able to boot into the OS, by messing around, looking at stuff, and typing exit enough at the initramfs prompt.

I can also confirm that when quiet and spash are off, it attemps to bring up each SATA device a few times.

Bert Massop (bert-massop) wrote :

As far as I can see, all of you use motherboards featuring SATA connectivity, most of you use one or more SATA devices.

Joshua: I've got exactly the same motherboard. The kernel parameter pci=nomsi worked for me.

SideShow Bob: all_generic_ide might still work, even if you only use SATA drives. This is because most motherboards feature a IDE compatibility mode for accessing SATA drives by a non-SATA OS.

The following changes have been made to the 2.6.24 kernel's SATA subsystem:
* Link power management infrastructure. Device Initiated Power Management, which is defined in SATA 2.5 can be enabled for disks which support it. This feature enables DIPM in linux when the user sets the link power management policy to "min_power". It's also possible to set the PM policy to "max_performance" or "medium_power". Implement hw link power management support for ahci
* SATA Port Multiplier support. Implement PMP support for ahci and sata_sil24
* ACPI-based PATA/SATA hotplug
* libata_pata: ACPI support
* Turn on ACPI by default
* Add a IDE style DMA disable
* ahci: RAID mode SATA patch for Intel Tolapai, add MCP79 support to AHCI driver
* pata_ns87415: Initial cut at 87415/87560 IDE support
* pata_sil680: Add MMIO support
* sata_nv: add SW NCQ support for MCP51/MCP55/MCP61
(source: http://kernelnewbies.org/Linux_2_6_24 )

I think at least the first two items are very interesting, beacause they describe (in my opinion) major changes.

HansHook (hans-hook) wrote :

For what it is worth I like to add that I was stuck with the same problems as described above on a MSI K9A Platinum mobo (Gutsy and Hardy).
A BIOS upgrade (from 1.5 to 1.8) solved all my problems entirely!

Regards
Hans Höök

CryptiniteDemon (cryptdemon) wrote :

Okay, I have a 320 gb sata150 hard drive on a brand new laptop.

I tried the pci=nomsi option. Didn't work at all. Still goes to busybox

I then tried
all_generic_ide floppy=off irqpoll

This loads up the gui for the installer, but then when I get to the partitioner screen, it won't show me any hard drive space, and again I can't install.

Robert Bernecky (bernecky) wrote :

I'm having similar problems on two ASUS boxes, both with SATA drives attached.

One of them, an ASUS V8M-MX/S, refuses to boot AT ALL after the Hardy upgrade. It always drops into the initramfs screen.
Adding all_generic_ide "fixed" it, in the sense that it now boots, but I have no idea if this has resulted in degraded performance, etc.

The other box, also an ASUS, but I don't have the MB name handy, is an Opteron-based board. It frequently requires
several hard boots (reset button) to boot after power-up, stopping in the same screen as above. Also, reboots
from the shutdown menu frequently stall the same way. I have NOT tried all_generic_ide, but will do that and see if
it helps.

This is irritating, and I'd like to see it fixed. If someone has fault-isolation suggestions (NOT workarounds - I want this
fixed properly), I'm happy to try them, within reason.

I'll post an update to this after a few reboots with all_generic_ide.

Robert Bernecky (bernecky) wrote :

Adding all_generic_ide to the grab boot paragraph/phrase appears to have fixed the problem: several boot-ups from
power-on and from panel/runninggreenmanexitsign/restart have proceeded without the hang. I have not
observed any hangs since making the change.

However, I have NO idea how this change affects disk performance. Can someone perhaps leave a note on that topic?

Thanks.
Bob

ps: The ASUS motherboard SATA controller claims to be an Nvidia MCP51, if that helps.

Robert Bernecky (bernecky) wrote :

See also bug#172563 and #227003.

plovell (plovell) wrote :

I'm having the same problems with a Dell Vostro 200 (Core 2 Duo 2.2GHz).

LiveCD x86 drops to busybox
LiveCD 64 drops to busybox
Alternate CD x86 install fine, restart drops to busybox

The "all_generic"ide" option for grub make things work.

This system has SATA disk and SATA DVD - no PATA/IDE at all. No floppy either, although it does have media reader for memory cards etc.

I don't know any way to capture the boot-time messages when we get to busybox. I have other hardware here (Macs mostly) but not much experience with Linux internals such as these. If someone can point me the way to save messages I'd be happy to get them and add to here.

There is one message in the failure that also appears in the success, so I have it. It happens just before the "unhappy" messages in the failure case, so I suspect it may be significant. It says
[ 64.530772] Driver 'sd' needs updating - please use bus_type methods
There's also one in the success case a few lines further down that says
sda: <4>Driver 'sr' needs updating - please use bus_type methods

In the failure case, the SATA drive is being handled as ATA/IDE and various speeds are attempted. It starts as 133, then tries 100, 66 and finally 33.

Robert Bernecky (bernecky) wrote :

I observe the same "Driver 'sd' needs updating - please use bus_type methods" message on my system, in dmesg.
This is WITH the all_generic_ide option in grub.

mrmalte (malte--v) wrote :

As HansHook also mentioned the solution for a MSI K9A Platinuum is to update BIOS to version 1.8. This solved the start up problem for ubuntu 8.04 hardy heron. If you use a RAID set - do not worry - it will stay intact after bios update (only testet with windows xp dual boot).
By the way: disabling the sata controller in the BIOS will make it possible for ubuntu 8.04 to boot from ide harddisk even if you do not use BIOS version 1.8.

I upgraded the ASUS A8N-VM CSM BIOS to this level (the most recently
available on the ASUS web site as of a week or two ago):
A8N-VM-ASUS-CSM-1007.ROM

I also REMOVED the "all-generic-ide" line from /boot/grub/menu.lst.
Since that time, I have not observed ANY of the hangs I reported earlier.

IMO, this problem is resolved.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Andreas (afg0510) wrote :

Same problem but INTERMITTENT, on 1st boot following fresh bare install of 8.04 (2.6.24-16-server) on Q6600 with 8GB. When it drops me into shell I enter bash, exit, ls, etc. -- then Alt-Ctrl-Del. Sometimes I do this 2..4 times, then it sails right past to the login prompt.

I don't need this boot enhancment. How can I deactivate it?

jonbey (jonpaulwade) wrote :

RE: azurehi wrote on 2008-04-28: (permalink)
Following the suggestion of Jong http://ubuntuforums.org/showthread.php?t=765195&page=7 I was able to boot from ubuntu 8.04 HH live CD desktop. After selecting language, install, F6 I entered:
all_generic_ide floppy=off irqpoll
The image booted from cd-rom and the installation proceeded without problem. I am hopeful others will have the same success."

Azurehi, you have saved me. Been struggling to get a linux live cd to work on a new Dell pc all night. Desperately trying to repartition a hard drive with Vista on it. May finally get there!

No idea what the code meant (well, rough guess) but it worked!

Cheers

Jon,.

Can anyone confirm if this is still an issue with the Intrepid Ibex 8.10 release? Thanks.

Changed in linux:
status: New → Incomplete
KOR (kevin-bethke) wrote :

Yes it's still a problem I got an msi VR630-Q6026VHP Notebook and I'm unable to install ubuntu 8.10 The Ubuntu Logo appears after saying install Ubuntu the thing under it scrolls a couple time back and forth then it starts from the left after about an eights the screen goes black and nothing happens. I tried all of the boot Options given in this thread, but no change.
CPU: AMD DUAL Core QL60
HDD SATA 160GB
Memory 2GB
Grafics: nvidea
There seem to be other Users having problems with the msi VR630 notebook
I tried only the 32bit version cause people said this one has less isues.
please help

kstanoev (civ-mail) wrote :

Same problem, also on an MSI VR630.

kstanoev (civ-mail) wrote :

It's noteworthy that it comes with freedos installed, which crashes after some use, and also a xubuntu 8.04 cd.

kstanoev (civ-mail) wrote :

Arch linux stalls during "loading Udev uevents" and outputs a blank screen. I get a blinking cursor in the upper left corner when I run the Ubuntu live CD with "acpi=off".
I also get a GRUB error 2 when I try to boot Archlive from a USB drive unless I switch the "order of the hdds" whatever that means form the BIOS and put the USB drive before the HDD. Someone suggested in a thread in the ubuntu forums to switch off auto recognition of IDE [sic] devices (a SATA HDD and SATA DVD drive) and use DMA, but the two options in the BIOS are auto and disabled.

Azurehi, since you are the original bug reporter, can you also confirm this still to be an issue with Intrepid. Does the workaround of booting with "all_generic_ide floppy=off irqpoll" still work for you with Intrepid? If you boot with the "quiet" and "splash" options removed, are there any additional error messages you see prior to being dropped into a busybox shell? If so, would you be able to take digital photo of those errors and attach it to this report? Thanks.

Ecker Sandor (esanya) wrote :

On the page: http://wiki.ubuntuforums.org/showthread.php?t=1009417 there is a discussion about the MSI VR630 and install linux...

I'm currently using elive this works, but I would like to use ubuntu... When I will have time I will try to install ubuntu 8.10...

Ecker Sandor (esanya) wrote :

With ubuntu 9.04 daily live cd the installation breaks with black screen (no problem with initramfs..)

https://bugs.launchpad.net/ubuntu/+bug/311879

Andreas (afg0510) wrote :

Right after 8.04 64bit server install, it would die 3 out of 4 boots. I'd hit Ctrl-D, enter some 'ls' command, plug/unplug some usb devices, LAN cable, anything, and reboot. After a few such tries it would boot all the way. Later I did apt-get upgrade + update and saw initramfs rebuild. since then the problem occurs less frequently but become more "stubbern" to trick. Live-CD never booted. This vmware server includes Intel Q6600, 8GB, SATA on motherboard, PCI IDE+SATA+RAID card, Mtron SSD (SATA), SATA and PATA (IDE) HDDs, 10/100Mb TCP/IP on motherboard, Gigabit on PCI card. My guess: Timing, interrupts, interaction between multiple processors, multiple disks, mixture of IDE (PATA) and SATA, multiple USB bridges and hubs. In fact it was worse when booting from the Mtron solid-state disk. I'd like to ask an initramfs guru for HOWTO rebuild it on the fly.

Wally80 (dvalerio) wrote :

Same problem here.

Surprisingly I am having this issue ONLY with ubuntu64 8.10.
I can install without problem ubuntu32 8.10 and Kubuntu64 8.10.

I checked the iso with md5 and verified the burning process.
So, no idea where the problem could be...
I don't want to use the option all_generic_ide since noone yet explained if it degrades performance.
So, for now I am sticking to Kubuntu64.

My hardware:
Gigabyte GA-X48T-DQ6, rev.1.1 (Bios F6a)
Intel E8400
2x1024MB DDR3 OCZ Platinum PC3-12800
1000GB 3,5" Samsung SpinPoint F1 HD103UJ SATA2
External DVD drive: TSSTCorp CD/DVDWSH-W162C

It would be great if anyone would be willing to test installing the latest pre-release of Jaunty (currently Alpha3) to confirm if this issue still exists. http://cdimage.ubuntu.com/releases/jaunty/ . Please let us know your results. Thanks.

Greg Manrodt (greg-manrodts) wrote :

I also have this issue with an ASUS motherboard and SATA and IDE drives attached. I can also confirm, beyond a doubt that adding all_generic_ide degrades disk performance. My copy speed between internal HDs (SATA->SATA or IDE->SATA) is around 500 KB/s. My download speed from the internet is faster than that...

I have also just changed my grub and removed the all_generic_ide and added pci=nomsi. I am not sure that everything is running as fast as it could, but it is a LOT faster than it was yesterday. :) My copy speeds are now around 15MB/s, or so, from IDE -> SATA. and 25 MB/s from SATA -> SATA.

I am running a fresh install of Ubuntu 8.10, 64-bit, on an AMD 64 939 proc. I have two SATA drives, an IDE drive and a SATA DVD-ROM.

Greg Manrodt (greg-manrodts) wrote :

EDIT: I have an ASUS a8x-xe MB, with an AMd Athlon 64 3400+, Seagate 1.5 TB SATA drive, 200 GB WD SATA, and nVidea GeForce 7800.

Having the same problem with Ubuntu 9;04 beta, on a Vostro 1000.

Bert Massop (bert-massop) wrote :

8.10 didn't boot the graphical environment at all for me, but that should be a display driver issue or something.

+ + Jaunty 9.04 works like a charm in LiveCD mode, install not tested yet (I'll try that later).

- - USB Install works, but booting from the installed USB does __NOT__! It has the well-known initramfs problem, that's a pity. I'll investigate that (and may even include some dmesg output) later.

My system specs are still unchanged, see one of the upper posts.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers