Wireless(Intel PRO/Wireless 3945BG) stopped working after upgrade to kubuntu 8

Bug #229611 reported by Anarki on 2008-05-12
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-source-2.6.15

Hello,
I got this issue after upgrading to Kubuntu 8 my wireless connection was working before the upgrade so please help , my wireless card is Intel PRO/Wireless 3945BG, btw i'm new to linux,
Thanks :)

Anarki (ahmed-ahd) wrote :

lspci -vvnn output

Matthew Woerly (nattgew) wrote :

Thank you for reporting this bug and helping to make Ubuntu better.
Are you sure that you're using this version of the kernel? What do you get from
uname -r
in a terminal?

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

cman (diegoocampo8) wrote :

I can confirm that the wireless card Intel PRO/Wireless 3945BG is not working with the most new version of the 2.6.27 kernel (the one that Ubuntu Intrepid Ibex beta brings).
I have reported a bug about this in https://bugs.launchpad.net/ubuntu/+bug/279246

carutsu (carlos-licea) wrote :

I can confirm that wireless is not working here either. It used to.

Is this still an issue with the latest 2.6.27-7.14 kernel? If so, per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux:
status: New → Incomplete

This bug also affects the Intel PRO/Wireless 2915ABG MiniPCI card.

I would like to add that this bug is triggered what appears to be randomly. At times, my laptop is fine for hours on end (10+), and at others it dies within minutes (15-30). It may also be important to note that my CPU (and thus the fans on my laptop) goes haywire and begins peaking one or both cores at 100% usage. System Monitor shows no process as being the culprit - everything listed is below 3% CPU usage while this is occurring.

Wired internet still works after this bug occurs. I am posting this using it right now just after the bug has occurred.

* Attached is the dmsg log.

* Attached is the version log.

* Attached is the lspci -vvnn log.

Sorry for 4 posts in a row, but I thought it would also be good to mention I'm running Ubuntu 8.10 Intrepid Ibex and am using the 2.6.27-7-generic kernel according to uname -r. Aptitude doesn't say there are any new kernel updates, so I believe this is the newest one.

This problem persists through the recent kernel update. /proc/version_signature now yields:

Ubuntu 2.6.27-7.16-generic

I have attached my dmesg output after the bug occurred once again.

carutsu (carlos-licea) wrote :

I can confirm that this is still happening even with the latest upgrades. It's so annoying!.

Carutsu, what card and which version of Ubuntu are you running? Just saying "me too" without any additional info will not bring us any closer to a fix.

Also, to everyone with a 3945BG card...is it that your wireless does not work at all? Or is it that it works, but dies randomly and requires a restart? I'm wondering if my issue with my 2915ABG card is the same or if I should really be filing another bug report.

carutsu (carlos-licea) wrote :

The command lspci gives me:
>Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
My wireless works but then randomly it stops working and in order to re-activate it I have to restart the machine. From time to time i have to reboot the machine twice.
Please let me know anything if you need more information.

carutsu (carlos-licea) wrote :

I forgot to mention that I'm running Kubuntu 8.10 with all the repostories enabled.

Can you post some of the log files that Leann asked for? I'm not entirely sure what is needed to fix this, but it seems to me that more log files would probably help.

It appears to me that we have the same issue and that this bug may actually be the same as (or have something to do with) this bug here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/179698

Can any devs give me some direction on how I might help with this? This bug (for me) was not present in Hardy, so I would assume something went wrong inbetween. Are there any more tests/logs I can run/give to help figure out the problem?

carutsu (carlos-licea) wrote :

Here are the files requested by Leann Ogasawara.

carutsu (carlos-licea) wrote :
carutsu (carlos-licea) wrote :

Hi Everyone,

@Alsandair, I'd like for you to try a few things first. I may have you open a new bug report since you are using the ipw2200 wifi driver and this bug was reported against the iwl3945 driver. However for now please try the following:

1) can you try booting with the "irqpoll" option as that should get rid of at least one of the errors I saw in your dmesg output.
2) Assuming you still see issues with wifi after booting with the "irqpoll" option, please also then try installing the linux-backports-modules-intrepid package (you'll need to reboot after installing) as it contains and updated version of the compat-wireless stack.

@carutsu, care to also try installing linux-backports-modules-intrepid to see if it helps?

@Anarki, since you are the original bug reporter, can you comment if you are still having issues with Intrepid's final release? Thanks.

carutsu (carlos-licea) wrote :

@Leann: I'll install it and report.

carutsu (carlos-licea) wrote :

I installed linux-backports-modules-intrepid, later when I lost the connection, then I rebooted only to find out that I cannot connect wirelessly anymore in that kernel, 2.6.27-8, even after I rebooted several times; I tried removing the package but didin't help. I still don't have wireless in that kernel version.
If I boot in older kernels, 2.6.27-7 or 2.6.27-4, the wireless is still working (with disconnects of course).

@Leann - I added the irqpoll option to my GRUB boot options, and found that it ultimately does not rectify the issue. I believe it may make it take longer to occur, but it still occurs. Unfortunately, it occurred over night and overheated my laptop and shut it off before I could wake up and get any log files from it, but I do know it occurred. Also, irqpoll causes my trackpad on my laptop to virtually not function anymore, so I'm not so sure I want to use that option anyway.

I'll be trying out the linux-backports-modules-intrepid package later today and will report back with any findings. At that point, let me know whether you'd like me to open a new bug or not.

It appears this issue is more common than we thought, and possibly affects many more cards:

http://ph.ubuntuforums.com/showthread.php?t=970818

I have just installed linux-backports-modules-intrepid, so we'll see what happens.

I installed linux-backports-modules-intrepid and have not noticed any changes over the past few days with it installed. My network card has failed at least 5-6 times during the past 3-4 days while doing everything from nothing to internet browsing to playing Diablo II over TCP/IP through Wine.

I have decided to file a new bug for my issue, as it seems to be slightly different from this one. My new bug report is here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/303802

What can be done now?

Hi carutsu,

Can you test the most recent 2.6.27-9 kernel update? Thanks.

karenin (einstand) wrote :

I have the same problem with the 2.6.27-9 kernel too. (HP 6710b)

carutsu (carlos-licea) wrote :

I can't test it anymore since my laptop has been sent to be repaired (problems with the battery). I cannot help till I get it back.

@karenin, what driver are you using? Have you tried installing linux-backports-modules-intrepid as described above? Thanks.

Have any of you had any luck with the new network-manager updates that have come out today? My performance has been improved significantly because of the patch and, although my driver and card are different, I wonder what effect it will have for the rest of you...

raymano (rezgol) wrote :

I can verify that this is still a problem with the latest kernel 2.6.27-9-generic. I have tried installing linux-backports-modules-intrepid but no luck. Any other workarounds yet?

No other workarounds have been found that I know of, however I am having a similar problem and you may want to try some of the things perscribed to me by Leann Ogasawara in my bug report:

https://bugs.launchpad.net/bugs/303802

Perhaps some of that stuff will help you, too?

I'm running in a similar problem with that card on Ubuntu 8.10 amd64. I have found a workaround after reading all the posts in this bug and the related ones. Basically I got the wifi card disabled after startup and the kill switch on the pc (a hp nc8430) doesn't turn it on. However to my surprise I found that rmmod iwl3945 turns it on. Shouldn't have it got the module off the kernel and made the card definitely unusable?

Things get complicated after suspending the pc. The general idea is that the card stays on after the resume but the kill switch fails to turn it on after I switch it off for the first time but I still didn't have time to test all the combinations of events.

I attach a file with the log of dmesg and the commands I gave from the console.

An important note: I'm booting Ubuntu with this /etc/modprobe.d/iwl3945

alias wlan0 iwl3945
options iwl3945 disable_hw_scan=1

I don't know exactly what that does (I only started playing with modules today after reading your posts) but if there is anything I can do to sort out this bug, just tell me how I can help.

Paolo

Hi All,

For those still experiencing issues, could you please test the latest pre-release of Jaunty 9.04 (currently Alpha3) - http://cdimage.ubuntu.com/releases/jaunty/ . It contains a newer 2.6.28 based kernel. You should be able to test via a LiveCd. Please let us know your results. Thanks.

Jim Lieb (lieb) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04 - http://www.ubuntu.com/getubuntu/download. If the issue remains in Jaunty, please test the latest upstream kernel build - https://wiki.ubuntu.com/KernelMainlineBuilds . To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers