Ubuntu 18.04 can't load kernel on Acer Aspire A315 (Ryzen5/Radeon/FHD)

Bug #1776563 reported by Richard Baka on 2018-06-12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

CPU: Ryzen 5 2500U
VGA: Radeon 535
Notebook: Acer Aspire A315
I've just bought a new AMD Ryzen/Radeon notebook (Acer Aspire 3) and I wanted to install an Ubuntu/Kubuntu 18.04 on it. I checked the bios settings and uefi was the only boot option, so there is no legacy mode what I had used with my old computer before. I downloaded the normal iso image and made an usb boot pendrive using mkusb. The boot was okay, I got an uefi type menu but after starting the kernel it paniced(?) instantly.
Error messages: ACPI Error [MAC0] Namespace lookup failure
ACPI ERROR 1 table load failures, 13 successful
BUG: soft lockup CPU#0 stuck for 22s
EFI VGA framebuffer device
clocksource tsc mask
Switching to colour framebuffer device
[28.040001] ...

I've tried to boot the same pendrive on my girlfriend's Acer Travelmate with uefi and worked well.

I searched and I found that the problem is maybe in connection with uefi framebuffer but I am not sure.

Ubuntu 16.04 can be loaded with nomodeset and noacpi parameters but for 18.04 none of them are working. I tried 4.16,4.17 kernels too (replaced on live usb) but without any success. The result is totally equivalent.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1776563

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic

apport-collect 1776563 can't be entered because the kernel can not load.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
summary: - Acer Aspire A315 (Ryzen5/Radeon/FHD) Ubuntu 18.04 kernel cant load
+ Ubuntu 18.04 kernel can't load kernel on Acer Aspire A315
+ (Ryzen5/Radeon/FHD)
summary: - Ubuntu 18.04 kernel can't load kernel on Acer Aspire A315
- (Ryzen5/Radeon/FHD)
+ Ubuntu 18.04 can't load kernel on Acer Aspire A315 (Ryzen5/Radeon/FHD)
no longer affects: bugzilla (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-amdgpu (Ubuntu):
status: New → Confirmed
Freihut (freihut) wrote :

Had this on my A315 too, but I returned it to the vendor. Seems to be an UEFI-Bug, because it doesn't happened with my Ryzen 2500U from HP. Could also be related to that Ryzen/Radeon 535 combination (Vega/CGN 3).

On Grub-Menu press E and add "pci=noacpi" as kernel-parameter (where normally "quite splash" is). Then go on booting by pressing F10.
Sometimes (XFCE) it was also necessary to add "nomodeset" to boot, Gnome for example didn't need it (AFAIK).

I remember, I also needed to install amd's pro driver (for 18.04) via amdgpu-pro-install to get rid of the "nomodeset". I was able to run amdgpu-pro-uninstall later and still not needed the "nomodeset". Could be related to my system, but you may give it a try.
I was also using Kernel 4.17 (Mainline), which is available on http://kernel.ubuntu.com/~kernel-ppa/mainline/ or with UKUU https://www.omgubuntu.co.uk/2017/02/ukuu-easy-way-to-install-mainline-kernel-ubuntu

Richard Baka (bakarichard91) wrote :

Thanks Freihut, I will try this.

Richard Baka (bakarichard91) wrote :

It works but very slow. This could be an ACPI problem.

Richard Baka (bakarichard91) wrote :

I installed the new amdgpu pro driver and everything is very fast now. This bug should be reported to freedesktop, would you like somebody to do it? :D

Richard Baka (bakarichard91) wrote :

*Sorry correction: Who would like to do it? :D

Richard Baka (bakarichard91) wrote :

"The fact that ACPI was designed by a group of monkeys high on LSD, and is some of the worst designs in the industry obviously makes running it at any point pretty damn ugly."
Torvalds, Linus (2005-07-31). Message. linux-kernel mailing list. IU. Retrieved on 2006-08-28.

Richard Baka (bakarichard91) wrote :

Power management doesn't work well this way. It was hot a little. I've changed back to win10. This should be fixed by kernel developers or with a downstream patch.

no longer affects: xserver-xorg-video-amdgpu (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.