Ubuntu 16.04: Suspend freezes the system after upgrade to linux image 4.4.0-16

Bug #1566302 reported by macias on 2016-04-05
This bug affects 209 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I'm using ubuntu 16.04 on a XPS 15 9550.

Suspend/resume worked flawlessly with linux image 4.4.0-15, and after standard upgrade yesterday (5/04/2016) which installed image 4.4.0-16, the system freezes when attempting a suspend. I get no response from the system (nor keyboard, nor screen, nor touchpad), but it gets very hot, so that it must be running something.

Booting with 4.4.0-15 makes the suspend to work perfectly.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-extra-4.4.0-16-generic 4.4.0-16.32
ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
Uname: Linux 4.4.0-15-generic x86_64
ApportVersion: 2.20.1-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: macias 1770 F.... pulseaudio
CurrentDesktop: X-Cinnamon
Date: Tue Apr 5 14:56:17 2016
HibernationDevice: RESUME=UUID=4180adfa-3852-4a96-86b4-f3696448c743
InstallationDate: Installed on 2016-03-07 (28 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160304)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 04f3:21d5 Elan Microelectronics Corp.
 Bus 001 Device 002: ID 0a5c:6410 Broadcom Corp.
 Bus 001 Device 004: ID 1bcf:2b95 Sunplus Innovation Technology Inc.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. XPS 15 9550
ProcEnviron:
 LANGUAGE=es_ES
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic.efi.signed root=UUID=673f4658-75f8-4c01-bcd8-0af860269699 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-15-generic N/A
 linux-backports-modules-4.4.0-15-generic N/A
 linux-firmware 1.157
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/25/2016
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 01.01.19
dmi.board.name: 0N7TVV
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr01.01.19:bd01/25/2016:svnDellInc.:pnXPS159550:pvr:rvnDellInc.:rn0N7TVV:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: XPS 15 9550
dmi.sys.vendor: Dell Inc.

macias (macias-depeca) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.6 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-rc2-wily/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
macias (macias-depeca) wrote :

Yes, the issue start happening after update to 4.4.0-16 on 5/04/2016 (morning update). The problem did not happened with 4.4.0-15.

I tested uptream kernels 4.5 and 4.6 and I didn't have the freeze after suspend. Actually, yesterday night (5/04/2016) there was another ubuntu update (including kernel update to 4.4.0-17) and I can confirm that the bug seems to be fixed also for 4.4

I then booted again with the supposedly buggy kernel 4.4.0-16, and I couldn't replicate the bug, so my guess is that the bug reason was not actually in the kernel, but due to some other package.

So: the bug seems to be fixed with the ubuntu distribution as of yesterday night (kernel 4.4.0-16 and whatever additional updated packages). Also fixed for 4.5 and 4.6.

Thanks for your time and great work!

Bruno Jesus (brunojesus) wrote :

In my case none of the 4.4 kernels have suspension working, but in 4.6 it's working fine.

I also have a Dell but it's an Inspiron 17R-5737.

Jeroen van der Gun (jeroen-0) wrote :

I have similar experiences since I upgraded from Ubuntu 15.10 to 16.04. I can no longer suspend or hibernate, the screen goes black but the PC stays on, heating up and triggering the fan after a while.

When I run Ubuntu 16.04 with kernel 4.2.0-35-generic (which was still installed) instead of kernel 4.4.0-21-generic, the problem does not occur, so I've uninstalled 4.4.0-21-generic for now until there's a better solution. I have no kernel versions in between available in my package manager.

Ubuntu 16.04 xenial (x86-64)
Cinnamon 2.8.6
Kernel 4.4.0-21-generic
Processor AMD A8-5550M APU with Radeon(tm) HD Graphics x 2
7.0 GiB memory
315 GB hard disks
Advanced Micro Devices, Inc. [AMD/ATI] Richland [Radeon HD 8550G] (prog-if 00 [VGA controller]) graphics card
No proprietary drivers in use
For completeness: unlike suspend, hibernate has never worked perfectly (screen would stay black after resume, workaround to wake up screen was suspend and resume from suspend)

BobbyHo (bobbyho) wrote :

I'm using Ubuntu 16.04.
I can wake up from suspend in 4.6, but not in 4.4.0-35.

林博仁 (buo-ren-lin) on 2016-04-23
tags: added: regression-update
Petr Gladkikh (petrglad) wrote :

I have this problem since upgrade from 15.10 to 16.04

I have disabled discrete video card in bios and now use Intel HD graphics only. With this configuration suspend works.

My environment Xubuntu 16.04, kernel 4.4.0-21-generic

Jeroen van der Gun (jeroen-0) wrote :

I also tried upstream kernel 4.5.2-040502-generic, which solves the problem except that it cannot wake up from hibernate. So I'm sticking with 4.2.0-35-generic for now.

I can confirm, that kernel 4.6.0-040600rc5-generic solves the problem on Dell Inspiron N5110 (latest BIOS A11). Kernel 4.4.0-21-generic fails to suspend on newest BIOS. On my Inspiron I have no BIOS options to disable the discrete video card.

milton hagler (miltonh26) wrote :

On my Asus U44S optimus laptop with Nvidia Geoforce GT 610M kernel 4.5.2 -040502-generic solve the issue for me.

Olivier Febwin (febcrash) wrote :

Same here: Dell Latitude E6520

Braiam Peguero (braiampe) wrote :

macias, since you were able to find that the issue was fixed upstream, could you follow the procedure that Joseph explained? Specifically:

> If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

and

> Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

This will allow the team to pinpoint what went wrong, and offer a solution for everyone else.

mookey41 (redguy41) wrote :

Same here, 4.4. kernel on Ubutnu 16.04 LTS and Lenovo z51-70 80K, i5.

macias (macias-depeca) on 2016-04-30
tags: added: kernel-fixed-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Installing recent Kernel 4.4.9 also resolves the issue. Suspend and Hibernate works.
Dell Inspiron 15R 5537.

Confirming that this bug occurred at all 4.4.0 kernel, including the latest 4.4.0-22 kernel update.

Installing newer kernel solve the issue.

Roygbiv (silentvoice37) wrote :

I can also confirm that the bug persists even after the 4.4.0-22 kernel update. (Dell Inspiron 15)

claudio (cardi-93) wrote :

I also confirm for samsung series 7 ultra

Confirming that this bug also appears on HP ZBook 15u G2 with the 4.4.0-22 kernel.

rim (rim-a) wrote :

I can also confirm for Lenovo C560 (Kubuntu 16.04). I've tried 4.4.0, 4.4.6, 4.4.8, 4.5.3, 4.6-rc7 kernels. but it didn't help

Kaushik Evani (kaushik-evani) wrote :

I can confirm that I also had the issue with 4.4.0. Recent upgrade to 4.4.9 has fixed the issue!

ianholing (ianholing) wrote :

I've never install an updated package manually which I already have into system packages. Will this manual update block the future patch update?

Rien Heuver (rienheuver) wrote :

I have this problem too on Dell XPS 13 (9350 model). Tried kernels:
4.4.2
4.4.8
4.4.9
None fixed it for me. Neither did I find a kernel that does (yet).

Rien Heuver (rienheuver) wrote :

Update: I just tried 4.6 RC7 and it didn't fix it either.

What is the normal schedule to fix this bug for 16.04 users?

If I decide to install the 4.4.9 packages elpocho indicated, will it block the official package to be upgraded via apt-get dist-upgrade?

Ismail Gjevori (isgjevori) wrote :

I think that the importance of this bug should be High...
@alvaroguimareaes https://wiki.ubuntu.com/Kernel/MainlineBuilds

raphael (raphdruon) wrote :

I'm using a Dell Inspiron 5537, it hangs only the second time I try to suspend it.
I tried kernels 4.4.8 and 4.4.9

Strange raphael, I also have a Dell Inspiron 5537 and all works with Mainline Kernel 4.4.9. I can suspend and hibernate lots of times with no problem!?!?
I think is related to ati radeon graphis card! I don't need it so I turn it off in /etc/rc.local with the command "echo "OFF" > /sys/kernel/debug/vgaswitcheroo/switch".
If it's Your case try it and see if works for you.

Rien Heuver (rienheuver) wrote :

Perhaps that's the case for the Inspiron model(s), but definitely not for all devices nor Dell models. My Dell XPS 13 (9350) has Intel HD Graphics but this bug too.

raphael (raphdruon) wrote :

Thanks cascagrossa #29 , this solved my problems :-)

Bug confirmed on 4.4.0-22.

Dell 7000, with
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
08:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Opal XT [Radeon R7 M265]

Miguel A. Martinez (migmartri) wrote :

I can confirm the issue in my Dell XPS 13 9350

Kernel version: 4.4.0-22-generic

bill (bill-zannoni) wrote :

I confirm that here the problem is still there with kernel 4.4.0-22, I have a Lenovo ThinkPad S540 with i7 and:
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
06:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330]

I first noticed the problem with kernel 4.4.0-21, but I can't be sure with which update it appeared. What I can say is that if I start with kernel 3.16.0-34 (only other version of the kernel I Have a part from 4.x) suspension feature work normally.

adutzu89 (verbanady) wrote :

Confirming here also, Ubuntu 16.04 fresh install, with Kernel 4.4.0-22-generic on a Dell Inspiron 15 5555

Download full text (6.0 KiB)

I confirm this bug on Thinkpad S540.
System specs:

-Computer-
Processor : 4x Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz
Memory : 7817MB (3057MB used)
Operating System : Ubuntu 16.04 LTS
Date/Time : mer 18 mag 2016 09:13:04 CEST
-Display-
Resolution : 1920x1980 pixels
OpenGL Renderer : Mesa DRI Intel(R) Haswell Mobile
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA Intel HDMI
Audio Adapter : HDA-Intel - HDA Intel PCH
-Input Devices-
 Power Button
 Lid Switch
 Power Button
 AT Translated Set 2 keyboard
 Video Bus
 Video Bus
 SynPS/2 Synaptics TouchPad
 Logitech USB Receiver
 Logitech USB Receiver
 ThinkPad Extra Buttons
 HDA Intel HDMI HDMI/DP,pcm : 3=
 HDA Intel HDMI HDMI/DP,pcm : 7=
 HDA Intel HDMI HDMI/DP,pcm : 8=
 SYNAPTICS Synaptics Large Touch Screen
 HDA Intel PCH Mic
 HDA Intel PCH Headphone
 Integrated Camera
 TPPS/2 IBM TrackPoint
PDF : <i>Default</i>
-SCSI Disks-
ATA SAMSUNG MZ7TE256

-Version-
Kernel : Linux 4.4.0-22-generic (x86_64)
Compiled : #40-Ubuntu SMP Thu May 12 22:03:46 UTC 2016
C Library : Unknown
Default C Compiler : GNU C Compiler version 5.3.1 20160413 (Ubuntu
5.3.1-14ubuntu2)
Distribution : Ubuntu 16.04 LTS
-Current Session-
Computer Name :
Desktop Environment : Unity (ubuntu)
-Misc-
Uptime : 8 minutes
Load Average : 0,00, 0,00, 0,00

$ lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated
Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller
(rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev
04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev
04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev
e4)
00:1c.1 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 2 (rev
e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev
e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev
e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev
e4)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI
mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
04:00.0 Network controller: Intel Corporation Wireless 7260 (rev 83)
05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227
PCI Express Card Reader (rev 01)
06:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT
[Radeon HD 8670A/8670M/8690M / R5 M330]

=========================

*Michele Spartano*

OSCP certified

Email: <email address hidden>

Mobile: +39 3484023371

2016-05-17 19:01 GMT+02:00 adutzu89 <email address hidden>:

> Confirming here also, Ubuntu 16.04 fresh install, with Kernel
> 4.4.0-22-generic on a Dell Inspiron 15 5555
>
> --
> You received this bug notification becaus...

Read more...

Sergio Callegari (callegar) wrote :

Same issue here: DELL Precision T5400 with nvidia graphics cannot suspend anymore after upgrade to xenial.

ronexus (ronexus) wrote :

Same issue here: Thinkpad T410 with nvidia graphics cannot suspend anymore after upgrade to xenial.
Tested with 4.4.0-21-generic & 4.4.0-22-generic

capaj (capajj) wrote :

I have Dell inspiron and I can confirm this bug as well. Started after upgrading to 16.04. My uname -r prints out:
4.4.0-22-generic

Will test with a newer one.

tags: added: bios-outdated-01.02.00 kernel-fixed-upstream-4.6-rc2 needs-reverse-bisect
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Guex (guex) on 2016-06-04
Changed in linux (Ubuntu):
status: Invalid → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu):
status: Invalid → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
no longer affects: linux
81 comments hidden view all 161 comments
rewound (rewound) wrote :

Bug 1620733 may be of interest, it uses kernel 4.8.0-040800rc5-generic

Jason Gambrel (jaygambrel) wrote :

So far have tried kernels:
4.8-rc5 - breaks Wi-Fi
4.6.7 - breaks Wi-Fi
4.4.9 - still random freezes on resume from suspend
4.2.8 ckt13 - still random freezes on resume from suspend

The only other thing I can think of is that I installed TLP shortly after installing this version of elementary. Not sure if that is causing a problem. Will remove and keep trying.

Wolf (drechsel) wrote :

Does anybody know, when kernel 4.6 will be released within an "official" system update? -

Tried to install 4.8, or older versions still available on my computer, but each of them made the X server (nvidia graphics) unusable.

Jason Gambrel (jaygambrel) wrote :

Still freezing after removing tlp. Added "acpi_osi='!Windows 2013' acpi_osi='!Windows 2012'" to grub configuration.

Jason Gambrel (jaygambrel) wrote :

Still freezes with the grub modification. Tried kernel 4.5.2, same problem. For me it seems to happen most frequently with changing power sources while suspended (ie. plugging in or unplugging while suspended) At least I can avoid this. Not sure what to do at this point.

Tim (0rca-l3lacksail) wrote :

The issue for me was not due to resuming from hibernate or suspend. The issue persisted after disabling both.

Monitor would go black in ten minutes but power the light was not blinking (steady) yet upon resume I get the same graphical freeze.

Purging xautolock->reboot solved the issue for me. Screen still goes black in 10 minutes but I've resumed successfully several times in the last 24 hours with no repeat occurrence.

I know this isn't a fix but thought it would be worth posting the possibility of an alt root cause.

Mark Alan (malan) wrote :

@Tim: I have purged xautolock a long time ago (due to other reason) but I am still having the freezes ( from which I recover by a keyboard key combination that I mapped to: xrandr --auto )

Tim (0rca-l3lacksail) wrote :

Did you nuke xscreensaver and or light lock. If you disabled all else (for testing) the last option should apply prior to resuming.

Blinking Green power = Suspend
No light on power = Hibernate
Solid green power = xautolock, screensaver, or equivalent

Prior - I could make hibernate and suspend work consistently (inside 10 minutes). If the last option is causing the issue the screen will go black at exactly 10 minutes. The only way I could resume properly every time was to remove them.

Jason Gambrel (jaygambrel) wrote :

Tried reinstalling elementary OS Loki stable. No change. Caps lock doesn't change the light on my keyboard so I'm thinking it is definitely a kernel issue.

Jason Gambrel (jaygambrel) wrote :

Turned out to be a hardware issue. My bluetooth would give errors on startup and only work intermittently. Edited /etc/modprobe.d/blacklist.conf and blacklisted bluetooth and btusb. Also disabled it via: sudo systemctl mask dbus-org.bluez.service. Now works suspending works like a charm.

Glen (glentupling-hotmail) wrote :

This is a serious issue for me, I don't want to restart my computer every 10 minutes!

Glen (glentupling-hotmail) wrote :

Upgraded to 16.04 this morning, issue did not exist before today. kernel 4.4.0-38-generic, pc is no-name Intel core 2 duo cpu e7300 s.66GHz x 2, graphics Gallium 0.4 on ATI RV370, no bluetooth, no wireless. System will not recover from sleep or hibernate.

tombiggar (tombiggar) wrote :

I did an install of 16.04 kernel 4.4.0-38-generic and also had the freeze after waking from sleep. The screen was visible but non responsive. I had a lot of hard drive activity on boot when I did a power down restart and a brief message about cleaning up orphaned inodes. After reading the posts above, I tried replacing the X-Org video driver that was installed by default with the Nvidia driver listed under System Settings and the problem seems to be gone. It was pretty consistent before I replaced the driver and has not happened in the last 2 days since I replaced the driver. Also, the orphaned inode message has not appeared and the hard drive behaves normally on boot. I'll post if it occurs again. Hope this helps someone.

Andrzej Mazur (andrzej-mazur) wrote :

the same problem for me:

When I start fresh system, the suspend to RAM and resume works properly.
But after certain amount of time when OS works, suspending and resuming ends with no response (blank screen).

Ubuntu 16.04 64bit, Toshiba A200-1N8, 4.4.0-38-generic, Intel(R) Core(TM)2 Duo CPU T7250

Milo (mloa727) wrote :

I have this issue with 4.4.0-43. I did notice that there were no problems when I was running 4.4.0-36.

Download full text (3.2 KiB)

Resolved for me with kernel 4.8.2
/jaaka

Skickat från min Samsung-enhet

-------- Originalmeddelande --------
Från: Mark Loatman <email address hidden>
Datum: 2016-10-20 00:45 (GMT+01:00)
Till: <email address hidden>
Rubrik: [Bug 1566302] Re: Ubuntu 16.04: Suspend freezes the system after upgrade to linux image 4.4.0-16

I have this issue with 4.4.0-43. I did notice that there were no
problems when I was running 4.4.0-36.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1566302

Title:
  Ubuntu 16.04: Suspend freezes the system after upgrade to linux image
  4.4.0-16

Status in linux package in Ubuntu:
  Won't Fix

Bug description:
  I'm using ubuntu 16.04 on a XPS 15 9550.

  Suspend/resume worked flawlessly with linux image 4.4.0-15, and after
  standard upgrade yesterday (5/04/2016) which installed image 4.4.0-16,
  the system freezes when attempting a suspend. I get no response from
  the system (nor keyboard, nor screen, nor touchpad), but it gets very
  hot, so that it must be running something.

  Booting with 4.4.0-15 makes the suspend to work perfectly.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-extra-4.4.0-16-generic 4.4.0-16.32
  ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
  Uname: Linux 4.4.0-15-generic x86_64
  ApportVersion: 2.20.1-0ubuntu1
  Architecture: amd64
  AudioDevicesInUse:
   USER PID ACCESS COMMAND
   /dev/snd/controlC0: macias 1770 F.... pulseaudio
  CurrentDesktop: X-Cinnamon
  Date: Tue Apr 5 14:56:17 2016
  HibernationDevice: RESUME=UUID=4180adfa-3852-4a96-86b4-f3696448c743
  InstallationDate: Installed on 2016-03-07 (28 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160304)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 04f3:21d5 Elan Microelectronics Corp.
   Bus 001 Device 002: ID 0a5c:6410 Broadcom Corp.
   Bus 001 Device 004: ID 1bcf:2b95 Sunplus Innovation Technology Inc.
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. XPS 15 9550
  ProcEnviron:
   LANGUAGE=es_ES
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=es_ES.UTF-8
   SHELL=/bin/bash
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic.efi.signed root=UUID=673f4658-75f8-4c01-bcd8-0af860269699 ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-15-generic N/A
   linux-backports-modules-4.4.0-15-generic N/A
   linux-firmware 1.157
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/25/2016
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 01.01.19
  dmi.board.name: 0N7TVV
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvr01.01.19:bd01/25/2016:svnDellInc.:pnXPS159550:pvr:rvnDellInc.:rn0N7TVV:rvrA00:cvnDellInc.:ct9:cvr:
  dmi.product.name: XPS 15 9550
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.ne...

Read more...

Wolf (drechsel) wrote :

The problem persisted with Kernel 4.8 - but I found it was a hardware issue:
My power supply was faulty - installing a new one resolved the problem.

In addition I found that the BIOS battery was down to 1,3V; inserting a new one re-enabled the "resume on power off" feature. Multi-factor problems really are great joy.

Utz (utz-recke) wrote :

I experience the same problem on Ubuntu 16.10. Kernel 4.8.0-26-generic and Intel graphics

Hamzeh Ahmad (hamzeh-ahmad) wrote :

I had the same problem and I solved this way, a work around:

am not sure but I think in that case swap memory should be equal to your ram size or more, I resized to to 8gb which is equal to my ram.

open terminal and do the following:

sudo gedit /etc/default/grub

replace the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash'"

With

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi='!Windows 2013' acpi_osi='!Windows 2012'"

save and close then also in terminal

uncomment the line #HandleLidSwitch and make sure value equal suspend (or hibernate,depend on wha you want) to look like this

HandleLidSwitch=suspend

you have to restart fully twice , then try.

in case it didnt work out try uninstall acpi-support y typing
sudo apt-get remove acpi

I found the first step of the solution from this guy
https://www.youtube.com/watch?v=l8xa-PkDhhk

now both hibernate and suspend works !!

OOps! Sorry! Now, I see that the workaround is described at #140 (just before my post).

@hamzeh-ahmad, I think that

uncomment the line #HandleLidSwitch and make sure value equal suspend

is not necessary.

I'm guessing that commented parameters at /etc/systemd/logind.conf are the defaults.

So, the line:

#HandleLidSwitch=suspend

is equivalent to:

HandleLidSwitch=suspend

In fact, I didn't need to modify it.

Hamzeh Ahmad (hamzeh-ahmad) wrote :

@jpujades you are right maybe, it was equal hibernate for me not suspend.

I cant remember if it was like that or I changed it while I was trying other solutions.

let say it's a make sure step.

Hamzeh Ahmad (hamzeh-ahmad) wrote :

And Yes #HandleLidSwitch=suspend is in the file

/etc/systemd/logind.conf

Arne (old-man999-r) wrote :

We experienced this on a HP-Probook 6450B with kernel 4.4 running the provided tests:

echo platform > /sys/power/disk

[ 533.556002] perf interrupt took too long (2507 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[ 1830.133850] perf interrupt took too long (5002 > 5000), lowering kernel.perf_event_max_sample_rate to 25000
[ 2537.897989] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 2537.898048] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
[ 3313.942173] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 3313.942273] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
[ 3313.977472] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder B FIFO underrun

echo disk > /sys/power/state

[18786.704686] sd 0:0:0:0: [sda] Starting disk
[18786.708197] ERROR @wl_wowl_ind_wake_reason : Unable to get wake reason, err = -95

Hamzeh Ahmad (hamzeh-ahmad) wrote :

@arne the solution i proposed has been applied on kernal version 4.8
i have updated to from 4.5 to 4.8 and no problems occured , then i tried the steps above

acar burak (acarbura) wrote :

@Hamzeh, does your solution only work with the 4.8 kernel?

Hamzeh Ahmad (hamzeh-ahmad) wrote :

@acarbura yes it does

Acer TM (TravelMate) B117M N3150 processor using SSD (manufactured on Jully-2016)

Lubuntu 14.04 LTS + LTSEnablementStack
(https://wiki.ubuntu.com/Kernel/LTSEnablementStack)

We have about 110 units of this model. Some of them are freezing using them and after suspend.

We migrated some machines to latest stable kernel (4.8.10). Computers are more stable.
(https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1575467/comments/142)

but... they continue to freeze after suspend.

Modifing /etc/default/grub as suggested at comment #140 seems to solve the freezing after suspend.

@old-man999-r, thanks for your test at #146. I didn't know them.
(https://www.kernel.org/doc/Documentation/power/basic-pm-debugging.txt)

I tried the workaround on Asus E502SA but lost touchpad with it applied.

Andrew (coder27) wrote :

I encoutered the same issue with my Lenovo IdeaPad S205.

I've tried several kernels, including latest mainline 4.10 rc2, but no lack - just black screen on wake up.

But I have noticed that the laptop resumes sucessfully from sleep when the power plug has been removed just before pressing a key to wake it up (i.e. It resumes succesfully when powered from battery only).

Hope it helps to fix that annoyance.

If someone needs my log files or hardware reports, please let me know.

Andrew (coder27) wrote :

Hello.

I've tried Linix Mint 18, Ubuntu Mate 16.04 - the problem appeared right after booting live image from USB stick. Ubuntu Mate 16.10 does not have the issue. So I've installed 16.10.

The kernel from 16.10 does not fix Mint 18 and Ubuntu 16.04, so I think it is not a kernel code regression.

Please, copy/paste the output of the command:

uname -a

Like this others (than Mint flavor) can know which kernel version you're using.

Thanks in advance!

Oleg (kwazaro) wrote :

I tried different kernels, settings, even instructions from #140 post of this thread... Nothing could help. But some distros worked fine on this laptop - for example Manjaro and CentOS (waking up from suspend without issues). On my Lenovo s205 the only installing "tlp" and "tlp-rdw" (Linux Advanced Power Management) solved problem with freezing after suspend. The Kernel I'm using is 4.4.0-62-generic (Linux Mint 18.1). More about "tpl" here: http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html

Trueman (d-artyukh) wrote :

Nothing helped: not grub editing from comment #140 neiter instalalling and starting "tlp"...
Fujitsu A555 laptop freezes after 2nd wake up from suspend.
Ubuntu 16.04 with any kernel in range 4.4.0-11 - 4.4.0-59.
I've to use 4.4.0-10 kernel where the issue is not replicated.
Very frustrating...

Manuel (deco3051) wrote :

Solved by disabling the xCHI usb 3.0 on the bios. adding parameters to Grub didn´t.

Now Freezes does not happen after suspend, hibernate, close the lip or turning off.

It takes a decent amount of time to turn off and the screen flash in different shades of black when booting though. would be nice to see this solved.

Hope it helps and that this is the proper place to share this.

I had the same problem here on Acer Aspire E15.

Draven Grey (draven.grey) wrote :

Running into the same thing on an old Macbook with Ubuntu. So far, nothing's worked to fix it. Sadly, there is no USB3 to turn off in order to try the last "fix" posted.

Jeff Cragg (jeffcragg) wrote :

Getting this on 16.04.1 on live try from a usb key, also on 16.10. Black screen on resume. Motherboard is Asus extreme 3 gen 3. Get it when using intel on-board graphics or nvidia card. Have a soundcard if that makes any difference. This bug was introduced at some point before these versions. So suspend/hibernate bug is not -just- suspend/hibernate. Without being able to suspend, it requires repeatedly power cycling the machine. If you have the ram with suspend that going to be better the longer the use the machine, not if you have to power cycle. Also loading up all the apps again, pita. I am going to try Debian and see if the Jessie release fixes this. 16.04+ is plain buggy. I don't think you should have released as a LTS. Check it out this is a common issue.

https://www.google.co.jp/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=ubuntu+suspend+resume+bugs+16.04&*

Andrew (drewandrew) on 2017-04-04
no longer affects: linux
Maxim (maximca) wrote :

Hi, I have same problem and probably my bug report will help to find the problem.

Currently I'm using Lenovo Thinkpad Carbon 4th gen and ubuntu 16.04.2:
Linux carbon 4.8.0-54-generic #57~16.04.1-Ubuntu SMP Wed May 24 16:22:28 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I have problems with suspend only after I plug external screen to my computer. It happens no matter if the screens are connected via the dock station or directly to DP port(s). Also it doesn't matter if suspend was triggered by closing the laptop lid or by the timer.

There are 2 ways I can avoid freezing after suspend:
1) Call "xrandr --auto" after I unplug external screens
2) Execute "sudo pm-suspend" manually

If I do one of the steps above suspend works perfectly and the laptop wakes up with no problems.

One thing to notice: while I was debugging this issue I put a script to the /etc/pm/sleep.d/ which simply logging the fact of its execution. When I'm using pm-suspend this script is being executed but if I simply close the lid then this script is not being executed. I believe when I'm closing the lid some other suspend mechanism is triggered not the pm-suspend.

I can confirm that this bug appeared in 16.04 LTS. I tried all kernels and all workarounds suggested in this post and none of them worked. Also I had same issue on previous Lenovo Carbon x1 rev (3).

For anyone dealing with this issue on a Dell XPS 13 with a touchscreen on Ubuntu 16.04, it seems to re-enabling the touch screen in the laptop bios resolved it for me. I usually keep the touch screen disabled but there must have been a regression in one of the kernel updates that I got that made it suddenly an issue.

I'll update this comment if it turns out I was just lucky for the last few days and that isn't really the solution.

Displaying first 40 and last 40 comments. View all 161 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

  • auto-steverovsky Edit

Bug watches keep track of this bug in other bug trackers.