8086:0116 [Dell Inspiron 14z (N411z)] Display brightness keys don't generate evdev events after saucy upgrade

Bug #1229591 reported by Chris Stratford on 2013-09-24
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

On raring (and precise) the display brightness keys (fn+f4 and fn+f5) on my Dell Inspiron 14z turned the brightness up and down. After a saucy upgrade this no longer happens (I don't see the popup brightness bubble either). The other, similar keys (volume adjustment, etc) still work fine.

Changing the values in /sys/class/backlight/intel_backlight/brightness works (temporarily - it gets reset after the screen lock kicks in)

I tried following the instructions in https://wiki.ubuntu.com/Hotkeys/Troubleshooting but this appears to be out of date (it references /usr/share/doc/udev/README.keymap.txt which does not exist)

Ubuntu kernel version bisect revealed:
First bad Ubuntu kernel: 3.11.0-0.2
last good Ubuntu kernel: 3.10.0-6.17

The results of a commit bisect are pending.

---
ApportVersion: 2.12.4-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: chris 2646 F.... pulseaudio
DistroRelease: Ubuntu 13.10
EcryptfsInUse: Yes
InstallationDate: Installed on 2011-11-18 (675 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Dell Inc. Dell System Inspiron N411Z
MarkForUpload: True
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-8-generic root=UUID=8bcbab07-7d4f-4c89-b6db-54aeed6ad1c4 ro quiet splash pcie_aspm=force i915.i915_enable_rc6=1 vt.handoff=7
ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-8-generic N/A
 linux-backports-modules-3.11.0-8-generic N/A
 linux-firmware 1.114
Tags: saucy
Uname: Linux 3.11.0-8-generic x86_64
UpgradeStatus: Upgraded to saucy on 2013-09-21 (2 days ago)
UserGroups: adm admin cdrom davfs2 dialout lpadmin plugdev sambashare
dmi.bios.date: 09/10/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 0P01VP
dmi.board.vendor: Dell Inc.
dmi.board.version: FAB1
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd09/10/2012:svnDellInc.:pnDellSystemInspironN411Z:pvr:rvnDellInc.:rn0P01VP:rvrFAB1:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System Inspiron N411Z
dmi.sys.vendor: Dell Inc.

Can you please install "evtest", run "sudo evtest" in a terminal, choose the right device ("Dell extra keys", or just the standard keyboard), press these two keys, and copy&paste the output? Use Control-C to stop. Please also run "udevadm info --export-db > /tmp/udev.txt" and attach /tmp/udev.txt here. Thanks!

summary: - display brightness keys stop working after saucy upgrade
+ [keymap] display brightness keys stop working after saucy upgrade
affects: udev (Ubuntu) → systemd (Ubuntu)
Changed in systemd (Ubuntu):
status: New → Incomplete

$ sudo evtest
No device specified, trying to scan all of /dev/input/event*
Available devices:
/dev/input/event0: Power Button
/dev/input/event1: Sleep Button
/dev/input/event2: Lid Switch
/dev/input/event3: Power Button
/dev/input/event4: AT Translated Set 2 keyboard
/dev/input/event5: Video Bus
/dev/input/event6: HDA Intel PCH HDMI/DP,pcm=7
/dev/input/event7: HDA Intel PCH HDMI/DP,pcm=3
/dev/input/event8: HDA Intel PCH Headphone
/dev/input/event9: HDA Intel PCH Mic
/dev/input/event10: Dell WMI hotkeys
/dev/input/event11: SynPS/2 Synaptics TouchPad
/dev/input/event12: Laptop_Integrated_Webcam_HD
Select the device event number [0-12]: 10
Input driver version is 1.0.1
Input device ID: bus 0x19 vendor 0x0 product 0x0 version 0x0
Input device name: "Dell WMI hotkeys"
Supported events:
  Event type 0 (EV_SYN)
  Event type 1 (EV_KEY)
    Event code 148 (KEY_PROG1)
    Event code 149 (KEY_PROG2)
    Event code 161 (KEY_EJECTCD)
    Event code 224 (KEY_BRIGHTNESSDOWN)
    Event code 225 (KEY_BRIGHTNESSUP)
    Event code 227 (KEY_SWITCHVIDEOMODE)
    Event code 236 (KEY_BATTERY)
    Event code 238 (KEY_WLAN)
    Event code 240 (KEY_UNKNOWN)
  Event type 4 (EV_MSC)
    Event code 4 (MSC_SCAN)
Properties:
Testing ... (interrupt to exit)

It displayed nothing when I pressed the keys. I also tried choosing event4 with the same result (or rather, lack of result)

Martin Pitt (pitti) wrote :

Thanks. Your attached udev.txt confirms that the keymap matching worked:

P: /devices/platform/i8042/serio0/input/input4/event4
[...]
E: KEYBOARD_KEY_85=brightnessdown
E: KEYBOARD_KEY_86=brightnessup
[...]

and your evdev output on event10 confirms that the device *claims* to support KEY_BRIGHTNESS{UP,DOWN}.

If you don't get any events on either device, this must be fixed in the kernel keyboard driver, reassigning to linux. Any chance you could try to install/boot the raring kernel on current saucy, to check if that brings back the keys?

affects: systemd (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New
summary: - [keymap] display brightness keys stop working after saucy upgrade
+ display brightness keys don't generate evdev events after saucy upgrade

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1229591

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: saucy

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Just tried with an older kernel, as suggested (3.8.0-30) and it brings the correct behaviour back.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.12 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc2-saucy/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-bisect regression-release

Tested with linux-image-3.12.0-031200rc2-generic, but no change.

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: latest-bios-a06
tags: added: kernel-bug-exists-upstream-v3.12-rc2 needs-upstream-testing
removed: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Latest kernel installed:

$ uname -a
Linux tuor 3.12.0-031200rc6-generic #201310191635 SMP Sat Oct 19 20:36:43 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Brightness keys still don't work and evtest still registers no keypresses.

Chris Stratford, the next step would be to bisect from Raring to Saucy, in order to identify the offending commit. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection ?

tags: added: kernel-bug-exists-upstream-v3.12-rc6
removed: kernel-bug-exists-upstream-v3.12-rc2

I've narrowed it down to 3.11.0-0.2 as the start of the problem. The last working saucy kernel was 3.10.0-6.17

description: updated

Trying bisecting didn't work for me, as (according to the wiki's translation of the output) it spans non-linear tags. My attempt to build from a 3.10 mainline kernel produced an image that suffered from the same issue, but that didn't provide a linux-image-extras package which seems to be necessary for the brightness controls to work.

Consulting http://kernel.ubuntu.com/~kernel-ppa/info/kernel-version-map.html :
3.11.0-0.2 3.11.0-rc4
3.11.0-0.1 3.11.0-rc3
3.10.0-6.17 3.10.3

Hence, before commit bisecting, one would want to switch to the mainline, and further kernel version bisect. Hence, from your last information provided, we have as per http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D :
v3.11-rc3-saucy/
v3.11-rc2-saucy/
v3.11-rc1-saucy/
v3.10.19-saucy/
v3.10.18-saucy/
v3.10.17-saucy/
v3.10.16-saucy/
v3.10.15-saucy/
v3.10.14-saucy/
v3.10.13-saucy/
v3.10.12-saucy/
v3.10.11-saucy/
v3.10.10-saucy/
v3.10.9-saucy/
v3.10.8-saucy/
v3.10.7-saucy/
v3.10.6-saucy/
v3.10.5-saucy/
v3.10.4-saucy/
v3.10.3-saucy/

Hence, is this problem reproducible in v3.10.13-saucy/ ?

Rather bizarrely, I can't get it to work with any of the mainline kernels. Even going back to 3.9.11-030911-generic which should work (since the real 3.10.0-6 works fine) I get no brightness control.

I've also noticed the screen never seems to get turned off. After a while it will blank the screen, but the backlight is still on. This may be completely unconnected, but thought I'd mention it here just in case it may be relevant.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - display brightness keys don't generate evdev events after saucy upgrade
+ 8086:0116 [Dell Inspiron 14z (N411z)] Display brightness keys don't
+ generate evdev events after saucy upgrade

I've just tested the latest trusty-desktop-amd64.iso and it has the same problem. There's still no response to the brightness keys.

tags: added: trusty

Chris Stratford, thank you for testing Trusty. Just to clarify, were you utilizing the following kernel boot parameters in your bisection or Trusty testing:
pcie_aspm=force i915.i915_enable_rc6=1

As well, could you please comment to why you have these?

For my Trusty test it would not have been used (at least not intentionally), as that was from a pure live CD boot.

For all other tests, it would be. Offhand, I don't recall why or when they were added, but I suspect it was an attempt to improve battery life or reduce the temperature.

Chris Stratford, thank you for your quick response. Could you please clear out the non-default kernel boot parameters, and test the following individually and advise if it changes anything:
acpi_backlight=vendor
video.use_bios_initial_backlight=0

when only testing a mainline kernel v3.13.x+ (for example http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13-rc6-trusty/ ):
video.use_native_backlight=1

No change I'm afraid.

I might be misunderstanding what those options do, but the problem isn't the backlight itself. As I stated in the original bug report, changing the value in /sys/class/backlight/intel_backlight/brightness does dim the screen (as does the slider in system settings / brightness & lock). The problem is that the brightness function keys (Fn+F4 and Fn+F5) stopped working after upgrading to Saucy.

Somehow, what appears to be a keyboard issue seems to have morphed into hunting for a backlight-related problem (unless the two are more intertwined than I think)

affects: linux (Ubuntu) → xorg (Ubuntu)
Changed in xorg (Ubuntu):
importance: Medium → Low
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
affects: xorg (Ubuntu) → linux (Ubuntu)

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
madvinegar (madvinegar) wrote :

I have exactly the same problem and exactly the same laptop. I would be very very happy to see this fixed at least for 14.04.

I have 14.04 installed right now on this laptop but I still have the same problem with the function keys.
In case you need to do any tests in 14.04 release, please let me know if I can be of assistance.

madvinegar (madvinegar) wrote :

Just to add that I have today updated my BIOS to the latest available for my laptop (I had A02 and I updated to A06), however the brightness function keys still don't work.

So we will have to wait for a fix to be included in a newer kernel.

madvinegar (madvinegar) wrote :

Hi. Thanx for your reply.
Since I have exactly the same laptop with the same GPU (id 8086:0116) would it be better just to keep updating this bug report and provide additional info? (rather than opening a new bug report?)
I could provide additional info by running:

apport-collect -p linux #1229591

For your info I am using for the moment the ubuntu repository kernel 3.13.0-8.
Please let me know if you agree.

madvinegar (madvinegar) wrote :

I made a clean installation of 14.04 yesterday but unfortunately the problem with the brightness keys is still present.

Have there been any developments as regards isolating the culprit?

It is very strange considering that the keys worked just fine up to 13.04 and kernel 3.8.

I don't know if it helps but the key combination (Fn+F4 and Fn+F5) is like it is dead. I do not get any feedback/result from acpi_listen when pressing them.

In case you have any news, please let me know.
Thank you.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
madvinegar (madvinegar) wrote :

I installed today kernel 3.14.1. The problem is still present.

I have not tried yet kernel 3.15 as it is in a very early (RC2) stage yet.

I have also tried hundreds of grub parameters and conf files inside X11 (following the ARCH wiki here: https://wiki.archlinux.org/index.php/backlight) but still I could not make the brightness keys work.

My opinion is that this is clearly a kernel problem. Something that will not be fixed by just adding parameters in grub etc.
The buttons do not produce any kind of result in acpi_listen.

Since this function was working just fine in earlier kernels, it must mean that there is a change or breakage as regards this aspect in the newer kernels.

madvinegar, if you would like to help with this issue, please test the latest mainline kernel via http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-rc2-trusty/ and advise to the results. The fact it is an RC is not relevant information here, as it contains new patches not found in prior kernel releases.

madvinegar (madvinegar) wrote :

Thank you for your reply. I will test kernel 3.15 and revert with news (probably later on today).

In the meantime and after reading various reported bugs, I came accross this one:
http://www.aristofunnies.gr/wp-content/uploads/2010/12/photo-12.jpeg

It regards dell xps13, but refers to the exact same GPU (id 8086:0116).
As you will read, the same problem persists especially on kernels after the 3.8, and they way to fix the fn function of the brightness keys in newer kernels is to set from the BIOS the "Load Legacy Option Rom" to "Enabled".

Unfortunately even if I have installed the lasted version of BIOS proposed by the DELL manufacturer (i.e. version A06), there is no option for legacy option.

I am just throwing ideas. It may help you go towards the right direction for solving the bug.

I will revert with news about the 3.15 kernel.

In case you have any suggestions, please let me know.

madvinegar (madvinegar) wrote :

Just tried kernel 3.15 rc3, but unfortunately the brightness functions keys (Fn+F4 and Fn+F5) still do not work.

Any comments/ideas regarding my previous post?

Chris Stratford / madvinegar, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://wiki.ubuntu.com/Bugs/Upstream/kernel ?

Please provide a direct URL to your e-mail to the mailing list once you have made it so that it may be tracked.

Thank you for your understanding.

tags: added: kernel-bug-exists-upstream-v3.15-rc3
removed: kernel-bug-exists-upstream-v3.12-rc6
tags: added: cannot-bisect
removed: needs-bisect
tags: removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Triaged
madvinegar (madvinegar) wrote :

Hi, Thanx for your reply.
Could you please be a little more specific?
To whom should I send/mail all the info I will gather from the terminal commands/results when using the latest 3.15 kernel?

madvinegar, you may want to start with linux-input.

madvinegar (madvinegar) wrote :

I have sent the email with all the info to Mr Matthew Garret at <email address hidden>.

madvinegar, you shouldn't be sending e-mails to any one person. Instead, as noted in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1229591/comments/51 you should be sending it to the linux-input mailing list, as previously advised to you in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1229591/comments/53 .

madvinegar (madvinegar) wrote :

I have also sent the email to <email address hidden>

I got a reply from Jani Nikula as per below:

"A bisect result on upstream kernel pointing at the regression might be
useful... although we've changed the code considerably since 3.14."

And from Daniel Vetter as per below.

"Yeah, if the bug still persists on latest upstream kernels then a
bisect between 3.11 and 3.10 should be enlightening."

The problem is that I don't know how to "bisect" the kernels. I don't even know what it means.
I am no linux super user. I am just experienced up to a certain level.
The things I am asked to do become more and more complicated and I cannot keep up, I am sorry.

Could you forward the above bug report to whoever you feel is more appropriate? I really hope that developers already have enough info to find the culprit.

madvinegar, one may learn about bisecting following https://wiki.ubuntu.com/Kernel/KernelBisection .

madvinegar (madvinegar) wrote :

Apologies, I cannot do it. It's too dificult for me. I tried various things and almost made my system inoperable.
I hope devs can solve it with the info and terminal results already provided.
Otherwise, if anyone has more knowledge on these things, he is free to try.
Last working kernel was 3.10.0-6.17

madvinegar (madvinegar) wrote :

Just another piece of information I would like to add.
As I said, I have ubuntu 14.04 installed with kernel 3.13.

I have downloaded from here: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.59-precise/ the latest 3.2 kernel and installed it.
More specifically I downloaded and installed the following 3 packages:

linux-headers-3.2.59-030259-generic_3.2.59-030259.201405181035_amd64.deb
linux-headers-3.2.59-030259_3.2.59-030259.201405181035_all.deb
linux-image-3.2.59-030259-generic_3.2.59-030259.201405181035_amd64.deb

I rebooted and then booted with kernel 3.2.
So my system was 14.04 but with kernel 3.2.

Much to my surprise the brightness function keys did NOT work !!!
I booted a live USB with ubuntu 12.04 (kernel 3.2) and the brightness keys worked just fine.

So, is it NOT a kernel thing? Is it something else??? What could it be...????

Regular User (dot.ru) wrote :

I also suffer from this bug. I have used 12.10 for the past year and upgraded to 14.04 but aside from the fact that it seemed generally buggy this did not work. Going over all the versions between 12.10 and 14.04 revealed that 13.04 is the only one where the brightness keys still work. After that they don't work on any other release. I did a lot of experimenting with grub parameters and what not to no avail.

rpgmaker, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

madvinegar (madvinegar) wrote :

Just to add another piece of information.

The brightness function keys work just fine when I am in BIOS.

madvinegar (madvinegar) wrote :

Also, the brightness keys work when I am in the Grub Menu !!!

That is, before loading the OS.

What could be wrong after loading the OS ???

madvinegar (madvinegar) wrote :

Just a pastebin of xorg that might bve of assistance.

http://paste.ubuntu.com/7582689/

As you will see it says:

intel(0): found backlight control interface acpi_video0 (type 'firmware')

madvinegar (madvinegar) wrote :

I also tried latest fedora, arch and suse, and the same problem persists.

So it must be a kernel problem and not something debian-based.

Jeremy (wa113y3s) wrote :

Bug still present in 3.16 RC3

madvinegar (madvinegar) wrote :

I confirm the above statement. Also tried Fedora 21 rawhide (with kernel 3.16) and the bug is still present.

Regular User (dot.ru) wrote :

I can still experience the issue on 14.04.1

Changed in linux (Ubuntu):
status: Triaged → Confirmed

postadelmaga, please do not adjust the Status. For more on this, please see https://wiki.ubuntu.com/Bugs/Status .

Changed in linux (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions