8086:0116 [Dell Inspiron 14z (N411z)] Display brightness keys do not work on kernels 3.11 and 3.13

Bug #1280394 reported by madvinegar on 2014-02-14
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Brightness keys Fn+F4 and Fn+F5 (decrease and increase brightness) do not work on 13.10 and 14.04.
On 12.04 (up to 12.04.3) and 13.04 worked ok.
That is, up to ubuntu repository kernel 3.8 the brightness keys worked ok.

On ubuntu repository kernels 3.11 and 3.13, the brightness keys do not work. (this includes 12.04.4 that has kernel 3.11).

I currently have installed 14.04 with kernel 3.13.0-8.

However, brightness can be adjusted just fine by going to system settings > Brightness Control and moving the slider back and forth.
So the problem is specific only to the function keys.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-8-generic 3.13.0-8.28
ProcVersionSignature: Ubuntu 3.13.0-8.28-generic 3.13.2
Uname: Linux 3.13.0-8-generic x86_64
ApportVersion: 2.13.2-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mike 1549 F.... pulseaudio
CurrentDesktop: Unity
Date: Fri Feb 14 20:01:28 2014
HibernationDevice: RESUME=UUID=4ffb442c-e2bf-4dbd-8a25-6a4ef0e346f2
InstallationDate: Installed on 2014-01-25 (19 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140124)
MachineType: Dell Inc. Dell System Inspiron N411Z
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-8-generic root=UUID=308a58c8-4425-4ae1-b9a5-86bee1de5030 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-8-generic N/A
 linux-backports-modules-3.13.0-8-generic N/A
 linux-firmware 1.124
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:

dmi.bios.date: 09/10/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 0YWNPW
dmi.board.vendor: Dell Inc.
dmi.board.version: FAB1
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd09/10/2012:svnDellInc.:pnDellSystemInspironN411Z:pvr:rvnDellInc.:rn0YWNPW:rvrFAB1:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System Inspiron N411Z
dmi.sys.vendor: Dell Inc.

madvinegar (madvinegar) wrote :
description: updated
summary: - 8086:0116 [Dell Inspiron 14z (N411z)] Display brightness keys don't
- generate evdev events after saucy upgrade
+ 8086:0116 [Dell Inspiron 14z (N411z)] Display brightness keys do not
+ work on kernels 3.11 and 3.13
description: updated
description: updated
description: updated
description: updated
madvinegar (madvinegar) on 2014-02-14
description: updated

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.13 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14-rc2-trusty/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
madvinegar (madvinegar) wrote :

Just tried kernel 3.14.0-031400rc2 but unfortunately the bug is still present. The brightness function keys do not work.
(not even the volume function keys work - Fn+F11 and Fn+F12)

tags: added: kernel-bug-exists-upstream
madvinegar (madvinegar) on 2014-02-14
description: updated
tags: added: latest-bios-a06
tags: added: kernel-bug-exists-upstream-3.14-rc2
tags: added: regression-release
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Regular User (dot.ru) wrote :

I can confirm this on both releases mentioned in this bug report. I have the exact same machine and everything worked PERFECTLY on 12.10.

madvinegar (madvinegar) wrote :

rpgmaker, can you also follow the discussion in: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1229591

Do you know how to bisect a kernel...?

Regular User (dot.ru) wrote :

@madvinegar: No, I don't know how to do that.

I can still experience the issue on 14.04.1 which is just crazy. I'm on 13.04 trying to avoid losing this functionality but now they took all the repositories offline because its support life cycle ended. It would seem that 14.04 support was the one that ended though given how this hasn't even been looked at (along with many others bug reports).

rpgmaker, as this bug report is a duplicate of #1229591, it notes above the comment box:
"Comment here only if you think the duplicate status is wrong. "

Hence, please refrain from making any further comments here. Instead, please file a new report so your hardware may be tracked, via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to the new report.

As well, there is no need to make any further follow up comment about how you made a new report.

Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers