Ubuntu

backlight brightness not adjustable by default on Dell XPS 13

Reported by Daniel Jared Dominguez on 2012-03-14
252
This bug affects 49 people
Affects Status Importance Assigned to Milestone
Dell Sputnik
Undecided
Unassigned
linux (Ubuntu)
Medium
Kamal Mostafa
Precise
Medium
Kamal Mostafa
Quantal
Medium
Kamal Mostafa
Raring
Medium
Kamal Mostafa

Bug Description

The backlight brightness is not changeable by default on a Dell XPS 13 running Precise beta 1 (or later). If I run the following command as root, I can adjust the brightness:
    /bin/echo 0 > /sys/class/baclight/intel_backlight/brightness
However, I must do this whenever I turn on the computer or resume it from suspend.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: None
Date: Tue Mar 13 20:56:36 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:052e]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MachineType: Dell Inc. Dell System XPS L321X
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=6a0a6c9c-fb29-446a-8806-e431d38c95e8 ro quiet splash i915.i915_enable_fbc=1 i915.i915_enable_rc6=1 pcie_aspm=force vt.handoff=7
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/30/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.name: 085X6F
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd01/30/2012:svnDellInc.:pnDellSystemXPSL321X:pvr:rvnDellInc.:rn085X6F:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L321X
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.7.0+bzr3035-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Oops, the command I mention above should be:
    /bin/echo 0 > /sys/class/backlight/intel_backlight/brightness

Sorry for the typo.

Bryce Harrington (bryce) wrote :

Xorg has not managed the power settings for quite some time.
Since the kernel interface apparently works, it doesn't sound like a drm driver bug.
The kernel doesn't persist its settings, that's gnome's job.
Bumping bug to the g-p-m queue.

affects: xserver-xorg-video-intel (Ubuntu) → gnome-power-manager (Ubuntu)

Thank you. I wasn't entirely sure what package to report the bug against.

Mario Limonciello (superm1) wrote :

At least to me this doesn't look like it's at all caused by a userspace interpretation problem, it's caused only by this intel_backlight interface. It's defaulting to the maximum value it can be set to (4882).

* The button presses do actually translate into the values of /sys/class/backlight/acpi_video0/brightness changing between 0 and 15 as they should.

Manually putting any numbers into /sys/class/backlight/intel_backlight/brightness smaller than max_brightness allows the ACPI video control to work*.

Now most values above 0 set for intel_backlight seem to cause a horrible flicker on the screen as the ACPI values are changed.

I compared to another machine with a properly functioning backlight control, and it's defaulting to a more sane 118 (out of max 976) on it's intel_backlight/brightness value. So for whatever reason, the intel_backlight value that is defaulted on this laptop is 4882.

affects: gnome-power-manager (Ubuntu) → linux (Ubuntu)
Brad Figg (brad-figg) on 2012-04-05
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Invalid

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-22.35
Mario Limonciello (superm1) wrote :

Actually I have tested it with 3.2.0.22-generic #35. Persists with that kernel too.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: bot-stop-nagging
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc1-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Mario Limonciello (superm1) wrote :

Yes, the problem persists with the upstream kernel listed there:
(Linux test-Dell-System-XPS-L321X 3.4.0-030400rc1-generic #201203312035 SMP Sun Apr 1 00:36:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux)

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Kamal Mostafa (kamalmostafa) wrote :

Mario, from your comment #5, it sounds to me like the problem may be due to there being two /sys/class/backlight interfaces present (acpi_video0 and intel_backlight). Mario & Daniel, you might try booting with the kernel boot parameter "acpi_backlight=vendor" which should disable acpi_video0 leaving only intel_backlight. Does that improve any of the behaviors you're seeing (or make them worse)?

Kamal,

I booted with acpi_backlight=vendor, and that makes things worse out of the
box. At max brightness (what it boots by default) no discernable
difference. Then when the screen goes into idle after a few minutes not on
AC it starts flickering at me violently. The same thing happens if I
manually hit the brightness down keys. The lower the brightness the more
aggressive the flicker until I go to zero brightness when the flicker goes
away.

Also, it's worth noting, booting with that option created a dell_backlight
in /sys/class/backlight as well as that intel_backlight.

This is the same type of flicker that happens if I manually set any value
(that I tried) in /sys/class/backlight/intel_backlight/brightness other
than 0 or 4882.

On Tue, Apr 10, 2012 at 16:33, Kamal Mostafa <email address hidden> wrote:

> Mario, from your comment #5, it sounds to me like the problem may be due
> to there being two /sys/class/backlight interfaces present (acpi_video0
> and intel_backlight). Mario & Daniel, you might try booting with the
> kernel boot parameter "acpi_backlight=vendor" which should disable
> acpi_video0 leaving only intel_backlight. Does that improve any of the
> behaviors you're seeing (or make them worse)?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/954661
>
> Title:
> backlight brightness not adjustable by default on Dell XPS 13
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/954661/+subscriptions
>

--
Mario Limonciello
<email address hidden>

Kamal Mostafa (kamalmostafa) wrote :

Mario, how about trying with "acpi_backlight=vendor" and also "dell_laptop.backlight=0" (goal still being to leave only intel_backlight).

Please report what you end up with in /sys/class/backlight in that case, and then whether you still see the flicker when you adjust the intel_backlight/brightness value.

Mario Limonciello (superm1) wrote :

Kamal:

With those boot options I only have intel_backlight in /sys/class/backlight. The brightness keys do move up and down the values, but the screen brightness pulsates rather than flickers.

Robert Hooker (sarvatt) wrote :

http://permalink.gmane.org/gmane.linux.gentoo.user/255182 seems to imply an echo 0 > /sys/class/backlight/intel_backlight/brightness fixes the acpi_video0 interface

Mario Limonciello (superm1) wrote :

Robert,

Yes, that is correct. Matter of fact for now on this machine I've created
an upstart job and pm resume script to do just that on boot so that
brightness control is functional until intel_backlight can be sorted out
properly.

On Tue, Apr 10, 2012 at 17:40, Robert Hooker <email address hidden> wrote:

> http://permalink.gmane.org/gmane.linux.gentoo.user/255182 seems to imply
> an echo 0 > /sys/class/backlight/intel_backlight/brightness fixes the
> acpi_video0 interface
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/954661
>
> Title:
> backlight brightness not adjustable by default on Dell XPS 13
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/954661/+subscriptions
>

--
Mario Limonciello
<email address hidden>

Kamal Mostafa (kamalmostafa) wrote :

I have a Dell XPS13 in hand now and can easily reproduce the problem; I am working on an improved work-around.

Changed in linux (Ubuntu):
assignee: nobody → Kamal Mostafa (kamalmostafa)
status: Triaged → In Progress
Kamal Mostafa (kamalmostafa) wrote :

I've written a patch which provides a new kernel boot param "i915.enable_backlight=0".

    i915.enable_backlight=0 can be used to disable i915 backlight control
    and the /sys/class/backlight/intel_backlight interface -- useful for
    systems where intel_backight conflicts with BIOS backlight control.

An Ubuntu Precise PPA kernel with the patch applied is here: https://launchpad.net/~kamalmostafa/+archive/i915-enable-backlight

Mario/others, please apply the PPA kernel, then boot with "i915.enable_backlight=0". This should resolve the problem (it does on my XPS13). Please confirm.

The attachment "i915-enable-backlight.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Kamal Mostafa (kamalmostafa) wrote :

Robert Hooker has provided an additional patch which automatically switches off the i915.enable_backlight parameter (see comment #18) for the Dell XPS13.

The PPA kernel now includes both patches (as of the ~kamal1 version): https://launchpad.net/~kamalmostafa/+archive/i915-enable-backlight

With the PPA kernel installed, backlight control should work properly on the Dell XPS13 without needing any special boot parameters.

2 comments hidden view all 110 comments
Mario Limonciello (superm1) wrote :

Kamal,

I can confirm this works for me too, thanks.

Kamal Mostafa (kamalmostafa) wrote :

The "i915-enable-backlight" kernel PPA has been moved to: https://launchpad.net/~kamalmostafa/+archive/dellxps and includes additional fixes relevant to Dell XPS 13z and XPS 15z.

Kamal Mostafa (kamalmostafa) wrote :

Patches submitted to intel-gfx.

Changed in linux (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Medium
Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: New → Invalid
Thomas Lärm (rundablage) wrote :

The ppa-kernel actually helped me on a Panasonic CF-18 which had the same problem under Precise. There were two interfaces under /sys/class/brightness: intel_backlight and panasonic. I think the XF86BrightnessUp only tried to adjust the intel_backlight, which did nothing.

Writing directly to panasonic worked, so I assume it's the same problem. Anyway, running the DellXPS-Kernel -> working backlight hotkeys.

Thanks Kamal!

Kamal Mostafa (kamalmostafa) wrote :

Upstream developer Daniel Vetter has developed a more sophisticated backlight patch set which fixes this problem for the Dell XPS 13z. I have updated my DellXPS kernel PPA to include this new patch set since it will likely appear in the mainline kernel soon (the new "kamal1" version of the PPA kernel is queued to build, and will become available within the next day or so):

    https://launchpad.net/~kamalmostafa/+archive/dellxps

Note that the new PPA kernel NO LONGER includes the i915.enable_backlight kernel boot parameter -- it is no longer necessary for the Dell XPS 13z. Hopefully it is likewise no longer necessary for other systems which saw improvement with the old kernel...

@Thomas Lärm (rundablage) - Please advise whether the new "kamal1" version PPA kernel still fixes your brightness control on your Panasonic CF-18!

Anyone else with a brightness control problem machine other than Dell XPS 13z - Please advise if the new "kamal1" version PPA kernel makes brightness control better, or worse (reports of "no change" are not needed).

Thomas Lärm (rundablage) wrote :

Installed the new kernel and it still fixes it on my Panasonic CF-18. Nice one.

Tim Gardner (timg-tpi) on 2012-09-19
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-15.21

---------------
linux (3.5.0-15.21) quantal; urgency=low

  [ Tim Gardner ]

  * ubuntu: AUFS -- update to 18e455787597579fe144cdb2f18aa6a0a32c46a4
  * [Config] Enable aufs
    - LP: #908784

  [ Upstream Kernel Changes ]

  * eCryptfs: check for eCryptfs cipher support at mount
    - LP: #338914
  * drm/i915: pnv has a backlight polarity control bit, too
    - LP: #954661
  * drm/i915: clear up backlight #define confusion on gen4+
    - LP: #954661
  * drm/i915: properly enable the blc controller on the right pipe
    - LP: #954661
  * drm/i915: allow pipe A for lvds on gen4
    - LP: #954661
 -- Tim Gardner <email address hidden> Tue, 18 Sep 2012 08:37:51 -0400

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Chris Van Hoof (vanhoof) on 2012-09-21
no longer affects: xserver-xorg-video-intel (Ubuntu)
no longer affects: xserver-xorg-video-intel (Ubuntu Precise)
no longer affects: xserver-xorg-video-intel (Ubuntu Quantal)
Changed in linux (Ubuntu Precise):
status: Confirmed → In Progress
Kamal Mostafa (kamalmostafa) wrote :

Unfortunately, due to various regressions observed on other machines, we've had to revert the backlight control fixes from Ubuntu Quantal (as of 3.5.0-15.23). I will continue to supply these fixes via the Sputnik kernel PPA (for Precise and Quantal), while working on solutions for those problems: https://launchpad.net/~canonical-hwe-team/+archive/sputnik-kernel

Changed in linux (Ubuntu Quantal):
status: Fix Released → In Progress
lrbabe (public-lrbabe) wrote :

Hi Kamal,

I'm having the same problem with my Sony Vaio T13 with intel graphics.
How should I install the alternative kernel you are maintaining? I've added the ppa for the sputnik kernel but I don't know which packets I should install and if there's any risk in installing this alternative kernel.

Thanks.

lrbabe (public-lrbabe) wrote :

Wow, don't try the alternative kernel provided by Kamal if you don't own a Dell XPS 13!

I just tried it on a Sony Vaio T13 and, after restarting, my backlight was completely switched off!
The screen was black and restoring it to its normal state (when you can read what's on the screen, you know) was a pain in the a**!

I repeat, don't try these fixes on any computer other than the Dell XPS 13, even if you have Intel graphics!

Kamal Mostafa (kamalmostafa) wrote :

@lrbabe- As has been documented in this bug report, the Sputnik kernel is constructed and tested specifically for the Dell XPS 13. Users have reported that it is also beneficial for some other laptop models, but it is not expected to fix all Intel-graphics laptops with non-functional brightness controls. Given your result, it is not likely that the fixes would be relevant for your Sony Vaio T13 anyway, regardless of the backlight-off-at-boot problem. There is always some risk associated with installing any alternative kernel.

AlessandroS (cicerone54) wrote :

I have a brand new dell xps 13 (L321X). I downloaded the kernel from the Sputnik project but it didn't solved the problem of the backlight.
I tried also the method here:
http://askubuntu.com/questions/142017/brightness-keys-f4-and-f5-not-working-on-dell-xps-15-6-laptop
(change /etc/default/grub)
and here:
https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/762670
(add /etc/X11/xorg.conf)
but didn't help.

Any suggestions?

AlessandroS (cicerone54) wrote :

Hi! I installed the new version of the kernel and I still have the same brightness problem as before.

I'm not an expert but I thought about this:
I noticed that the screensaver is functioning, hence the system has a way of changing the brigthness. Maybe if it is possible to check how the screensaver is working I can understand why the brightness is not functioning??

Daniel Farina (drfarina) wrote :

I also have this problem on the Sputnik; uname -a:

Linux sputnik 3.5.0-22-generic #34-Ubuntu SMP Tue Jan 8 21:47:00 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

The workaround (echo 0 > ...) is successful.

AlessandroS (cicerone54) wrote :

For me this command is not functioning : (

Changed in linux (Ubuntu Precise):
assignee: nobody → Kamal Mostafa (kamalmostafa)
Tim Gardner (timg-tpi) on 2013-02-13
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.8.0-6.13

---------------
linux (3.8.0-6.13) raring; urgency=low

  [Tim Gardner]

  * Release Tracking Bug
    - LP: #1125364
  * Add ahci modules to d-i
    - LP: #1124415

  [ Chris Wilson ]

  * SAUCE: drm/i915: Wait for pending flips to complete before tearing down
    the encoders
    - LP: #1097315
 -- Tim Gardner <email address hidden> Wed, 13 Feb 2013 12:16:48 -0700

Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
lrbabe (public-lrbabe) wrote :

Any hint how to get this fix in Quantal? Or should we just wait?

30 comments hidden view all 110 comments
tim.tadh (tim-tadh) wrote :

I should also note if I set brightness (using /sys/class/backlight/intel_backlight/brightness) to anything other than 4882 or 0 it occilates between 2 values constantly. I assume this is because several subsystems are fighting?

basketcase (basketcase) wrote :

Also experiencing this in 3.8.0-23-generic, it is also broke in 'proposed' 3.8.0-25-generic.

Francisco Cribari (cribari) wrote :

Will there be a fix for this bug?

basketcase (basketcase) wrote :

Also broke in 3.8.0-26

➜ ~ uname -r
3.8.0-26-generic

➜ ~ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.04
Release: 13.04
Codename: raring

➜ ~ dmidecode -s bios-version
A07

Mark Rose (markrose) wrote :

Still broken in Raring.

Dekos Namax (dekos-namax) wrote :

Indeed.

I have this problem since Ubuntu 10.04. Couldn't fix it.

Using a LG laptop and Ubuntu 13.04 x64 (Kernel: 3.8.0-25).

Francisco Cribari (cribari) wrote :

Will there be a fix?

Itai Ganot (camelel) wrote :

Update:
For reasons which are not related to this issue I had to format my laptop and re-install it, I am now running 3.8.0-23 , I've added the lines from post #54 and it's working like a charm now.

Itai Ganot (camelel) wrote :

Well, seems like is doesn't work like a charm after all...
After going out from screen saver (black screen) brightness is not adjustable again.

Francisco Cribari (cribari) wrote :

The problem remains in kernel 3.10.0.

Francisco Cribari (cribari) wrote :

The problem remains in kernel 3.8.0-26.

Brian Semrad (bjsemrad) wrote :

I just installed fedora on XPS 13 kernel 3.9.9-301.fc19.x86_64, same issue. Does anyone have the link to the Kernel bug?

1 comments hidden view all 110 comments
Francisco Cribari (cribari) wrote :

The problem remains in kernel 3.8.0-27.

c0h1b4 (dwidman) wrote :

All 3.10.x kernels still have this problem. Using the script workaround on the /etc/pm/sleep.d only fixes shutdown/boot and suspend/wakeup (via software).
When I close the lid of the Dell XPS 13 FHD and open it back, /sys/class/backlight/intel_backlight/brightness value returns to 4882. Then I need to issue an echo 0 > /sys/class/backlight/intel_backlight/brightness to have brightness back to original level and have it working again.

kernel v3.11-rc3-saucy from http://kernel.ubuntu.com/~kernel-ppa/mainline/ (ubuntu kernel mainline ppa) fix the problem (I tested it and it is reported in changelog too)

c0h1b4 (dwidman) wrote :

I confirm after several tests that v3.11.rc3-saucy fixes the problem. It works perfectly now. Great job.

Download full text (3.9 KiB)

I have ha several friends report that using xfce on fedora 3.10.3 also
resolves the problem. I am curious if it is gnome related.

On Thursday, August 1, 2013, c0h1b4 wrote:

> I confirm after several tests that v3.11.rc3-saucy fixes the problem. It
> works perfectly now. Great job.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/954661
>
> Title:
> backlight brightness not adjustable by default on Dell XPS 13
>
> Status in Dell Sputnik:
> New
> Status in “linux” package in Ubuntu:
> Fix Released
> Status in “linux” source package in Precise:
> In Progress
> Status in “linux” source package in Quantal:
> In Progress
> Status in “linux” source package in Raring:
> Fix Released
>
> Bug description:
> The backlight brightness is not changeable by default on a Dell XPS 13
> running Precise beta 1 (or later). If I run the following command as root,
> I can adjust the brightness:
> /bin/echo 0 > /sys/class/baclight/intel_backlight/brightness
> However, I must do this whenever I turn on the computer or resume it
> from suspend.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
> ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
> Uname: Linux 3.2.0-18-generic x86_64
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.94.1-0ubuntu2
> Architecture: amd64
> CompizPlugins:
> [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
> CompositorRunning: None
> Date: Tue Mar 13 20:56:36 2012
> DistUpgraded: Fresh install
> DistroCodename: precise
> DistroVariant: ubuntu
> ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in
> Ubuntu
> GraphicsCard:
> Intel Corporation 2nd Generation Core Processor Family Integrated
> Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
> Subsystem: Dell Device [1028:052e]
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64
> (20120301)
> MachineType: Dell Inc. Dell System XPS L321X
> ProcEnviron:
> TERM=xterm
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic
> root=UUID=6a0a6c9c-fb29-446a-8806-e431d38c95e8 ro quiet splash
> i915.i915_enable_fbc=1 i915.i915_enable_rc6=1 pcie_aspm=force vt.handoff=7
> SourcePackage: xserver-xorg-video-intel
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 01/30/2012
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: A02
> dmi.board.name: 085X6F
> dmi.board.vendor: Dell Inc.
> dmi.board.version: A00
> dmi.chassis.type: 8
> dmi.chassis.vendor: Dell Inc.
> dmi.chassis.version: 0.1
> dmi.modalias:
> dmi:bvnDellInc.:bvrA02:bd01/30/2012:svnDellInc.:pnDellSystemXPSL321X:pvr:rvnDellInc.:rn085X6F:rvrA00:cvnDellInc.:ct8:cvr0.1:
> dmi.product.name: Dell System XPS L321X
> dmi.sys.vendor: Dell Inc.
> version.compiz: compiz 1:0.9.7.0+bzr3035-0ubuntu1
> version.ia32-libs: ia32-libs N/A
> ...

Read more...

Antti Kaijanmäki (kaijanmaki) wrote :

After upgrading to 3.11 on saucy today the problem seems to be fixed. The backlight control buttons work as expected.

Nikki1993 (nikki-icekronik) wrote :

To all those wondering about backlight in Precise and Quantal, if you switch your BIOS mode to UEFI, and reinstall Ubuntu in UEFI mode, it will fix the brightness issue. You can use your function keys out of the box, and they will change the brightness accordingly.

The only issue is, with the fresh Precise installation, you will need to update your kernel through the Updater, otherwise your brightness will be stuck on the lowest one. After an update, all issues gone, and you can use your laptop as is :D

Francisco Cribari (cribari) wrote :

Still broken in kernel 3.8.0-29.

j0sh (josh-pixael) wrote :

Guys I'm on
Linux XPS-L322X 3.11.0-031100rc6-generic #201308181835 SMP Sun Aug 18 22:35:54 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
and the brightness control show me the notification panel but it doesn't change anything. I've been stuck at maximum brightness from months.

1 comments hidden view all 110 comments
Alex Comba - Agile BG (tafaru) wrote :

3.8.0-30-generic #44 with raring, bios-version: A06
Now it works again :)

Thank U

Ross Williams (gunzy83au) wrote :

Confirmed. Appears to be working now without passing 0 to /sys/class/backlight/intel_backlight/brightness on boot and resume after updating to 3.8.0-30-generic #44. Also tested waking the monitor from power saving state (machine is still up, screen is off) and can confirm this now works as expected as well.

Borislav Slavov (borislav) wrote :

Hi,

Im on Linux Linux Bob-Dell 3.2.0-53-generic #81-Ubuntu SMP Thu Aug 22 21:01:03 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
and the brightness control is not working. The notification panel is shown when using F4/F5 but the brightness level does not change.
It was working yesterday but after a software update today it broke again :/
Please Help!!

Elco (eajnab) wrote :

Same here (as #97), yesterday everything was working fine, and this morning after a reboot the screen brightness is very dim. I couldn't see anything.

My workaround is currently to fall back to the previous kernel (3.8.0-29-generic), which is working fine, 3.8.0-30 is however not working.

David Piggott (dhpiggott) wrote :

I've got the FHD XPS 13 and am pleased to note that the upgrade to 3.8.0-30-generic that I got this morning has fixed this - I now longer have to pass 0 to /sys/class/backlight/intel_backlight/brightness on boot/resume to adjust the brightness.

Thanks for the fix.

Same problem........my laptop (XPS13) has started to fail with backlight just after updating to 3.8.0-30

Brian Pitts (bpitts) wrote :

This is working for me in 3.8.0-30.44

David Piggott (dhpiggott) wrote :

I spoke a bit too soon it seems.

It had been working fine. Just now I left my laptop for ~5 minutes (it was on, screen open, brightness on full when I left).

I came back and found the brightness stuck on minimum (and my session had timed out, prompting me for my password - presumably something that happened as part of the time out is what triggered this bug and thus the brightness to be stuck on minimum).

Echoing 0 to /sys/class/backlight/intel_backlight/brightness did not fix it. Suspending and unsuspending the laptop did fix it - the brightness was back at full when I unsuspended, and I have control again.

I seem to recall reading either further up on here or elsewhere that the root cause is/was a race condition. I know next to nothing about things at this level (my current expertise is in Android and at the SDK level) but what I saw just now seemed like it could be explained in terms of a race condition.

Mephi (mephi-mephi) wrote :

Add me to the list of affected people....

It's a clean install of Ubuntu 13.04 running 3.2.0-30 and so far I've tried:
Echoing 0 to /sys/class/backlight/intel_backlight/brightness
Adding acpi_backlight=vendor go the grub config
Downgrading to 3.8.0-29 (this just dumps me to a terminal and doesn't load the GUI)

I'm now kicking off the upgrade to 13.10 beta, to see if that works :-)

Matt

My XPS 13.3FHD brightness has been off since kernel 3.8.0-30. Lucky for me I never removed kernel 3.8.0-29, since I can reboot into that kernel an everything works.

SjB

Daniele Dellafiore (ildella) wrote :

still not working with XPS 13 and 3.8.0-31-generic that I got from upgrade today.
I have to start with 3.8.0-29-generic to have it working.

Ross Williams (gunzy83au) wrote :

I am now on the 3.8.0-31-generic kernel and it is still working for me as per my previous comment (#96). Weird we are getting such variable results here! 2013 XPS13 FHD with Intel i5.

Bib (bybeu) on 2013-09-30
tags: added: l321x

Same problem as most of the audience......Being forced to log in from 3.8.0-29 as new "31" has the same brightness problem as "30".........

Holly shit.... :-)

If you are using the XPS 13 L322x HD syste and booting with the EFI loader you may want to try setting your bios to these settings.

I booted into my XPS bios setup, navigated to the boot tab, and configure the setting as below;

Secure Boot: Disable
Load Legacy Option Rom: Enabled
Boot List Option: UEFI

Thanks Steve:

My BIOS was set to Load Legacy Option Rom: Disabled

As soon as I have set it to Enabled, now the backlight is working with last released kernels.

Thank you so much for the tip!!.

jalon (jalonwong) wrote :

I have same problem on my Dell Latitude 3540 with Ubuntu 13.10.

Displaying first 40 and last 40 comments. View all 110 comments or add a comment.