psmouse serio1: Trackpad lost sync at byte 1 ... driver resynced

Bug #1229361 reported by David Zumbrunnen
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Joseph Salisbury
Raring
Medium
Joseph Salisbury
Saucy
Medium
Joseph Salisbury

Bug Description

When the lid of my Dell XPS 13 Developer Edition is closed (or when I place a piece of paper or my hand on the Trackpad) I get a flood of these messages in /var/log/kern.log:

Sep 23 21:09:02 helium kernel: [ 353.953960] psmouse serio1: Trackpad at isa0060/serio1/input0 lost sync at byte 1
Sep 23 21:09:02 helium kernel: [ 353.956037] psmouse serio1: Trackpad at isa0060/serio1/input0 - driver resynced.
Sep 23 21:09:02 helium kernel: [ 353.985707] psmouse serio1: Trackpad at isa0060/serio1/input0 lost sync at byte 1
Sep 23 21:09:02 helium kernel: [ 353.987062] psmouse serio1: Trackpad at isa0060/serio1/input0 - driver resynced.
Sep 23 21:09:02 helium kernel: [ 354.017140] psmouse serio1: Trackpad at isa0060/serio1/input0 lost sync at byte 1
Sep 23 21:09:02 helium kernel: [ 354.018946] psmouse serio1: Trackpad at isa0060/serio1/input0 - driver resynced.
Sep 23 21:09:02 helium kernel: [ 354.049057] psmouse serio1: Trackpad at isa0060/serio1/input0 lost sync at byte 1
Sep 23 21:09:02 helium kernel: [ 354.050688] psmouse serio1: Trackpad at isa0060/serio1/input0 - driver resynced.
Sep 23 21:09:02 helium kernel: [ 354.081213] psmouse serio1: Trackpad at isa0060/serio1/input0 lost sync at byte 1
Sep 23 21:09:02 helium kernel: [ 354.082774] psmouse serio1: Trackpad at isa0060/serio1/input0 - driver resynced.
Sep 23 21:09:02 helium kernel: [ 354.112302] psmouse serio1: Trackpad at isa0060/serio1/input0 lost sync at byte 1
Sep 23 21:09:02 helium kernel: [ 354.114059] psmouse serio1: Trackpad at isa0060/serio1/input0 - driver resynced.
Sep 23 21:09:02 helium kernel: [ 354.143780] psmouse serio1: Trackpad at isa0060/serio1/input0 lost sync at byte 1
Sep 23 21:09:02 helium kernel: [ 354.145029] psmouse serio1: Trackpad at isa0060/serio1/input0 - driver resynced.
Sep 23 21:09:02 helium kernel: [ 354.174322] psmouse serio1: Trackpad at isa0060/serio1/input0 lost sync at byte 1
Sep 23 21:09:02 helium kernel: [ 354.176148] psmouse serio1: Trackpad at isa0060/serio1/input0 - driver resynced.
Sep 23 21:09:02 helium kernel: [ 354.206523] psmouse serio1: Trackpad at isa0060/serio1/input0 lost sync at byte 1

According to this two other bug reports, this bug seems to have never been fixed since 12.04:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1171902
https://bugs.launchpad.net/dell-sputnik/+bug/1048258

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-8-generic 3.11.0-8.15
ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
Uname: Linux 3.11.0-8-generic x86_64
ApportVersion: 2.12.4-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: dave 2010 F.... pulseaudio
 /dev/snd/controlC0: dave 2010 F.... pulseaudio
Date: Mon Sep 23 21:10:22 2013
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=2c84d8ac-a986-49a8-87fe-c831618c27eb
InstallationDate: Installed on 2013-09-21 (2 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130921)
MachineType: Dell Inc. Dell System XPS L322X
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-8-generic root=UUID=a8e9f770-5a80-4ce0-92c2-451af2f20c64 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-8-generic N/A
 linux-backports-modules-3.11.0-8-generic N/A
 linux-firmware 1.114
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/15/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0PJHXN
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd05/15/2013:svnDellInc.:pnDellSystemXPSL322X:pvr:rvnDellInc.:rn0PJHXN:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L322X
dmi.sys.vendor: Dell Inc.

Revision history for this message
David Zumbrunnen (zumbrunnen) wrote :
Revision history for this message
Brad Figg (brad-figg) wrote : Status changed to Confirmed

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

It looks like we just need to set the finger count to 0 in the case of palm detect. I'll put together a patch that can be sent upstream and SRU'd to the stable releases. I'll build a test kernel and post a link to it shortly.

Changed in linux (Ubuntu Saucy):
assignee: nobody → Joseph Salisbury (jsalisbury)
status: Confirmed → In Progress
Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

I posted a test kernel for download at:
http://kernel.ubuntu.com/~jsalisbury/lp1229361/

Can you test this kernel and see if it resolves this bug? Note, you will have to install both the linux-image and linux-image-extra .deb packages.

Thanks in advance!

Revision history for this message
David Zumbrunnen (zumbrunnen) wrote :

Hi Joseph

Thank you for the very fast response! I've just installed it and tested it: No more flooding of kern.log and the palm detection works much better: no more jumping from window to window.

Without seeing a patch, I guess you've changed the result code in cypress_get_finger_count (as in https://bugs.launchpad.net/dell-sputnik/+bug/1048258/comments/41 ), right?

Dave

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Thanks for testing, David. Yes that is what the patch does. I'll submit this patch for inclusion upstream and in the stable Ubuntu kernels.

Changed in linux (Ubuntu Raring):
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Joseph Salisbury (jsalisbury)
Andy Whitcroft (apw)
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Saucy):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.11.0-9.16

---------------
linux (3.11.0-9.16) saucy; urgency=low

  [ Andy Whitcroft ]

  * Revert "SAUCE: (no-up) scsi: hyper-v storage -- mark as preferring READ
    CAPACITY (16) at SPC-2"
  * Revert "SAUCE: (no-up) scsi: hyper-v storage -- mark as VPD capable at
    SPC-2"
  * Revert "SAUCE: (no-up) scsi: add scsi device flag to request READ
    CAPACITY (16) be preferred"
  * Revert "SAUCE: (no-up) scsi: add scsi device flag to request VPD pages
    be used at SPC-2"

  [ Seth Forshee ]

  * SAUCE: (no-up) ACPI: Disable Windows 8 compatibility for some Lenovo
    ThinkPads
    - LP: #1183856

  [ Tim Gardner ]

  * [Config] CONFIG_CRYPTO_CRCT10DIF=y, CONFIG_CRYPTO_CRCT10DIF_PCLMUL=m
  * [packaging] Bump ABI for every new release
  * rebase to v3.11.2
  * Release tracker
    - LP: #1231999

  [ Upstream Kernel Changes ]

  * scsi: hyper-v storsvc switch up to SPC-3
  * perf/x86: Add Silvermont (22nm Atom) support
    - LP: #1091539
  * perf/x86/intel: Fix Silvermont offcore masks
    - LP: #1091539
  * modules: add support for soft module dependencies
    - LP: #1188010
  * Reinstate "crypto: crct10dif - Wrap crc_t10dif function all to use
    crypto transform framework"
    - LP: #1188010
  * skge: fix broken driver
    - LP: #1216745
  * Input: cypress_ps2 - Return zero finger count if palm is detected.
    - LP: #1229361
  * udf: Standardize return values in mount sequence
    - LP: #1228751
  * udf: Refuse RW mount of the filesystem instead of making it RO
    - LP: #1228751
  * rebase to v3.11.2
 -- Tim Gardner <email address hidden> Mon, 23 Sep 2013 07:41:07 -0600

Changed in linux (Ubuntu Saucy):
status: Fix Committed → Fix Released
Revision history for this message
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-raring' to 'verification-done-raring'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-raring
Revision history for this message
David Zumbrunnen (zumbrunnen) wrote :

I've successfully tested this on a fresh install of raring:

3.8.0-19.30: kern.log is flooded with messages as in this bug's description
3.8.0-32.47: no more flooding, palm is properly detected, bug seems fixed

tags: added: verification-done-raring
removed: verification-needed-raring
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (9.5 KiB)

This bug was fixed in the package linux - 3.8.0-32.47

---------------
linux (3.8.0-32.47) raring; urgency=low

  [Steve Conklin]

  * Release Tracking Bug
    - LP: #1233777

  [ Upstream Kernel Changes ]

  * Revert "net/core/sock.c: add missing VSOCK string in
    af_family_*_key_strings"
    - LP: #1233227
  * Input: cypress_ps2 - Return zero finger count if palm is detected.
    - LP: #1229361
  * isofs: Refuse RW mount of the filesystem instead of making it RO
    - LP: #1228751
  * udf: Standardize return values in mount sequence
    - LP: #1228751
  * udf: Refuse RW mount of the filesystem instead of making it RO
    - LP: #1228751
  * ARM: update FIQ support for relocation of vectors
    - LP: #1233227
  * ARM: Fix FIQ code on VIVT CPUs
    - LP: #1233227
  * regmap: Add another missing header for !CONFIG_REGMAP stubs
    - LP: #1233227
  * ALSA: hda - Add inverted digital mic fixup for Acer Aspire One
    - LP: #1233227
  * mac80211: add missing channel context release
    - LP: #1233227
  * iwl4965: fix rfkill set state regression
    - LP: #1233227
  * ath9k_htc: Restore skb headroom when returning skb to mac80211
    - LP: #1233227
  * ath9k: Enable PLL fix only for AR9340/AR9330
    - LP: #1233227
  * ALSA: hda - Fix NULL dereference with CONFIG_SND_DYNAMIC_MINORS=n
    - LP: #1233227
  * lparcfg: don't bother saving pointer to proc_dir_entry
    - LP: #1233227
  * powerpc/pseries/lparcfg: Fix possible overflow are more than 1026
    - LP: #1233227
  * powerpc: Don't Oops when accessing /proc/powerpc/lparcfg without
    hypervisor
    - LP: #1233227
  * powerpc: Work around gcc miscompilation of __pa() on 64-bit
    - LP: #1233227
  * powerpc/hvsi: Increase handshake timeout from 200ms to 400ms.
    - LP: #1233227
  * net: Check the correct namespace when spoofing pid over SCM_RIGHTS
    - LP: #1233227
  * ALSA: opti9xx: Fix conflicting driver object name
    - LP: #1233227
  * SUNRPC: Fix memory corruption issue on 32-bit highmem systems
    - LP: #1233227
  * drivers/base/memory.c: fix show_mem_removable() to handle missing
    sections
    - LP: #1233227
  * memcg: check that kmem_cache has memcg_params before accessing it
    - LP: #1233227
  * workqueue: cond_resched() after processing each work item
    - LP: #1233227
  * drm/i915: ivb: fix edp voltage swing reg val
    - LP: #1233227
  * drm/vmwgfx: Split GMR2_REMAP commands if they are to large
    - LP: #1233227
  * af_key: initialize satype in key_notify_policy_flush()
    - LP: #1233227
  * Linux 3.8.13.9
    - LP: #1233227
  * zram: allow request end to coincide with disksize
    - LP: #1233227
  * mtd: nand: fix NAND_BUSWIDTH_AUTO for x16 devices
    - LP: #1233227
  * HID: hidraw: correctly deallocate memory on device disconnect
    - LP: #1233227
  * xen-gnt: prevent adding duplicate gnt callbacks
    - LP: #1233227
  * ath9k: always clear ps filter bit on new assoc
    - LP: #1233227
  * ceph: Don't forget the 'up_read(&osdc->map_sem)' if met error.
    - LP: #1233227
  * libceph: unregister request in __map_request failed and nofail == false
    - LP: #1233227
  * usb: config->desc.bLength may not exceed amount of data returned by the
    device
    - LP: #12332...

Read more...

Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Revision history for this message
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-saucy' to 'verification-done-saucy'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-saucy
Revision history for this message
David Zumbrunnen (zumbrunnen) wrote :

Marking as verified as the fix has been published in Saucy's stable branch for a long time now.

tags: added: verification-done-saucy
removed: verification-needed-saucy
Revision history for this message
Sylvain Duchesne (c-mail-j) wrote :

I am facing quite a similar bug.

[ 5064.348229] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 5064.374647] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 5064.401144] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 5064.427147] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 5064.453618] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 5064.453630] psmouse serio1: issuing reconnect request

The touchpad is not responding during several seconds. It could happen again some seconds later or not happen during hours.
This is very annoying :(

Note: I had this issues years ago then it disappeared (maybe thanks to the fix associated to this thread) and now this problem is back (from one month or two).

Revision history for this message
Dima Ryazanov (dima-gmail) wrote :

In my case, scrolling sometimes stops working. If I switch to a VT then back to X, it starts working again.

This started happening when I upgraded to 15.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers