Cypress trackpad gets psmouse lost sync / driver resynced warnings

Reported by Serge Gélinas on 2012-09-09
72
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Dell Sputnik
Low
Kyle Fazzari
linux (Ubuntu)
Medium
Unassigned
Precise
Undecided
Kyle Fazzari
Quantal
Undecided
Kyle Fazzari

Bug Description

I installed Kubuntu 12.04 with ppa suggested on this forum but I still have intermittent problem with touchpad.I also install kde-config-touchpad and have full control on touchpad(ex.: disable when mouse plugged).

It work like I want but after come back from sleep mode, I got error message about synaptics and the syslog look like this:
Sep 9 10:28:34 XPS-L321X kernel: [ 6839.441575] psmouse serio1: Trackpad at isa0060/serio1/input0 lost sync at byte 1
Sep 9 10:28:34 XPS-L321X kernel: [ 6839.442852] psmouse serio1: Trackpad at isa0060/serio1/input0 - driver resynced.

These lines are repeated in infinite loop.

I tried these command:
sudo modprobe -r psmouse
sudo modprobe psmouse

It reassign input:
input: CyPS/2 Cypress as /devices/platform/i8042/serio1/input/input17
It stop the loop for 2 minutes and start again

Only way to fix is restart x session

Kyle Fazzari (kyle.f) wrote :

Can you please explain the error message regarding Synaptics? That syslog looks normal-- it's a known issue and shouldn't really be causing you problems.

Serge Gélinas (srggelinas) wrote :

Since last ubuntu update, synaptics error didnt come back.
Loop on driver recsynced continue infinitly in syslog. But I dont see impact.
If you tell me, that s a known bug, its OK.
My only concern now is ressource lost with this bug.

Thanks for answer

Kamal Mostafa (kamalmostafa) wrote :

The Cypress driver appears to make psmouse emit flurries of these pairs of "lost sync" / "driver resynced" messages -- usually between 20 and 100 pairs in each batch. On my Ubuntu 12.04 Sputnik XPS 13, the flurries sometimes occur when I rapidly tap and click on the pad randomly (I don't need to suspend/resume).

Aside from their appearance in dmesg they don't seem to cause any functional problem with the touchpad. In particular, I do not see the messages repeating in an "infinite loop" -- just occasional flurries.

@Serge, does your condition match what I describe above (occasional flurries)? Or are you actually getting new instances of these messages being added *continuously* to dmesg? Pound on your touchpad randomly for a moment to make a flurry of the messages occur, then run dmesg. Assuming that the last message printed is a "driver resynced", note its timestamp, then without touching the pad at all run dmesg a couple more times -- does the timestamp change or stay the same?

Changed in dell-sputnik:
importance: Undecided → Low
status: New → Confirmed
summary: - touchpad
+ Cypress trackpad gets psmouse lost sync / driver resynced warnings
Kyle Fazzari (kyle.f) wrote :

Wanted to throw in my two cents: this seems to be caused by palm detection-- that's the only time I can get this to occur.

Serge Gélinas (srggelinas) wrote :

I use synaptics with option to disable trackpad when mouse is connected most of time now( and this way give me confort I need).

My syslog contains for now about 5 minutes of log:
$cat /var/log/syslog|grep -c resynced
The result is 2985

@Kyle, you put finger on. Even if mouse plugged or not and trackpad disabled or not by synaptics, driver resynced messages occur in any condition with palm touch for next 5 minutes approx.

Kyle Fazzari (kyle.f) wrote :

Quick proof that it's related to the palm touch. Run:

tail -f /var/log/kern.log

Touch your palm to the touchpad, and notice the lost sync messages start flying. Remove the palm, and notice them stop. I'm unable to do anything else that causes the lost sync messages.

A possible hypothesis is that the touchpad sends a particular message upon palm detection that the driver doesn't read correctly. The symptoms are similar to what I would expect if it read more (or less) than a single packet, failed a checksum, then had to re-sync. This happens in a loop as long as one's palm is in contact.

Serge Gélinas (srggelinas) wrote :

You re right again. It s palm detection start and stop as soon as left hand.

Serge Gélinas (srggelinas) wrote :

The point now is: why there is a palm detection even if trackpad is disable.
But I understand, it s a driver concern

Thanks

Kyle Fazzari (kyle.f) wrote :

The issue is indeed that the driver incorrectly handles palm detection, but it wasn't quite what I thought. It invalidates the packets generated by palm contact, which causes it to think it lost sync and attempt a resync. I have attached a patch that fixes this issue by instead simply setting the number of contacts to zero upon palm contact (thereby doing nothing).

Changed in dell-sputnik:
assignee: nobody → Kyle Fazzari (kyle.f)
Kyle Fazzari (kyle.f) on 2012-10-08
Changed in dell-sputnik:
status: Confirmed → In Progress
Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → Kyle Fazzari (kyle.f)
Chris Van Hoof (vanhoof) on 2012-10-09
Changed in linux (Ubuntu Quantal):
milestone: none → quantal-updates
Changed in linux (Ubuntu Precise):
milestone: none → precise-updates
status: New → In Progress
Changed in linux (Ubuntu Precise):
assignee: nobody → Kyle Fazzari (kyle.f)
Kamal Mostafa (kamalmostafa) wrote :

Kyle, I confirm that your patch fixes the problem. Thanks very much for your work!

The patch has been applied to the Sputnik PPA kernel (versions labelled +kamal11 or higher):

  https://launchpad.net/~canonical-hwe-team/+archive/sputnik-kernel

I'll contact you to arrange for the patch to be applied to Ubuntu Quantal and Precise also.

Changed in dell-sputnik:
status: In Progress → Fix Committed
Kyle Fazzari (kyle.f) wrote :

Sweet, thanks for confirming Kamal!

The attachment "Fixed by setting the contact count to zero upon palm detection instead of an invalid value." of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Kyle Fazzari (kyle.f) on 2012-10-14
Changed in dell-sputnik:
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi) on 2012-10-18
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) on 2012-10-18
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Quantal in -proposed solves the problem (3.5.0-18.29). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
Kamal Mostafa (kamalmostafa) wrote :

Verified fixed in quantal 3.5.0-18.29.

tags: added: verification-done-quantal
removed: verification-needed-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (16.4 KiB)

This bug was fixed in the package linux - 3.5.0-18.29

---------------
linux (3.5.0-18.29) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1068224

  [ Andy Whitcroft ]

  * [packaging] do not fail secure copy on older kernels
  * SAUCE: efivarfs: efivarfs_file_read ensure we free data in error paths
    - LP: #1063061
  * SAUCE: efivars: efivarfs_create() ensure we drop our reference on inode
    on error
    - LP: #1063061
  * SAUCE: efivarfs: efivarfs_fill_super() fix inode reference counts
    - LP: #1063061
  * SAUCE: efivarfs: efivarfs_fill_super() ensure we free our temporary
    name
    - LP: #1063061
  * SAUCE: efivarfs: efivarfs_fill_super() ensure we clean up correctly on
    error
    - LP: #1063061
  * [Config] add fs/udf to linux-image to support DVD/CD formats in virtual
    instances
    - LP: #1066921

  [ Jeremy Kerr ]

  * SAUCE: efi: Handle deletions and size changes in efivarfs_write_file
    - LP: #1063061
  * SAUCE: efivarfs: Implement exclusive access for {get, set}_variable
    - LP: #1063061

  [ Kamal Mostafa ]

  * SAUCE: input: Cypress PS/2 Trackpad list additional contributors

  [ Kyle Fazzari ]

  * SAUCE: input: Cypress PS/2 Trackpad fix lost sync upon palm contact
    - LP: #1048258
  * SAUCE: input: Cypress PS/2 Trackpad fix taps turning into hardware
    clicks
    - LP: #1064086

  [ Leann Ogasawara ]

  * Revert "SAUCE: ext4: fix crash when accessing /proc/mounts
    concurrently"
    - LP: #1066176
  * Revert "SAUCE: ALSA: hda/realtek - Fix detection of ALC271X codec"
    - LP: #1066176

  [ Lee, Chun-Yi ]

  * SAUCE: efi: add efivars kobject to efi sysfs folder
    - LP: #1063061

  [ Matt Fleming ]

  * SAUCE: efivarfs: Add documentation for the EFI variable filesystem
    - LP: #1063061

  [ Matthew Garrett ]

  * SAUCE: efi: Add support for a UEFI variable filesystem
    - LP: #1063061

  [ Sarveshwar Bandi ]

  * SAUCE: bridge: Pull ip header into skb->data before looking into ip
    header.
    - LP: #1065150

  [ Upstream Kernel Changes ]

  * Revert "drm/i915: correctly order the ring init sequence"
    - LP: #1066176
  * vfs: dcache: fix deadlock in tree traversal
    - LP: #1063761
  * dm mpath: only retry ioctl when no paths if queue_if_no_path set
    - LP: #1063761
  * dm: handle requests beyond end of device instead of using BUG_ON
    - LP: #1063761
  * dm table: clear add_random unless all devices have it set
    - LP: #1063761
  * dm verity: fix overflow check
    - LP: #1063761
  * usb: gadget: make g_printer enumerate again
    - LP: #1063761
  * usb: gadget: initialize the strings in tcm_usb_gadget properly
    - LP: #1063761
  * USB: option: blacklist QMI interface on ZTE MF683
    - LP: #1063761
  * USB: ftdi_sio: add TIAO USB Multi-Protocol Adapter (TUMPA) support
    - LP: #1063761
  * USB: qcaux: add Pantech vendor class match
    - LP: #1063761
  * usb: host: xhci: Fix Null pointer dereferencing with 71c731a for
    non-x86 systems
    - LP: #1063761
  * USB: serial: fix up bug with missing {}
    - LP: #1063761
  * staging: speakup_soft: Fix reading of init string
    - LP: #1063761
  * tty: keyboard.c: Remove locking from vt_get_leds.
  ...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel (3.2.0-34.53) in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Kamal Mostafa (kamalmostafa) wrote :

Verified fixed in precise (3.2.0-34.53).

tags: added: verification-done-precise
removed: verification-needed-precise
Launchpad Janitor (janitor) wrote :
Download full text (19.5 KiB)

This bug was fixed in the package linux - 3.2.0-34.53

---------------
linux (3.2.0-34.53) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1078760

  [ Kamal Mostafa ]

  * SAUCE: input: Cypress PS/2 Trackpad list additional contributors

  [ Kyle Fazzari ]

  * SAUCE: input: Cypress PS/2 Trackpad fix multi-source, double-click
    - LP: #1055788
  * SAUCE: input: Cypress PS/2 Trackpad fix lost sync upon palm contact
    - LP: #1048258
  * SAUCE: input: Cypress PS/2 Trackpad fix taps turning into hardware
    clicks
    - LP: #1064086

  [ Tim Gardner ]

  * [Config] remove ndiswrapper from Provides:
    - LP: #1076395
  * [Config] CONFIG_HP_WATCHDOG=m for x86en
    - LP: #1076342

  [ Upstream Kernel Changes ]

  * Revert "SUNRPC: Ensure we close the socket on EPIPE errors too..."
    - LP: #1075355
  * Revert "ath9k_hw: Updated AR9003 tx gain table for 5GHz"
    - LP: #1075355
  * eCryptfs: check for eCryptfs cipher support at mount
    - LP: #338914
  * isci: fix isci_pci_probe() generates warning on efi failure path
    - LP: #1068162
  * mtd: nand: Use the mirror BBT descriptor when reading its version
    - LP: #1068162
  * drm/i915: prevent possible pin leak on error path
    - LP: #1068162
  * workqueue: add missing smp_wmb() in process_one_work()
    - LP: #1068162
  * TTY: ttyprintk, don't touch behind tty->write_buf
    - LP: #1068162
  * Remove BUG_ON from n_tty_read()
    - LP: #1068162
  * n_gsm.c: Implement 3GPP27.010 DLC start-up procedure in MUX
    - LP: #1068162
  * n_gsm: uplink SKBs accumulate on list
    - LP: #1068162
  * n_gsm : Flow control handling in Mux driver
    - LP: #1068162
  * char: n_gsm: remove message filtering for contipated DLCI
    - LP: #1068162
  * n_gsm: added interlocking for gsm_data_lock for certain code paths
    - LP: #1068162
  * n_gsm: avoid accessing freed memory during CMD_FCOFF condition
    - LP: #1068162
  * n_gsm: replace kfree_skb w/ appropriate dev_* versions
    - LP: #1068162
  * n_gsm: memory leak in uplink error path
    - LP: #1068162
  * UBI: fix autoresize handling in R/O mode
    - LP: #1068162
  * UBI: erase free PEB with bitflip in EC header
    - LP: #1068162
  * firmware: Add missing attributes to EFI variable attribute print out
    from sysfs
    - LP: #1068162
  * tools/hv: Fix exit() error code
    - LP: #1068162
  * slab: fix the DEADLOCK issue on l3 alien lock
    - LP: #1068162
  * gspca_pac7302: Add usb-id for 145f:013c
    - LP: #1068162
  * gspca_pac7302: add support for device 1ae7:2001 Speedlink Snappy
    Microphone SL-6825-SBK
    - LP: #1068162
  * xhci: Warn when hosts don't halt.
    - LP: #1068162
  * xHCI: add cmd_ring_state
    - LP: #1068162
  * xHCI: add aborting command ring function
    - LP: #1068162
  * xHCI: cancel command after command timeout
    - LP: #1068162
  * hpsa: Use LUN reset instead of target reset
    - LP: #1068162
  * rc: ite-cir: Initialise ite_dev::rdev earlier
    - LP: #1068162
  * staging: speakup_soft: Fix reading of init string
    - LP: #1068162
  * target: fix return code in target_core_init_configfs error path
    - LP: #1068162
  * powerpc/eeh: Lock module while handling EEH event
  ...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released

This fix does not appear to be in the 3.8 kernel for Raring. I see the same kernel messages:
[ 326.372692] psmouse serio1: Trackpad at isa0060/serio1/input0 lost sync at byte 1
[ 326.374291] psmouse serio1: Trackpad at isa0060/serio1/input0 - driver resynced.

The kernel I am running is 3.8.0-11.20.

Changed in linux (Ubuntu):
assignee: Kyle Fazzari (kyle.f) → nobody
status: Fix Committed → New

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1048258

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

ApportVersion: 2.9.1-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jared 1925 F.... pulseaudio
DistroRelease: Ubuntu 13.04
HibernationDevice: RESUME=UUID=293cdf82-ef61-45de-8ab3-5113c6788a9b
InstallationDate: Installed on 2013-03-01 (7 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Dell Inc. Dell System XPS L322X
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-11-generic.efi.signed root=UUID=df7e7b2b-6e65-4011-9eff-5fcfa75a363f ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-11.20-generic 3.8.2
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-11-generic N/A
 linux-backports-modules-3.8.0-11-generic N/A
 linux-firmware 1.103
Tags: raring
Uname: Linux 3.8.0-11-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 02/21/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: B40
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrB40:bd02/21/2013:svnDellInc.:pnDellSystemXPSL322X:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L322X
dmi.sys.vendor: Dell Inc.

tags: added: apport-collected raring

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I've tested on a second system and found the same behavior.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Iggy (iggy-theiggy) wrote :

Confirmed. I see this on my XPS 12 with 3.8.0-16-generic.

Julian Neil (julian-neil) wrote :

I have this problem with 13.04 beta 2 using both 3.8.0-18-generic and linux-image-3.9.0-030900rc6-generic_3.9.0-030900rc6.201304080035_amd64

Owen Williams (ywwg) wrote :

As of kernel 3.8, it looks like the function has changed and is now returning -1 instead of 0:

static int cypress_get_finger_count(unsigned char header_byte)
{
    unsigned char bits6_7;
    int finger_count;

    bits6_7 = header_byte >> 6;
    finger_count = bits6_7 & 0x03;

    if (finger_count == 1)
        return 1;

    if (header_byte & ABS_HSCROLL_BIT) {
        /* HSCROLL gets added on to 0 finger count. */
        switch (finger_count) {
            case 0: return 4;
            case 2: return 5;
            default:
                /* Invalid contact (e.g. palm). Ignore it. */
                return -1;
        }
    }

    return finger_count;
}

my guess is this is causing the same problem as returning 6 was before.

Owen Williams (ywwg) wrote :

I changed -1 to 0 and this solved the problem for me (Dell XPS 13, Ubuntu 13.04)

I'm seeing the same thing on 13.04 I get this error 32 per second and it's filling up my syslog

May 8 15:31:03 buster kernel: [ 623.395845] psmouse serio1: Trackpad at isa0060/serio1/input0 lost sync at byte 1
May 8 15:31:03 buster kernel: [ 623.397519] psmouse serio1: Trackpad at isa0060/serio1/input0 - driver resynced

I have the same issue (Dell XPS 13, Ubuntu 13.04).

Just wanted to add that the messages in /var/log/syslog appear only when
the laptop's _lid is closed_ (I close it when using an external monitor/keyboard).

When I open the lid the messages immediately and consistently stop.
I guess the lid is messing with the touchpad's sensors.

Me too!

I am on Linux xps13 3.8.0-22-generic #33-Ubuntu SMP Thu May 16 15:17:14 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

"watch ls -l /var/log/syslog" is a good way to watch your log file fill up before your eyes :)

> "messages in /var/log/syslog appear only when the laptop's _lid is closed_"

what about when you put your palm on the trackpad?

Owen Williams (ywwg) wrote :

Closing the lid activates the same effect as resting my palm on the trackpad. In both cases the trackpad is getting multiple "contacts"

This is literally a two-character fix, it's the same concept as the previous fix, and it works, what needs to happen to get this moved along in the bug queue?

Kyle Fazzari (kyle.f) wrote :

Guys thanks for bringing this one back up, it only just now caught my attention. Can anyone verify whether this is an issue in Precise? Or is it just Raring?

in case it is not inferable from my uname -a, I am on Raring

Kyle Fazzari (kyle.f) wrote :

Dang... I might have to install Raring. When I get home I'll test this issue on my Precise install and check for myself. If the issue has regressed there as well this should be fixed rather quickly.

Kyle Fazzari (kyle.f) wrote :

Hmm... doesn't look like this regressed in Precise. Owen, why don't you generate a patch of your fix and attach it to this bug report?

Owen Williams (ywwg) wrote :

diff generated against linux-3.8.0-21-generic:

Owen Williams (ywwg) wrote :

So I attached a patch, it would be nice if this could get applied.

Andrew Woodward (xarses) wrote :

Applying patch from @ywwg into 3.10.0-2-generic resolved thhis issue for me. Please apply the patch
+1

radsaq (radsaq) wrote :

Saucy/3.11 are affected by this, too. Anyone interested in getting this moved upstream?

Joseph Salisbury (jsalisbury) wrote :

@radsaq,

I posted a Saucy test kernel, which can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1229361/

Can you test this kernel and see if it resolves this bug? Note, you will have to install both the linux-image and linux-image-extra .deb packages.

This test kernel just sets finger_count to zero in the case of a palm detect.

Thanks in advance!

Owen Williams (ywwg) wrote :

@jsalisbury, that kernel fixes the bug for me.

Allan Crooks (amcone) wrote :

Has the patch been applied to any recent kernel releases?

Kyle Fazzari / Kamal Mostafa, I just wanted to ping you about if the patch would be submitted upstream to the linux-input mailing list for upstream inclusion, or you could advise on upstream discussion of this?

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Kyle Fazzari (kyle.f) wrote :

@Allan Crooks: It looks like Joseph got it into Raring, so you should have seen it in a kernel update. Is that not the case?

@Christopher Penalver: I'm not sure where along the line that got set back to -1, so the fixed version may have actually been pushed upstream and a mistake made for Raring. I'm checking into this now-- I'll be in touch.

Kyle Fazzari (kyle.f) wrote :

@Christopher Penalver: I've confirmed that Joseph's patch has made it all the way upstream to the base Linux kernel (http://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git). Is this issue then resolved? Is anyone still having issues with it?

Kyle Fazzari, thank you for your quick response. Let us keep open the linux (Ubuntu) task for now, as it would track this issue for being released in Trusty, for the original reporter Serge Gélinas if he decided to update to 14.04 hardware enablement stack as per https://wiki.ubuntu.com/Kernel/LTSEnablementStack in Precise, and for the "Me too!"s who advised their issue is fixed via this patch.

Allan Crooks (amcone) wrote :

@Kyle Fazzari - it turns out that my laptop has an Alps touchpad rather than a Cypress one, so the fix would have no effect for me anyway.. Searching for the error message had brought me here, so I presumed it was the same issue. I've opened up a separate bug for the Alps touchpad (see #1258837).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers