[ASUS ZENBOOK UX32VD] Screen stays black after grub resume from suspend

Bug #1085166 reported by peterrus on 2012-11-30
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

On my Asus UX32V (Intel HD4000) the screen stays black after grub. I do not see plymouth nor the login screen. When suspending to ram, and waking up the device the screen works fine. External monitors also work fine (when plugged in before boottime).

This happens at:
linux-image-3.5.0-19-generic
linux-image-3.5.0-18-generic
linux-image-3.5.0-17-generic

but not at

linux-image-3.5.0-10-generic

Everything between is not tested (Reinstalled my system first to make sure I made no configuration errors)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.5.0-19.30-generic 3.5.7
Uname: Linux 3.5.0-19-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Fri Nov 30 19:56:58 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:1507]
   Subsystem: ASUSTeK Computer Inc. Device [1043:1507]
InstallationDate: Installed on 2012-11-30 (0 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: ASUSTeK COMPUTER INC. UX32VD
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-19-generic root=UUID=9db55df0-afc5-4902-9a70-935e603c1158 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/17/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX32VD.212
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX32VD
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX32VD.212:bd09/17/2012:svnASUSTeKCOMPUTERINC.:pnUX32VD:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX32VD:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: UX32VD
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
version.compiz: compiz 1:0.9.8.4+bzr3407-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.40+git20121123.171666e4-0ubuntu0ricotz2~quantal
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1~git20121128.ffc318a9-0ubuntu0ricotz~quantal
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0.901+git20121123+server-1.13-branch.c0e68f8e-0ubuntu0ricotz~quantal
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.0.99+git20121126.60cd6cea-0ubuntu0sarvatt~quantal
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.14+git20121126.7a904ce8-0ubuntu0sarvatt~quantal
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.4+git20121126.3b33a0b4-0ubuntu0sarvatt~quantal

peterrus (petorrus) wrote :
description: updated
peterrus (petorrus) wrote :

Where could I find previous kernels, I could then test them one by one to find out where the problem starts occuring

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Märt Suga (mart-suga) wrote :

You can find older and newer kernels here: http://kernel.ubuntu.com/~kernel-ppa/mainline/
Raring kernels are also compatible with Quantal.

Download full text (4.2 KiB)

Please note mainline kernels do not contain ubuntu-specific patches and
might thus not provide a true testing ground as it introduces an aditional
variable.
On Jan 3, 2013 4:01 PM, "Märt Suga" <email address hidden> wrote:

> You can find older and newer kernels here:
> http://kernel.ubuntu.com/~kernel-ppa/mainline/
> Raring kernels are also compatible with Quantal.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1085166
>
> Title:
> Screen stays black after grub. Suspend activates it.
>
> Status in “xorg” package in Ubuntu:
> Confirmed
>
> Bug description:
> On my Asus UX32V (Intel HD4000) the screen stays black after grub. I
> do not see plymouth nor the login screen. When suspending to ram, and
> waking up the device the screen works fine. External monitors also
> work fine (when plugged in before boottime).
>
> This happens at:
> linux-image-3.5.0-19-generic
> linux-image-3.5.0-18-generic
> linux-image-3.5.0-17-generic
>
> but not at
>
> linux-image-3.5.0-10-generic
>
> Everything between is not tested (Reinstalled my system first to make
> sure I made no configuration errors)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: xorg 1:7.7+1ubuntu4
> ProcVersionSignature: Ubuntu 3.5.0-19.30-generic 3.5.7
> Uname: Linux 3.5.0-19-generic x86_64
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.6.1-0ubuntu6
> Architecture: amd64
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> Date: Fri Nov 30 19:56:58 2012
> DistUpgraded: Fresh install
> DistroCodename: quantal
> DistroVariant: ubuntu
> EcryptfsInUse: Yes
> ExtraDebuggingInterest: Yes
> GraphicsCard:
> Intel Corporation 3rd Gen Core processor Graphics Controller
> [8086:0166] (rev 09) (prog-if 00 [VGA controller])
> Subsystem: ASUSTeK Computer Inc. Device [1043:1507]
> Subsystem: ASUSTeK Computer Inc. Device [1043:1507]
> InstallationDate: Installed on 2012-11-30 (0 days ago)
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64
> (20121017.5)
> MachineType: ASUSTeK COMPUTER INC. UX32VD
> MarkForUpload: True
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-19-generic
> root=UUID=9db55df0-afc5-4902-9a70-935e603c1158 ro quiet splash vt.handoff=7
> SourcePackage: xorg
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 09/17/2012
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: UX32VD.212
> dmi.board.asset.tag: ATN12345678901234567
> dmi.board.name: UX32VD
> dmi.board.vendor: ASUSTeK COMPUTER INC.
> dmi.board.version: 1.0
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 10
> dmi.chassis.vendor: ASUSTeK COMPUTER INC.
> dmi.chassis.version: 1.0
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvrUX32VD.212:bd09/17/2012:svnASUSTeKCOMPUTERINC.:pnUX32VD:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX32VD:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
> dmi.product.name: UX32VD
> dmi.product.version: 1.0
> dmi.sys.vendor: ASUSTeK COMPUTER INC.
> version.compiz: compiz 1:0....

Read more...

I used the following kernel: https://launchpad.net/ubuntu/quantal/amd64/linux-image-3.5.0-10-generic/3.5.0-10.10 (64 bit) using this kernel, the issue does not manifest itself.

peterrus (petorrus) wrote :

it seems everything before 3.5.0-17-generic does not have this issue.

I installed every kernel (-10 to -16) and with none of them running the issue was present. -17 came with the Quantal installation and does have the issue. I am not 100% sure I have tested this the correct way ( there may be some other factors) but this might mean that the issue started to appear in 3.5.0-17 which has the following changelog: http://changelogs.ubuntu.com/changelogs/pool/main/l/linux/linux_3.5.0-17.28/changelog . The log does not seem to contain anything relevant, but I might be overlooking something.

peterrus (petorrus) wrote :
Timo Aaltonen (tjaalton) on 2013-01-08
affects: xorg (Ubuntu) → linux (Ubuntu)
peterrus (petorrus) wrote :

Workaround:

enable the xorg-edgers repository (sudo apt-add-repository ppa:xorg-edgers/ppa; sudo apt-get update; sudo apt-get dist-upgrade -y)

Which gives you, at the time of writing kernel 3.7.0-7, which does not suffer the issue.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.8 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc2-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
status: Incomplete → Triaged
tags: added: regression-update
Changed in linux (Ubuntu):
status: Triaged → Incomplete
peterrus (petorrus) on 2013-01-08
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-fixed-upstream

peterrus, could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - Screen stays black after grub. Suspend activates it.
+ [ASUS ZENBOOK UX32VD] Screen stays black after grub resume from suspend
tags: added: bios-outdated-214
peterrus (petorrus) wrote :

The issue does not persist anymore

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers