[SATELLITE P875, Realtek ID 280, Speaker, Internal] No sound at all

Bug #1017017 reported by Richard Crossley on 2012-06-24
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
David Henningsson

Bug Description

Hi,

I purchased a new PC yesterday and had installed Ubuntu 12.04, 64 bit desktop on it. There is no sound at all from the speakers, but the head phone jack does provide sound, which is a shame because the internal speakers do sound quite good under Windows and would like them working in Ubuntu.

How to reproduce:

Search for the "Sound" program in Unity and execute

The listed sound card should be:
Output = Analogue Output (Buitin Audio)

Ensure the output is not muted (check box is clear)
Press the "Test Sound" button, which opens a new window with two "Test" buttons, for front left and front right.
With the head phones connected, I can hear the voice say "Front Left" and "Front Right". Without the headphones connected, no sound.

The sounds in the "Sound Effects" tab also work with the headphones connected, but not without, but I suppose that is to be expected.

I have included details that may be relevant, please let me know if you need anything further, many thanks...

Richard.

richard@lhkg010ltp:~$ apt-cache policy alsa-base
alsa-base:
  Installed: 1.0.25+dfsg-0ubuntu1
  Candidate: 1.0.25+dfsg-0ubuntu1
  Version table:
 *** 1.0.25+dfsg-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
richard@lhkg010ltp:~$

richard@lhkg010ltp:~$ apt-cache policy pulseaudio
pulseaudio:
  Installed: 1:1.1-0ubuntu15.1
  Candidate: 1:1.1-0ubuntu15.1
  Version table:
 *** 1:1.1-0ubuntu15.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:1.1-0ubuntu15 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
richard@lhkg010ltp:~$

Output from alsa-info.sh is attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: HDA Generic [HDA Generic]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: richard 1825 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xda710000 irq 46'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0280,1179fc1f,00100003 HDA:80862806,1179fc1f,00100000'
   Controls : 11
   Simple ctrls : 5
Date: Sun Jun 24 01:59:16 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH failed
Symptom_Card: Built-in Audio - HDA Intel PCH
Symptom_DevicesInUse:
 1825 richard F.... pulseaudio
     PID ACCESS COMMAND
Symptom_Jack: Speaker, Internal
Symptom_Type: No sound at all
Title: [SATELLITE P875, Realtek ID 280, Speaker, Internal] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/20/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 1.20
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: MP
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: OEM Chassis Manufacturer
dmi.chassis.version: OEM Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvr1.20:bd04/20/2012:svnTOSHIBA:pnSATELLITEP875:pvrPSPLBE-01T00FEN:rvnTOSHIBA:rnPortablePC:rvrMP:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
dmi.product.name: SATELLITE P875
dmi.product.version: PSPLBE-01T00FEN
dmi.sys.vendor: TOSHIBA

David Henningsson (diwic) wrote :
Changed in alsa-driver (Ubuntu):
assignee: nobody → David Henningsson (diwic)
David Henningsson (diwic) wrote :

Hi Richard!

It seems you have a new chip (ALC280) which is not yet supported by kernel driver.
I've written a small patch to enable it. Can you test it and see if all inputs and outputs work correctly?

(I see you have a subwoofer, not sure if that one will work correctly)

Please do the following:

1) Download and install the attached deb package
2) Reboot
3) Test

Thanks!

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: patch

Hi,

Many thanks.

I have reinstalled Ubuntu and updated to the latest set of patches.

I applied the .deb and it compiled for 3.2.0-25-generic

After a reboot I ran the test routine in the sound settings
- Sound was heard through the speakers
- Sound was heard through the headphones

I recorded a number words and phrases through the sound recorder, they were correctly reproduced.

I'm not sure the subwoofer works either, but having the speakers working is definitely an improvement.

Will this make it into the next set of updates and future Ubuntu releases?

Many thanks.

Changed in linux (Ubuntu):
importance: Undecided → Medium
David Henningsson (diwic) wrote :

Thanks for your encouraging reply! I've sent my patch upstream with cc to stable, which means that in a month or two - hopefully - it will come through as a kernel update to 12.04. Until then, you can use the dkms package.

I wish all bugs were this easy to fix :-)

Changed in linux (Ubuntu):
status: Incomplete → In Progress
Download full text (5.2 KiB)

On Mon, 2012-06-25 at 17:51 +0000, David Henningsson wrote:

> I wish all bugs were this easy to fix :-)
>

I know that feeling, many thanks for being able to help.

Kindest Regards,

Richard Crossley.

On Mon, 2012-06-25 at 17:51 +0000, David Henningsson wrote:
> Thanks for your encouraging reply! I've sent my patch upstream with cc
> to stable, which means that in a month or two - hopefully - it will come
> through as a kernel update to 12.04. Until then, you can use the dkms
> package.
> I wish all bugs were this easy to fix :-)
>
> ** Changed in: linux (Ubuntu)
> Status: Incomplete => In Progress
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1017017
>
> Title:
> [SATELLITE P875, Realtek ID 280, Speaker, Internal] No sound at all
>
> Status in “linux” package in Ubuntu:
> In Progress
>
> Bug description:
> Hi,
>
> I purchased a new PC yesterday and had installed Ubuntu 12.04, 64 bit
> desktop on it. There is no sound at all from the speakers, but the
> head phone jack does provide sound, which is a shame because the
> internal speakers do sound quite good under Windows and would like
> them working in Ubuntu.
>
> How to reproduce:
>
> Search for the "Sound" program in Unity and execute
>
> The listed sound card should be:
> Output = Analogue Output (Buitin Audio)
>
> Ensure the output is not muted (check box is clear)
> Press the "Test Sound" button, which opens a new window with two "Test" buttons, for front left and front right.
> With the head phones connected, I can hear the voice say "Front Left" and "Front Right". Without the headphones connected, no sound.
>
> The sounds in the "Sound Effects" tab also work with the headphones
> connected, but not without, but I suppose that is to be expected.
>
> I have included details that may be relevant, please let me know if
> you need anything further, many thanks...
>
> Richard.
>
> richard@lhkg010ltp:~$ apt-cache policy alsa-base
> alsa-base:
> Installed: 1.0.25+dfsg-0ubuntu1
> Candidate: 1.0.25+dfsg-0ubuntu1
> Version table:
> *** 1.0.25+dfsg-0ubuntu1 0
> 500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
> 100 /var/lib/dpkg/status
> richard@lhkg010ltp:~$
>
> richard@lhkg010ltp:~$ apt-cache policy pulseaudio
> pulseaudio:
> Installed: 1:1.1-0ubuntu15.1
> Candidate: 1:1.1-0ubuntu15.1
> Version table:
> *** 1:1.1-0ubuntu15.1 0
> 500 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
> 100 /var/lib/dpkg/status
> 1:1.1-0ubuntu15 0
> 500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
> richard@lhkg010ltp:~$
>
>
> Output from alsa-info.sh is attached.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: alsa-base 1.0.25+dfsg-0ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
> Uname: Linux 3.2.0-23-generic x86_64
> NonfreeKernelModules: nvidia
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
> ApportVersion: 2.0.1-0ubuntu8
...

Read more...

solab (info-solab) wrote :

FYI

It seems i had the same problem with ubuntu 12.4 and Toshiba with ALC280 chip .

I installed the patch as explained in #3 and now have working sound.

Thanks
gio

David Henningsson (diwic) wrote :

It's been proposed to 3.2-stable now, so it will reach 12.04 in a few weeks time hopefully.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-3.3

---------------
linux (3.5.0-3.3) quantal-proposed; urgency=low

  [ Andy Whitcroft ]

  * [Config] enable CONFIG_MEMTEST=y
    - LP: #1004535
  * [Config] config-check: add support for a cut operation
  * [Config] enforcer -- switch to cut where appropriate

  [ Leann Ogasawara ]

  * Rebase to v3.5-rc5
  * [Config] Updateconfigs after rebase to v3.5-rc5

  [ Luis Henriques ]

  * SAUCE: ocfs2: Fix NULL pointer dereferrence in
    __ocfs2_change_file_space
    - LP: #1006012

  [ Seth Forshee ]

  * SAUCE: (drop after 3.5) drm/i915: ignore pipe select bit when checking
    for LVDS register initialization
    - LP: #1012800

  [ Upstream Kernel Changes ]

  * rebase to v3.5-rc5
    - LP: #1013183
    - LP: #1017017
    - LP: #884652
 -- Leann Ogasawara <email address hidden> Mon, 02 Jul 2012 06:41:58 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem (3.0.0-24.40). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-29.46). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise

Kernel 3.2.0-29.46 has solved my problem with soundcard. A minor issue is that after boot, sound level starts out max.

Hi Luis,
Sorry to say but I do not know how tag 'verification-done-precise'. Anyway
kernel 3.2.0-29.46 has solved my soundcard problem. A minor issue is
that audio level after boot always starts out at 'max'.

Br. Lars

Den 30-07-2012 11:36, Luis Henriques skrev:
> This bug is awaiting verification that the kernel for Precise in
> -proposed solves the problem (3.2.0-29.46). Please test the kernel and
> update this bug with the results. If the problem is solved, change the
> tag 'verification-needed-precise' to 'verification-done-precise'.
>
> If verification is not done by one week from today, this fix will be
> dropped from the source code, and this bug will be closed.
>
> See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how
> to enable and use -proposed. Thank you!
>
>
> ** Tags added: verification-needed-precise
>

--
Med venlig hilsen/Best regards/Mit freundlichen Grüssen Lars

Luis Henriques (henrix) wrote :

Hi Lars, thank you for testing. I'll tag the bug as verified (you just click the 'Edit tags' button on the top, after the "Bug Description").

tags: added: verification-done-precise
removed: verification-needed-precise
Luis Henriques (henrix) wrote :

As this fix came from stable updates, and it has already been verified on Precise, I'm tagging it as verified in Oneiric as well.

tags: added: verification-done-oneiric
removed: verification-needed-oneiric

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Renee R (r3) wrote :

I applied this same patch to fixmy install on a new laptop. After buying this laptop, I added a boot option for Linux Mint Maya 13. Everything seemed to work fine except the speakers (headphones worked). I applied the patch and it worked!!!
Thanks, David.

Running Toshiba x870 series Intel I7 Gaming machine.
Um, now I just have to lookup if the secondary video card is being recognized by Linux. Took awhile to get X-plane in Windows (Ugh) to see it. :)

Waraqa (waraqa) wrote :

Dear David,
The package alsa-hda-dkms_0.1_all.deb provided above doesn't work for my laptop Toshiba Satellite P850-B236. I also checked alsa mixer for any mute channel. Could you investigate to make it also work for this model ?

David Henningsson (diwic) wrote :

Waraqa, you're probably suffering from a different bug. Please file a new bug with the "ubuntu-bug audio" command and if time permits, I or somebody else will look at it. Thanks.

Waraqa (waraqa) wrote :
To post a comment you must log in.