Ubuntu

Intel HDA sound broken on kernel 2.6.22-10.30

Reported by Jose Bernardo on 2007-08-22
172
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
linux-ubuntu-modules-2.6.22 (Ubuntu)
Medium
Ubuntu Audio Team

Bug Description

Binary package hint: linux-image-2.6.22-10-386

Sound got broken for me with the upgrade from kernel 2.6.22-9 to 2.6.22-10.30. Previously, the only problem I had was the microphone not working. I started describing this in bug #116326, but since my realtek has a different ID and worked until this update, I think it is probably a new bug.

$ aplay --list-devices
**** Lista de Dispositivos de Hardware PLAYBACK ****
placa 0: Intel [HDA Intel], dispositivo 0: HDA Generic [HDA Generic]
  Subdispositivos: 0/1
  Subdispositivo #0: subdevice #0

Jose Bernardo (bernardo-bandos) wrote :
Jose Bernardo (bernardo-bandos) wrote :

$ tail -2 /proc/asound/oss/sndstat
Mixers:
0: Realtek ID 861

Jose Bernardo (bernardo-bandos) wrote :
Jose Bernardo (bernardo-bandos) wrote :

$ asoundconf list
Names of available sound cards:
Intel

Jose Bernardo (bernardo-bandos) wrote :
Jose Bernardo (bernardo-bandos) wrote :

$ cat /proc/interrupts
           CPU0 CPU1
  0: 5413376 0 IO-APIC-edge timer
  1: 6153 0 IO-APIC-edge i8042
  8: 3 0 IO-APIC-edge rtc
  9: 10916 0 IO-APIC-fasteoi acpi
 12: 143 0 IO-APIC-edge i8042
 14: 32266 0 IO-APIC-edge libata
 15: 0 0 IO-APIC-edge libata
 17: 1108876 0 IO-APIC-fasteoi uhci_hcd:usb4, eth0, i915@pci:0000:00:02.0
 18: 545028 0 IO-APIC-fasteoi uhci_hcd:usb3, ohci1394, sdhci:slot0, ipw3945
 19: 78702 0 IO-APIC-fasteoi uhci_hcd:usb1, ehci_hcd:usb5
 20: 0 0 IO-APIC-fasteoi uhci_hcd:usb2
 21: 336702 0 IO-APIC-fasteoi HDA Intel
220: 69284 0 PCI-MSI-edge ahci
NMI: 0 0
LOC: 995847 4299778
ERR: 0
MIS: 0

Jose Bernardo (bernardo-bandos) wrote :

I forgot to add, my laptop is a Fujitsu Siemens Amilo Pi1505. I had good sound both on feisty and gutsy until today, with this kernel update.

Jose Bernardo (bernardo-bandos) wrote :

This is the codec for the hda-intel sound card

Jose Bernardo (bernardo-bandos) wrote :

This is the codec for the internal modem (I think).

Frank (frank-schaeffer) wrote :

Same here on Thinkpad Z61m except that here the sound is very quietly or rather inaudibly. The sound card is identified and configured just as well reported by Jose above.

uname -r
2.6.22-10-generic

Frank (frank-schaeffer) wrote :

dmesg

Frank (frank-schaeffer) wrote :

asoundconf

Frank (frank-schaeffer) wrote :

interrupts

Frank (frank-schaeffer) wrote :

Sorry, just forgot to mention. I'am on Kubuntu Gutsy 64bit. The problem exist for all mediaplayers I've installed (e. g. amarok, xine, kaffeine, noatun....)

Best regards

Frank

flowbot (flowbot) wrote :

This kernel breaks my (already a bit broken) sound, too. I have an Inspiron 1420 (to get sound working previously, had to add "options snd-hda-intel position_fix=1 model=3stack" to /etc/modprobe.d/alsa-base).

lspci-vv attached, more to follow.

flowbot (flowbot) wrote :
flowbot (flowbot) wrote :
flowbot (flowbot) wrote :
flowbot (flowbot) wrote :
flowbot (flowbot) wrote :
BronsCon (keith-bronstrup) wrote :

Make sure linux-ubuntu-modules-2.6.22-10-[your arch here] is installed and you are booting the correct kernel.

For some reason, for 2.6.22-20, both generic and 386 kernels were installed, while only the generic kernel's modules were installed and the 386 kernel was made default in GRUB.

My solution was to install the modules for 2.6.22-10-386 and, when that worked (and I realized the generic ran better on my system), I removed the 386 kernel and modules, which never should have made their way on to my system to begin with, and went back to the generic kernel.

Everything works over here now that I have the proper kernel and modules installed.

Hope this helps someone else -- and closes this bug.

description: updated

I changed the name and binary package hint to reflect the source of the issue.

linux-image-2.6.22-10-386 was a dependency of linux-image-generic. This appears to have been resolved already.

If you are running linux-image-2.6.22-10-386 and should not be, remove this kernel and use a more appropriate one (perhaps linux-image-generic will now choose the correct kernel for you?) and this should fix the problem.

flowbot (flowbot) wrote :

This wasn't the problem for me - 386 kernel didn't get installed, just the generic. I've updated synaptic, but nothing new in there. Still, I've got no sound.

BronsCon (keith-bronstrup) wrote :

flow,

Is linux-ubuntu-modules-2.6.22-10-generic installed?

Double check this and, if it's not installed, correct this and reboot. All should work.

If this doesn't help, let me know so I can undo the edits I made to this bug.

flowbot (flowbot) wrote :

Hi Brons,

linux-ubuntu-modules-2.6.22-10-generic is installed. Alsamixer tells me my chip is SigmaTel ID 7616, but I remember it being something different when all worked.

@BronsCon, Please revert you edits - I also only have generic kernel and modules installed.

I reverted the edits I made.

Do you still have an older kernel available? (press ESC when prompted to access the GRUB menu)

if so, can you boot into that kernel? If everything works, can you report what Alsamixer identifies your sound chip as, provide a lspci, lsmod and possibly a dmesg listing? Then, boot back into 2.6.22-10 and provide the same?

I dont know if, perhaps, someobody more knowledgeable is watching, maybe this will allow them to help? If not, I'll be unavailable until after 3MP EST but will do my best (which, admittedly, I have not done thus far) to get this bug resolved.

Changed in linux-source-2.6.22:
status: New → Confirmed
lithorus (lithorus) wrote :

Sound breaks for me too.
I get sound through the speakers of the laptop, but none through the headphone jack when plugged in.

lspci -s 00:1b -vv :
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: Sony Corporation Unknown device 81fd
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 23
        Region 0: Memory at d6300000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000 Data: 0000
        Capabilities: [70] Express Unknown type IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
                Device: Latency L0s <64ns, L1 <1us
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed unknown, Width x0, ASPM unknown, Port 0
                Link: Latency L0s <64ns, L1 <1us
                Link: ASPM Disabled CommClk- ExtSynch-
                Link: Speed unknown, Width x0

lithorus (lithorus) wrote :

Forgot,
Codec: SigmaTel ID 7664

BronsCon (keith-bronstrup) wrote :

Don't know why I didn't hink of this before. Those who aren't getting sound from their speakers, try headphones.

If your chip is being identified, it should be working at least somewhat.

Sound chips fillowing the Intel HDA spec will have at least 2 pairs of 2 channels (left and right) with independent volume controls. On most laptops, one will be the speakers and the other will be headphones. These will have separate controls in the mixer; make sure the mixer marked Speaker is turned up and unmuted (or if it is, make sure the one marked Headphone is turned up, perhaps they are mislabeled, which would be another bug altogether, but still mention it here).

I know, before the new kernel, my sound system would route to speakers until I plugged in headphones, then it would shut off the speakers. I believe this can be configured; I'll look into it when I return at about 15:00 EST. Now, they are controlled seperately and the Headphone channel was beign used as the Master. This can be changed in your mixer.

I'm right now on kernel 2.6.22-9, and in fact the sound on the speakers is disabled when I plug in my headphones. I never thought of trying if the headphones worked on 2.6.22-10, will try after a reboot. Here is the info for 2.6.22-9, working sound on headphones and speakers:
$ aplay --list-devices
**** Lista de Dispositivos de Hardware PLAYBACK ****
placa 0: Intel [HDA Intel], dispositivo 0: ALC861 Analog [ALC861 Analog]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0
placa 0: Intel [HDA Intel], dispositivo 6: Si3054 Modem [Si3054 Modem]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0

First big change - the modem was detected on 2.6.22-9, isn't detected on 2.6.22-10
Second change - the sound card here shows as ALC861, on 2.6.22-10 shows as hda-generic

exactt (giesbert) wrote :

i also have the "no sound" problem with a Realtek 883 on Intel HDA.

Neither the speakers nor the headphones work. just silence...

$ tail -2 /proc/asound/oss/sndstat
Mixers:
0: Realtek ALC861

$ asoundconf list
Names of available sound cards:
Intel

$ cat /proc/interrupts
           CPU0 CPU1
  0: 447380 0 IO-APIC-edge timer
  1: 2109 0 IO-APIC-edge i8042
  8: 3 0 IO-APIC-edge rtc
  9: 1328 0 IO-APIC-fasteoi acpi
 12: 143 0 IO-APIC-edge i8042
 14: 3704 0 IO-APIC-edge libata
 15: 0 0 IO-APIC-edge libata
 17: 164991 0 IO-APIC-fasteoi uhci_hcd:usb4, eth0, i915@pci:0000:00:02.0
 18: 62698 0 IO-APIC-fasteoi uhci_hcd:usb3, ohci1394, sdhci:slot0, ipw3945
 19: 55370 0 IO-APIC-fasteoi uhci_hcd:usb1, ehci_hcd:usb5
 20: 0 0 IO-APIC-fasteoi uhci_hcd:usb2
 21: 7131 0 IO-APIC-fasteoi HDA Intel
220: 18397 0 PCI-MSI-edge ahci
NMI: 0 0
LOC: 166757 388642
ERR: 0
MIS: 0

The codec for the sound card

The codec for the modem

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-audio
importance: Undecided → Medium
status: Confirmed → Triaged
36 comments hidden view all 116 comments
Jonh Wendell (wendell) wrote :

This upload fixes this issue:

linux-ubuntu-modules-2.6.22 (2.6.22-10.24) gutsy; urgency=low

  [Kyle McMartin]

  * revert to stock snd-hda-intel code
  * fix 3-udebs.mk to call depmod with path

  [Tim Gardner]

  * Lirc SIR & TTUSBIR Support

 -- Kyle McMartin <email address hidden> Mon, 27 Aug 2007 15:31:01 +0000

Changed in linux-source-2.6.22:
status: Triaged → Fix Released

COnfirmed, with this update I have sound again working as expected.

Ryan (rpm) wrote :

Where can I get the update?

Kishore (kitts) wrote :

With the latest update of LUM, sounds has been restored.

Ryan (rpm) wrote :

I know this is a stupid question, but will the update make to me via apt? Or do I need to download and install it using dpkg?

Ryan (rpm) wrote :

ignore my last comment, i installed linux-ubuntu-modules-2.6.22-10-generic and now the snd-hda-intel driver is avaialble.

thank you.

Mike Basinger (mike.basinger) wrote :

On my Lenovo 3000 N100 I have sound but headphone switching using linux-ubuntu-modules-2.6.22-10-generic-2.6.22-10.24 still.

Matthijs De Smedt (matthijs--) wrote :

I have an Asus A6 laptop with:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

Sound from the speakers works, and the speakers mute when headphones is plugged in. But there's no sound coming through the headphones. Tried every possible model in /etc/modprobe.d/alsa-base and even installing alsa-source. None of these changed anything. Sound still works, except for the headphone jack.

Which version of the linux-ubuntu-modules-2.6.22-10-generic do you have
installed? This sounds excactly like the bug I had when I didn't have the
updated version of linux-ubuntu-modules-2.6.22-10-generic.

2.6.22-10.23 had the problem and was fixed in 2.6.22-10.24

On 8/31/07, Matthijs de Smedt <email address hidden> wrote:
>
> I have an Asus A6 laptop with:
> 00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High
> Definition Audio Controller (rev 02)
>
> Sound from the speakers works, and the speakers mute when headphones is
> plugged in. But there's no sound coming through the headphones. Tried
> every possible model in /etc/modprobe.d/alsa-base and even installing
> alsa-source. None of these changed anything. Sound still works, except
> for the headphone jack.
>
> --
> Intel HDA sound broken on kernel 2.6.22-10.30
> https://bugs.launchpad.net/bugs/134146
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Matthijs De Smedt (matthijs--) wrote :

Ah, indeed. I do still have linux-ubuntu-modules-2.6.22-10-generic 2.6.22-10.23. Could you please tell me how to upgrade? apt-get update && apt-get upgrade obviously doesn't do the trick.

Matthijs De Smedt (matthijs--) wrote :

Well I got a deb from here:
https://launchpad.net/ubuntu/gutsy/+source/linux-ubuntu-modules-2.6.22/2.6.22-10.24

And I have headphone sound now. It's really glitchy though. I need to set 'line-in' to exactly 52 (0.00 dB gain) to get sound. Somehow this also increases the volume on my laptop speakers to unreasonable levels.

lithorus (lithorus) wrote :

<https://launchpad.net/ubuntu/gutsy/+source/linux-ubuntu-modules-2.6.22/2.6.22-10.24>
2.6.22-10.25 is the latest.

Btw. I would recommend using a GUI when upgrading Gutsy. apt-get update etc.
is simply not good to resolve package breakage.

Make sure that you have linux-generic installed which depends on the latest
linux-ubuntu-modules. Something you can see in a GUI package manager
frontend (eg. aptitude).

On 8/31/07, Matthijs de Smedt <email address hidden> wrote:
>
> Well I got a deb from here:
>
> https://launchpad.net/ubuntu/gutsy/+source/linux-ubuntu-modules-2.6.22/2.6.22-10.24
>
> And I have headphone sound now. It's really glitchy though. I need to
> set 'line-in' to exactly 52 (0.00 dB gain) to get sound. Somehow this
> also increases the volume on my laptop speakers to unreasonable levels.
>
> --
> Intel HDA sound broken on kernel 2.6.22-10.30
> https://bugs.launchpad.net/bugs/134146
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Matthijs De Smedt (matthijs--) wrote :

Synaptic shows the same thing. I have:
linux-generic 2.6.22.10.11
linux-image-2.6.22-20-generic 2.6.22.10.30
linux-ubuntu-modules-2.6.22-10-generic 2.6.22-10.23 (now manually upgraded to .24)

According to syntaptic and aptitude, these are the latest versions. I have everything checked in software sources except commercial and backports. This setup was done from a Tribe 5 CD. Is everybody else getting newer packages from the gutsy tree?

Matthijs De Smedt (matthijs--) wrote :

Ah. Obviously completely unrelated to this bug. nl.archive.ubuntu.com is far from up to date. When the 170mb of updates are finished I'll check if hda-intel is also working properly on my asus laptop. Thanks for your patience.

Anish Bhatt (anish7) wrote :

I have an HP dv6500-t with a realtek 268 card. And none of that is working for me ! Optimistically updating everyday, hope something works out !

gutsy 64-bit, lum 2.6.22-10.25 and alsa-driver-1.0.15rc1

ntt (ntt) wrote :

almost exactly the same here: HP DV6560EL running Gutsy5 AMD64 (plus
updates).

I fear we've got no chances of audio working out of the box, unless the
Ubuntu kernel modules maintainers do bite the bullet and start using
ALSA-HG (the ALSA "current", developer version) instead of the latest
ALSA release.

Or else, we'll probably have to wait until the next Ubuntu release,
April '08. or pray very hard about backporting.

but... wait a minute... where have you got that ALSA 1.05rc1 driver???

did you recompile the kernel modules, or is just the latest update
(which my usual mirror hasn't received yet)?

anish wrote:
> I have an HP dv6500-t with a realtek 268 card. And none of that is
> working for me ! Optimistically updating everyday, hope something works
> out !
>
> gutsy 64-bit, lum 2.6.22-10.25 and alsa-driver-1.0.15rc1
>

ntt (ntt) wrote :

in the meantime I've checked out the changelog of ALSA 1.0.5-rc1: it
seems it _should_ have some support for the Realtek ALC268 chip (and,
more important, for some variations of it - like ACER and Toshiba)

still, you reported it didn't work for you... I'm wondering whether the
  ALC268 HP uses in its notebooks has some differences from the generic
Realtek chip...

well, at least something is now moving. cross fingers!

anish wrote:
> I have an HP dv6500-t with a realtek 268 card. And none of that is
> working for me ! Optimistically updating everyday, hope something works
> out !
>
> gutsy 64-bit, lum 2.6.22-10.25 and alsa-driver-1.0.15rc1
>

Elisée Maurer (elisee) wrote :

I think I have the same problem, sound was working under Feisty after DSDT correction (I'm on a Toshiba P100-477), but now under Gutsy, I have no more sound... hope it gets fixed before gutsy release!

Rocco (rocco) wrote :

I have the same problem on a Dell Vostro 1700. I have compiled and installed alsa-driver 1.0.15rc1 from source. Then the sound works OK.

ntt (ntt) wrote :

Thanks for the info

Rocco wrote:
> I have the same problem on a Dell Vostro 1700. I have compiled and
> installed alsa-driver 1.0.15rc1 from source. Then the sound works OK.
>

Elisée Maurer (elisee) wrote :

How should I achieve this? Do I have to first uninstall alsa-driver 1.0.14 via apt? And what packages should I install? Only alsa-driver? Thanks in advance.

Changed in linux-source-2.6.22:
status: New → Invalid
Anish Bhatt (anish7) wrote :

could someone explain what's 'fakeroot debian/rules binary' in jose bernardo's comments ?

Kishore (kitts) wrote :

On Friday 07 Sep 2007 8:16:24 pm anish wrote:
> could someone explain what's 'fakeroot debian/rules binary' in jose
> bernardo's comments ?

It is the command used to build the package. It executes the script "rules"
which helps generate the .deb package.
--
Cheers!
kitts

It is still an issue with September 10 daily build. Is there any hope for a fix before Gutsy comes gold?

My Packard Bell BU45 described at: https://wiki.ubuntu.com/LaptopTestingTeam/PackardBellENBU45

- The internal mic doesn't work.
- The mic jack does receive sound, but this is not recognized by apps (Ekiga, sound preferences)
- The sound preferences dialog says:
    Failed to construct test pipeline for 'gconfaudiosrc ! audioconvert ! audioresample ! gconfaudiosink profile=chat'

See following attachments.

5 comments hidden view all 116 comments

The mic is the only problem on the BU45, playing sound works.

Neither one of thehis fixes works for me on my Toshiba PSPA6U (I also posted tin a similar thread)

But that seems not to be the only problem, The fan has also gone down, this laptop used to work so cool with kernel 2.6.20 and now is burning my fingers.

I have a custom dsdt fixed with no errors and warnings on my BIOS v2.4, v3.8 and v4.0

all of them were already fixed and the three of them conserve the same behavior

Markus Vuori (lite) wrote :

After upgrading to gutsy (in september) the snd-hda-driver started to misbehave.

Now I have on up-to-date gutsy on Lenovo T60 and I have to always modprobe (and modprobe -r) the driver at least twice before it works. And the first modprobe takes more than 10 seconds. After a couple of load/unload cycles the sound works.

lspci -vv:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
 Subsystem: Lenovo ThinkPad T60/R60 series
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin B routed to IRQ 21
 Region 0: Memory at ee400000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>

Markus Vuori (lite) wrote :

And before the two modprobes sound applications either hang or don't find any sound devices.

Greg Toombs (greg-toombs) wrote :

I don't see why canonical doesn't just copy the snd_hda_intel module code from alsa-drivers. Because it works.

Greg Toombs (greg-toombs) wrote :

In gentoo, I meant to say.

In gentoo and most of other distributions.

El jue, 01-11-2007 a las 15:29 +0000, Greg Toombs escribió:
> In gentoo, I meant to say.
>

mccubbin.t (mccubbin-t) wrote :

I guess this bug is most similar to what i am experiencing. I have an HP dv6500t and gutsy installed. No sound.

Anish Bhatt (anish7) wrote :

Downloading and recompiling ALSA from source solves the problem. Just move the original snd-hda-intel module from /lib/modules/<kernel>/ubuntu/media/snd-hda-intel to somewhere else to avoid a conflict. Get alsa-driver, alsa-lib and alsa-utils.

ntt (ntt) wrote :

Confirmed, with your audio chip (same I have on my HP DV6560-EL) you need ALSA v1.0.15 or newer.

I found this Ubuntu page to be useful in installing the new ALSA driver by hand:

https://help.ubuntu.com/community/HdaIntelSoundHowto

It will take you just 5 minutes to compile and install the new ALSA driver, and rest assured your sound chip _will_ work afterwards, as mine does now.

give it a try.

Displaying first 40 and last 40 comments. View all 116 comments or add a comment.