[regression] acx does not load

Bug #118539 reported by Toby Smithe on 2007-06-03
Affects Status Importance Assigned to Milestone
linux-ubuntu-modules-2.6.22 (Ubuntu)
Ben Collins

Bug Description

Whilst the available firmware seems the same, the module "acx" provided by this kernel version will not load with my hardware, whereas it would in prior versions.

Relevant `lspci -vvnn` section:

03:01.0 Network controller [0280]: Texas Instruments ACX 111 54Mbps Wireless Interface [104c:9066]
        Subsystem: Abocom Systems Inc Unknown device [13d1:ab90]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 21
        Region 0: Memory at feafa000 (32-bit, non-prefetchable) [size=8K]
        Region 1: Memory at feac0000 (32-bit, non-prefetchable) [size=128K]
        Capabilities: <access denied>

Ben Collins (ben-collins) wrote :

Please provide dmesg after trying to load the module (attach to the bug report via the web interface, do not paste into comment).


Changed in linux-source-2.6.22:
assignee: nobody → ben-collins
status: Unconfirmed → Needs Info
Toby Smithe (tsmithe) wrote :

The attached dmesg shows the message generated after inserting the module, but wouldn't appear (to me) an error message. modprobe claims Invalid Argument, and the module does not load. I have tried every available firmware version.

Toby Smithe (tsmithe) wrote :

Any more info required?

Toby Smithe (tsmithe) wrote :

Hi - could someone clarify the status of this bug?

Phil Bull (philbull) wrote :

I have the same (or a similar) problem with Gutsy.

$ sudo modprobe -v acx
insmod /lib/modules/2.6.22-6-generic/ubuntu/wireless/acx/acx.ko firmware_ver=
FATAL: Error inserting acx (/lib/modules/2.6.22-6-generic/ubuntu/wireless/acx/acx.ko): Invalid argument

(I changed firmware_ver from 'default' to '', with no effect)

$ dmesg #last line of dmesg
[ 715.364000] acx: Loaded combined PCI/USB driver, firmware_ver=

The card (D-Link GWL-650+, ACX111 chipset) was working normally under Feisty, through the wlan0 interface, and still shows up in hal-device-manager on Gutsy. However, wlan0 isn't there any more:

$ iwconfig
lo no wireless extensions.
eth0 no wireless extensions.

Phil Bull (philbull) wrote :

This is still an issue after the latest gutsy updates.

Ivan Giuliani (giuliani.v) wrote :

The same here, I tried to load different firmware versions (I even tried to download the firmware images from the acx100's website) but I always get "invalid argument" when modprobe-ing.

Samuel Abels (knipknap) wrote :

Same problem with most recent Gutsy.

Toby Smithe (tsmithe) wrote :

Hmm I think this is enough info to confirm this bug... Is there more needed? If so, how could we be of service?

martyscholes (martyscholes) wrote :

I can also confirm. This seems related to the 2.6.22-7 kernel. Loading under the previous 2.6.20-16 kernel works just fine. Copying /lib/modules/2.6.20-16-generic/kernel/ubuntu/wireless/acx/acx.ko to /lib/modules/2.6.22-7-generic/ubuntu/wireless/acx/acx.ko does not help.

Is this possibly related to moving the module from the /lib/modules/*/kernel subtree to the /lib/modules/*/ubuntu subtree?

Just thoughts...

Phil Bull (philbull) wrote :

Confirming bug due to multiple reports.

Changed in linux-ubuntu-modules-2.6.22:
status: Incomplete → Confirmed
Jasey (jason-rivers) wrote :

is there any news on this?

I can confirm this on a SiteCom wireless card based on ACX111 chipset running Gutsy 18-07-2007

si (menzies-conachers) wrote :

I ran in to this one too after having upgraded to Gutsy tonight. I tried compiling the AC100 driver against the latest headers and got the following errors

/usr/src/acx-20070101/acx-20070101/common.c: In function ‘acx_l_rxmonitor’:
/usr/src/acx-20070101/acx-20070101/common.c:2757: error: ‘struct sk_buff’ has no member named ‘mac’
make[1]: *** [/usr/src/acx-20070101/acx-20070101/common.o] Error 1
make: *** [_module_/usr/src/acx-20070101/acx-20070101] Error 2
make: Leaving directory `/usr/src/linux-headers-2.6.22-8-generic'

I hope that this helps someone.

Joachim Namislow (jfrieben) wrote :

Driver snapshot "acx-20070101" is not compatible with the new "mac80211" wireless stack of kernel version 2.6.22.x and later. However, there is a modified version by Hauke available at

    http://www.hauke-m.de/fileadmin/acx/acx-20070610.tar.bz2 .

This one builds and works nicely for me up to the latest 2.6.23 snapshots! I cannot tell for sure how this will work with "Gutsy" since I am running the "Fedora" development tree, but it seems obvious to me that the issue is due to a broken interface to the wireless stack. I strongly recommend to update the "Gutsy" driver source to this snapshot!

si (menzies-conachers) wrote :

Cheers Joachim, I'll try and build this tonight and report back.

si (menzies-conachers) wrote :

OK I've built the above and it builds fine but when I install it I get the following errors in dmesg

[ 51.079446] acx: need to load firmware for acx111 chipset with radio ID 16, p
lease provide via firmware hotplug:
[ 51.079451] acx: either one file only (<c>ombined firmware image file, radio-
specific) or two files (radio-less base image file *plus* separate <r>adio-speci
fic extension file)
[ 51.079461] requesting firmware image 'tiacx111c16'
[ 51.996052] acx: firmware image 'tiacx111c16' was not provided. Check your ho
tplug scripts
[ 51.996064] requesting firmware image 'tiacx111'
[ 52.005342] acx: firmware image 'tiacx111' was not provided. Check your hotpl
ug scripts

the firmware is in the /lib/firmware/2.6.22-9-generic/acx/default directory as it was for previous kernels. What have I done wrong. Cheers

Joachim Namislow (jfrieben) wrote :

Using the current "Fedora" development tree, that's hard to tell for me. Here, "hotplug" is not used at all. What I can state is that on my sytem, the firmware can be found at "/lib/firmware/tiacx111c16". You might want to try copying your firmware file to this location or have a look at the "hotplug" scripts of your system and/or the driver source.
For your information, I have attached the "dmesg" output which shows the correct function of the kernel module for my system. Btw, I am using F/W but F/W works equally well.

si (menzies-conachers) wrote :

I've had another try and managed to get it working by copying the tiacx11c16 file to /lib/firmware/2.6.22-9-generic. Thanks for all your help.

Leonardo Prosperi (leo1981) wrote :

I managed to get it working in Feisty with Gutsy kernel 2.6.22..
I compiled the module acx-20070101 with this patch:
I copied the firmware in /lib/firmware/ (I don't know if it is necessary).

Same for me with a D-Link AirPlus: DWL-650+:


02:00.0 Network controller: Texas Instruments ACX 100 22Mbps Wireless Interface

My last update of gutsy : 15/08/2007 15 h 43 (in france)

same error at module insertion ...

Same bug in the 64 bits kernel ...

Patch it !! :)

This patch work for me too !

Please don't forget to patch it for the next kernel build :-)

bert07 (marien.bert) wrote :

Installed Tribe 5. Still the same: The acx directory and files are there, but no wireless detected.

I strongly recommend Ubuntu team to fixed this problem. If necessary, even
patch the kernel. I have been bothered by this problem for quite a long

On 8/23/07, bert07 <email address hidden> wrote:
> Installed Tribe 5. Still the same: The acx directory and files are
> there, but no wireless detected.
> --
> [regression] acx does not load
> https://bugs.launchpad.net/bugs/118539
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.

Forrest Sheng Bao,
Department of Computer Science
Texas Tech University

Home Page: http://forrest.bao.googlepages.com
MSN: <email address hidden>
Yahoo! : <email address hidden>
Google : <email address hidden>
AIM: forrestbao
Skype: forrestbao
Facebook: Forrest Sheng Bao
Tel: +1 (806) 283-4348
China Tel: 86-13915962625 (also available in USA)

Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html

Martin Jackson (mhjacks) wrote :

I can confirm the same brokenness with an acx-based Linksys WPC54G v2.0

Phil Bull (philbull) on 2007-08-30
Changed in linux-ubuntu-modules-2.6.22:
importance: Undecided → Medium

I can confirm this with acx based USR 5410 on tribe 5 (gutsy). Worked great with Feisty from the Live CD. I had reported a bug here https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.22/+bug/134920

Matt Joiner (anacrolix) wrote :

i have trouble with this driver for G520+ for both feisty and gutsy tribe 5.

temporally I use the windows driver with ndisgtk (ndiswrapper gtk GUI) and it work perfectly (mostly better (WPA work with ndiswrapper and not with native driver))

bert07 (marien.bert) wrote :

I installed the daily build of 03/09/2007, still the same. No wireless.
Is anyone going to fix this? 'Cause without this fixed, I cannot use gutsy at all. And many others with me.

Leonardo Prosperi (leo1981) wrote :

I think Ubuntu doesn't like acx.
In 6.06 and 6.10 there was a bug (a wrong link, easy to fix), that was fixed in 7.04.
Now this bug, I compiled myself the driver with the patch for the new kernel and it works.
I don't want to wait 8.04.
I suggest also to use ndiswrapper for the WPA, waiting for the new acx-mac80211.

Matt Joiner (anacrolix) wrote :

I can get a D-Link G520+ to come up and do unencrypted wireless (I haven't tested others).
I followed the following article: http://acx100.sourceforge.net/wiki/Distribution_list/Ubuntu
this module: http://lisas.de/~andi/acx100/acx-20070101.tar.bz2
and applied this patch: http://acx100.sourceforge.net/wiki/Patch_2.6.22
I also created soft symbolic links to the firmware requested in dmesg after modprobing the compiled driver in /lib/firmware/`uname -r`
lrwxrwxrwx 1 root root 21 2007-09-06 03:19 tiacx111 -> acx/
lrwxrwxrwx 1 root root 24 2007-09-06 03:23 tiacx111c16 -> acx/
lrwxrwxrwx 1 root root 24 2007-09-06 03:24 tiacx111r16 -> acx/

As I understand it, WPA doesn't work, but I've not tried.

Hamish Downer (mishd) wrote :

had the same problem when I tried tribe 5.

This is stopping me using gutsy for testing purposes. And if this is not fixed before release there'll be a lot of very unhappy people who installed feisty and their wireless 'just worked' (tm) do an upgrade and suddenly they can't access the net ...

Marco A S Ribeiro (salsichad2) wrote :

had the same problem in tribe 5/6 Kernel 2.6.22-11

Same problem here, solved by either booting from kernel 2.6.20, or by installing ndisgtk and using ndis wrappers,

bert07 (marien.bert) wrote :

Downloaded i386 live cd of 14/09/2007. Did not install it (I'm getting tired of doing so). Still no wireless. Will this be fixed before the final release? Somebody! Please?!

Leonardo Prosperi (leo1981) wrote :

The beta freeze is September 20th and the kernel freeze is October 4th.
I hope they have a minute to fix this bug.
Probably Canonical is working on the compatibility with Dell computers.

Id2ndR (id2ndr) wrote :

Bug confirmed with daily livecd 20070921.1 and a trendnet PCI card using acx 111.

Ben Collins (ben-collins) wrote :

Fixed this problem in ubuntu-gutsy-lum git. Will be uploaded for 7.10-beta inclusion.

Changed in linux-ubuntu-modules-2.6.22:
importance: Medium → High
status: Confirmed → Fix Committed
bert07 (marien.bert) wrote :

Thank you very much. I'm looking forward to test the beta.

Ben Collins (ben-collins) wrote :

linux-ubuntu-modules-2.6.22 (2.6.22-12.31) gutsy; urgency=low

  [Ben Collins]

  * acx: Add proper config defines to get a proper build
    - LP: #118539

 -- Ben Collins <email address hidden> Sat, 22 Sep 2007 12:08:54 -0400

Changed in linux-ubuntu-modules-2.6.22:
status: Fix Committed → Fix Released

Thank you very very Much. You save Me !

bert07 (marien.bert) wrote :

Downloaded the daily build of 20070925-2 for i386. Didn't install it yet, but I did run the live cd and I can say that the wireless is back for those who need acx drivers.
Although it took a little bit of doing because it didn't work with my first configuration; somehow the network manager did not load the new configuration. I changed wep key hex to wep key ascii and then it did load the new configuration. Alas my access point does not seem to understand ascii, so I changed it back to wep key hex, and this time the network manager loaded the configuration with the hex key.
Acx wireless is back in Gutsy!
Thank you all!

bert07 (marien.bert) wrote :

Downloaded the i386 beta version of Ubuntu yesterday.
Wireless with acx drivers worked okay.
No problems found.

Bart Heinsius (bheinsius) wrote :


I believe that this bug still exists for Gutsy Server.
Anyway, my D-Link DWL-G650+ AirPlusG+ with acx111 would not work out-of-the-box, with messages in dmesg like above:

[ 51.079461] requesting firmware image 'tiacx111c16'
[ 51.996052] acx: firmware image 'tiacx111c16' was not provided. Check your ho
tplug scripts
[ 51.996064] requesting firmware image 'tiacx111'
[ 52.005342] acx: firmware image 'tiacx111' was not provided. Check your hotpl
ug scripts

In my Gutsy Server install, these images got installed in /lib/firmware/2.6.22-14-generic/acx.
I copied the directory /lib/firmware/2.6.22-14-generic/acx to /lib/firmware/ and now it works.

regards Bart.

Jonas (jonass) wrote :

With Ubuntu 8.10 the D-Link DWL-G650+ seems to be recognized but my computer crashes when the card is activated. I tried twice: 1. booting with card inserted 2. boot without card and insert later. I used the live-CD without installing Ubuntu on harddrive. My card is H/W A1 and F/W ver 1.0.

PrinceRiley (wmarketing3) wrote :
Download full text (4.4 KiB)

Just found this page and still can't figure out what are the steps needed to get the ACX111 drivers to work on the Hardy LiveCD.

The Sourceforge project page om the ACX111 is far from clear and seems to point in different directions (what to do) based on the Ubuntu release. There are several mentions in the linked pages to disabling the NetworkManager which I am loath to do since this bug has been around since early 2007.

Here are the steps I've taken so far ....
ubuntu@ubuntu:~$ sudo lspci
00:00.0 Host bridge: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 12)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 12)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 Controller (rev 12)
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 12)
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus Controller (rev 12)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 12)
02:00.0 Network controller: Texas Instruments ACX 111 54Mbps Wireless Interface
02:01.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500] (rev a1)
02:02.0 Mass storage controller: Silicon Image, Inc. PCI0680 Ultra ATA-133 Host Controller (rev 02)
02:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:0a.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 03)
ubuntu@ubuntu:~$ lspci -n
00:00.0 0600: 8086:1a30 (rev 03)
00:01.0 0604: 8086:1a31 (rev 03)
00:1e.0 0604: 8086:244e (rev 12)
00:1f.0 0601: 8086:2440 (rev 12)
00:1f.1 0101: 8086:244b (rev 12)
00:1f.2 0c03: 8086:2442 (rev 12)
00:1f.3 0c05: 8086:2443 (rev 12)
00:1f.4 0c03: 8086:2444 (rev 12)
02:00.0 0280: 104c:9066 <------------- Wireless card here
02:01.0 0300: 10de:0326 (rev a1)
02:02.0 0180: 1095:0680 (rev 02)
02:09.0 0200: 10ec:8139 (rev 10)
02:0a.0 0401: 1274:5880 (rev 03)
ubuntu@ubuntu:~$ sudo find /lib/modules/`uname -r` -name "*acx*"
ubuntu@ubuntu:~$ sudo apt-get install linux-restricted-modules-2.6.24-16-386
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
Suggested packages:
  linux-doc-2.6.24 linux-source-2.6.24 avm-fritz-firmware-2.6.24-16 nvidia-glx
  nvidia-glx-legacy nvidia-glx-new
The following NEW packages will be installed:
  linux-image-2.6.24-16-386 linux-restricted-modules-2.6.24-16-386
0 upgraded, 2 newly installed, 0 to remove and 1 not upgraded.
Need to get 36.3MB of archives.
After this operation, 107MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com hardy/main linux-image-2.6.24-16-386 2.6.24-16.30 [18.3MB]
Get:2 http://archive.ubuntu.com hardy/restricted linux-restricted-modules-2.6.24-16-386 [18.0MB]
Fetched 36.3MB in 2min10s (279kB/s)
Selecting p...


To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers