Wifi-enabled led is not lit on ipw2200 cards

Bug #21367 reported by Jean-Louis Boers on 2005-09-11
102
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Andy Whitcroft
Declined for Karmic by Stefan Bader
Jaunty
Undecided
Andy Whitcroft
linux-source-2.6.20 (Ubuntu)
Low
Unassigned
Declined for Karmic by Stefan Bader
Jaunty
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Low
Unassigned
Declined for Karmic by Stefan Bader
Jaunty
Undecided
Unassigned

Bug Description

Wifi Status LED can be made to work easily by editing /etc/modprobe.d/ipw2200.
i.e. 'sudo gedit /etc/modprobe.d/ipw2200' add the following text to it, save,
and after your next reboot you will have a functioning blue LED. 'options
ipw2200 led=1'

The wifi on/off switch works properly for me on Breezy C-4

https://wiki.ubuntu.com/LaptopTestingTeam/HPNC6120: https://wiki.ubuntu.com/LaptopTestingTeam/HPNC6120

Jean-Louis Boers (jl-tuxair) wrote :

verified that a fresh PR does not activate the wifi LED. creating the file
/etc/modprobe.d/ipw2200 and adding

options ipw2200 led=1

makes it work.

William Grant (wgrant) wrote :

I can confirm this, it works if you add that line on my Dell Inspiron 630m... Although it behaves oddly. It's always on, except for a half-second flash just after I turn the radio on. This is pretty odd...

William Grant (wgrant) wrote :

Confirming...

Tom R (asub) wrote :

Did NOT work on my Dell 630m. I have rmmod'd the module, modprobed it with the option, that didn't bring it on. I added the line to the file, rebooted, still didn't light.

Fabio Parri (parrif-ibb) wrote :

Works for me too. I suggest fixing it in Breezy so that you don't have to add it anymore :)

Michel D'HOOGE (michel-dhooge) wrote :

I also have a dell 630m and also have some strange behaviour. Not 100% sure, but it seems the LED is on only when associated with a network. According to me, would be better to have it on when radio is on.

michelem (michele-marcucci) wrote :

It works for me too on a Dell D610 and Edgy Eft, finally...

Liam Fishwick (fryingfish1) wrote :

Works for me, but not on boot, if I boot then the light doesn't activate, but a rmmod and modprobe (or by using the hardware switch) then it does work. (dell inspiron 630m , edgy eft)

Tormod Volden (tormodvolden) wrote :

I would think the led=1 should be the default for the ipw2200 module.

Andrew Ash (ash211) wrote :

Matthew Garrett:

This bug is currently assigned to you. What sort of progress is being made on this bug?

Matthew Garrett (mjg59) wrote :

The documentation still indicates that this may cause problems on some hardware. I'll look into it.

Changed in linux-source-2.6.20:
importance: Medium → Low

Problem and stated solution confirmed on HP Pavilion dv4150 (a.k.a. v4100) notebooks.

Billy Kwong (tuppa) wrote :

Problem seems to be resolved on my ASUS W3N, using 2.6.20-13-generic.

Tormod Volden (tormodvolden) wrote :

Billy, what is your hardware? lspci | grep -i wireless

(Nothing changed here, with Intel Corporation PRO/Wireless 2915ABG)

Roel Huybrechts (rulus) wrote :

The same 'problem' and solution described in the bug report also applies here, with an Acer Aspire 1692 laptop. It'll be cool to fix this in Gutsy :)

Miles Lane (miles-lane) wrote :

Why is it taking a year and a half to add this option?
This option also works on my HP dv1240us. It took me ages to track down this option.

On my Dell XPS Gen2, I get odd behaviour. Adding the led=1 option means that after boot the wifi works, but the LED is off. If I use the soft toggle (Fn+F2 on this laptop) to switch bluetooth and wifi off, the bluetooth LED goes out, then when I toggle it back on, both the bluetooth and the wifi lights come on. Not major, just odd that it doesn't work on boot, only after a kill switch toggle.

Roel Huybrechts (rulus) wrote :

The problem persists on Gutsy RC, the fix of adding the led=1 option still solves it though.

$ lspci | grep -i wireless
06:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)

$ uname -a
Linux gutsy 2.6.22-14-generic #1 SMP Wed Oct 10 06:00:47 GMT 2007 i686 GNU/Linux

Changed in linux-source-2.6.22:
importance: Undecided → Low
status: New → Triaged
Chris Beaven (smileychris) wrote :

The fix worked flawlessly for me also (in Gutsy final).

$ lspci | grep -i wireless
06:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)

This will be retargeted towards the Hardy kernel once it is released. I've tagged this as "hardy-kernel-candidate" so that we make sure to retarget this report once the new release is out. However against the linux-source-2.6.22 and linux-source-2.6.20 packages this is being marked as "Won't Fix" as it does not meet the criteria for a stable release update. To learn more about the stable release update process please refer to https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-source-2.6.22:
status: Triaged → Won't Fix
Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Changed in linux:
status: New → Incomplete

Still broken with Hardy Heron Alpha2.

On the bright side, this was reported > 2 years ago, so if we just wait another 3 years or so, all the laptops with this bug should be out of service.

Changed in linux:
assignee: nobody → ubuntu-kernel-network
importance: Undecided → Low
status: Incomplete → Triaged

The fix proposed on 2005 by Jean-Louis Boers works for Acer Travelmate 3000, too. Could the setting "options
ipw2200 led=1" be included in Ubuntu by default?

Led light tested, details of hardware
http://www.iki.fi/karvinen/acer_travelmate_3004wtmi_with_linux.html#wlan_light
http://myy.helia.fi/~karte/acer_travelmate_3004wtmi_command_outputs.html

Changed in linux:
assignee: ubuntu-kernel-network → ubuntu-kernel-team
zhanzh@shanghai (zhanzh-sh) wrote :

guys,

I tried it on my Dell Inspiron 1300, but it didn't work out for me. (and tried Fn + F2, without luck).

zhanzh:~$ uname -r
2.6.22-14-386

zhanzh:~$ cat /etc/modprobe.d/ipw2200
options ipw2200 led=1

zhanzh:~$ lspci | grep -i wireless
02:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)

zhanzh:~$ lsmod | grep ipw2200
ipw2200 135728 0
ieee80211 49900 1 ipw2200

Any one made it work on Dell Inpspiron 1300?

zhanzh@shanghai (zhanzh-sh) wrote :

Finally, finally, my wireless connection is working.

I followed the post, http://ubuntuforums.org/showthread.php?t=185174

Note: need to mv bcmwl5.sys wl_apsta.o

Thanks, Nick.

Problem is still present in Hardy 8.04. WLAN enabled light is not lit on Acer Travelmate 3000.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Giovanni Condello (nanomad) wrote :

Bug is still present. And the solution provided is still valid. (Ibex Alpha 5)
Kernel info:
linux acer 2.6.27-3-generic #1 SMP Wed Sep 10 16:02:00 UTC 2008 i686 GNU/Linux

Tormod Volden (tormodvolden) wrote :

(I deleted the tag 'linux-2.6.27' since it's reserved for bugs _introduced_ by 2.6.27 if I understand correctly.)

Still present in Intrepid RC. Adding the line 'options ipw2200 led=1' to /etc/modprobe.d/ipw2200 does still work. 3 year old bug with 3 year old fix, this is sad :(

Asraniel (asraniel) wrote :

Probably this bug should just be closed. I don't think it will never be fixed. So when closing that bug, it makes room for other bugs.

OK, that was sarcastic ;)

jrav (jravac) wrote :

had bug on intrepid, fixed w/ above, what's the specific reason this isn't incorp mainstream? (i saw the criteria page, but dunno how this fits exclusion).

Tormod Volden (tormodvolden) wrote :

What I miss is a clear bug reference to systems that would break if led=1 by default. The fix might have been held back for years on anecdotal evidence. Matthew Garrett promised to check this in comment #11 two years ago, but did not follow up.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Giovanni Condello (nanomad) wrote :

This bug is still vaild for Jaunty

Linux acer 2.6.28-11-generic #36-Ubuntu SMP Fri Mar 20 19:40:40 UTC 2009 i686 GNU/Linux

As #33 pointed, there is no clear reference to any bugs related with led=1. Please fix it since it is very annoying (and straightforward to fix too)

TJ (tj) wrote :

Documentation/networking/README.ipw2200 says:

 NOTE: The LED code has been reported to hang some systems when
 running ifconfig and is therefore disabled by default.

git blame Documentation/networking/README.ipw2200

826d2abe (James Ketrenos 2005-11-07 18:56:59 -0600 315) NOTE: The LED code has been reported to hang some systems when

commit 826d2abe9945372c8838398bfd88a1caa5844d41
Author: James Ketrenos <email address hidden>
Date: Mon Nov 7 18:56:59 2005 -0600

So, based on the fact that information was added in late 2005 and we're now in 2009 and I've not seen any crash reports related to LED being enabled I think we should push this forward.

Changed in linux (Ubuntu):
assignee: nobody → intuitivenipple
status: Triaged → In Progress
Giovanni Condello (nanomad) wrote :

Thanks TJ.

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
TJ (tj) on 2009-03-24
Changed in linux (Ubuntu):
assignee: intuitivenipple → nobody
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package linux - 2.6.28-11.38

---------------
linux (2.6.28-11.38) jaunty; urgency=low

  [ Brad Figg ]

  * When AppArmor is configured, securityfs must be as well.
    - LP: #344370
  * ARM: Enable AA with SECURITYFS for imx51
    - LP: #344370

  [ Bryan Wu ]

  * Add 3 missing files to prerm remove file list
    - LP: #345623

  [ Daniel T Chen ]

  * SAUCE: (drop after 2.6.28) Don't trust hw-ptr blindly
    - LP: #330814
  * SAUCE: (drop after 2.6.28) Apply further pcm_lib updates for hw_ptr
    - LP: #330814

  [ Ike Panhc ]

  * Copy header files for various kernel media driver
    - LP: #322732

  [ Tim Gardner ]

  * Revert "Fix the VFP handling on the Feroceon CPU"
    Only applied to mv78xx0 ARM flavour.
  * Enabled drivers/staging/at76_usb
    - LP: #152626

  [ <email address hidden> ]

  * SAUCE: ipw2200: Enable LED by default
    - LP: #21367
  * SAUCE: wistron_btns: support Prestigio Wifi RF kill button over suspend
    - LP: #346586

  [ Upstream Kernel Changes ]

  * Build fix for __early_pfn_to_nid() undefined link error
  * Fix misreporting of #cores as #hyperthreads for Q9550
  * eventfd: remove fput() call from possible IRQ context
  * S390: __div64_31 broken for CONFIG_MARCH_G5
  * ALSA: Fix vunmap and free order in snd_free_sgbuf_pages()
  * ALSA: mixart, fix lock imbalance
  * ALSA: pcm_oss, fix locking typo
  * ALSA: hda - Fix DMA mask for ATI controllers
  * ALSA: hda - Workaround for buggy DMA position on ATI controllers
  * ALSA: opl3sa2 - Fix NULL dereference when suspending snd_opl3sa2
  * nfsd: nfsd should drop CAP_MKNOD for non-root
  * NFSD: provide encode routine for OP_OPENATTR
  * dm ioctl: validate name length when renaming
  * dm io: respect BIO_MAX_PAGES limit
  * dm crypt: fix kcryptd_async_done parameter
  * dm crypt: wait for endio to complete before destruction
  * ata_piix: add workaround for Samsung DB-P70
  * V4L/DVB (10218): cx23885: Fix Oops for mixed install of analog and
    digital only cards
  * thinkpad-acpi: fix module autoloading for older models
  * Add '-fwrapv' to gcc CFLAGS
  * Move cc-option to below arch-specific setup
  * USB: storage: Unusual USB device Prolific 2507 variation added
  * USB: Add Vendor/Product ID for new CDMA U727 to option driver
  * USB: option.c: add ZTE 622 modem device
  * USB: Add device id for Option GTM380 to option driver
  * USB: Option: let cdc-acm handle Sony Ericsson F3507g / Dell 5530
  * USB: Updated unusual-devs entry for USB mass storage on Nokia 6233
  * USB: unusual_devs: Add support for GI 0431 SD-Card interface
  * USB: serial: add FTDI USB/Serial converter devices
  * USB: serial: ftdi: enable UART detection on gnICE JTAG adaptors
    blacklist interface0
  * USB: serial: new cp2101 device id
  * USB: usbtmc: fix stupid bug in open()
  * USB: usbtmc: add protocol 1 support
  * USB: usbfs: keep async URBs until the device file is closed
  * USB: EHCI: expedite unlinks when the root hub is suspended
  * USB: EHCI: Fix isochronous URB leak
  * powerpc: Remove extra semicolon in fsl_soc.c
  * menu: fix embedded menu snafu
  * Linux 2.6.28.9
  * Add '-fwrapv' to gcc CFLAGS
    - LP: #348015
  * Move cc-option to below arch-s...

Read more...

Changed in linux:
status: Fix Committed → Fix Released
Hassan El Jacifi (waver) wrote :

Bug still valid. (Tested with Dell Inspiron 6000)

Linux Mars 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.04
Release: 9.04
Codename: jaunty

lsmod | grep ipw
ipw2200 150984 0
ieee80211 38344 1 ipw2200

 lspci -v -s 03:03.0
03:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
        Subsystem: Intel Corporation Device 2722
        Flags: bus master, medium devsel, latency 64, IRQ 17
        Memory at dfcfd000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 2
        Kernel driver in use: ipw2200
        Kernel modules: ipw2200

Bug is fixed on my laptop: HP Compaq nc6220

Linux valentin-laptop 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

valentin@valentin-laptop:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.04
Release: 9.04
Codename: jaunty

valentin@valentin-laptop:~$ lsmod | grep ipw
ipw2200 150984 0
ieee80211 38344 1 ipw2200

valentin@valentin-laptop:~$ sudo lspci -v -s 02:04.0
02:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
 Subsystem: Hewlett-Packard Company Device 12f6
 Flags: bus master, medium devsel, latency 64, IRQ 21
 Memory at d0100000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [dc] Power Management version 2
 Kernel driver in use: ipw2200
 Kernel modules: ipw2200

I also have a Dell Inspiron 6000 running Jaunty and I can confirm that the bug is still there.
Seems to be a stubborn bug.

Giovanni Condello (nanomad) wrote :

Bug reopened since it is vaild for Karmic. Looks like we need the same patch as before (offsets may need changes)

The old patch was this one:
http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-jaunty.git;a=commitdiff;h=5ceaf4c594a79e7d50f66943abf068042ae05ba5

Giovanni Condello (nanomad) wrote :

Reopened as Karmic still has this bug

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Vish (vish) wrote :

Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.

A hardware specific issue is not a papercut.
A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
Andy Whitcroft (apw) wrote :

This was applied after the karmic split and will get reintegrated during the patch review shortly.

Changed in linux-source-2.6.20 (Ubuntu Jaunty):
status: New → Won't Fix
Changed in linux-source-2.6.22 (Ubuntu Jaunty):
status: New → Won't Fix
Changed in linux (Ubuntu Jaunty):
assignee: nobody → Andy Whitcroft (apw)
status: New → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andy Whitcroft (apw)

The light doesn't come on when I start the computer.
But when I turn wifi off and on with the Fn-F2 buttons on my Dell Inspiron 6000, I noticed that the wifi-led actually starts to work as intended.

 I'm still running Jaunty.

I recently ran a live-cd with Linux Mint 7 and it had exactly the same behavior

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-10.35

---------------
linux (2.6.31-10.35) karmic; urgency=low

  [ Amit Kucheria ]

  * Disable CONFIG_UEVENT_HELPER_PATH

  [ Andy Whitcroft ]

  * [Config] Enable CONFIG_USB_GADGET_DUMMY_HCD
  * remove the tlsup driver
  * remove lmpcm logitech driver support

  [ Bryan Wu ]

  * Add 3 missing files to prerm remove file list
    - LP: #345623, #415832

  [ Chris Wilson ]

  * [Upstream] drm/i915: Check that the relocation points to within the
    target
    - LP: #429241

  [ Luke Yelavich ]

  * [Config] Set CONFIG_EXT4_FS=y on ports architectures

  [ Manoj Iyer ]

  * SAUCE: Added quirk to recognize GE0301 3G modem as an interface.
    - LP: #348861

  [ Tim Gardner ]

  * Revert "[Upstream] ACPI: Add Thinkpad W500, W700, & W700ds to OSI(Linux) white-list"
  * Revert "[Upstream] ACPI: Add Thinkpad R400 & Thinkpad R500 to OSI(Linux) white-list"
  * Revert "[Upstream] ACPI: Add Thinkpad X300 & Thinkpad X301 to OSI(Linux) white-list"
  * Revert "[Upstream] ACPI: Add Thinkpad X200, X200s, X200t to OSI(Linux) white-list"
  * Revert "[Upstream] ACPI: Add Thinkpad T400 & Thinkpad T500 to OSI(Linux) white-list"
    Upstream suggests that this is not the right approach.

  * [Config] Set default I/O scheduler to DEADLINE
    CFQ seems to have some load related problems which are often exacerbated by sreadahead.
    - LP: #381300

  [ <email address hidden> ]

  * SAUCE: ipw2200: Enable LED by default
    - LP: #21367

  [ Upstream Kernel Changes ]

  * ALSA: hda - Add support for new AMD HD audio devices
    - LP: #430564

 -- Andy Whitcroft <email address hidden> Wed, 16 Sep 2009 15:37:49 +0100

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Tim Lunn (darkxst) wrote :

I have just started getting this issue on Karmic in the last week.

Tormod Volden (tormodvolden) wrote :

Tim, please check with "cat /proc/version_signature" which kernel you are using. It works fine here with 2.6.31-14.48-generic.

Maverick, on a Dell XPS-M140. The wifi led only turns on after disabling and re-enabling wifi using the FN+F2 key combination.

Chris Wilson (notgary) on 2013-02-11
no longer affects: hundredpapercuts
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.