Atheros wireless (AR5007) not working on various laptops, including the ASUS Eee PC

Bug #182489 reported by Martijn vdS on 2008-01-13
284
This bug affects 16 people
Affects Status Importance Assigned to Milestone
MadWifi
Won't Fix
Unknown
linux-backports-modules-2.6.24 (Baltix)
Undecided
Unassigned
linux-backports-modules-2.6.24 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
linux-restricted-modules-2.6.24 (Ubuntu)
High
Unassigned
Hardy
High
Unassigned
Intrepid
High
Amit Kucheria

Bug Description

Binary package hint: linux-restricted-modules

The Eee PC has non-working wireless out of the box. A patch is available from the madwifi website:

http://madwifi.org/ticket/1679

I'd like to have working wireless in hardy, without having to patch/compile manually :)

Martijn vdS (martijn) wrote :
Martijn vdS (martijn) wrote :
Martijn vdS (martijn) wrote :
Bryce Harrington (bryce) wrote :

Wireless driver: atheros-swan-modules-2.6.21.4-eeepc_20070713-2_i386.deb

It sounds like the madwifi drivers for Atheros are considered to be an acceptable substitute, however there is a patch (see http://wiki.eeeuser.com/ubuntu) to Ubuntu's version of the driver to make it work with EEE PC.

Changed in linux-restricted-modules-2.6.24:
importance: Undecided → High
status: New → Confirmed
Changed in linux-restricted-modules-2.6.24:
assignee: nobody → ubuntu-kernel-team
status: Confirmed → Triaged
Andrew Straw (astraw) wrote :

For what it's worth, here's a list of steps I did to get the madwifi drivers working in Hardy:

{{{
# remove all linux-restricted-modules-* packages
sudo apt-get install build-essential
sudo rmmod ath_pci
sudo rmmod ath_hal
sudo rmmod wlan
wget http://snapshots.madwifi.org/special/madwifi-ng-r2756+ar5007.tar.gz
tar xvzf madwifi-ng-r2756+ar5007.tar.gz
cd madwifi-ng-r2756+ar5007
make
sudo make install
# reboot to reset the ethernet hardware.
}}}

Ben Collins (ben-collins) wrote :

Amit uploaded an lrm with latest madwifi, which seems to have this patch.

Changed in linux-restricted-modules-2.6.24:
assignee: ubuntu-kernel-team → amitk
status: Triaged → Fix Released
Andrew Straw (astraw) wrote :

Unfortunately, Amit's upload does not have the AR2425 (AR5007EG) patch. Actually, the whole thing looks pretty ugly -- the patch (see http://madwifi.org/ticket/1679 ) "breaks the ABI for all non-i386 HAL binaries". I don't know if this issue makes the patch unacceptable as something that could get into Hardy's l-r-m package, even if only the i386 architecture binary. Furthermore, the patch apparently does not apply cleanly to the 0.9.3.3 release, only to r2756 (e.g. snapshots.madwifi.org/madwifi-ng/madwifi-ng-r2756-20071018.tar.gz ). :(

So, is is possible that these patches could be incorporated into the next release of lrm?

Darn those binary blobs...

Andrew Straw (astraw) wrote :

I'm changing the status back from "Fix Released" to "Confirmed" because the fix isn't released in the Ubuntu l-r-m package.

Changed in linux-restricted-modules-2.6.24:
status: Fix Released → Confirmed
Andrew Paulin (trash-eighty) wrote :

I know this driver's in a pretty ugly situation, but is there any chance of it getting into the Hardy release (perhaps as an 'alternate" version of the package)?

any update on this? It doesn't seem to be in the latest Hardy kernel set.

eee users really need it.

Yes, Eee users (as well as a few other newer laptops) need the AR5007
driver, but so far, the madwifi devs have been helpless to integrate
the driver into the mainline madwifi driver. IMHO, we should be able
to put the 5007 driver in a seperate package and use
restricted-manager to pick the proper driver, but I'm not aware enough
of how the internals work to know if we can fix it.

On Wed, Feb 27, 2008 at 9:08 AM, GiuseppeVerde <email address hidden> wrote:
> any update on this? It doesn't seem to be in the latest Hardy kernel
> set.
>
> eee users really need it.
>
> --
> Atheros wireless (AR5006EG) not working on ASUS Eee PC
> https://bugs.launchpad.net/bugs/182489
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Another here trying to add weight to getting this in for Hardy.

Theres lots of people with eee PC's that have to fiddle to get the WiFi working.

I'll add my voice to the choir asking for the ar5007 patch to be added to madwifi in hardy. The AR5007EG is used in many current laptops and I think hardy should support it out of the box being a LTS release.

lod (altoas) wrote :

i'm with the same chip and I;m forced to use ndiswrapper, but it work fine. It's sad that this bug isn't fix for mounts!

vnieto (vnieto) wrote :

Hi I use a hp Pavilion dv6721 an use an ar5007. I Think hardy shold support it on amd64 for use mi laptop.

Tk

vnieto, at the moment, it's impossible to use this driver in AMD64.
Unfortunately, there's nothing we can do about it at the moment.

On Wed, Mar 26, 2008 at 2:15 AM, vnieto <email address hidden> wrote:

> Hi I use a hp Pavilion dv6721 an use an ar5007. I Think hardy shold
> support it on amd64 for use mi laptop.
>
> Tk
>
> --
> Atheros wireless (AR5006EG) not working on ASUS Eee PC
> https://bugs.launchpad.net/bugs/182489
> You received this bug notification because you are a direct subscriber
> of the bug.
>

just another voice in the crowd, but I too would greatly appreciate hardy having "out of the box" wifi capabilities for this card. I am trying to convert others to linux, yet the lack of this feature on my one and only laptop is preventing me from giving them a demonstration of the live-cd's power. Please incorporate it, even if it is just a copy of the patched source code, it would be much easier to have it on the live cd than to have to plug up to an ethernet cable. Thanks!!

vnieto (vnieto) wrote :

I Use ndiswrapper with 64 bit windows xp driver and work fine the first time (clean instalation).
Before a restart I see all networks but I can't connect to.

I need remove module (sudo -r ndiswrapper) and put on blacklis ath_pci and load module (sudo modprobe ndiswrapper) again to connect sucessfuly.

If I forgot remove from blacklist ath_pci before restarts, don't work later.

Is really difficult and tortuose, but work.

vnieto (vnieto) wrote :

I use the script attached for do the ndiswrapper work for me.

Jonas (jon-stekas) wrote :

Acer Aspire 5520 laptop and Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter not working, hope it will be fixed soon.

Matt Bamford (mbamford) wrote :

The Debian EEE PC team (http://debian-eeepc.alioth.debian.org , http://wiki.debian.org/DebianEeePC) has created a package, madwifi-eee containing the patched version. It builds on Hardy after I built a new version of madwifi-tools 1:0.9.4~rc2+dfsg-1 from Debian lenny. (Hardy only has 1:0.9.3+dfsg-3, and madwifi-eee requires > 1:0.9.4~rc2+dfsg-1).

Any chance we could see a new updated madwifi-tools for hardy, and then the madwifi-eee packages included so that EEE (and other AR5007) users aren't left in the dark?

vnieto (vnieto) wrote :

MAtt, the madwifi-eee work over amd64 hardy version?

Matt Bamford (mbamford) wrote :

No, the patch for madwifi will only work under i386, regardless of how you choose to install and use it.

If anyone's interested, I've put the two packages into my PPA (https://launchpad.net/~mbamford/+archive). Works great for me.

frederyk (frederyk) wrote :

And just another voice for getting hardy to support eeepc wlan ou of the box. The idea with the restricted driver section is the best I think, because this ugly patch would not match the typical ubuntu quality, but there are so many novice users with the eeepc, an easy wlan install will be essential for getting more ubuntuusers.

jyio (inportb) wrote :

This is an Atheros issue, not an Ubuntu/MadWifi issue. I have an AR5007 as well, but was able to get it working very easily using the patch on my ia32 laptop. It was also trivial to apply the Aircrack-ng patch. The only ugliness I see is that Atheros has not released any Linux drivers for their hardware.

The guys behind MadWifi are working on porting this patch to the other platforms. Once this has been done successfully, everyone will have AR5007 support.

Changed in linux-restricted-modules-2.6.24:
milestone: none → ubuntu-8.04.1
sam tygier (samtygier) wrote :

according to bug #209414 i have the same atheros card in an aspire 7520

05:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
 Subsystem: AMBIT Microsystem Corp. Unknown device 0428
 Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Interrupt: pin A routed to IRQ 19
 Region 0: Memory at f2200000 (64-bit, non-prefetchable) [disabled] [size=64K]
 Capabilities: <access denied>

running hardy 64bit. would be nice to have a fix

ibizatunes (ibizatunes) wrote :

Yep just another person saying that it doesnt work on hardy, on tosiba statillitle a215-s4747
does anyone have a fix for this yet? or is there a ETA on it a patch yet?

vnieto (vnieto) wrote :

I made working atheros ar5007 over amd64 hardy with ndiswrapper, some tortouse, but work-
first install the ndiswrapper and the xp64 driver, then basicaly I use this procedure when start X session:

sudo modprobe -r ndiswrapper
sudo cp /etc/modprobe.d/blacklist .
sudo sed 's/#blacklist ath_pci/blacklist ath_pci/g' /etc/modprobe.d/blacklist>blacklist3
sudo mv blacklist3 /etc/modprobe.d/blacklist
sudo ndiswrapper -ma && sudo ndiswrapper -mi
sudo modprobe ndiswrapper
sudo sed 's/blacklist ath_pci/#blacklist ath_pci/g' /etc/modprobe.d/blacklist>blacklist3
sudo mv blacklist3 /etc/modprobe.d/blacklist

and before work.
I Attach one script to do, simply run with: sudo ./subirwifi.sh before start x session

Not is the nest way, but work

Srikrishna Das (srikrishna) wrote :

Acer Aspire 4315 has Atheros Communications Inc. AR242x. Restricted drivers in hardy doesn't work.

. (e-mail-address-mailinator) wrote :

+1 Fujitsu Siemens Amilo Li 2727 same issue with the Atheros Wifi adapter.

Toshiba A205-S5843 same issue with the Atheros Wifi adapter, restricted drivers in hardy doesn't work.

arconww (arconworldwide) wrote :

Are ya'll kidding me?!
This driver, for the Atheros card has been patched and has been working perfectly, for at least the past 2 months! [At least on all Tosiba statillitle a215s]
That means 32 bit & 64 bit, not to mention the ndiswrapper - without any further adu - even longer.
[Is "Ubuntu" an African word for "I can't configure Debian.... - let alone Linux". ]
People, check out the WORKING drivers/patches from the Debian/sid and/or Sidux and/or - if you're an ndiswrapper fan for some reason - just get the right firmware from the Check guy's site - who's address is not in the front of me, as I am on the run, on someone else's machine. {He is the only one on the Web with the right firmware, so say a BIG "thank you" for his efforts.}
Bye bye...

darren (darrenm) wrote :

Arconww - Great thanks!

Can you tell me how I install Ubuntu on a laptop with this wireless chip and then get it working? I only have a wireless connection.

  • unnamed Edit (1.4 KiB, text/html; charset=ISO-8859-1)

Follow these instructions for installing the necessary software to compile
the madwifi driver with then you will have to get the latest madwifi
driver--the instructions for downloading it did not work for me but the
location is correct. Once you compile the driver and install it following
the instructions it just worked. If you have trouble let me know and i will
try to help.

http://ubuntuforums.org/showpost.php?p=2731459&postcount=25

On Wed, May 7, 2008 at 5:49 PM, darren <email address hidden> wrote:

> Arconww - Great thanks!
>
> Can you tell me how I install Ubuntu on a laptop with this wireless chip
> and then get it working? I only have a wireless connection.
>
> --
> Atheros wireless (AR5007) not working on ASUS Eee PC
> https://bugs.launchpad.net/bugs/182489
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
"Those who say it can't be done are usually interrupted by others doing
it."--James Arthur Baldwin

Hi, anyone can tell me hoe to runa ascript before start Xsession ???

Thanks in advance.

Jose Coma.

parwrench (parwrench) wrote :

I too was rather disappointed when my Acer 5520 wireless didnt work with gutsy. those of you who have an atheros 5006/7 may want to follow the latest instructions on the madwifi site..i am not using ndiswrapper .... and the madwifi module was not working for me in gutsy or hardy untill I read up on the madwifi site...i am pleased to announce that my atheros wireless is working just fine with the latest files from madwifi. Thanks guys. However it was after some rather extensive research that i got it working. Fortunately i didnt have to do all the research again when i upgraded a week ago. I did have to reinstall the madwifi drivers but all is well.
I am no expert at computers, but i am smart enough to know what Billy is up to!

Peace among men (women too)
parwrench

parwrench (parwrench) wrote :

I failed to mention my other findings on the atheros wireless.
first..it was detected and installed ..not sure it was properly..but madwifi was there.
the thing that wasnt detected was the dritek keyboard..with some extra buttons..one of which was to turn on/off the wireless. there was no other way to turn it on (I even tried in hopes that the toshkey util would do something..but no good). in my research i found a post that called for removing the card and covering one of the contacts but it was for mini pci and i have mini pci express, so that didnt work.
the new drivers allowed me to start the connection at boot and it worked ok.
also failed to mention specs.
acer aspire 5520 AMD turion 64 Atheros ar5007 Ubuntu hardy 32bit.

Steve Langasek (vorlon) on 2008-05-22
Changed in linux-restricted-modules-2.6.24:
milestone: ubuntu-8.04.1 → none
Britt (brittrossiter) wrote :

Another voice in the chorus. My Atheros AR5007 is in a HP Pavilion laptop dv6736nr, AMD Turion 64. Same problems as noted above.

Lionel Dricot (ploum) wrote :

Same bug on a fujitsu siemens here. Any chance to see it in Hardy proposed ?

Jim Lewellyn (styyle14) wrote :

For all who have this wireless card, there is a new Hardware Access Layer in development that has AR5007 support. It has been tested and proven successful on numerous 64-bit systems. Go to http://madwifi.org/ticket/1679 and read the comments at the bottom which give install instructions and links to download.

ENJOY!!!!

Steve Langasek (vorlon) on 2008-06-30
Changed in linux-restricted-modules-2.6.24:
milestone: ubuntu-8.04.1 → ubuntu-8.04.2
Changed in madwifi:
status: Unknown → Confirmed
Amit Kucheria (amitk) on 2008-10-05
Changed in linux-restricted-modules-2.6.24:
status: Confirmed → Fix Released
assignee: amitk → nobody
Daniel Miles (themono) on 2008-10-05
Changed in linux-restricted-modules-2.6.24:
status: Fix Released → In Progress
Krinn (kr86420) on 2008-10-07
Changed in linux-backports-modules-2.6.24:
status: New → Fix Committed
Martin Pitt (pitti) on 2008-10-14
Changed in linux-backports-modules-2.6.24:
status: Fix Committed → Fix Released
status: New → Invalid
Amit Kucheria (amitk) on 2008-10-24
Changed in linux-restricted-modules-2.6.24:
status: In Progress → Won't Fix
assignee: amitk → timg-tpi
85 comments hidden view all 165 comments
Roy Jamison (xteejx) wrote :

I believe this MIGHT be part of the problem that I am having with my Compaq Presario CQ50-110EM bug #287244 but not sure if this would lock up the kernel during live CD / install boot.

Roy Jamison (xteejx) wrote :

Disregard the above message it is incorrect it's a PCI type problem.

The AR5007 is a problem for me though.

Laptop: Compaq Presario CQ50-110EM

Roy Jamison (xteejx) wrote :

I can confirm the above works.

Find an ethernet connection and using synaptic install linux-backports-modules-2.6.24-21-generic and reboot. Ensure HAL and support for 5xxx series are enabled in Hardware Drivers.

Working for me now!

The best solution at the moment seems to be installing Adam McDaniel's
kernel (linux-image-2.6.27-7-eeepc). This works perfectly on an eee PC
900.

You can download it from:

http://www.array.org/ubuntu/index.html

If you follow his instructions it is simple to set up.

2008/11/2 Teej <email address hidden>:
> I can confirm the above works.
>
> Find an ethernet connection and using synaptic install linux-backports-
> modules-2.6.24-21-generic and reboot. Ensure HAL and support for 5xxx
> series are enabled in Hardware Drivers.
>
> Working for me now!
>
> --
> Atheros wireless (AR5007) not working on various laptops, including the ASUS Eee PC
> https://bugs.launchpad.net/bugs/182489
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Roderic Jones

Trout Cottage
Llanvihangel Crucorney
Abergavenny
Monmouthshire
NP7 7NB

Telephone 01873 890050

On Sun, Nov 02, 2008 at 09:55:34PM -0000, Roderic Jones wrote:
> The best solution at the moment seems to be installing Adam McDaniel's
> kernel (linux-image-2.6.27-7-eeepc). This works perfectly on an eee PC
> 900.
>
> You can download it from:
>
> http://www.array.org/ubuntu/index.html
>
> If you follow his instructions it is simple to set up.

Installing the linux-modules-backports-intrepid package has been
reliable for me. I used these tips:

http://ubuntu-tutorials.com/2008/11/02/wireless-networking-on-eeepc-701-ubuntu-810-intrepid/

Many thanks - this works (EeePC 900). There were two slight problems -
you have to remove the quote marks and re-type them if you cut and
paste and the WiFi was turned off in the bios during this process and
had to be turned on again. It now works fine.

2008/11/3 Christer Edwards <email address hidden>:
> On Sun, Nov 02, 2008 at 09:55:34PM -0000, Roderic Jones wrote:
>> The best solution at the moment seems to be installing Adam McDaniel's
>> kernel (linux-image-2.6.27-7-eeepc). This works perfectly on an eee PC
>> 900.
>>
>> You can download it from:
>>
>> http://www.array.org/ubuntu/index.html
>>
>> If you follow his instructions it is simple to set up.
>
> Installing the linux-modules-backports-intrepid package has been
> reliable for me. I used these tips:
>
> http://ubuntu-tutorials.com/2008/11/02/wireless-networking-on-
> eeepc-701-ubuntu-810-intrepid/
>
> --
> Atheros wireless (AR5007) not working on various laptops, including the ASUS Eee PC
> https://bugs.launchpad.net/bugs/182489
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Roderic Jones

Trout Cottage
Llanvihangel Crucorney
Abergavenny
Monmouthshire
NP7 7NB

Telephone 01873 890050

I have the new emachines D620 (very Linux compatible!) with:
05:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

Running Linux Mint (Elyssa 5-r1 fully updated w/Mint Update) I got the wireless card running very well with ath5k by upgrading the Kernel to vmlinuz-2.6.24-21-generic and adding the backports (also restricted-modules and ubuntu-modules for good measure).

Then all I had to do was disable the two madwifi modules in "restricted drivers" (Administration/Hardware Drivers), reboot, then and enable the new Atheros 5xxx module after (may have been enabled by default).

I did this twice because I hosed the installation while screwing around with Gentoo, so it is repeatable.

No joy at all with Intrepid. Also no joy with Gentoo in the latest unstable kernel 2.6.27-gentoo-r2 and ath5k (won't associate). (I will get this working - in time!)

I did get the wifi working using ath5k easily with Sidux (now fully dist-upgraded) but performance is terrible.

Update on above:

Reinstalled Xubuntu Intrepid on the emachine D620. With a wired connection I added the backports and after a reboot all I had to do was setup my wireless connection with the Network Manager. Speed is approximately the same as with the wired port.

dmesg identifies the chip as follows: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)

As a side note, neither Mint nor Sidux could successfully configure the wireless NIC with ndiswrapper and the driver that came with the computer. (no wireless extensions after setup).

Changed in madwifi:
status: Confirmed → Won't Fix
giacomo (giacomodorigo) wrote :

I have an ASUS eeePC 1000h, with windows everything was working fine but with Ubuntu the wireless doesn-t work.

I have tried the backports packages but they didn't work neither on 8.04.1 nor on 8.10.

I have tried the fork Ubuntu-eee and the wireless works.

I wonder if there is a package for the Ubuntu mainstream distro which just wraps the Ubuntu-eee fix for this bug with Atheron

Giacomo, I suppose your eee pc doesn't contain an Atheros wifi card, like mine. It can contain an other wifi card. You can verify that with the "lspci" command. If that doesn't give you something named Atheros, you don't have an Atheros card. My eee contains a RaLink card, which needs the rt2860sta driver. That driver is not included in Ubuntu yet, even in backports, but it is included in Ubuntu-eee. See https://bugs.launchpad.net/linux/+bug/210725 for more info on the RaLink driver.

giacomo (giacomodorigo) wrote :

Thank you so much Gabor!!!
I am a Linux newbie and I didn't know lspci command, so I was basing myself on this page
https://help.ubuntu.com/community/EeePC/Fixes
that actually was misguiding me!
You were right and it reports a Ralink card!

Thanks again!

sebass (js-bruzzone) wrote :

HI to all!
I had been working around this issue since October 2007, including several distributions and I still, I found the same "solutions".
I have an aspire 7520, and I spent a LOT of time trying with madwifi, ndiswrapper, acer_wmi, you name it, and after 6 months, I got my atheros AR 5007 working on hardy. (I followed all the procedures, installing ndiswrapper, blacklisting, installing acer_wmi, dmesg, ..etc). bad, very bad
When Ibex came, I tried it, and I had more problems (out of the box) than on hardy, but more important, that still, no wifi.
This time, ndiswrapper doesn't work, and I won''t try using also the acer_wmi stuff.
So, I will like to know the real status of this issue, at least what options do I have at the moment, if I try again the amd64 dist or the 32bit.
If madwifi will work on 64bits or keep trying on ndiswrapper.
This is so frustrating that I had been using Vista since October (Ibex release time).
Thanks in advance.
Best Regards!!!
Sebass

HI
    I have been haunted by this problem on my Toshiba L200 as well, no
matter in ubuntu 8.04 nor 8.10. I am looking forward to have an effective
way to solve this problem, since the bug has become a legacy of ubuntu and
it would be unwise to make it into a legend for our honorable community.

--------------------------------------------------
From: "sebass" <email address hidden>
Sent: Monday, December 22, 2008 7:45 PM
To: <email address hidden>
Subject: [Bug 182489] Re: Atheros wireless (AR5007) not working on
variouslaptops, including the ASUS Eee PC

> HI to all!
> I had been working around this issue since October 2007, including several
> distributions and I still, I found the same "solutions".
> I have an aspire 7520, and I spent a LOT of time trying with madwifi,
> ndiswrapper, acer_wmi, you name it, and after 6 months, I got my atheros
> AR 5007 working on hardy. (I followed all the procedures, installing
> ndiswrapper, blacklisting, installing acer_wmi, dmesg, ..etc). bad, very
> bad
> When Ibex came, I tried it, and I had more problems (out of the box) than
> on hardy, but more important, that still, no wifi.
> This time, ndiswrapper doesn't work, and I won''t try using also the
> acer_wmi stuff.
> So, I will like to know the real status of this issue, at least what
> options do I have at the moment, if I try again the amd64 dist or the
> 32bit.
> If madwifi will work on 64bits or keep trying on ndiswrapper.
> This is so frustrating that I had been using Vista since October (Ibex
> release time).
> Thanks in advance.
> Best Regards!!!
> Sebass
>
> --
> Atheros wireless (AR5007) not working on various laptops, including the
> ASUS Eee PC
> https://bugs.launchpad.net/bugs/182489
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in MadWifi - Atheros Drivers: Won't Fix
> Status in “linux-backports-modules-2.6.24” source package in Ubuntu:
> Invalid
> Status in “linux-restricted-modules-2.6.24” source package in Ubuntu: In
> Progress
> Status in linux-backports-modules-2.6.24 in Ubuntu Hardy: Fix Released
> Status in linux-restricted-modules-2.6.24 in Ubuntu Hardy: Confirmed
> Status in linux-backports-modules-2.6.24 in Ubuntu Intrepid: Invalid
> Status in linux-restricted-modules-2.6.24 in Ubuntu Intrepid: Won't Fix
> Status in “linux-backports-modules-2.6.24” source package in Baltix: New
>
> Bug description:
> Binary package hint: linux-restricted-modules
>
> The Eee PC has non-working wireless out of the box. A patch is available
> from the madwifi website:
>
> http://madwifi.org/ticket/1679
>
> I'd like to have working wireless in hardy, without having to
> patch/compile manually :)

frank, sebass, have you installed linux-backport-modules?

Hello Dimitrios, yes I did, that was one of the first things that I have
tried.(actually after a fresh install of ibex)
After that ndiswrapper and acer_wmi, later on madwifi but It didn't had
64bit support.
cheers

2008/12/22 Dimitrios Symeonidis <email address hidden>

> frank, sebass, have you installed linux-backport-modules?
>
> --
> Atheros wireless (AR5007) not working on various laptops, including the
> ASUS Eee PC
> https://bugs.launchpad.net/bugs/182489
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in MadWifi - Atheros Drivers: Won't Fix
> Status in "linux-backports-modules-2.6.24" source package in Ubuntu:
> Invalid
> Status in "linux-restricted-modules-2.6.24" source package in Ubuntu: In
> Progress
> Status in linux-backports-modules-2.6.24 in Ubuntu Hardy: Fix Released
> Status in linux-restricted-modules-2.6.24 in Ubuntu Hardy: Confirmed
> Status in linux-backports-modules-2.6.24 in Ubuntu Intrepid: Invalid
> Status in linux-restricted-modules-2.6.24 in Ubuntu Intrepid: Won't Fix
> Status in "linux-backports-modules-2.6.24" source package in Baltix: New
>
> Bug description:
> Binary package hint: linux-restricted-modules
>
> The Eee PC has non-working wireless out of the box. A patch is available
> from the madwifi website:
>
> http://madwifi.org/ticket/1679
>
> I'd like to have working wireless in hardy, without having to patch/compile
> manually :)
>

Thanks first, however, I did it as well, unfortunately it does not work.

--------------------------------------------------
From: "sebass" <email address hidden>
Sent: Monday, December 22, 2008 9:40 PM
To: <email address hidden>
Subject: Re: [Bug 182489] Re: Atheros wireless (AR5007) not working on
variouslaptops, including the ASUS Eee PC

> Hello Dimitrios, yes I did, that was one of the first things that I have
> tried.(actually after a fresh install of ibex)
> After that ndiswrapper and acer_wmi, later on madwifi but It didn't had
> 64bit support.
> cheers
>
>
> 2008/12/22 Dimitrios Symeonidis <email address hidden>
>
>> frank, sebass, have you installed linux-backport-modules?
>>
>> --
>> Atheros wireless (AR5007) not working on various laptops, including the
>> ASUS Eee PC
>> https://bugs.launchpad.net/bugs/182489
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in MadWifi - Atheros Drivers: Won't Fix
>> Status in "linux-backports-modules-2.6.24" source package in Ubuntu:
>> Invalid
>> Status in "linux-restricted-modules-2.6.24" source package in Ubuntu: In
>> Progress
>> Status in linux-backports-modules-2.6.24 in Ubuntu Hardy: Fix Released
>> Status in linux-restricted-modules-2.6.24 in Ubuntu Hardy: Confirmed
>> Status in linux-backports-modules-2.6.24 in Ubuntu Intrepid: Invalid
>> Status in linux-restricted-modules-2.6.24 in Ubuntu Intrepid: Won't Fix
>> Status in "linux-backports-modules-2.6.24" source package in Baltix: New
>>
>> Bug description:
>> Binary package hint: linux-restricted-modules
>>
>> The Eee PC has non-working wireless out of the box. A patch is available
>> from the madwifi website:
>>
>> http://madwifi.org/ticket/1679
>>
>> I'd like to have working wireless in hardy, without having to
>> patch/compile
>> manually :)
>>
>
> --
> Atheros wireless (AR5007) not working on various laptops, including the
> ASUS Eee PC
> https://bugs.launchpad.net/bugs/182489
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in MadWifi - Atheros Drivers: Won't Fix
> Status in “linux-backports-modules-2.6.24” source package in Ubuntu:
> Invalid
> Status in “linux-restricted-modules-2.6.24” source package in Ubuntu: In
> Progress
> Status in linux-backports-modules-2.6.24 in Ubuntu Hardy: Fix Released
> Status in linux-restricted-modules-2.6.24 in Ubuntu Hardy: Confirmed
> Status in linux-backports-modules-2.6.24 in Ubuntu Intrepid: Invalid
> Status in linux-restricted-modules-2.6.24 in Ubuntu Intrepid: Won't Fix
> Status in “linux-backports-modules-2.6.24” source package in Baltix: New
>
> Bug description:
> Binary package hint: linux-restricted-modules
>
> The Eee PC has non-working wireless out of the box. A patch is available
> from the madwifi website:
>
> http://madwifi.org/ticket/1679
>
> I'd like to have working wireless in hardy, without having to
> patch/compile manually :)

AGAIN! [for sebass benefit]. All works fine for me on HP dv6809 w/Atheros, using Madberry procedure only.

I've upgraded each hardy kernel, since worked out in August 2008, using that procedure. [intrepid live cd fails 267198 ].
But [again] I do not use backport modules, NDISWRAPPER, blacklists or any of that. See 10/21/08 for reinstall info.
Hope this helps. Merry Christmas.

Tim Gardner (timg-tpi) wrote :

If the Hardy madwifi driver in linux-restricted-modules doesn't work for you, then try the DKMS madwifi package in the PPA http://ppa.launchpad.net/timg-tpi/ubuntu. Beyond that, you'll have upgrade to Intrepid for better Atheros 5K support.

Changed in linux-restricted-modules-2.6.24:
assignee: timg-tpi → nobody
status: In Progress → Won't Fix

Hi, I will try that, the only thing is that I installed Intrepid since it
has a better 3g usb modeminterface, with Hardy I couldn't connect to
internet with that kind of modem.
(there is also a bug there with the dns server addresses, that doesn't allow
you to
surf the web, each time it uses 11.12.13.14 instead of the one you choose,
so I can't
connect either, wireless at work only (via atheros with hardy))
Thank you and happy hollidays!!
seba

2008/12/22 Bob Gotthardt <email address hidden>

> AGAIN! [for sebass benefit]. All works fine for me on HP dv6809
> w/Atheros, using Madberry procedure only.
>
> I've upgraded each hardy kernel, since worked out in August 2008, using
> that procedure. [intrepid live cd fails 267198 ].
> But [again] I do not use backport modules, NDISWRAPPER, blacklists or any
> of that. See 10/21/08 for reinstall info.
> Hope this helps. Merry Christmas.
>
> --
> Atheros wireless (AR5007) not working on various laptops, including the
> ASUS Eee PC
> https://bugs.launchpad.net/bugs/182489
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in MadWifi - Atheros Drivers: Won't Fix
> Status in "linux-backports-modules-2.6.24" source package in Ubuntu:
> Invalid
> Status in "linux-restricted-modules-2.6.24" source package in Ubuntu: In
> Progress
> Status in linux-backports-modules-2.6.24 in Ubuntu Hardy: Fix Released
> Status in linux-restricted-modules-2.6.24 in Ubuntu Hardy: Confirmed
> Status in linux-backports-modules-2.6.24 in Ubuntu Intrepid: Invalid
> Status in linux-restricted-modules-2.6.24 in Ubuntu Intrepid: Won't Fix
> Status in "linux-backports-modules-2.6.24" source package in Baltix: New
>
> Bug description:
> Binary package hint: linux-restricted-modules
>
> The Eee PC has non-working wireless out of the box. A patch is available
> from the madwifi website:
>
> http://madwifi.org/ticket/1679
>
> I'd like to have working wireless in hardy, without having to patch/compile
> manually :)
>

Steve Langasek (vorlon) wrote :

Tim,

should I understand from your latest comment that there are no plans to try to backport a fix here to lrm-2.6.24, and we should mark this 'wontfix' for hardy?

Steve Langasek (vorlon) on 2009-01-22
Changed in linux-restricted-modules-2.6.24:
milestone: ubuntu-8.04.2 → none
status: Confirmed → Won't Fix
Tim Gardner (timg-tpi) wrote :

People can try a DKMS package that I developed for Hardy that solves the problem for some.

https://edge.launchpad.net/%7Etimg-tpi/+archive/ppa/+files/madwifi-kernel-source_0.3862-1_all.deb

Download full text (4.2 KiB)

Alleluya !!!!!!!!!!!!
Alleluya Brothers and Sisters!
Yes yes yes yes yes!!!
Go to Synaptics, install the following:

linux-backports-modules-intrepid-generic

and surf the web!
also, full 3g usb-modem support!

For the very first time in more than one year, I'm enjoying ubuntu
graphics, sound, wifi, 3g, everything!
Thanks to all of you for your time and dedicated support!!!
About the upgrades, I don't know wich one is it, I will carefully
look them before installung, for sure, no new kernel for me.
Cheers

*** This bug is a duplicate of bug 182489 ***
   https://bugs.launchpad.net/bugs/182489

I think ath5k is blacklisted in Intrepid so as not to interfere with the
venerable madwifi which does not support atheros 5007 with the hal
ubuntu shipped.

The better work around for atheros 5007 based wireless cards in intrepid
is to install the linux-backports-modules-intrepid-generic module

The intrepid release notes [ located here
https://wiki.ubuntu.com/IntrepidReleaseNotes ] have the workaround which
I have copy pasted for your benefit.

"Atheros ath5k wireless driver not enabled by default

The version of the ath5k driver for Atheros wireless devices included in
Linux 2.6.27 interferes with the use of the madwifi driver for some
wireless devices and as a result has been disabled by default. Many
Atheros chipsets will work correctly with the madwifi driver, but some
newer chipsets may not, and the madwifi driver may not work with WPA
authentication. If you have an Atheros device that does not work with
madwifi, you will want to install the linux-backports-modules-intrepid-
generic package, which includes an updated version of the ath5k driver.
While not installed by default, this linux-backports-modules-intrepid-
generic package is included on the Ubuntu 8.10 CD and DVD images for
ease of installation."

** This bug has been marked a duplicate of bug 182489
  Atheros wireless (AR5007) not working on various laptops, including the
ASUS Eee PC

--
atheros 5007eg Intrepid update
https://bugs.launchpad.net/bugs/307933
You received this bug notification because you are a direct subscriber
of the bug (via bug 182489).

Status in "linux-restricted-modules-2.6.24" source package in Ubuntu: New

Bug description:
I tried this a few times and it happed each time. I install Intrepid 8.10. I
can get the Atheros 5007eg to work just by deactivating the restricted
drivers. It works fine until I download and install the hundred and some
Ubuntu updates. One or more of the updates kills the wireless lan. I can't
get it to work until I wipe the drive and reinstall Ubuntu 8.10 again. It
will work as long as I don't update. Once I do, the wlan stops working
again. I tried to figure out which update is the culprit, but I got tired of
reinstalling Ubuntu and went back to Vi$ta. Do you have any idea which
update is the one?

2009/1/22 Tim Gardner <email address hidden>

> People can try a DKMS package that I developed for Hardy that solves the
> problem for some.
>
> https://edge.launchpad.net/%7Etimg-tpi/+archive/ppa/+files/madwifi-
> kernel-source_0.3862-1_all.deb<https://edge.launchpad.net/%7Etimg-tpi/+archive/ppa/+files/madwifi-kernel-source_0.3862-1_a...

Read more...

Download full text (5.8 KiB)

I didn't find it at the Synaptics web site. All I get is touchpad drivers.

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
sebass
Sent: Thursday, January 22, 2009 11:13 PM
To: <email address hidden>
Subject: Re: [Bug 182489] Re: Atheros wireless (AR5007) not working on
variouslaptops, including the ASUS Eee PC

Alleluya !!!!!!!!!!!!
Alleluya Brothers and Sisters!
Yes yes yes yes yes!!!
Go to Synaptics, install the following:

linux-backports-modules-intrepid-generic

and surf the web!
also, full 3g usb-modem support!

For the very first time in more than one year, I'm enjoying ubuntu
graphics, sound, wifi, 3g, everything!
Thanks to all of you for your time and dedicated support!!!
About the upgrades, I don't know wich one is it, I will carefully
look them before installung, for sure, no new kernel for me.
Cheers

*** This bug is a duplicate of bug 182489 ***
   https://bugs.launchpad.net/bugs/182489

I think ath5k is blacklisted in Intrepid so as not to interfere with the
venerable madwifi which does not support atheros 5007 with the hal
ubuntu shipped.

The better work around for atheros 5007 based wireless cards in intrepid
is to install the linux-backports-modules-intrepid-generic module

The intrepid release notes [ located here
https://wiki.ubuntu.com/IntrepidReleaseNotes ] have the workaround which
I have copy pasted for your benefit.

"Atheros ath5k wireless driver not enabled by default

The version of the ath5k driver for Atheros wireless devices included in
Linux 2.6.27 interferes with the use of the madwifi driver for some
wireless devices and as a result has been disabled by default. Many
Atheros chipsets will work correctly with the madwifi driver, but some
newer chipsets may not, and the madwifi driver may not work with WPA
authentication. If you have an Atheros device that does not work with
madwifi, you will want to install the linux-backports-modules-intrepid-
generic package, which includes an updated version of the ath5k driver.
While not installed by default, this linux-backports-modules-intrepid-
generic package is included on the Ubuntu 8.10 CD and DVD images for
ease of installation."

** This bug has been marked a duplicate of bug 182489
  Atheros wireless (AR5007) not working on various laptops, including the
ASUS Eee PC

--
atheros 5007eg Intrepid update
https://bugs.launchpad.net/bugs/307933
You received this bug notification because you are a direct subscriber
of the bug (via bug 182489).

Status in "linux-restricted-modules-2.6.24" source package in Ubuntu:
New

Bug description:
I tried this a few times and it happed each time. I install Intrepid 8.10. I
can get the Atheros 5007eg to work just by deactivating the restricted
drivers. It works fine until I download and install the hundred and some
Ubuntu updates. One or more of the updates kills the wireless lan. I can't
get it to work until I wipe the drive and reinstall Ubuntu 8.10 again. It
will work as long as I don't update. Once I do, the wlan stops working
again. I tried to figure out which update is the culprit, but I got tired of
reinstalling Ubuntu and went back to Vi$ta. Do you have any idea which
upda...

Read more...

Download full text (6.5 KiB)

Um, you want Synaptic (the program in System-Admin, not Synaptics, the touchpad driver :)
--
Andrew Paulin
<email address hidden>
(502) 644-8892
BlackBerry:24429309

-----Original Message-----
From: k browne <email address hidden>

Date: Fri, 23 Jan 2009 14:12:35
To: <email address hidden>
Subject: RE: [Bug 182489] Re: Atheros wireless (AR5007) not working on
 variouslaptops, including the ASUS Eee PC

I didn't find it at the Synaptics web site. All I get is touchpad
drivers.

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
sebass
Sent: Thursday, January 22, 2009 11:13 PM
To: <email address hidden>
Subject: Re: [Bug 182489] Re: Atheros wireless (AR5007) not working on
variouslaptops, including the ASUS Eee PC

Alleluya !!!!!!!!!!!!
Alleluya Brothers and Sisters!
Yes yes yes yes yes!!!
Go to Synaptics, install the following:

linux-backports-modules-intrepid-generic

and surf the web!
also, full 3g usb-modem support!

For the very first time in more than one year, I'm enjoying ubuntu
graphics, sound, wifi, 3g, everything!
Thanks to all of you for your time and dedicated support!!!
About the upgrades, I don't know wich one is it, I will carefully
look them before installung, for sure, no new kernel for me.
Cheers

*** This bug is a duplicate of bug 182489 ***
   https://bugs.launchpad.net/bugs/182489

I think ath5k is blacklisted in Intrepid so as not to interfere with the
venerable madwifi which does not support atheros 5007 with the hal
ubuntu shipped.

The better work around for atheros 5007 based wireless cards in intrepid
is to install the linux-backports-modules-intrepid-generic module

The intrepid release notes [ located here
https://wiki.ubuntu.com/IntrepidReleaseNotes ] have the workaround which
I have copy pasted for your benefit.

"Atheros ath5k wireless driver not enabled by default

The version of the ath5k driver for Atheros wireless devices included in
Linux 2.6.27 interferes with the use of the madwifi driver for some
wireless devices and as a result has been disabled by default. Many
Atheros chipsets will work correctly with the madwifi driver, but some
newer chipsets may not, and the madwifi driver may not work with WPA
authentication. If you have an Atheros device that does not work with
madwifi, you will want to install the linux-backports-modules-intrepid-
generic package, which includes an updated version of the ath5k driver.
While not installed by default, this linux-backports-modules-intrepid-
generic package is included on the Ubuntu 8.10 CD and DVD images for
ease of installation."

** This bug has been marked a duplicate of bug 182489
  Atheros wireless (AR5007) not working on various laptops, including the
ASUS Eee PC

--
atheros 5007eg Intrepid update
https://bugs.launchpad.net/bugs/307933
You received this bug notification because you are a direct subscriber
of the bug (via bug 182489).

Status in "linux-restricted-modules-2.6.24" source package in Ubuntu:
New

Bug description:
I tried this a few times and it happed each time. I install Intrepid 8.10. I
can get the Ath...

Read more...

You might have to enable the proposed updates in your sources list. Go to System/Administration/software sources , then the tab called "updates" and check the proposed updates.

vnieto (vnieto) wrote :

Work fine in jaunty fresh install.
Use the ath5k driver

Thanks for the info, I will try it.
Is it coming with ext4 from default?
I hope that I comes also with the 3g usb modem support.
best regards
seba

2009/2/17 vnieto <email address hidden>

> Work fine in jaunty fresh install.
> Use the ath5k driver
>
> --
> Atheros wireless (AR5007) not working on various laptops, including the
> ASUS Eee PC
> https://bugs.launchpad.net/bugs/182489
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in MadWifi - Atheros Drivers: Won't Fix
> Status in "linux-backports-modules-2.6.24" source package in Ubuntu:
> Invalid
> Status in "linux-restricted-modules-2.6.24" source package in Ubuntu: Won't
> Fix
> Status in linux-backports-modules-2.6.24 in Ubuntu Hardy: Fix Released
> Status in linux-restricted-modules-2.6.24 in Ubuntu Hardy: Won't Fix
> Status in linux-backports-modules-2.6.24 in Ubuntu Intrepid: Invalid
> Status in linux-restricted-modules-2.6.24 in Ubuntu Intrepid: Won't Fix
> Status in "linux-backports-modules-2.6.24" source package in Baltix: New
>
> Bug description:
> Binary package hint: linux-restricted-modules
>
> The Eee PC has non-working wireless out of the box. A patch is available
> from the madwifi website:
>
> http://madwifi.org/ticket/1679
>
> I'd like to have working wireless in hardy, without having to patch/compile
> manually :)
>

jap1968 (jap1968) wrote :

> Work fine in jaunty fresh install.

Are you sure?

On what model?

I tested on EeePC 701 Jaunty alfa 4 (may be it was alfa 3???) and I was not able to make the wireless working.
I did not install it, I just run it from a live-usb.

geert.vl2 (geert-vl2) wrote :

Hello,
I am just a not nowing person.
But when i installed EEEBUNTU Standerd everything was just working perfect automatical.
So that could giff the answer to all problems.
And to go even on, I just put Kubuntu 8.04.2 on my Netbook and it looks very good it boots good and everything is working as far as i can see.
So Boys and Girls maby there is the solution to tge problems.
Geatings Geert vl2

1 comments hidden view all 165 comments
kseise (kevin-seise) wrote :

Not working on my Jaunty system on a Thinkpad A21M.

kseise@old-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:02.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:02.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:03.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 09)
00:03.1 Serial controller: Xircom Mini-PCI V.90 56k Modem
00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24/30 [CrystalClear SoundFusion Audio Accelerator] (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M AGP 2x (rev 64)
02:00.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)
kseise@old-laptop:~$

vnieto (vnieto) wrote :

I am Shure.
I using it in this moment.

Also work from live cd alfa 4
lspci:
00:00.0 RAM memory: nVidia Corporation MCP67 Memory Controller (rev a2)
00:01.0 ISA bridge: nVidia Corporation MCP67 ISA Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP67 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP67 Memory Controller (rev a2)
00:01.3 Co-processor: nVidia Corporation MCP67 Co-processor (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
00:04.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
00:04.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP67 IDE Controller (rev a1)
00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP67 PCI Bridge (rev a2)
00:09.0 IDE interface: nVidia Corporation MCP67 AHCI Controller (rev a2)
00:0a.0 Ethernet controller: nVidia Corporation MCP67 Ethernet (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
00:0d.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
00:12.0 VGA compatible controller: nVidia Corporation GeForce 7150M (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:05.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
02:05.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
02:05.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
02:05.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
02:05.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)
03:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

vnieto, your atheros is a different one, no? this bug is about ar5007, and you have ar242x...

vnieto (vnieto) wrote :

I am not sure, but i think is the same.

Atheros card works fine [not sure about Intrepid]!

Upgraded my HP DV6809 to Intrepid and followed new MadBerry procedure to install [thanks again].
[ http://madberry.org/2008/11/how-to-get-atheros-ar242x-to-work-on-810-intrepid-ibex/ ]

Hi Ubuntu Team your reading this mail all the way from South East Asia Phil..I decided to post this questions here because there is no Linux/Ubuntu community here in my location(Phil. Mindanao).
I have Installed Ubuntu hardy Heron on my compaq c700 presario Laptop as a virtual machine Operating system which enables me to run windows vista starter and Ubuntu hardy heron at the same time,It works but Im having alot of issues with it:
1.Wireless connection is not working!?I have the option to add a wireless networks but Im not finding any network at all.
2.Every Time I launch the Ubuntu hardy as a virtual machine Im getting a High I/O in my harddrive!

And would there be any website, community forums and computer group in the Phil.
 in Mindanao region that I can link with? It seems that Im the only one using Ubuntu in my neigborhood!? and if this system would crash I need perhaps some guidance with it any links or online manual that I can get from the net?
Im new with the system.

The specs of the laptops are

1.5 ram
80 gb harddrive
celeron r processor
wifi adapter atheros(which I think may not support ubuntu not unless theres a driver for it?)

jap1968 (jap1968) wrote :

...I have Installed Ubuntu hardy Heron on my compaq c700 presario Laptop as a virtual machine ...

If you installed it as a virtual machine, the physical hardware has nothing to do with the virtual hardware, as seen from the guest operating system.

I think that your problem is not related at all with the topic of this thread.

What hardware does Linux quest VM think it is using?

For those unaware [and have no other reason for 'linux restricted modules'], MadBerry's procedures [see 2/19] work on all ubuntu kernels [for me] since 2008-08-25. Check this log for any details.

fx_3600 (fx-3600-ozo) on 2010-02-02
Changed in linux-backports-modules-2.6.24 (Ubuntu Hardy):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
mercutio22 (macabro22) wrote :

Guys, the wirelless device is still problematic in karmic. Dmesg shows:

[ 2483.325516] ath5k phy0: unsupported jumbo
[ 2616.601183] ath5k phy0: unsupported jumbo
[ 2834.055473] ath5k phy0: unsupported jumbo
[ 2841.692099] ath5k phy0: unsupported jumbo
[ 2896.072732] ath5k phy0: unsupported jumbo
[ 3032.987866] ath5k phy0: unsupported jumbo
[ 3195.345404] ath5k phy0: unsupported jumbo
[ 3225.722805] ath5k phy0: unsupported jumbo
[ 3310.922771] ath5k phy0: unsupported jumbo
[ 3317.450791] ath5k phy0: unsupported jumbo
[ 3560.978110] ath5k phy0: unsupported jumbo
[ 3573.727252] ath5k phy0: unsupported jumbo
[ 3616.676045] ath5k phy0: unsupported jumbo
[ 3813.206013] ath5k phy0: unsupported jumbo
[ 3844.361229] ath5k phy0: unsupported jumbo
[ 3982.939615] ath5k phy0: unsupported jumbo
[ 4081.575872] ath5k phy0: unsupported jumbo

Roy Jamison (xteejx) on 2010-12-27
Changed in linux-backports-modules-2.6.24 (Ubuntu Hardy):
status: Fix Released → Invalid
Roy Jamison (xteejx) wrote :

Please don't change the Status unless you know what you are doing.
Any update on this? The bug watch points to nothing now, maybe a website change or something, but I searched and couldn't find the reported upstream bug report.

Displaying first 40 and last 40 comments. View all 165 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.