[Upstream] soffice.bin crashed with SIGSEGV in X11SalGraphics::GetResolution()

Bug #916357 reported by Robert Jordens on 2012-01-14
374
This bug affects 44 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Critical
libreoffice (Ubuntu)
Medium
Björn Michaelsen

Bug Description

Crashes right at start up. This is a two-monitor configuration:

Screen 0: minimum 320 x 200, current 3200 x 1200, maximum 8192 x 8192
DisplayPort-0 connected 1920x1200+1280+0 (normal left inverted right x axis y axis) 519mm x 324mm
   1920x1200 60.0*+
   1600x1200 60.0
   1680x1050 60.0
   1280x1024 75.0 60.0
   1152x864 75.0
   1024x768 75.1 60.0
   800x600 75.0 60.3
   640x480 75.0 60.0
   720x400 70.1
DVI-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 359mm x 287mm
   1280x1024 60.0*+
   1024x768 75.1 60.0
   800x600 75.0 60.3
   640x480 75.0 60.0
   720x400 70.1

It does not crash if only one monitor is used.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: libreoffice-core 1:3.5.0~beta2-2ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-8.15-generic 3.2.0
Uname: Linux 3.2.0-8-generic x86_64
ApportVersion: 1.90-0ubuntu2
Architecture: amd64
Date: Fri Jan 13 19:55:47 2012
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdline: /usr/lib/libreoffice/program/soffice.bin --splash-pipe=6
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fd209039dca <_ZN14X11SalGraphics13GetResolutionERiS0_+10>: mov 0x238(%rax),%rdx
 PC (0x7fd209039dca) ok
 source "0x238(%rax)" (0x00000238) not located in a known VMA region (needed readable region)!
 destination "%rdx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: libreoffice
StacktraceTop:
 X11SalGraphics::GetResolution(int&, int&) () from /usr/lib/libreoffice/program/libvclplug_genlo.so
 ?? () from /usr/lib/libreoffice/program/libvcllo.so
 ?? () from /usr/lib/libreoffice/program/libvcllo.so
 ?? () from /usr/lib/libreoffice/program/libvcllo.so
 ?? () from /usr/lib/libreoffice/program/libvcllo.so
Title: soffice.bin crashed with SIGSEGV in X11SalGraphics::GetResolution()
UpgradeStatus: Upgraded to precise on 2012-01-12 (1 days ago)
UserGroups: adm admin cdrom dialout kvm libvirtd lpadmin plugdev sambashare video

Laptop X86
Ubuntu
Extra monitor

Trying to start from terminal:
Gdk-CRITICAL **: IA__gdk_display_get_screen: assertion `ScreenCount (GDK_DISPLAY_X11 (display)->xdisplay) > screen_num' failed

Build ID: 5317074-2fcbe65-1f92ab1-3bd0388-ce71330
Build ID: 93acae3-090bcba-45cf606

Is no problem with older builds from master, e.g Build ID: 4456143-f6a1fc5-e1a2fb3

so... when I start without the extra monitor, then connect the monitor, and try to open a document > same crash

So - this is a linux & gtk backend error. I can't reproduce - indeed, with my second monitor connected everything works beautifully, and I get remote projecting just nicely. My xrandr output is:

$ xrandr
Screen 0: minimum 320 x 200, current 2944 x 1200, maximum 8192 x 8192
LVDS1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1920x1200 60.0*+ 50.0
   1600x1200 60.0
   1400x1050 60.0
   1280x1024 60.0
   1280x960 60.0
   1024x768 60.0
   800x600 60.3 56.2
   640x480 59.9
VGA1 connected 1024x768+1920+432 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768 60.0*
   800x600 60.3 56.2
   848x480 60.0
   640x480 59.9 59.9

Can you attach yours ?

The extra monitor giving the problems is at my office.

At home I have two monitors that do not give the problem:

-I-
Screen 0: minimum 320 x 200, current 2646 x 1024, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
   1366x768 60.0*+
   1360x768 59.8 60.0
   1024x768 60.0
   800x600 60.3 56.2
   640x480 59.9
VGA1 connected 1280x1024+1366+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024 60.0*+ 75.0
   1280x960 75.0 70.0 60.0
   1152x864 75.0 70.0 60.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
TV1 unknown connection (normal left inverted right x axis y axis)
   848x480 30.0 +
   640x480 30.0 +
   1024x768 30.0
   800x600 30.0

-II-
Screen 0: minimum 320 x 200, current 2048 x 768, maximum 8192 x 8192
LVDS1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
   1366x768 60.0 +
   1360x768 59.8 60.0
   1024x768 60.0*
   800x600 60.3 56.2
   640x480 59.9
VGA1 connected 1024x768+1024+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768 60.0*
   800x600 60.3 56.2
   848x480 60.0
   640x480 59.9
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
TV1 unknown connection (normal left inverted right x axis y axis)
   848x480 30.0 +
   640x480 30.0 +
   1024x768 30.0
   800x600 30.0

Will post info on the other monitor asap, probably next Monday

So here the output with the divice that make's it impossible to run the mentioned versions:

Screen 0: minimum 320 x 200, current 2646 x 1024, maximum 8192 x 8192
LVDS1 connected 1366x768+1280+256 (normal left inverted right x axis y axis) 293mm x 165mm
   1366x768 60.0*+
   1360x768 59.8 60.0
   1024x768 60.0
   800x600 60.3 56.2
   640x480 59.9
VGA1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 340mm x 270mm
   1280x1024 75.0*+ 60.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
TV1 unknown connection (normal left inverted right x axis y axis)
   848x480 30.0 +
   640x480 30.0 +
   1024x768 30.0
   800x600 30.0

OOh - you have three displays ? and one rather nasty; can you send a screenshot of the gnome display configuration applet ? can you confirm that if you disable the TV output you don't get the bug ?

TV1 unknown connection (normal left inverted right x axis y axis)
   848x480 30.0 +
   640x480 30.0 +

Any chance you can run a build with symbols in it under gdb thus:

gdb ./soffice.bin
break g_logv
run

when it fails:

t a a bt

Thanks :-)

Well, I have TWO displays...

and the output is:
~$ xrandr
Screen 0: minimum 320 x 200, current 2646 x 1024, maximum 8192 x 8192
LVDS1 connected 1366x768+1280+256 (normal left inverted right x axis y axis) 293mm x 165mm
   1366x768 60.0*+
   1360x768 59.8 60.0
   1024x768 60.0
   800x600 60.3 56.2
   640x480 59.9
VGA1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 340mm x 270mm
   1280x1024 75.0*+ 60.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
TV1 unknown connection (normal left inverted right x axis y axis)
   848x480 30.0 +
   640x480 30.0 +
   1024x768 30.0
   800x600 30.0

Now I pull out the VGA cable:
~$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
   1366x768 60.0*+
   1360x768 59.8 60.0
   1024x768 60.0
   800x600 60.3 56.2
   640x480 59.9
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
TV1 disconnected (normal left inverted right x axis y axis)

:-)

And yes, the behavior is consistent: without the extra monitor, libreOffice Build ID: 93acae3-090bcba-45cf606 starts.

So a rather unusual situation here..

I have no build with symbols, but could give that a try if it may add for this situation

did run it with gdb.
pasted output here: http://pastebin.com/reqfRyEF
(think only for one day - but have it local too, for just in case that)

oops, forget previous comment please. I started the wrong office-installation ;-)

new output http://pastebin.com/0yruh0iN
(no idea if it makes much difference)
BTW: I did only a remake with symbols of vcl

symbols are still missing, best to use attachments anyway rather than temporary pastebins

Download full text (4.8 KiB)

full rebuild with symbols

Here Thread 1 (out of 6, I expect the others are not that useful)

Thread 1 (Thread 0xb3f7d6d0 (LWP 2482)):
#0 0xb1d9b8e6 in g_logv () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1 0xb1d9bf62 in g_log () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2 0xb1d9c18d in g_return_if_fail_warning () from
/lib/i386-linux-gnu/libglib-2.0.so.0
#3 0xb2083175 in gdk_display_get_screen () from /usr/lib/libgdk-x11-2.0.so.0
#4 0xb25154d3 in GtkSalDisplay::GetScreenSize (this=0x80ff2e0, nScreen=1)
    at /home/cono/src/git/libo_core/vcl/unx/gtk/window/gtkframe.cxx:4163
#5 0xb250ea2d in GtkSalFrame::calcDefaultSize (this=0x854ee20)
    at /home/cono/src/git/libo_core/vcl/unx/gtk/window/gtkframe.cxx:1322
#6 0xb250cb80 in GtkSalFrame::InitCommon (this=0x854ee20) at
/home/cono/src/git/libo_core/vcl/unx/gtk/window/gtkframe.cxx:679
#7 0xb250d634 in GtkSalFrame::Init (this=0x854ee20, pParent=0x0,
nStyle=2147483648)
    at /home/cono/src/git/libo_core/vcl/unx/gtk/window/gtkframe.cxx:940
#8 0xb250bb3e in GtkSalFrame::GtkSalFrame (this=0x854ee20, pParent=0x0,
nStyle=2147483648)
    at /home/cono/src/git/libo_core/vcl/unx/gtk/window/gtkframe.cxx:463
#9 0xb24f4188 in GtkInstance::CreateFrame (this=0x8088328, pParent=0x0,
nStyle=2147483648)
---Type <return> to continue, or q <return> to quit---
    at /home/cono/src/git/libo_core/vcl/unx/gtk/app/gtkinst.cxx:325
#10 0xb61cf1ba in Window::ImplInit (this=0x854ebb0, pParent=0x0,
nStyle=8589934592, pSystemParentData=0x0)
    at /home/cono/src/git/libo_core/vcl/source/window/window.cxx:851
#11 0xb612f5d1 in ImplBorderWindow::ImplInit (this=0x854ebb0, pParent=0x0,
nStyle=8589934592, nTypeStyle=8, pSystemParentData=0x0)
    at /home/cono/src/git/libo_core/vcl/source/window/brdwin.cxx:1910
#12 0xb612f755 in ImplBorderWindow::ImplBorderWindow (this=0x854ebb0,
pParent=0x0, pSystemParentData=0x0, nStyle=8589934592,
    nTypeStyle=8) at
/home/cono/src/git/libo_core/vcl/source/window/brdwin.cxx:1945
#13 0xb61f6e38 in WorkWindow::ImplInit (this=0xb3749724, pParent=0x0,
nStyle=8589934592, pSystemParentData=0x0)
    at /home/cono/src/git/libo_core/vcl/source/window/wrkwin.cxx:72
#14 0xb6150f06 in IntroWindow::IntroWindow (this=0xb3749724) at
/home/cono/src/git/libo_core/vcl/source/window/introwin.cxx:56
#15 0xb06c5ed0 in desktop::SplashScreen::SplashScreen (this=0xb3749708,
rSMgr=...)
    at /home/cono/src/git/libo_core/desktop/source/splash/splash.cxx:80
#16 0xb06c875c in desktop::SplashScreen::getInstance (rSMgr=...)
    at /home/cono/src/git/libo_core/desktop/source/splash/splash.cxx:559
#17 0xb78f538b in cppu::OSingleFactoryHelper::createInstanceEveryTime
(this=0xb06f2f2c, xContext=...)
    at /home/cono/src/git/libo_core/cppuhelper/source/factory.cxx:181
#18 0xb78f554d in cppu::OSingleFactoryHelper::createInstanceWithContext
(this=0xb06f2f2c, xContext=...)
    at /home/cono/src/git/libo_core/cppuhelper/source/factory.cxx:213
#19 0xb78f5ecd in cppu::OFactoryComponentHelper::createInstanceWithContext
(this=0xb06f2ef8, xContext=...)
    at /home/cono/src/git/libo_core/cppuhelper/source/factory.cxx:489
#20 0xb78f5598 in
cppu::OSingleFactoryHelper::createInstanceWithArgumentsAndContext
(this=0xb06f2f2c, ...

Read more...

Hi *,

Is the most recent info I gave useful?

Looking at the error message
   "... `ScreenCount (GDK_DISPLAY_X11 (display)->xdisplay) > screen_num' failed "
and indeed the ourput of xrandr for me, showing three devises ( :-) ) there seems to be a trace to follow.

And of course, something in the code has changed that it crashes me nwo and did not before...

Anything I can do to help?

Pushed what (I hope) is a fix; at least it shouldn't crash anymore:

commit 9bdfd1fa4dde2f4901900f7447b588c2640ff3f4
Author: Michael Meeks <email address hidden>
Date: Fri Dec 16 15:56:23 2011 +0000

    teach old-style method about the new form of screen numbering fdo#43458

    We number now with a flat set of indicees across Xinerama
    and more standard multi-screen setups.

I'll pick that back into 3.5.0 - should be in B2.

(In reply to comment #14)
> Pushed what (I hope) is a fix; at least it shouldn't crash anymore:

Thanks!
I had a local build from iirc November 30 with the same bug. So I could try to apply your patch and see if it solves the problem?

sounds fine; the bug has been there for a while :-)

Download full text (3.5 KiB)

(was able to bike past the office to test ..)

I paste all output that I've got, since that might give a pointer as to why it still gives an error.

- changed the code according to the patch
- did partial rebuild:

$ cd /vcl
/vcl$ make -sr
/home/cono/src/git/libo_core/vcl/StaticLibrary_vclmain.mk:49:
[ WARN ] !!!
[ WARN ] !!! vcl/source/salmain/salmain is linked in by Library/libvcllo.so StaticLibrary/libvclmain.a
[ WARN ] !!!
[ build CXX ] vcl/unx/gtk/window/gtkframe
[ build DEP ] LNK:Library/libvclplug_gtklo.so
/home/cono/src/git/libo_core/vcl/StaticLibrary_vclmain.mk:49:
[ WARN ] !!!
[ WARN ] !!! vcl/source/salmain/salmain is linked in by Library/libvcllo.so StaticLibrary/libvclmain.a
[ WARN ] !!!
[ build LNK ] Library/libvclplug_gtklo.so
[ build MOD ] vcl
[ build ALL ] top level modules: vcl
[ build ALL ] loaded modules: vcl

[ build CHK ] loaded modules: vcl

- did separate install
  $ $ solenv/bin/ooinstall <path>

- running first time without the extra monitor
./program/soffice
create vcl plugin instance with gtk version 2 24 4
warn:configmgr:4423:1:/home/cono/src/git/libo_core/configmgr/source/xcuparser.cxx:764: unknown property "HelpFile" in "file:///home/cono/.config/libreoffice/3/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luyt7gbc.tmp/SunPresentationMinimizer.xcu"
warn:configmgr:4423:1:/home/cono/src/git/libo_core/configmgr/source/xcuparser.cxx:764: unknown property "STR_HELP" in "file:///home/cono/.config/libreoffice/3/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luyt7gbc.tmp/SunPresentationMinimizer.xcu"

** (soffice:4423): WARNING **: Internal - un-mapped error

** (soffice:4423): WARNING **: Internal - un-mapped error

** (soffice:4423): WARNING **: Internal - un-mapped error

** (soffice:4423): WARNING **: Internal - un-mapped error

** (soffice:4423): WARNING **: Internal - un-mapped error

** (soffice:4423): WARNING **: Internal - un-mapped error
Exited with code '0'

  > so it runs fine

- running the second time with the trouble causing monitor:
$ ./program/soffice
create vcl plugin instance with gtk version 2 24 4
warn:configmgr:5705:1:/home/cono/src/git/libo_core/configmgr/source/xcuparser.cxx:764: unknown property "HelpFile" in "file:///home/cono/.config/libreoffice/3/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luyt7gbc.tmp/SunPresentationMinimizer.xcu"
warn:configmgr:5705:1:/home/cono/src/git/libo_core/configmgr/source/xcuparser.cxx:764: unknown property "STR_HELP" in "file:///home/cono/.config/libreoffice/3/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luyt7gbc.tmp/SunPresentationMinimizer.xcu"
Exited with code '139'
cono@cono-tm-new:~/LibreOffice/35master111130A$ ./program/soffice
create vcl plugin instance with gtk version 2 24 4
warn:configmgr:5726:1:/home/cono/src/git/libo_core/configmgr/source/xcuparser.cxx:764: unknown property "HelpFile" in "file:///home/cono/.config/libreoffice/3/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luy...

Read more...

which suggests an additional problem with no proven link to the first one.

Gosh - what fun :-) So - finding these 'exited with error 12345' type errors is a bit of a pain. You need to:

gdb ./soffice.bin
b _exit
b exit
r

and then when it exits, a 't a a bt' would be great.

Thanks for persisting Cor ! - much appreciated. Are you sure that the problem is specific to connecting the 2nd monitor ?

I'm also rather interested in your hardware: how did you get this odd TV output goodness ? :-)

(In reply to comment #18)
> which suggests an additional problem with no proven link to the first one.

might well be. I'm known for strange problems ;-)

(In reply to comment #19)
> Gosh - what fun :-) So - finding these 'exited with error 12345' type errors is
> a bit of a pain. You need to:

I realised later - but was running for a train ...
Will be at the office tomorrow and create better output

Created attachment 54594
gdb output

so attached the output with gdb running. Hope it is helpful.

Easy to fix the crasher you point to, -but- since I can't reproduce it - and it is only a symptom not the real bug - life is a bit tough ...
Can you give more information on your hardware ? what is this monitor you connect - that looks like a TV1 as well - what is your graphics card (lspci might tell you) etc.

Really frustrating; I simply can't reproduce this the most exotic combinations of xrandr settings simply don't do it for me. What I really need is ssh access to your machine & some interactive help debugging - is that going to be possible ?

Hi Michael,

Monitor: Iiyama AS4314UT - must be an old one

$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
01:00.0 Network controller: Intel Corporation WiFi Link 5100
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

ssh: lets talk on ICR, maybe tomorrow? mostly en route today.

The root cause is a mismatch between gtk+'s new idea of screen indicees, and gtk3's new munged Xinerama screen vs. xrandr monitor magic that I tried to flatten. And therein lies the problem.

Thanks Cor for debugging help !

It all comes down from non-default primary monitor setting:

xrandr --output VGA1 --primary

on my machine re-creates the problem; once

(gdb) p gdk_screen_get_primary_monitor(<default screen>)

returns 1 not 0 - the fun starts ... nice; should be reasonably possible to debug now.

Robert Jordens (jordens) wrote :

StacktraceTop:
 X11SalGraphics::GetResolution (this=0x13aba20, rDPIX=@0x13ab928, rDPIY=@0x13ab92c) at /build/buildd/libreoffice-3.5.0~beta2/vcl/unx/generic/gdi/salgdi.cxx:498
 Window::ImplInit (this=0x13010d0, pParent=0x0, nStyle=274877906944, pSystemParentData=<optimized out>) at /build/buildd/libreoffice-3.5.0~beta2/vcl/source/window/window.cxx:938
 ImplBorderWindow::ImplInit (this=0x13010d0, pParent=<optimized out>, nStyle=<optimized out>, nTypeStyle=<optimized out>, pSystemParentData=<optimized out>) at /build/buildd/libreoffice-3.5.0~beta2/vcl/source/window/brdwin.cxx:1910
 ImplBorderWindow::ImplBorderWindow (this=0x13010d0, pParent=0x0, pSystemParentData=0x0, nStyle=274877906944, nTypeStyle=8) at /build/buildd/libreoffice-3.5.0~beta2/vcl/source/window/brdwin.cxx:1945
 WorkWindow::ImplInit (this=0x1300920, pParent=0x0, nStyle=274877906944, pSystemParentData=0x0) at /build/buildd/libreoffice-3.5.0~beta2/vcl/source/window/wrkwin.cxx:72

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Robert Jordens (jordens) on 2012-01-14
visibility: private → public

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

Same problem here. If I disconnect my second monitor, LibreOffice works.

I pushed a fix for the crash in master, but that still creates a messed up multi-display / presenter view issue. I have another fix for that - really a one-liner to gtkframe.cxx:

- maGeometry.nY = aNewMonitor.x;
+ maGeometry.nY = aNewMonitor.y;

But I also have a big slew of API cleanups and consistency improvements to the display code, a very large mechanical change that should make this more robust in future, but would make diffing between 3.5 and master particularly horrific if we don't get it into both.

I'll push that as well on Monday if the tinderboxes look happy.

Changed in df-libreoffice:
importance: Unknown → Critical
status: Unknown → Confirmed

As per downstream bug: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/916357

Version -> LibO 3.5.0 Beta2
Platform -> All Linux (All)

fixed pushed to master and libreoffice-3-5 - will be in 3.5.0RC1.

Thanks all :-)

pulled from master yesterday and build - does start normally now- thanks :-)

summary: - soffice.bin crashed with SIGSEGV in X11SalGraphics::GetResolution()
+ [Upstream] soffice.bin crashed with SIGSEGV in
+ X11SalGraphics::GetResolution()
Changed in df-libreoffice:
status: Confirmed → Fix Released

When is it going to be released Libreoffice 3.5 RC1 in the Precie reports?

tags: added: metabug

Status -> Fix Committed as per comment #22 commit & Michael Meeks commit(s) on 1/15/2012:
http://permalink.gmane.org/gmane.comp.documentfoundation.libreoffice.scm/4357

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Committed
Alan Bell (alanbell) wrote :

removing libreoffice-gtk seems to let it start and work normally whilst dropping some Ubuntu integration until the fix lands.

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
milestone: none → ubuntu-12.04
Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
John Burkhart (jfburkhart) wrote :

I have the problem on a fresh install of 12.04 Ubuntu with everything up to date.

Libreoffice 3.5.3.2 350m1(Build:2)

Disconnecting my monitors or removing libreoffice-gtk seem to solve the problem for now. Otherwise:

[jfb@olufino ~]$dmesg
[ 1392.501992] soffice.bin[4376]: segfault at 7fffa7565ff8 ip 00007f95bf15a7b5 sp 00007fffa7566000 error 6 in libvclplug_gtklo.so[7f95bf126000+74000]

My monitors:

[jfb@olufino ~]$xrandr
Screen 0: minimum 320 x 200, current 3200 x 1806, maximum 8192 x 8192
eDP1 connected 1280x800+0+1006 (normal left inverted right x axis y axis) 261mm x 163mm
   1280x800 60.0*+ 40.0
VGA1 connected 1920x1200+1280+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200 60.0*+
   1600x1200 60.0
   1680x1050 60.0
   1280x1024 60.0
   1440x900 59.9
   1280x960 60.0
   1280x800 59.8
   1024x768 60.0
   800x600 60.3 56.2
   640x480 60.0
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

John Burkhart, please file a new bug via the Terminal and feel free to subscribe me to it:
ubuntu-bug libreoffice

Thanks!

To post a comment you must log in.