[Upstream] Text not black in LibreOffice

Bug #628105 reported by Aethralis on 2010-09-01
148
This bug affects 48 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
libreoffice (Ubuntu)
Undecided
Unassigned
Nominated for Raring by Adam Stokes
Precise
Undecided
Björn Michaelsen
Quantal
Undecided
Björn Michaelsen

Bug Description

Binary package hint: light-themes

When using Ambiance theme the body text in Ooo Writer is not black but gray. This is quite uncomfortable when writing and thus renders the theme in effect unusable. See attached png.

[Impact]

 * Auto-colored text is illegible on dark background in LibreOffice.
 * Use "High Contrast" theme, unacceptable to customer.
 * User has to mnaually change the color from "automatic" to white.
 * This is affecting a flagship customer.

[Test Case]

 * In Libreoffice Impress the text with the color "automatic" is hard to read if the background color is set to black (example file/screenshot attached).

[Regression Potential]

 * This patch is a backport form upstream, and has been tested. I do not see any possible regression potential here.

[Workaround]
Go to Tools -> Options... -> LibreOffice -> Appearance -> Font Color and change the color from Automatic to Black.

Aethralis (aethralis) wrote :
Aethralis (aethralis) wrote :

Forgot to mention that I'm using light-themes 0.1.6.8~bzr14~ from ppa:murrine-daily/ppa.

Vallery Lancey (muscovy) wrote :

I won't confirm this bug because I'm not sure if the issue is specifically light-themes, but I have noticed the same thing. Most of the themes give the dark grey text, but some (like the GNOME theme) give black text. I think OpenOffice is inheriting settings from the themes.

Created attachment 44517
text-on-black-background.odp

In Libreoffice Impress the text with the color "automatic" is hard to read if the background color is set to black (example file attached). I have to change the color from "automatic" to white.

Please map the "automatic" color to white if the background color is set to black.

I initially filed this bug in Ubuntu: https://launchpad.net/bugs/734428

I could not reproduce this problem in 3.3.1 SLED 11 sp1.

1. In attached sample, set the font color to automatic =>the text is normally white

2. Change page background as solid white => the text turns to be black as expected

3. Change page background as solid black back => the text turns to be white again.

NOT Reproducible with "LibreOffice 3.3.2RC1 – WIN7 Home Premium (64bit) German UI [OOO330m19 (Build:201 / tag 3.3.2.1)]". I opened sample document, all teext looks white, I modified character color of 1 word in the text from "Auto" to "white" and I did not see any difference to color of "auto" colored characters.

Transferred information from Ubuntu bug tracking system:

DistroRelease: Ubuntu 11.04
Package: libreoffice-impress 1:3.3.1-1ubuntu5
Uname: Linux 2.6.38-997-generic x86_64
Architecture: amd64
Date: Sun Mar 13 18:09:02 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100921.1)
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: Upgraded to natty on 2011-03-11 (2 days ago)

Several information is missing!

@Benjamin Drung:
May be hints on <http://wiki.documentfoundation.org/BugReport> can be useuful for you?
Please:
- Attach screenshots with comments (you can add information using LibO DRAW
  and then attach your screenshot with comments as PDF)
- Contribute a step by step instruction containing every key press and every
  mouse click how to reproduce your problem
- add information
  -- what exactly is unexpected (what color do characters have)
  -- and why do you believe it's unexpected
  -- concerning your PC (especially: video card)
  -- concerning your LibO version and localization, It seems that that is a
     special Ubuntu LibO pack, not the vanilla LibO pack?
  –- Libo settings that might be related to your problems
    (video hardware acceleration ...)
  -- Whether the problem is limited to Presentation or also is visible in
     other LibO applications
  -- how you launch LibO
  -- everything else crossing your mind after you read a.m. URL
Can you please file Bug reports with status UNCONFIRMED if your are not absolutely sure that you contributed all required background information and that the problem will be reproducible with information you can provide? Thank you!

Created attachment 44565
automatic-text-on-black-background.png

I downloaded LibO_3.3.2rc1_Linux_x86-64_install-deb_en-US.tar.gz and installed it (with dpkg -i *.deb) on an up-to-date Ubuntu 11.04 (natty). Then I ran "/opt/libreoffice/program/simpress text-on-black-background.odp". The text "This text should be white!" has the color "automatic" and is gray (see screenshot), but I expect it to be white.

> Can you please file Bug reports with status UNCONFIRMED if your are not
> absolutely sure that you contributed all required background information and
> that the problem will be reproducible with information you can provide?

I will remember that for the next time. The status is hidden by default (-> Show Advanced Fields). I didn't change the status when I initial filed the bug (default was NEW).

@Benjamin Drung:
Do you see that problem only in Presentation or also in other applications?
If in WRITER, only for DRAWing text boxes or also for standard text?
We urgently need some more information.

The color I see in your screenshot seems to be not grey, but grey 70%. Can you please check and if necessary correct your report?

If you shut down LibO, rename your user profile (for WIN that's in "AppData", I do not know the folder name for Linux), relaunch LibO, do you still see that problem?

And yes, this default-status NEW is very worrying, but it seems that can not be changed with the current Bugzilla version.

Note, my personal opinionns:

I don't think we need to worry about this NEW vs. UNCONFIRMED thing, just ignore the difference. I doubt we want to use our resources on making sure the Bugzilla Process is perfect. We don't neeed to try to make it work exactly like OOo's bug workflow did; for instance, I don't necesarily see that much value in having a strict difference between CLOSED and RESOLVED. I much prefer just getting useful bug reports, and somebody asking for more information when necessary, i.e. just what you have been doing Rainer, thanks!

But others might disagree of course, maybe even some Document Foundation steering group wants to eventually decide something, or maybe they have?

OK, sure, if you *want* to do it, all is good then.

Created attachment 44578
black-background.odg

I see that problem in all applications. Example files and corresponding screenshots attached for Writer and Draw.

The color is some kind of gray (not the Gray from the color pallet). It's lighter than Gray 80% and darker than Gray 70% (see attached screenshots).

Removing the user profile (deleting ~/.libreoffice) has no effect.

BTW, I updated LibO to the latest 3.3.2 RC2 version as you can see in the screenshots.

Anything I forgot to provide or to test?

Created attachment 44579
black-background.odt

Created attachment 44580
draw-black-background.png

Created attachment 44581
writer-black-background.png

@Benjamin Drung:
Only one last question from Comment 4: problem only for DRAWing text boxes or also for standard text? (please delete keyword with your answer!).

Currently I do not have any more ideas what could be tested, and I'm afraid developers will not show interest before some more users will be affected. May be you can gamble with all settings referring to color, but I doubt that that will lead to anything useful.
May be you can publish your problem on an user mailing list, may be someone can contribute a good new idea.

> problem only for DRAWing text boxes or also for standard text?

As you can see in the black-background.odt, standard text is also affected.

I made a very interesting discovery: Debian unstable (which ship a very similar package of LibreOffice) is not affected. Then I discovered that the color depends on the GNOME theme. 'Automatic' translates to white on a black background for themes like Clearlocks and Skiki-Colors, but it translates to "dark grey" for Ambiance (the default theme for Ubuntu since 10.04) and Radiance.

The "automatic" text color maps to the GTK text color instead of mapping to white or black.

Open your gtk theme (in /usr/share/themes/<name>/gtk-2.0/gtkrc on Ubuntu) and search for ntext_color. Replace the following color with FF0000 (red) for example and you will see that Libreoffice maps the automatic color to red on all kinds (white and black) of backgrounds.

There are two issues here. The first is that LibreOffice doesn't correctly handle cases where the GTK theme's text color is something other than black or white. (See comment 14.) This is the case in Ambiance, Ubuntu's default theme. Thus, all Ubuntu users are potentially affected by this bug. This should be fixed to work correctly with all arbitrary colors.

Additionally, there's the issue of what behavior is correct here. In my opinion, LO should ignore the GTK theme entirely and default to black text on a white background. Here's a use case to illustrate: When I produce a document, the difference between the Ambiance default text color (#3C3C3C) and black isn't readily apparent on the screen unless the two colors are next to each other. (This probably explains why there haven't been too many bug reports about this issue.) However, when I print a document using auto colors on a black and white laser printer, the printer dithers the text to create a dark gray. That makes the text look messy.

Following the GTK theme is useful for situations where the content will blend in with other content on the screen. But for Writer, what counts is the paper and printer, not the on-screen appearance. And for Impress, presentations are shown without reference to the current theme. In fact, in general, a good GTK theme wouldn't make a good presentation theme, just as a good GTK theme wouldn't be good for a printed document.

At the very least, please set the auto text color for light backgrounds to black, without reference to the GTK theme.

This is just a quick ping to note that this bug persists. I hope that someone with the requisite skills can take a look at it, now that the problem has been identified.

Someone commented in the downstream bug (https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/734428/comments/27) that this is independent of GTK. He reported this bug in KDE with the GTK packages uninstalled.

Is there anything holding up work on this bug?

Andrea Cimitan (cimi) on 2012-04-27
Changed in light-themes (Ubuntu):
status: New → Incomplete
Aethralis (aethralis) wrote :

The same problem still persists. The difference of text color is evident when using Ambiance theme and e.g. High Contrast theme (see screenshot above). Using 12.04, Unity 3d, all default settings (no ppa's).

Adolfo Jayme (fitojb) on 2012-06-24
summary: - Text not black in Openoffice
+ Text not black in LibreOffice

Created attachment 63403
0001-fdo-35365-Set-the-default-font-color-to-black-and-th.patch

Here's the patch that I proposed on the mailing list to fix this bug.

Comment on attachment 63403
0001-fdo-35365-Set-the-default-font-color-to-black-and-th.patch

Review of attachment 63403:
-----------------------------------------------------------------

Looks good to me.

Benjamin Drung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d06094c701262ef54604be206c25dd87a77d224

fdo#35365 Set the default font color to black and the document color to white.

no longer affects: libreoffice (Ubuntu)
affects: light-themes (Ubuntu) → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed
summary: - Text not black in LibreOffice
+ [Upstream] Text not black in LibreOffice
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

patch got pushed to master, closing

Gurvinder Dadyala (gurvinder) wrote :

Hi All
I am using Following Libre Office version
LibreOffice 3.5.5.3
Build ID: 7122e39-92ed229-498d286-15e43b4-d70da21

I also have default font as Grey 80%

OS information:-
Ubuntu 10.04 LTS
Linux demosystem 2.6.32-41-generic #94-Ubuntu SMP Fri Jul 6 16:51:39 UTC 2012 i686 GNU/Linux

Regards
Gurvinder Dadyala

Josh Burghandy (kid1000002000) wrote :

Same issues, libreoffice 3.6.1.2. Ubuntu 12.04

Changed in df-libreoffice:
status: Confirmed → Fix Released
Adolfo Jayme (fitojb) wrote :

The fix will be available in LibreOffice 3.7.

Ritesh Khadgaray (khadgaray) wrote :
Ritesh Khadgaray (khadgaray) wrote :

[Impact]

 * Auto-colored text is illegible on dark background in LibreOffice.
 * Use "High Contrast" theme, unacceptable to customer.
 * User has to mnaually change the color from "automatic" to white.
 * This is affecting a flagship customer.

[Test Case]

 * In Libreoffice Impress the text with the color "automatic" is hard to read if the background color is set to black (example file/screenshot attached).

[Regression Potential]

 * This patch is a backport form upstream, and has been tested. I do not see any possible regression potential here.

tags: added: oneiric precise quantal
Benjamin Drung (bdrung) on 2013-01-21
description: updated
Ritesh Khadgaray (khadgaray) wrote :
Benjamin Drung (bdrung) wrote :

libreoffice 4.0.0~beta2 will be uploaded to raring soon. Therefore it make sense to wait for that upload instead of uploading the backported patch.

tuhu (tuhubage) wrote :

@Bejamin Drung: What about in Precise? Will there be any update soon?

Benjamin Drung (bdrung) wrote :

We missed the current upload to precise-proposed. The fix should be scheduled for the next upload to precise-proposed. This won't happen before the release of the next point release of precise which is planned for 2013-02-14.

Ritesh Khadgaray (khadgaray) wrote :
Changed in libreoffice (Ubuntu Precise):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)

https://gerrit.libreoffice.org/#/c/2156/ for possible 3.6 quantal SRU.

Benjamin Drung committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f10bb02eb3083a089e3ca28c45983e616ef84d58&h=libreoffice-3-6

fdo#35365 Set the default font color to black and the document color to white.

It will be available in LibreOffice 3.6.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

precise => vendor patched in Ubuntu packaging: http://anonscm.debian.org/gitweb/?p=pkg-openoffice/libreoffice.git;a=commit;h=2bed50225955d3923fcc65e50a3df6baa6653976
quantal => commited upstream for 3.6.6

Changed in libreoffice (Ubuntu Quantal):
status: New → Fix Committed
Changed in libreoffice (Ubuntu Precise):
status: New → Fix Committed
Changed in libreoffice (Ubuntu Quantal):
status: Fix Committed → In Progress
Sebastien Bacher (seb128) wrote :

thanks Björn, unsubscribing sponsors, that will be in the next uploads

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:4.0.0~beta2-0ubuntu2

---------------
libreoffice (1:4.0.0~beta2-0ubuntu2) raring; urgency=low

  * Build using the internal libmspub for a first build.
 -- Matthias Klose <email address hidden> Tue, 19 Feb 2013 00:05:26 +0100

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
Ritesh Khadgaray (khadgaray) wrote :

Hi

  Could this be also marked against oneiric, which is being used by one of our stratergic customer.

Thank you
-- ritz

Sebastien Bacher (seb128) wrote :

it's not likely that we will do extra oneiric libreoffice uploads at this point... how important is the fix for the customer?

Benjamin Drung (bdrung) wrote :

I recommend to use the workaround mentioned in the bug description on oneiric.

Sebastien Bacher (seb128) wrote :

unsubscribing sponsors and assigning to Bjoern, it's not likely other sponsors will pick that up to do a libreoffice SRU

Changed in libreoffice (Ubuntu Quantal):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)

*** Bug 63594 has been marked as a duplicate of this bug. ***

Milodovi'c (miloud-rashid) wrote :

no libreoffice unity integration 12.04.2 it is disabled
can't install lo-menubar

Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → New
Milodovi'c (miloud-rashid) wrote :

Since update to libreoffice 4.0.4 no unity integration
can't install lo-menubar

Changed in libreoffice (Ubuntu Precise):
status: New → Confirmed
Milodovi'c (miloud-rashid) wrote :

 ........................I disabled the internal unity
menu integration for backports as the unity side is just not ready to handle it
on these older releases. If you absolutely want to have this, use lo-menubar,
which should still be available on these Ubuntu releases. This allow people to
comfortably use the -gtk and -gnome integration, without the instablity of the
internal unity integration, which never was intended to be used on anything but
raring and later.

WHY EVEN LO-MENUBAR WE CAN'T INSTALL
THANKS

Mildovi'c, your issue sounds unrelated to this bug. Please file a new one instead of changing the status. Thanks.

Changed in libreoffice (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → Confirmed
Adolfo Jayme (fitojb) wrote :

Please do not mess with unrelated bugs. Thanks.

Changed in libreoffice (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → In Progress

@Ritesh: Why going back to "In progress?" -- this is already commited in https://launchpad.net/~libreoffice/+archive/libreoffice-3-5/+sourcepub/3333599/+listing-archive-extra and only needs an SRU. Do you want to help with the redtape for that?

Ritesh Khadgaray (khadgaray) wrote :

Hi @Björn

 Sorry about this. I was under the impression SRU was filled for this, and fix was released. Thank you.

-- ritz

Changed in libreoffice (Ubuntu Precise):
status: In Progress → Fix Committed

Looks like Impress has regressed, see bug #67529.

Nevermind the above comment.

Adam Stokes (adam-stokes) wrote :

According to Ritesh bug #1176923 has been tested and verified and the SRU template is complete. Also precise is marked as 'fix committed', however, I dont see any package relating to this in -proposed so I'm not sure what that status is referring to.

Moving precise back to in progress and nominated raring to be included in this sru as well.

Thanks
Adam

Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → In Progress

Its fixed for quantal in the ppa, but as is I wont do the redtape dance to SRU 3.6.7 to quantal anymore.

Changed in libreoffice (Ubuntu Quantal):
status: In Progress → Won't Fix
Martin Pitt (pitti) wrote :

Bjoern is handling this, and other sponsors shouldn't really touch a LibO SRU without coordinating with Bjoern, so unsubscribing sponsors.

Peter Matulis (petermatulis) wrote :

When will this be fixed in Precise?

tags: removed: oneiric quantal

Hello Aethralis, or anyone else affected,

Accepted libreoffice into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libreoffice/1:3.5.7-0ubuntu5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libreoffice (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Ritesh Khadgaray (khadgaray) wrote :

Works fine on precise, with libreoffice 3.5.7-0ubuntu5 .

tags: added: verification-done
removed: verification-needed
Peter Matulis (petermatulis) wrote :

When will 3.5.7-0ubuntu5 be pushed to precise-updates?

The verification of the Stable Release Update for libreoffice has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:3.5.7-0ubuntu5

---------------
libreoffice (1:3.5.7-0ubuntu5) precise; urgency=low

  * rebase changes on ppa
  * backport theming fix for dark themes (LP: #628105)
  * paint to overlay directly (LP: #1207057)
 -- Bjoern Michaelsen <email address hidden> Thu, 22 Aug 2013 12:42:12 +0200

Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → Fix Released

Seems this creates a nasty a11y bug; see bug#71511 - input there appreciated.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.