[maverick] Non-mirrored dual-screen gives narrow display on secondary monitor

Bug #619663 reported by Alan Pope 🍺🐧🐱 🦄 on 2010-08-18
300
This bug affects 53 people
Affects Status Importance Assigned to Milestone
DRI
Fix Released
Medium
Release Notes for Ubuntu
Undecided
Unassigned
libdrm (Ubuntu)
Undecided
Robert Hooker
Maverick
High
Robert Hooker
Natty
Undecided
Robert Hooker

Bug Description

Binary package hint: xserver-xorg-video-intel

Laptop has 1400x1050 internal panel and is attached to an external screen which is 1680x1050. If I set the screens to mirror then I can have the same on both screens and this works fine. If I set them not to mirror then the secondary (external) screen is black but I can _just_ about move the mouse onto it. i can see the cursor on the second screen but its not usable because it only goes a few pixels onto the second screen before hitting a 'wall'.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xserver-xorg-video-intel 2:2.12.0-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-15.21-generic 2.6.35.1
Uname: Linux 2.6.35-15-generic i686
Architecture: i386
DRM.card0.DVI.D.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1400x1050
 edid-base64:
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1680x1050 1600x1200 1600x1200 1680x1050 1400x1050 1400x1050 1280x1024 1280x1024 1280x960 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBaYxxqAQEBAQcQAQMIKxt4LsMVplZKmyQWUFS/74CzD6lAkECQT4GAgUBxT6lPITmQMGIaJ0BosDYAsQ8RAAAcAAAA/wBQWEMwNjA3MDI3MzMKAAAA/QAySx5eFQAKICAgICAgAAAA/ABWQTIwMTJ3U0VSSUVTALA=
Date: Wed Aug 18 07:46:26 2010
DkmsStatus:
 vboxnetflt, 3.2.8, 2.6.35-10-generic, i686: installed
 vboxdrv, 3.2.8, 2.6.35-10-generic, i686: installed
 vboxnetadp, 3.2.8, 2.6.35-10-generic, i686: installed
EcryptfsInUse: Yes
MachineType: TOSHIBA Portable PC
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-15-generic root=UUID=6f981968-9d73-43df-a42c-21d75e087ae5 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-intel
dmi.bios.date: 05/22/2008
dmi.bios.vendor: TOSHIBA
dmi.bios.version: Version 3.80
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Version A0
dmi.chassis.asset.tag: 0000000000
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: Version 1.0
dmi.modalias: dmi:bvnTOSHIBA:bvrVersion3.80:bd05/22/2008:svnTOSHIBA:pnPortablePC:pvrVersion1.0:rvnTOSHIBA:rnPortablePC:rvrVersionA0:cvnTOSHIBA:ct10:cvrVersion1.0:
dmi.product.name: Portable PC
dmi.product.version: Version 1.0
dmi.sys.vendor: TOSHIBA
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-15-generic

I can reproduce this and have tracked it down to a change in the ddx between db586624d4f2908d2a998ba87fe0ae31c10f46b91 and 41684d54592cf93554a4d6534e7ea74562b1798.

So the change to use drm to create the tiled buffer was the cause. We were failing to limit what we requested from the kernel and subsequently did not check the return code [EINVAL] and interpreted as a general failure.

commit 726210f87d558d558022f35bc8c839e798a19f0c
Author: Chris Wilson <email address hidden>
Date: Thu Jun 24 11:38:00 2010 +0100

    intel: Limit tiled pitches to 8192 on pre-i965.

    Fixes:

      Bug 28515 - Failed to allocate framebuffer when exceed 2048 width
      https://bugs.freedesktop.org/show_bug.cgi?id=28515

    Signed-off-by: Chris Wilson <email address hidden>

*** Bug 28571 has been marked as a duplicate of this bug. ***

It should be noted the fix is in drm master.

Binary package hint: xserver-xorg-video-intel

Laptop has 1400x1050 internal panel and is attached to an external screen which is 1680x1050. If I set the screens to mirror then I can have the same on both screens and this works fine. If I set them not to mirror then the secondary (external) screen is black but I can _just_ about move the mouse onto it. i can see the cursor on the second screen but its not usable because it only goes a few pixels onto the second screen before hitting a 'wall'.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xserver-xorg-video-intel 2:2.12.0-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-15.21-generic 2.6.35.1
Uname: Linux 2.6.35-15-generic i686
Architecture: i386
DRM.card0.DVI.D.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1400x1050
 edid-base64:
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1680x1050 1600x1200 1600x1200 1680x1050 1400x1050 1400x1050 1280x1024 1280x1024 1280x960 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBaYxxqAQEBAQcQAQMIKxt4LsMVplZKmyQWUFS/74CzD6lAkECQT4GAgUBxT6lPITmQMGIaJ0BosDYAsQ8RAAAcAAAA/wBQWEMwNjA3MDI3MzMKAAAA/QAySx5eFQAKICAgICAgAAAA/ABWQTIwMTJ3U0VSSUVTALA=
Date: Wed Aug 18 07:46:26 2010
DkmsStatus:
 vboxnetflt, 3.2.8, 2.6.35-10-generic, i686: installed
 vboxdrv, 3.2.8, 2.6.35-10-generic, i686: installed
 vboxnetadp, 3.2.8, 2.6.35-10-generic, i686: installed
EcryptfsInUse: Yes
MachineType: TOSHIBA Portable PC
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-15-generic root=UUID=6f981968-9d73-43df-a42c-21d75e087ae5 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-intel
dmi.bios.date: 05/22/2008
dmi.bios.vendor: TOSHIBA
dmi.bios.version: Version 3.80
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Version A0
dmi.chassis.asset.tag: 0000000000
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: Version 1.0
dmi.modalias: dmi:bvnTOSHIBA:bvrVersion3.80:bd05/22/2008:svnTOSHIBA:pnPortablePC:pvrVersion1.0:rvnTOSHIBA:rnPortablePC:rvrVersionA0:cvnTOSHIBA:ct10:cvrVersion1.0:
dmi.product.name: Portable PC
dmi.product.version: Version 1.0
dmi.sys.vendor: TOSHIBA
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-15-generic

Bryce Harrington (bryce) on 2010-08-18
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed

"Interestingly" If I set the external monitor to be full resolution and tell the gnome-display-properties to turn the laptop panel off, thus giving me full screen external display all is fine. However if I then choose to turn the laptop display back on and enable it, the laptop display is blank, however it's clear that gnome 'thinks' it's active because the panels disappear from the external display - presumably being displayed on the blank laptop panel. Of course if I switch the laptop panel off again the panels come back to the external display.

Albert Damen (albrt) wrote :

As you are using an intel 945 and the bug happens when you have an extended desktop with width > 2048 and there is the error message "(EE) intel(0): Failed to allocate framebuffer." this seems to be freedesktop bug 28515 (libdrm) which is fixed in:

commit 726210f87d558d558022f35bc8c839e798a19f0c
intel: Limit tiled pitches to 8192 on pre-i965.

Fixes: Bug 28515 - Failed to allocate framebuffer when exceed 2048 width
 https://bugs.freedesktop.org/show_bug.cgi?id=28515

Nick Moeck (nickmoeck) wrote :

This bug is fixed upstream, and the xorg-edgers PPA located at https://launchpad.net/~xorg-edgers/+archive/ppa has updated packages with the fix included. I don't know if that fix is going to make it into the official Maverick package, but I hope it does.

Søren Holm (sgh) wrote :

I have just installed the xorg-edgers packages. It works *really* nice. I would really hope that it gets into maverick. I remember karmic that shipped with realy broken intel drivers. It would be a real shame to repeat that.

I see the exact same behaviour with current maverick packages. My workaround is to make the second monitor below the first -- then I get two full monitors working.

Søren Holm (sgh) wrote :

Try the xorg-edger packages - they fix the issue. Maybe if we are enough to try them they can get into maverick

xorg-edgers fixed it for me.

Søren Holm (sgh) wrote :

Excellent.

Ubuntu guys: Would it be possible just to include the libdrm-fix in maverick when it ships ?

dalastdon (lilraphael-edu) wrote :

Am on maverick, How do i also get the xorg-edgers package to work for me as well?
I have successfully added the ppa stated in the https://launchpad.net/~xorg-edgers/+archive/ppa
Can someone kindly help me out with a step by step instructions?

Thanks

Nick Moeck (nickmoeck) wrote :

Once you've added the xorg-edgers PPA following the instructions on the PPA page, all you have to do is sudo apt-get update then sudo apt-get upgrade

If the xorg-edgers PPA somehow messes things up (it really shouldn't), you can revert by installing the package ppa-purge and running sudo ppa-purge xorg-edgers

*** Bug 30372 has been marked as a duplicate of this bug. ***

dalastdon (lilraphael-edu) wrote :

It didn't work for me because i had issues with my apt sources which has now been rectified.

Which particular packages do i install to fix my extended monitor stuff?

Just run "apt-get upgrade". I your ppa is set up correctly it will upgrade the
relevant packages.

Søren Holm (sgh) wrote :

Can we do anything to help getting the lastest libdrm into maverick? I can add that radeon-chipsets behave much better with the current version in the ppa.

Alex Bachmeier (cebalrai) wrote :

This really needs more attention, only 11 days from release. And the number of affected users is probably going to be relatively large. Xorg-Edgers isn't what one wants on production systems.

Added regression-potential and assigned ubuntu-release-notes as per https://wiki.ubuntu.com/QATeam/RegressionTracking

tags: added: regression-potential
Søren Holm (sgh) wrote :

Problably not. Would it be possible to cherry-pick commit 726210f87d558d558022f35bc8c839e798a19f0c for maverick?

dalastdon (lilraphael-edu) wrote :

It still doesn't work for me.

Any alternative options?

Using Xorg-Edgers PPA fixed the issue here, but this regression (compared to 10.04) prevents using dual-screen setups with intel chipsets, and this will likely impact lots of users.

Aanjhan Ranganathan (aanjhan) wrote :

So really, Ubuntu Maverick is going to be shipped without this fix?
Sad, if this is ignored.

Aanjhan Ranganathan (aanjhan) wrote :

OK. I can confirm that the xorg-edgers packages did the magic.

Thanks, it worked for me.

+1 for xorg-edgers

Starting from today, the xorg-edgers PPA is not an option anymore since the new xserver it containts coredumps at startup ... so if you read this message, don't update it !

dalastdon (lilraphael-edu) wrote :

Fine, so is Maverick going to be shipped without this fix for intel chipset users?

Changed in dri:
importance: Unknown → Medium
status: Unknown → Fix Released
Robert Hooker (sarvatt) wrote :

I'm looking to get the update in via a SRU as soon as possible, could the people experiencing this please try the libdrm package in this PPA and report your findings?

https://edge.launchpad.net/~sarvatt/+archive/yellow

https://bugs.edge.launchpad.net/ubuntu/+source/libdrm/+bug/654619

By the way Gilles, that problem is fixed in xorg-edgers now.

affects: xserver-xorg-video-intel (Ubuntu) → libdrm (Ubuntu)
Changed in libdrm (Ubuntu):
assignee: nobody → Robert Hooker (sarvatt)
importance: Undecided → High
Alex Bachmeier (cebalrai) wrote :

Your PPA fixes the bug for me.

Lets hope they include it in the release.

Robert Hooker (sarvatt) on 2010-10-07
Changed in libdrm (Ubuntu):
milestone: none → maverick-updates
status: Confirmed → Fix Committed
Nick Moeck (nickmoeck) wrote :

I can confirm that the ppa resolves the issue for me. Perhaps someone can contact the release team so that this gets into Maverick before release. I consider working dual-monitor support to be important enough for a freeze exception. I don't know the proper channels for requesting an exception though, unfortunately.

Søren Holm (sgh) wrote :

It fixes it for me too. Great job Robert! I hope is gets into maverick.

Colin Law (colin-law) wrote :

The ppa fixes for me too.

Robert Hooker (sarvatt) wrote :

debdiff against libdrm 2.4.21-1ubuntu2 targetting maverick-proposed containing the fix, it is also pushed to pkg-xorg git

http://git.debian.org/?p=pkg-xorg/lib/libdrm.git;a=shortlog;h=refs/heads/ubuntu

tags: added: patch
Cliff Dyer (jcd-sdf) wrote :

It also fixed my problem, reported over on #654619, where I couldn't get X to start at all.

Thanks!

Changed in ubuntu-release-notes:
status: New → In Progress
Changed in ubuntu-release-notes:
status: In Progress → Fix Released
gangely (gangely) wrote :

As released yesterday, Maverick seems to not include the fix.

So, I encountered the same problem on a Fujitsu-Siemens laptop upgraded from Lucid.

'add-apt-repository ppa:xorg-edgers/ppa' + update/upgrade solved the problem.

Many thanks :-)

Rick van den Hof (strlen) wrote :

I needed this PPA too, default Maverick upgrade broke my system.

I'm running Ubuntu on a HP-Compaq Dc5800 with an onboard Intel Corporation 82Q33 Express Integrated Graphics Controller.

Installing the updates from the PPA fixed it.

Rick van den Hof (strlen) wrote :

I noticed my mouse being kind of jerky since the update and kslowd00 seems to take up a lot of CPU time which led me to this:

http://www.gossamer-threads.com/lists/linux/kernel/1238374

Which also seems to be related to DRM, Intel and Ubuntu. Could it be that the commit they are referring to isn't reverted in Ubuntu?

Rick van den Hof (strlen) wrote :

See also Bug #609113.

Maverick unfortunatelly does not contain this fix. Problem still occurs. Is there any fix which does not require to use xorg-edgers? I'm afraid that for production purposes this solution is not acceptable.

Rudy (forestgeek) wrote :

I am on a Compaq nc6320 with 945GM/GMS 943/940GML and yesterday i upgraded to Ubuntu 10.10
As posted above, i had the same problem with my dual monitor setup.
A little twinkle with xrandr doen't solve the problem for me, but i was close. I had a one-and-a-half monitor setup :)

So i tried the xorg-edgers and whoah, it works like charm!!!
So thanx a lot guys/girls :)

Accepted libdrm into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libdrm (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Bastian (jemand-habmalnefrage) wrote :

seems to be the same problem with an ati x1300. Updating to all proposed packages fixed this also.

Just tried the libdrm packages from proposed and they fix the problem on an
IBM stinkpad T60. Side by side dual screen working properly again.

On 16 October 2010 17:53, Bastian <email address hidden> wrote:

> seems to be the same problem with an ati x1300. Updating to all proposed
> packages fixed this also.
>
> --
> [maverick] Non-mirrored dual-screen gives narrow display on secondary
> monitor
> https://bugs.launchpad.net/bugs/619663
> You received this bug notification because you are a direct subscriber
> of the bug.
>

tags: added: verification-done
removed: verification-needed
Alex Bachmeier (cebalrai) wrote :

Libdrm from proposed fixes the bug on a Intel G35.
No adverse effects so far.

dave tingley (dave-tingley) wrote :

Just did latest update with proposed turned on and It is still not working on a Dell Optiplex 620 with Intel graphics

dave tingley (dave-tingley) wrote :

Correction, after reboot (duh) it is working

Evan Carroll (evancarroll) wrote :

Enabling maverick proposed and upgrading (installing all modules in maverick proposed) worked perfectly for me. No observed side effects.

Changed in libdrm (Ubuntu Maverick):
milestone: none → maverick-updates
Changed in libdrm (Ubuntu Natty):
milestone: maverick-updates → natty-alpha-1
Changed in libdrm (Ubuntu Maverick):
assignee: nobody → Robert Hooker (sarvatt)
importance: Undecided → High
Changed in libdrm (Ubuntu Natty):
importance: High → Undecided
Changed in libdrm (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to natty as well.

Changed in libdrm (Ubuntu Natty):
status: Fix Committed → Fix Released
tags: added: regression-release
removed: regression-potential
Rob (rbnwmk) wrote :

Still having problem as of today (Netbook LCD 1024x600, external monitor at 1440x900). Updated and upgraded everything.

Both monitors flickering when both monitors are turned on at different resolutions.
Turning off either monitor worked fine.
Checked "Same image in all monitors" made LCD looks weird.(Narrow)

I am not sure what more info needed, hardware as below, do let me know at where ever needed:

HP Mini netbook

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller

Thanks.

At the moment I have no choice but to use 10.04 installed on another partition which works just fine.

dalastdon (lilraphael-edu) wrote :

Experiencing the some problem as Rob.... "Both monitors flicker when both monitors are turned on at different resolutions."

Bobly (gbobly) wrote :

-proposed added to sources, update/upgrade'd, libdrm2 is installed, the problem is still very much present.

How is this not fixed yet? Surely this must be affecting a lot of people.
Most budget netbooks will have intel chips, and a fair amount of these users must enjoy using an external monitor to make up for the small monitors when at home. Story aside, here are the details:

Clean Maverick Netbook Ed. install, updated, upgraded, plugged in second monitor, the second the Monitors configuration panel recognises it (either by starting it while already plugged in or running detect monitor if plugging it in after launched) the screen will resize itself more or less properly (hard to tell) but flicker (only desktop visible for ~3-4 seconds, then windows visible for 1/2 second, continuously). The computer will also only accept inputs while the windows are visible.

I'm sorry but this issue is most definitely not fixed :/

Colin Law (colin-law) wrote :

I think the flickering displays is a different issue. This bug is about only seeing a narrow window on the second monitor, the total image width being limited to 2048 pixels. That bug is fixed I believe. I think those seeing flickering windows had better look for a different existing bug or report a new one.

Cliff Dyer (jcd-sdf) wrote :

Flickering is a different issue. File a new ticket (or find another one which matches your problem). This is about not rendering widths > 2048 pixels.

Bobly (gbobly) wrote :

With all due respect I believe this is just a different manifestation of the same bug.
The reason I say this is, if the combined width is <2048, the flicker does not happen and the monitors will actually work. I'm not overly familiar with how these bug responses work but when I saw others mention flicker I figure I'd try and describe it a bit more as it still seems to be out there.

Bobly (gbobly) wrote :

Well personally I've found a fix for this issue, ditched Netbook Remix theme and just did a clean install of Ubuntu Desktop.

From my experience, as I remember having the narrow display on second monitor with Netbook Remix and saw it again after reinstalling Desktop, I think default installs of both have issues with intel chips and dual monitor solutions. While the libdrm fix works for the Desktop environment under compiz, my guess is that under mutter which comes bundled with the Netbook Remix edition (for which compiz doesn't work btw) there is the initial bug which is followed by flickering if this fix is applied for any max resolution >2048.

My temporary fix at first was to swivel my 24" 90 degrees as this allowed the full 1900x1200 and then I just reduced my laptop to 800x600 (total of 2000 wide) however on top of that, either mutter or the netbook remix theme itself was still a bit slow so I decided to revert back to a standard Ubuntu desktop install.

If you are having the flickering screen issue on Netbook Remix it may be worth sticking to Ubuntu desktop for now and waiting for 11.10 which it seems is the target for porting the netbook remix theme to compiz.

Rob (rbnwmk) wrote :

I chose Desktop login instead of netbook the normal NRE Unity environtment at login screen. Dual monitors with different resolutions works just fine. (Thanks Bobly)

I can't remember if gnome desktop was installed by default or I manually did it since 10.04 (I did a network auto distro upgrade)

sanmiguel9 (againsttcpa84) wrote :

Hello,
the update in Maverick allowed me again to place my two screens (1280x1024 and 1280x800) next to each other as it was the case in Lucid. However, if I enable compositing_manager in Gconf->apps->metacity all windows are overlayed by semi-transparent shadows (cf. attached screenshot). This happens only if the virtual screen exceeds 2048px.

My system:
Maverick on a Lenovo Ideapad S12 with intel graphics 945GME

Samantha Atkinsn (sjatkins) wrote :

The xorg-edgers stuff does not work for me. Dell Desktop upgraded from 10.04, 64 bit. Radeon 4870 graphics. My dual 1920x1080 monitors worked fine in non-mirrored mode before the upgrade. Not since. The edgers stuff did nothing. It appears to me as if the Preference->Monitors tool never gets around to changing any config files. Perhaps I could get up again if someone could just tell me how those config files should look? Or is it much deeper than that?

Samantha Atkinsn (sjatkins) wrote :

Mystery deepens. i had a spare partition so I tried a clean install. It worked! So I turned on the proprietary FGLRX driver. It (setting monitors to be non-mirror) stopped working. So I removed the driver in Administration->Additional Drivers. It worked again.

Thinking I was onto something I booted back to the upgraded partition. I tried to remove the driver. I could not do so. It through some bogus error. When I hit remove again it reinstalled it! Another bug. How do I remove this obviously troubled proprietary driver cleanly by hand?

Samantha Atkinsn (sjatkins) wrote :

Problem resolved once I found instructions for manually removing and cleaning up after the proprietary FGLRX. For my card it doesn't seem to be required anyway. Back to happy computing. YAY. It sure would be nice to not burn hours to days fixing things on every ubuntu upgrade though.

Samantha Atkinsn (sjatkins) wrote :

Except now it won't give be back my full desktop effects where in the fresh install it gave them to me without the proprietary driver. WTF? So I get a choice between two monitors and good graphics. Thanks a heap.

@samantha This bug relates to Intel video cards, I don't believe your ATI card is affected by this bug, perhaps you need to file a separate one?

@sanmiguel did you ever find a fix for your problem? I've been getting the same one and can't find anything that helps. I did discover that it goes away when I turn my second screen to a super low resolution so I'm betting it's got the same root as this bug.

I have an intel T2080 dual core processor and am attaching my system test xml if that helps.

sanmiguel9 (againsttcpa84) wrote :

@Hans Reichenbach: no sorry, I have not found any solution for these strange shadows on top of my windows. For the time being, I simply deactivate any kind of compositing... it is a pity, but I have no time and know-how to investigate :-I

Colin Law (colin-law) wrote :

This bug has been identified and fixed. Anyone experiencing similar problems on a fully up to date system is seeing a different bug. They should report it as a new bug after checking there is not another existing bug that matches their symptoms.

Changed in dri:
importance: Medium → Unknown
Changed in dri:
importance: Unknown → Medium
To post a comment you must log in.