Dual screen setup does noet work properly

Bug #612853 reported by Søren Holm on 2010-08-03
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

When setting my LVDS1-ouput to be place left of my DVI1-output I actually get picture on both.

My setup is like this :
---------- ---------
| LVDS1 | | DVI1 |
---------- ---------

LVDS1 has a resolution of 1400x1050 and DVI1 has 1920x1200

After setting up dual screen with xrandr I get a complete picuture on LVDS1 but on 1/3 of the width on DVI1

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xserver-xorg-video-intel 2:2.12.0-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-14.19-generic 2.6.35
Uname: Linux 2.6.35-14-generic x86_64
Architecture: amd64
DRM.card0.DVI.D.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1200 1920x1080 1920x1080 1600x1200 1680x1050 1280x1024 1440x900 1280x960 1280x800 1280x720 1280x720 1024x768 800x600 800x600 720x576 720x480 640x480
 edid-base64: AP///////wBMLYcFNDJZTQkUAQOANCB4Ku6Ro1RMmSYPUFQjCACpQIGAgUCBAJUAswABAQEBKDyAoHCwI0AwIDYABkQhAAAaAAAA/QAyPx5REQAKICAgICAgAAAA/ABTeW5jTWFzdGVyCiAgAAAA/wBIOVhaMzAxNTQ2CiAgAb4CAQQAAjqAGHE4LUBYLEUABkQhAAAeAjqA0HI4LUAQLEWABkQhAAAeAR0AclHQHiBuKFUABkQhAAAeAR0AvFLQHiC4KFVABkQhAAAejArQkCBAMSAMQFUABkQhAAAYjArQiiDgLRAQPpYABkQhAAAYAAAAAAAAAAAAAAAAAAAAlg==
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: Off
 modes: 1400x1050
 edid-base64:
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Tue Aug 3 07:54:32 2010
DkmsStatus: Error: [Errno 2] No such file or directory
GdmLog: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log'] failed with exit code 1: cat: /var/log/gdm/:0.log: No such file or directory
GdmLog1: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log.1'] failed with exit code 1: cat: /var/log/gdm/:0.log.1: No such file or directory
GdmLog2: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log.2'] failed with exit code 1: cat: /var/log/gdm/:0.log.2: No such file or directory
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100729)
MachineType: FUJITSU SIEMENS LIFEBOOK E8110
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   product info: "O2Micro", "SmartCardBus Reader", "V1.0", ""
   manfid: 0xffff, 0x0001
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   5.0V 16-bit PC Card
   Subdevice 0 (function 0) [unbound]
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-14-generic root=UUID=89d48ce8-f46c-40f0-a2b2-c0cdbaff07cb ro quiet splash
ProcEnviron:
 LANGUAGE=da_DK
 PATH=(custom, user)
 LANG=da_DK.utf8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-intel
dmi.bios.date: 12/21/2006
dmi.bios.vendor: FUJITSU // Phoenix Technologies Ltd.
dmi.bios.version: Version 1.19
dmi.board.name: FJNB1AF
dmi.board.vendor: FUJITSU
dmi.board.version: CP322567-02
dmi.chassis.type: 10
dmi.chassis.vendor: FUJITSU SIEMENS
dmi.chassis.version: E8110
dmi.modalias: dmi:bvnFUJITSU//PhoenixTechnologiesLtd.:bvrVersion1.19:bd12/21/2006:svnFUJITSUSIEMENS:pnLIFEBOOKE8110:pvr:rvnFUJITSU:rnFJNB1AF:rvrCP322567-02:cvnFUJITSUSIEMENS:ct10:cvrE8110:
dmi.product.name: LIFEBOOK E8110
dmi.sys.vendor: FUJITSU SIEMENS
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-14-generic

Søren Holm (sgh) wrote :
Bryce Harrington (bryce) on 2010-08-03
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2010-08-04
tags: added: kubuntu
Søren Holm (sgh) wrote :

What is the status of this. I will be happy to test some experimental packages to help getting this fixed for Maverick.

Søren Holm (sgh) wrote :
bugbot (bugbot) wrote :

Hey Søren,

Thanks for testing maverick during its development period. Unfortunately it looks like this bug report didn't get attention during the maverick development period. But I see there's not been more comments on the bug since the release, which makes me wonder if this is still an issue for you?

If you've not seen this issue since maverick's release yourself, it may have been solved by kernel or X or other updates that occurred late in the release; if so, would you mind please closing the bug for us? Go to the URL mentioned in this bug report, click the yellow icon(s) in the status column and set to 'Fix Released'.

If you no longer have the hardware needed to reproduce the problem, or otherwise feel the bug no longer needs tracked in Launchpad, you can set the status to 'Invalid'.

If you are the original reporter and still have this issue, just reply to this email saying so. (Or set the bug status to Confirmed.) If you are able to re-test this against 11.04 Natty Narwhal (our current development focus) and find the issue still affects Natty, please also run 'apport-collect <bug-number>' while running natty, which will add fresh logs and debug data, and flag it for the Ubuntu-X development team to look at.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Søren Holm (sgh) wrote :

Fixed in current maverick.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers