[945gme] Failed to allocate framebuffer with width >2048 with intel 2.12 drivers.

Bug #654619 reported by Cliff Dyer on 2010-10-04
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libdrm (Ubuntu)
High
Robert Hooker

Bug Description

I just updated my Acer Aspire One to Maverick pre-release (aptitude safe-upgraded as of ~10:00 AM EDT 2010/10/04), and when it loads up, I get dropped into the console, instead of GDM. My Xorg.0.log file shows the following errors:

    (EE) intel(0): Failed to allocate framebuffer.
    (EE) intel(0): Couldn't allocate initial framebuffer.

Has anybody seen this issue or know how to resolve it? I checked the bug tracker, and found [ticket #640432](https://bugs.launchpad.net/ubuntu/maverick/+source/xserver-xorg-video-nouveau/+bug/640432), but changing kernels doesn't fix my problem, so I think it might be something else.

Cliff Dyer (jcd-sdf) wrote :
Cliff Dyer (jcd-sdf) wrote :

Running X or xinit or startx from the command line, I also get:

    Fatal server error:
    AddScreen/ScreenInit failed for driver 0

Fabio Marconi (fabiomarconi) wrote :

Hello
have you tried reconfiguring xserver
sudo dpkg reconfigure-xserver-xorg
Fabio

Fabio Marconi (fabiomarconi) wrote :

oops
sudo dpkg-reconfigure xserver-xorg
sorry

Cliff Dyer (jcd-sdf) wrote :

Just tried it, and had no change in my error messages.

Fabio Marconi (fabiomarconi) wrote :

If not solve, can you run a live session and attach here
/var/log/syslog
/var/log/dmesg
/var/log/kern.log
/var/log/Xorg.0.log
of the damaged system.
Thanks
Fabio

Cliff Dyer (jcd-sdf) wrote :

I'm not sure if you meant something special by "run a live session, but I'm attaching the requested files from the failing system.

Cliff Dyer (jcd-sdf) wrote :
Cliff Dyer (jcd-sdf) wrote :
Cliff Dyer (jcd-sdf) wrote :
Fabio Marconi (fabiomarconi) wrote :

Perfect.
Thanks

affects: ubuntu → xserver-xorg-video-intel (Ubuntu)
Robert Hooker (sarvatt) wrote :

Can you please attach your /etc/X11/xorg.conf and try moving it out of the way so it is not used and then reboot? sudo mv /etc/X11/xorg.conf{,.bak} will do it.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Cliff Dyer (jcd-sdf) wrote :

Moving my xorg.conf out of the way allows me to get into X.

See attached file.

Robert Hooker (sarvatt) wrote :

Thanks, the problem is in libdrm and this is the fix for future reference on this bug

http://cgit.freedesktop.org/mesa/drm/commit/?id=726210f87d558d558022f35bc8c839e798a19f0c

affects: xserver-xorg-video-intel (Ubuntu) → libdrm (Ubuntu)
Changed in libdrm (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
summary: - X will not start on Acer Aspire One (intel drivers)
+ [945gme] Failed to allocate framebuffer with width >2048 with intel 2.12
+ drivers.
Robert Hooker (sarvatt) wrote :

Changing this to high importance, the 2048 width limit is easy to hit with with a multi monitor setup and the consequences of the bug are fatal enough to warrant it in my opinion. This particular case was because of an xorg.conf forcing a larger framebuffer but it can be reproduced by booting with 2 monitors plugged in with a combined width >2048 as well.

Cliff, can you please reenable your /etc/X11/xorg.conf and activate this PPA and tell me if it fixes the issue? It may take some time to build.

https://edge.launchpad.net/~sarvatt/+archive/yellow

Changed in libdrm (Ubuntu):
assignee: nobody → Robert Hooker (sarvatt)
importance: Medium → High
status: Confirmed → In Progress
Robert Hooker (sarvatt) on 2010-10-07
Changed in libdrm (Ubuntu):
status: In Progress → Fix Committed
Cliff Dyer (jcd-sdf) wrote :

I can confirm that it did indeed fix my problem, with the xorg.conf back in place. Thanks so much!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers