Ubuntu

Language-support-extra-de breaks OpenOffice spell checker in Jaunty

Reported by der_vegi on 2009-04-19
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by FriedChicken
Nominated for Karmic by FriedChicken
language-support-extra-de (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by FriedChicken
Nominated for Karmic by FriedChicken

Bug Description

See bug 329968.
hunspell-de-med in language-support-extra-de causes malfunction of openoffice's spell checker. It does not look like this issue will be fixed in time for Jaunty's release. Taking into account that everyone installing German language support over language-selector will be affected by this, I would suggest to remove hunspell-de-med as a workaround.

fx5 (packaging) wrote :

I can confirm this.

After a new installation of jaunty the system asked me to add the missing language-support. After doing so the spell-checking is broken.

"apt-get remove hunspell-de-med" fixes the bug.

This is a big problem, because every new german user will have broken spell-checking.

Uwe Mock (u-mock) wrote :

What a mess... I had the same problem: OpenOffice.org marked almost every single word as unknown. The workaround above worked - but this should be fixed ASAP.

knut (k-n-u-t) wrote :

yep, the dependency renders spellchecking useless for german; removal of hunspell-de-med solves the issue with language-support-extra-de removed either;
language-support-extra-de is installed by default in Ubuntu jaunty, so all german users won't have a working spellchecker;
suggestion: package "hunspell-de-med" should be suggested or proposed, not mandatory (fixinf the package would be cool either :)

FriedChicken (domlyons) wrote :

Please change dependecies of language-support-extra-de until the problem in hunspell-de-med is fixed.

For inexperienced users this problem will seem very "curious" and so I guess they won't even know, what they have to look for to workaround this bug.

Changed in language-support-extra-de (Ubuntu):
status: New → Confirmed
der_vegi (m-may) on 2009-05-26
summary: - Please remove hunspell-de-med in Jaunty
+ Language-support-extra-de breaks OpenOffice spell checker in Jaunty
Maurus (maurus-rman2) wrote :

I can confirm this bug for Kubuntu 9.0.4 Jaunty with OO 3.0.1. First I thought it was one of the usual Kubuntu translation problems...

Arne Goetje (arnegoetje) wrote :

The language-support-extra-* packages will go away in Karmic. No need to files this as a paper cut.

And regarding this bug report: I cannot reproduce this issue in Karmic with openoffice.org 3.1.0. I have all the German hunspell dicts installed, including the -med one and spellchecking works fine for me.

Can you please test, if this bug is still valid for Karmic? Thanks.

Changed in hundredpapercuts:
status: New → Invalid
Stagger (stagger-jmk) wrote :

I can confirm this bug in Karmic. I can reproduce it by deinstalling OpenOffice ("sudo apt-get remove openoffice*"), reinstalling it via the "ubuntu-desktop" package and then installing the German language support through System --> Systemverwaltung (Administration) --> Sprachunterstützung (Language support).

Stagger (stagger-jmk) wrote :

...forgot to add that "apt-get remove hunspell-de-med" fixed it for now.

jannollo (jannollo) wrote :

I can confirm this in Kubuntu 9.04 (KDE 4.2). I installed a different system language and for that reason my standard was added, too. Since then the problem appeared. I solved it removing hunspell-de-med.

Confirmed for Karmic Alpha 5, and I also had this bug in Jaunty (both with en_DK as the default locale plus German language support).

This needs to be fixed really urgently before Karmic is released, otherwise German-speaking users will be left without a working spell-checker in OpenOffice.org for yet another Ubuntu release cycle. Because that's just what this bug means: With hunspell-de-med installed, each and every non-medial term in any document will be marked as a spelling error. That's more than a paper cut, that's cerebral hemorrhage!

Sebastian Thürrschmidt wrote:
> Confirmed for Karmic Alpha 5, and I also had this bug in Jaunty (both
> with en_DK as the default locale plus German language support).
>
> This needs to be fixed really urgently before Karmic is released,
> otherwise German-speaking users will be left without a working spell-
> checker in OpenOffice.org for yet another Ubuntu release cycle. Because
> that's just what this bug means: With hunspell-de-med installed, each
> and every non-medial term in any document will be marked as a spelling
> error. That's more than a paper cut, that's cerebral hemorrhage!
>

It has been fixed already. Please remove the language-support-de-extra
package from your system, it isn't used anymore in Karmic and will be
removed from the archive soon.

Just for the record, I could not confirm that the spell checker is
broken after installing the medical dictionary has been installed. It
worked fine on my machine. Any steps to reproduce this?

> It has been fixed already.

That's great news, thank you very much!

> Any steps to reproduce this?

I did a fresh install of Karmic Alpha 5 (amd64, alternate installer), chosing en_DK as my default language as usual, then added language support for German as well as lots of other packages. Of course I kept my entire home directory from my previous Jaunty install, including hidden directories. And then, when I ran a spell-check in OpenOffice.org, I found that only medical terms where recognized, just like half a year ago in Jaunty. I can't tell you anything more specific then that, sorry.

Anyway, I removed hunspell-de-med, which in turn removed language-support-de-extra, and everything is fine again.

Arne Goetje (arnegoetje) wrote :

What I meant is, if the hunspell-de-med package is installed, how can I test if it breaks the spellchecking in oo.o? Do you have a sample text where I could see different results depending on if that package is installed or not?

Changed in language-selector (Ubuntu):
status: New → Fix Released
der_vegi (m-may) wrote :

German spell checker works for me now in Kubuntu Karmic Alpha 5, fresh install on USB disk.

Arne, here is random snippet of German text (taken from Pschyrembel's medical dictionary) that you can use to test the spellchecker:

Zur Erforschung des komplizierten Fortpflanzungszyklus seltener Steinlausarten wird experimentell versucht, diese durch Klonierung zu vermehren sowie deren Genom in einer Genbibliothek der Nachwelt zu hinterlassen.

When I spell-check this sentence with the language set to "Germany (Germany)" in OpenOffice.org 3.1.1 on Karmic Alpha 5/amd64, with hunspell-de-med NOT installed, "Steinlausarten" and "Klonierung" are the only words that are flagged as unknown.

On the other hand, when hunspell-de-med IS installed, each and every word single word is shown as "not in the dictionary", including for example "des" (a genitive singular form of the definite article, which must be among the ten or twenty most common words of the language). The suggestions listed are always medical or medical-sounding terms, like "Dermis" and "Delir" in the case of "des".

I hope this helps.

Vish (vish) on 2009-09-12
affects: hundredpapercuts → null
der_vegi (m-may) wrote :

Works as well in Ubuntu Alpha 6 (fresh install) for me after installing language-support.

der_vegi (m-may) wrote :

Ops. Ubuntu Karmic Alpha, I meant. *g

Catscrash (catscrash) wrote :

this happened again in current lucid for me

Just tried it in Lucid with Ooo 3.2, and it seems that the bug is back indeed, but ONLY if I manually install hunspell-de-med. language-support-extra-de, of which this used to be a part, is longer in the repositories at all (seems it was removed for Karmic). So for now I'd say the solution is simply not to install hunspell-de-med.

André Pirard (a.pirard) wrote :

There's a lot of reports around the Web
- that the de_med dictionary "no longer works"
- that it causes many collateral damages like crashing OOo

I'm surprised that nobody reported this:

$ hunspell -d de_med
Can't open affix or dictionary files.

According to man hunspell, there should be a
de_med.aff file in addition to de_med.dic
in the hunspell-de-med package.

Does "no longer work" mean "no longer work" or "causing problems"?

I think that that dictionary never worked since its introduction in Lucid.
Is that the reason for all your talk and the many problems?
Every fix I see is just dodging the problem.

Nominated for Jaunty, nominated for Karmic,
Can we hope that de_med.aff being added (back?) for Oneiric?

André Pirard (a.pirard) wrote :

$ hunspell -d de_med
Hunspell 1.2.8
ödem
*

öodem
& öodem 5 0: ödem, Ödem, Codein, demenz, Duodenum

I have written and attached a patch. It works for me.
Please have it validated by a doctor and a hunspell specialist, though.
According to the following, I know nothing about hunspell and languages ;-)
https://bugzilla.mozilla.org/show_bug.cgi?id=676500
I wouldn't like people to die on top of that ;-)

Remember that this bug causes many collateral damages !!!

Please include this patch as an update to all distributions where de_med.dic is present.
The attached file must be
/usr/share/hunspell/de_med.aff
/usr/share/myspell/dicts/de_med.aff --> symbolic link to the above one

To your health ;-)

Papou.

tags: added: patch
André Pirard (a.pirard) wrote :

Please ignore, or better erase that patch file and replace it with the symbolic links below.

That the lack of a de_med.aff file is an error is correct: the programs do not recognize that dictionary without it.
That its absence caused OpenOffice problems is possible.

With my file:

$ hunspell -d de_med
Hunspell 1.2.8
Abdomensonografiekontrollen
& Abdomensonografiekontrollen 4 0: Abdomensonografiekontrolle, Abdominalsonografisch, Abdomensono, Therapieverlaufskontrolle

the plural form is not recognized.
There must be a affix rule for plural in the .aff file.
Where is that file?

Without it, the best bet is to think that the rules are the same as for German.
And to add the following links instead.

/usr/share/hunspell/de_med.aff --> /usr/share/hunspell/de_DE.aff
/usr/share/myspell/dicts/de_med.aff -->/usr/share/hunspell/de_med.aff

With those aff rules, the plural is OK.

$ hunspell -d de_med
Hunspell 1.2.8
Abdomensonografiekontrollen
+ Abdomensonografiekontrolle

No guarantees that it's the correct aff file, though.

André Pirard (a.pirard) wrote :

I hacked hunspell-de-med_20100204-1_all.deb to apply what I say, plus=
- popping the version up to -2
- making hunspell-de-DE the only dependency.

Needs to check that de_DE.aff is a good aff file for de_med.dic

hunspell does correct checking.

After installing this DEB, Evolution detects the German (med) dictionary.
But Evolution seems to have a bug.

If Abdomensonografiekontrolle is typed, it is underline like a mistake.
Right click shows no suggestions.
Checking spelling shows strange suggestions

André Pirard (a.pirard) wrote :

I'm sorry. My above should be disregarded.
According to the following, de_med needs no .aff file of its own.

man hunspell
       -d en_US,en_geo,en_med,de_DE,de_med

       en_US and de_DE are base dictionaries, they consist of aff and dic
       file pairs: en_US.aff, en_US.dic and de_DE.aff, de_DE.dic. En_geo,
       en_med, de_med are special dictionaries: dictionaries without affix
       file. Special dictionaries are optional extension of the base dictio‐
       naries usually with special (medical, law etc.) terms. There is no
       naming convention for special dictionaries, only the ".dic" exten‐
       sion: dictionaries without affix file will be an extension of the
       preceding base dictionary (right order of the parameter list needs
       for good suggestions). First item of -d parameter list must be a base
       dictionary.

tags: removed: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.