knetworkmanager will no longer connect

Bug #259278 reported by Daniel Miles
240
This bug affects 11 people
Affects Status Importance Assigned to Milestone
knetworkmanager
Won't Fix
Medium
knetworkmanager (Ubuntu)
High
Jonathan Riddell
Nominated for Jaunty by naught101
Intrepid
High
Jonathan Riddell
knetworkmanager (openSUSE)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: network-manager-kde

As of the most recent update in Kubuntu Intrepid, Knetworkmanager will no longer connect to a wireless network for me. This is an unsecured network. It works fine with wired networks.

I'm pretty sure that the issue is with knetworkmanager rather than the backend, as I installed gnome's nm-applet and this connected fine to the same network.

Revision history for this message
Daniel Miles (themono) wrote :

I hope I'm correct subscribing you to this, Alexander - you seem to be the guru of all things NM0.7 so thought this should be seen by you.

Revision history for this message
Christophe Olinger (olingerc) wrote :

Same for me here. Intrepid kubuntu 64 bit fully updated. Wireless stopped working when I updated this morning.

Also, the wireless strength seems weaker than with hardy (a few days ago when it still worked)

Revision history for this message
Tore Anderson (toreanderson) wrote :

Confirmed (fully updated i386 Kubuntu, using iwl3945 on a Lenovo ThinkPad X61s). Reverting to NM0.6 resolves the issue.

Another thing worth noting is that the menu shown when the tray icon is clicked only shows my own wireless network (perhaps due to it being found in the configuration file). Not sure if this is intentional or not - NM0.6 behaviour was to show all networks in range (and GNOME's nm-applet still does after the upgrade). The box displayed by «Edit Connections... -> New Connection -> Wireless» shows a list of all networks in range, though.

Tore

Revision history for this message
Philipp Ehses (ehses-deactivatedaccount) wrote :

Confirmed here, too.

Until yesterday, I had this problem only with vpn-connections (which I rarely use). Wireless is of course much more important for me.

knetworkmanager does not even seem to try to connect to a network.

Daniel Miles (themono)
Changed in knetworkmanager:
status: New → Confirmed
Revision history for this message
Jeremy Wilkins (wjeremy) wrote :

I have done extensive testing on this issue and it doesn't even seem like KNetworkManager is doing anything at all. There are no debug messages. Its as if I clicked on a non-menu item when selecting a network. Even creating a new connection has no effect. I have tried both my Realtek 8185 using rtl8180 and my USB TrendNet TEW-424UB using zd1211rw. Both had no results.

Revision history for this message
Alexander Sack (asac) wrote :

Subscribed Jonathan who packaged the current knetworkmanager: did knetworkmanager upstream already update their svn to match the changed APIs on NM trunk?

Revision history for this message
Daniel Miles (themono) wrote :

Yes, to clarify on this, when i first switched to Alexander's PPA with NM 0.7, Knetworkmanager worked a treat. Same with the packages in Intrepid when 0.7 was brought in. But then the most recent update to Knetworkmanager killed it.

Revision history for this message
Luka Renko (lure) wrote :

I have the same problem on HP nw8440 with 3945ABG. It works fine if I use nm-applet (from network-manager-gnome) package.
I am using WPA2 Personal.

Revision history for this message
Luka Renko (lure) wrote :

It seems some API changes are in upstream SVN - not sure if this is enough:

r848503 | hschaa | 2008-08-18 00:56:31 +0200 (Mon, 18 Aug 2008) | 2 lines

Again NM API changes (breaks all VPNPlugins)

Revision history for this message
Christophe Olinger (olingerc) wrote :

Downlaoaded the kubuntu dailies from today and installed them. Wireless was ok. Then I did a full upgrade and now I have the same problems as before aka, wireless visible but it does not connect

Revision history for this message
Alexander Sack (asac) wrote : Re: [Bug 259278] Re: knetworkmanager will no longer connect

On Thu, Aug 21, 2008 at 05:44:28PM -0000, Christophe Olinger wrote:
> Downlaoaded the kubuntu dailies from today and installed them. Wireless
> was ok. Then I did a full upgrade and now I have the same problems as
> before aka, wireless visible but it does not connect
>

Can someone try if the new upstream sources work with the current NM
in my PPA?

 - Alexander

Revision history for this message
Christophe Olinger (olingerc) wrote :

Hey Alexander,

I enabled your ppa and upgraded. The "not connecting" problem still persists. I can see the connection but it won't connect. When I start knetworkmanager from the terminal and click on my wireless connection he just says "activate ...." with a long path containing freedesktop.org stuff. Sorry, I am on an another computer and can not verify.
Still connecting with nm-applet. Interestingly as soon as nm-applet is connected, knetworkmanager does so too!? It seems as if nm-applet helps knetworkmanager to overcome an obstacle?

- Christophe

Revision history for this message
Daniel Miles (themono) wrote :

As I understand it, Knetworkmanager sends a signal to the NM daemon to connect. The NM daemon sends back status messages, and Knetworkmanager updates the icon to reflect these.

What seems to be happening, is nm-applet sends the message to connect, which Knetworkmanager cannot do, but Knetworkmanager is still able to get the status updates back and update its icon. So it is really just reporting back on what nm-applet ordered.

Revision history for this message
waustin (waustin) wrote :

It's already confirmed, but one more can't hurt. I can connect to a wired network just fine, but wireless will not connect (though it is seen) as of 8/20.

Revision history for this message
hardhu (qzerty) wrote :

I have a similar problem here with intrepid. With knetworkmanager I can see my wireless network (and those of my neighbors too...) but when I try to associate nothing happens, regardless of the fact I am using authentication or not. It is also worth to mention that when knetwormanager is running, I cannot even connect to my wireless network using iwconfig: what I get is that my wireless card keeps on disassociating from the ap with error 'disassociate(reason=3)' when I force the association with iwconfig. If instead I quit knetworkmanager (be careful: I exactly mean 'quit', not switching on offline mode) then I can manually associate to the ap without problems and I can run dhclient with no problems.

Luka Renko (lure)
Changed in knetworkmanager:
importance: Undecided → High
milestone: none → intrepid-alpha-5
Revision history for this message
Pascal d'Hermilly (pascal-tipisoft) wrote :

I can confirm that this is still happening

Revision history for this message
Sokraates (sokraates) wrote :

This not only affects wireless WIFI but also wireless USB-modems (Huawei E220 here). The modem works with e.g. Vodafone Mobile Connect Card Driver (using it right now).

The symptoms are the same as with WIFI: The modem is shown as disconnected and can't be activated through knetworkmanager. It remains deactivated for knetworkmanager even though it is activated using another tool.

Revision history for this message
TFrog (stgparris) wrote :

I just reloaded Kubuntu 8.10 Alpha 4 again this morning and ran the updates. Even with the SVN version of knetworkmanager, I still am able to see the network that I connect to but no others (I know there are others around). I cannot connect though. My system is a Compaq R4125US laptop with a Broadcom 4318 wireless chipset. I have no problems with the base Alpha 4 and connecting. It's just after updating I'm unable to connect. I also noted the use of what appears to be the very latest kernel in this update (2.6.27). If I load regular Ubuntu 8.10 Alpha 4 I don't have this issue. I'll try again in a few days or after Alpha 5 is released. Otherwise, Kubuntu 8.10 looks promising.

Revision history for this message
hardhu (qzerty) wrote :

I don't know if this is related to this bug, however: today I connected for the first time my notebook to the wired network of the university where I work. I need to set a manual ip configuration with the ip address assigned to my notebook to have the connection working, even if the gateway I connect to has a dhcp server running (that is used for students that connect to the wireless netwok using a vpn client). What is happened is that knetworkmanager as boot establish a dhcp connection to the gateway, and it assigns me an ip address that doesn't work for me; then I create a new connection with the correct values for ip address and netmask, using the 'new connection' menu from knetworkmanager, and choosing the manual ip configuration. Neverthless, when I try to save the connection and to connect, nothing happens, and a look to syslog gives me this message:

Aug 29 14:33:18 eagle NetworkManager: <WARN> connection_get_settings_cb(): connection_get_settings_cb: Invalid connection: 'NMSettingIP4Config' / 'addresses' invalid: 1

Revision history for this message
Jonathan Riddell (jr) wrote :

"did knetworkmanager upstream already update their svn to match the changed APIs on NM trunk?"

No

Revision history for this message
TFrog (stgparris) wrote :

I just finished reloading Alpha 4 of Kubuntu 8.10 and updated it at around 7:30pm EST USA time today. Once rebooted to load new kernel and all updates knetworkmanager again showed the appropriate network to connect to but no others in the vicinity when I know there is at least 2 or 3 other networks. Again it failed to connect to the default (my network).

I attempted a manual configuration applying the appropriate information and knetworkmanager continued to fail to connect. This is a very odd issue. If I were to load Ubuntu 8.10 Alpha 4 with all updates I don't get this issue. Only with Kubuntu 8.10 Alpha 4 with all updates do I have this issue. I've also tried loading the KDE desktop on top of Ubuntu 8.10. the session manager will fail to locate KDE but that is another issue altogether.

Revision history for this message
Christophe Olinger (olingerc) wrote :

Will this be fixed for alpha 5? As far as I got it it is an upstream problem, isnt'it?

Revision history for this message
Alexander Sack (asac) wrote :

On Thu, Sep 04, 2008 at 10:54:13AM -0000, Christophe Olinger wrote:
> Will this be fixed for alpha 5? As far as I got it it is an upstream
> problem, isnt'it?
>

Yes, we are waiting for upstream knetworkmanager to support the latest
dbus API.

 - Alexander

Revision history for this message
Anish Bhatt (anish7) wrote :

Problem persists in Alpha 5. I can see connections, but cannot connect. Knetworkmanager fails silently, without giving any indication. No connection progress bar is seen either.

Revision history for this message
Alexander Sack (asac) wrote :

On Sat, Sep 06, 2008 at 01:25:37AM -0000, anish wrote:
> Problem persists in Alpha 5. I can see connections, but cannot connect.
> Knetworkmanager fails silently, without giving any indication. No
> connection progress bar is seen either.
>

could someone just try if the latest svn snapshot of knetworkmanger
works better?

 - Alexander

Revision history for this message
Oscar (osh-nbit) wrote :

Haven't tried the latest svn but I've noticed that things start to work after I kill wpa_supplicant. Before that everything is dead.
This is on Dell Latitude D810 (ipw2200).

Revision history for this message
Awaka (egf-vd-geer) wrote :

Kubuntu 8.10 alpha 5 full updated still got problem

Revision history for this message
KevinM (kevbert1) wrote :

Same problem here with Broadcom BCM4306 on Kubuntu 64bit kernel 2.6.27.2. Funnily enough I get two lots of my network shown when I click on available networks. The output from my card is reported as -27dB and input to it is 0 when using iwconfig??? I tried the same install method with Ubuntu 64bit (2.6.27.2) on the same PC and it works fine.

Revision history for this message
Santiago Zarate (foursixnine) wrote :

Same problem her :S

Revision history for this message
J Janz (jjanz) wrote :

The same still happens to alpha 5 updated till last night. It feels like it just misses start connecting, despite of creating/editing wireless connections correctly. BTW, I too feel a regression in functionality (that knm0.7's menu isn't showing available wireless networks as before, adding steps to what was simplier - as pointed previously here).

So, being these 2 issues, why don't we drop 0.7 and go back to a version that solves them (at least, till 0.7 is ok)?

Revision history for this message
Thomas Whm (twhm) wrote :

Maybe that this is not a problem of Knetworkmanager. Within alpha 5 a'm not able to connect to wireless network with iwconfig / dhclient:
*************************************************
ubuntu@ubuntu:~$ sudo ifconfig eth1 up
ubuntu@ubuntu:~$ sudo iwconfig eth1 mode managed key open s:xyzxyzxyzxyzx essid whmnet
ubuntu@ubuntu:~$ sudo dhclient eth1
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:13:ce:16:87:b5
Sending on LPF/eth1/00:13:ce:16:87:b5
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
*************************************************

Normally - in other versions - this will work fine.

I am using PRO/Wireless 2200BG Network Connection.

Revision history for this message
Oscar (osh-nbit) wrote :

To Thomas Whm.
Try killing wpa_supplicant and try that again. If that doesn't work also kill networkmanager.

This will give an idea on where the problem might be as I see it. If things start working after wpa_supplicant is dead, then the problem is probably there somewhere. Wouldn't you agree?

Revision history for this message
Thomas Whm (twhm) wrote :

Oscar, you are right. After killing processes 'NetworkManager' and 'wpa_supplicant' ifconfig, iwconfig and dhclient are working right. Thanks for your request.

Revision history for this message
Khem Raj (khem-raj) wrote :

killing newtworkmanager does not help. But killing wpa_supplicant helps however when I kill wpa_supplicant. System restarts it. So it never gets killed. I removed wpasupplicant package itself. Now that helps and I get connected to wireless network but when I reboot system it does not reconnect. Reinstalling wpasupplicant and rebooting again removing wpasupplicant helps.

Revision history for this message
Khem Raj (khem-raj) wrote :

Now I did replace /sbin/wpa_supplicant with a soft link to /bin/true (to make sure that it was wpa_supplicant) now I do

sudo ifconfig wlan0 up
sudo iwconfig wlan0 mode managed key xxxxxxxxxx essid MANIMAHESH
sudo dhclient3 wlan0

and it connects all the time.

Revision history for this message
Martin Nowack (martin-nowack) wrote :

Tested last revision (859085, 2008-09-09) from svn, doesn't work either.

Now, the funny thing: used the gnome applet in parallel which also tries to connect but does not work. But it seams to get a little bit further because it tries to connect and this is also indicated through knetworkmanager (rolling wheel and the half bar is shown).
I currently tried to connect to a WPA2 encrypted network which doesn't work. Can't change the encryption.

So maybe some of you should install package "network-manager-gnome" logout and loginto kde and then the applet is shown and try to connect through this if at least this works.

Revision history for this message
savasten (savasten) wrote :

"So maybe some of you should install package "network-manager-gnome" logout and loginto kde and then the applet is shown and try to connect through this if at least this works."

If I uninstall network-manager-kde and install the network-manager-gnome all is fine. I am using the latest SVN also.

Is this bug caused by the need/want to have NM-kde control WAN cards also? Does NM-kde work for any wi-fi?

Revision history for this message
Alexander Sack (asac) wrote :

On Tue, Sep 16, 2008 at 03:20:16PM -0000, savasten wrote:
> "So maybe some of you should install package "network-manager-gnome"
> logout and loginto kde and then the applet is shown and try to connect
> through this if at least this works."
>
> If I uninstall network-manager-kde and install the network-manager-gnome
> all is fine. I am using the latest SVN also.
>
> Is this bug caused by the need/want to have NM-kde control WAN cards
> also? Does NM-kde work for any wi-fi?
>

No ... atm you need to use nm-applet on kde to establish a connection.

 - Alexander

Revision history for this message
Dhaval Patel (dhuv) wrote :

Bal, which package contains nm-applet? I only see network-manager-kde and
network-manager-gnome.

Thanks,
Dhaval

Alexander Sack <email address hidden> wrote:

>On Tue, Sep 16, 2008 at 03:20:16PM -0000, savasten wrote:
>> "So maybe some of you should install package "network-manager-gnome"
>> logout and loginto kde and then the applet is shown and try to connect
>> through this if at least this works."
>>
>> If I uninstall network-manager-kde and install the network-manager-gnome
>> all is fine. I am using the latest SVN also.
>>
>> Is this bug caused by the need/want to have NM-kde control WAN cards
>> also? Does NM-kde work for any wi-fi?
>>
>
>No ... atm you need to use nm-applet on kde to establish a connection.
>
> - Alexander
>
>--
>knetworkmanager will no longer connect
>https://bugs.launchpad.net/bugs/259278
>You received this bug notification because you are a direct subscriber
>of a duplicate bug.

Revision history for this message
Alexander Sack (asac) wrote :

On Wed, Sep 17, 2008 at 12:09:25AM -0000, dhuv wrote:
> Bal, which package contains nm-applet? I only see network-manager-kde and
> network-manager-gnome.

The -gnome one.

 - Alexander

Jonathan Riddell (jr)
Changed in knetworkmanager:
milestone: intrepid-alpha-5 → ubuntu-8.10-beta
Changed in knetworkmanager:
status: Unknown → Confirmed
Changed in knetworkmanager:
status: Confirmed → Unknown
Changed in knetworkmanager:
status: Unknown → In Progress
Changed in knetworkmanager:
status: Confirmed → Fix Released
Changed in knetworkmanager:
status: In Progress → Fix Released
hardhu (qzerty)
Changed in knetworkmanager:
status: Fix Released → Confirmed
Steve Langasek (vorlon)
Changed in knetworkmanager:
milestone: ubuntu-8.10-beta → ubuntu-8.10
Changed in knetworkmanager:
assignee: nobody → jr
Jonathan Riddell (jr)
Changed in knetworkmanager:
status: Confirmed → Fix Released
Changed in knetworkmanager:
importance: Unknown → Undecided
status: Fix Released → New
mumismo (mumismo)
Changed in knetworkmanager:
status: Fix Released → Confirmed
46 comments hidden view all 126 comments
Revision history for this message
mumismo (mumismo) wrote :

Oh, I was wrong, the package is already using the new upstream code. According to the changelog of the the last update (October 26th) or network-manager-kde the new GUI is in fact using the new NM API, still it seems that some users have the problem.

Revision history for this message
WarrenTurkal (wturkal) wrote :

I have a IPW2200 and it works when I get my associate with WPA2 PSK
and get my address with DHCP. I don't know about the other cases.

wt

On Sat, Nov 1, 2008 at 8:04 AM, mumismo <email address hidden> wrote:
> Oh, I was wrong, the package is already using the new upstream code.
> According to the changelog of the the last update (October 26th) or
> network-manager-kde the new GUI is in fact using the new NM API, still
> it seems that some users have the problem.
>
> --
> knetworkmanager will no longer connect
> https://bugs.launchpad.net/bugs/259278
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Revision history for this message
Jeremy Wilkins (wjeremy) wrote :

This was probably already mentioned earlier, but what I have noticed is that my wireless works just fine with DHCP and WEP/WPA networks, but if the nm-applet (which is called network-manager-gnome in Ubuntu) is installed knetworkmanager doesn't work, but nm-applet does. If uninstalling nm-applet doesn't fix your problem, reinstall it and use it instead of knetworkmanager for now. I have found it generally better at supporting the NetworkManager core. I'm sure this will be fixed though, but probably for the next release of Ubuntu.

Revision history for this message
tzekwangteo (tkteo) wrote :

I was going to install network-manager-gnome in place of network-manager-kde, just to try to see if my situation is resolved. But as of right now, installing the -gnome version of the applet also entails installing additional packages such as libgweather, libsexy2, mobile-broadband-provider-info, notification-daemon, libpolkit-gnome0, libmbca0.

Is there a reason why there are so many additional dependencies for network-manager-gnome?

Revision history for this message
trylik (marek-nasionka) wrote :

it is working for me now

connectiong to WPA WEP as well

great job

Revision history for this message
jacoor (jacek-jacoor) wrote :

Hi
I had the problem as well - NM didn't connect after suspend to ram or reboot.
Trylik, could you please check if it does reconnect properly now after suspend to ram? Did You install the NM from official repos or somewhere else (link please)?
For now as a workaround i use wicd which works quite fine...

Thanks in advance for any information.

Revision history for this message
wli222 (wli222) wrote :
Download full text (11.1 KiB)

I have also a problem when connecting to my wireless device.

r
02:02.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
administrator@ubuntu:~$
administrator@ubuntu:~$ uname -a
Linux ubuntu 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686 GNU/Linux
administrator@ubuntu:~$

dmesg output

[ 24.671126] Yenta: Routing CardBus interrupts to PCI
[ 24.671131] Yenta TI: socket 0000:02:00.0, mfunc 0x01d21b22, devctl 0x64
[ 24.792533] ipw2200: Intel(;R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[ 24.792539] ipw2200: Copyright(c) 2003-2006 Intel Corporation
knetworkmanager console output[

administrator@ubuntu:~$ knetworkmanager
kbuildsycoca running...
NMSettings::NMSettings
restore setting: ConnectionSetting_rBMZwwOv5Kvy7oEl_connection
restore setting: ConnectionSetting_rBMZwwOv5Kvy7oEl_802-3-ethernet
restore setting: ConnectionSetting_rBMZwwOv5Kvy7oEl_ipv4
administrator@ubuntu:~$ Connection::GetSettings, obj: /org/freedesktop/NetworkManagerSettings/Connection/0
  Processing Setting 'connection'
  Attach setting 'connection'
    autoconnect: <bool>true</bool>
    id: <string>t</string>
    type: <string>802-3-ethernet</string>
    uuid: <string>rBMZwwOv5Kvy7oEl</string>
  Processing Setting '802-3-ethernet'
  Attach setting '802-3-ethernet'
    auto-negotiate: <bool>true</bool>
    mtu: <uint32>0</uint32>
    speed: <uint32>0</uint32>
  Processing Setting 'ipv4'
  Attach setting 'ipv4'
    ignore-auto-dns: <bool>false</bool>
    ignore-auto-routes: <bool>false</bool>
    method: <string>auto</string>
Connection::GetSettings, obj: /org/freedesktop/NetworkManagerSettings/Connection/0
  Processing Setting 'connection'
  Attach setting 'connection'
    autoconnect: <bool>true</bool>
    id: <string>t</string>
    type: <string>802-3-ethernet</string>
    uuid: <string>rBMZwwOv5Kvy7oEl</string>
  Processing Setting '802-3-ethernet' ...

Revision history for this message
trylik (marek-nasionka) wrote :

@jacoor

well most of the times it manages to connect even after suspend to RAM, but not all the time

for ex i have been at work and wpa wifi connection was active

then i moved to bluetooth hsdpa phone as internet source

then suspended to ram

then woken up at the cafe - no internet

then suspended to ram

then woken up at home - wifi connection active and working....

very strange

this is my version:
knetworkmanager:
  Installed: 1:0.7svn864988-0ubuntu1
  Candidate: 1:0.7svn864988-0ubuntu1
  Version table:
 *** 1:0.7svn864988-0ubuntu1 0
        500 http://pl.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

i cleared my /etc/network/interfaces file to have it working, maybe try this?

Revision history for this message
jacoor (jacek-jacoor) wrote :

@trylik
Thanks for your answer - I tried everything with old version of NM (restarting HAL, clearing config files, restarting networking)
and.. The only thing that worked from time to time was right key on tray icon, disable wireless, wait a minute, enable and try to connect.
I think I will watch this topic and for now I stay with wicd - works just fine.

Thanks again for posting.

Changed in knetworkmanager:
status: Unknown → Confirmed
Revision history for this message
naught101 (naught101) wrote :

I'm also having this problem. Can see wireless connections, can't connect.

02:03.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

Revision history for this message
grahamt (grahamtooley) wrote :

I had this bug, and I've resolved it (at least for me).

I'm using Kubuntu Intrepid with Proposed updates on a Acer Travelmate 520 with a Linksys Broadcom bcm43 PCMCIA wireless card.

This setup worked fine under Hardy, but I suffered from this bug after upgrade to Intrepid.

A comment above suggested I use nm-applet as a workaround replacement for knetworkmanager.

In order to avoid I conflict, I thought it best to apt-get remove knetworkmanager prior to installing nm-applet. But apt-get reported that knetworkmanger was _NOT_ installed (!?).

So I ran 'apt-get install knetworkmanager' which apt-get reported as installing normally, rebooted, and now it's connecting working fine...

Revision history for this message
Chekio (atsergio) wrote :

Yo solucione el bug:

Visite la web de mi ISP y alli tenia tb la clave de acceso wifi en forma hexadecimal. Edite la conexion y puse la constraseña en formato hexadecimal y por fin fue¡¡¡

I resolved this bug:

I went to ISP web, and there I take a hexadecimal access. I use this code to enter in my wifi conexions. Its done¡¡

Revision history for this message
jacoor (jacek-jacoor) wrote :

Grahamt method worked for me too. I installed KnetworkManager today again (removing WICD at the same time) and now when I suspend to ram and change networks it works fine.
If something breakes I let you know.

Thanks Grahamt.

Revision history for this message
naught101 (naught101) wrote :

grahamt: the knetworkmanager in the intrepid repos is a dummy package - it doesn't do anything by itself, it just depends on netowrk-manager-kde (which is knetworkmanager renamed). If you installed from a CD, knetworkmanager shouldn't be installed, and installing it won't change anything (unless network-manager-kde also wasn't installed). If you upgraded, the Hardy knetworkmanager is replaced with the dummy package, which requests that network-manager-kde is installed.

In otherwords, if you already had the knetworkmanager program running, then installing the knetworkmanager doesn't make a difference.

The only reason that might have fixed your problem, that I can think of, is that network-manager-kde was somehow reconfigured at the same time, however, I tried "sudo dpkg-reconfigure network-manager-kde" and it didn't fix anything for me.

Revision history for this message
naught101 (naught101) wrote :

changing this back, since I'm using 1:0.7svn864988-0ubuntu1 and it's still not working...

Changed in knetworkmanager:
status: Fix Released → Confirmed
Revision history for this message
naught101 (naught101) wrote :

nominating for jaunty since network-manager-kde is the same version in both, as is network-manager.

Revision history for this message
naught101 (naught101) wrote :

just checked out and compiled from svn from instructions at http://en.opensuse.org/Projects/KNetworkManager#Download

Checked out revision 887865.

No joy.

Revision history for this message
naught101 (naught101) wrote :
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Your bug is entirely different than this API change bug. They just happen to have the same symptom, non-working wireless.

Changed in knetworkmanager:
status: Confirmed → Fix Released
status: Confirmed → Fix Released
Revision history for this message
naught101 (naught101) wrote :

Jonathan: There is no info in the bug to indicate it's an API problem. Perhaps the details should be edited to suit, and I can open a new bug.

Revision history for this message
Jonathan Thomas (echidnaman) wrote :
Revision history for this message
Alexander Sack (asac) wrote :

On Mon, Nov 24, 2008 at 12:45:50PM -0000, Jonathan Thomas wrote:
> See: https://bugs.launchpad.net/ubuntu/+source/knetworkmanager/+bug/259278/comments/6
> https://bugs.launchpad.net/ubuntu/+source/knetworkmanager/+bug/259278/comments/9
> https://bugs.launchpad.net/ubuntu/+source/knetworkmanager/+bug/259278/comments/20
> and https://bugs.launchpad.net/ubuntu/+source/knetworkmanager/+bug/259278/comments/48
>

Jonathan, consider to change the bug title to something more specific
than "will not connect". otherwise folks will reopen this bug in two
years still ;) ....

Thanks!

 - Alexander

Revision history for this message
mrvanes (mrvanes) wrote :

This problem is still present in Jaunty, network-manager-kde 0.7svn864988-0ubuntu8. nm-applet works fine.

Revision history for this message
Jose Bernardo (bernardo-bandos) wrote :

Yes, this one is back in jaunty. But wireless in jaunty seems pretty bad right now. On my aspire one, besides knetwork manager no longer working (again) ath5k drivers will keep roaming away from the AP when there is more than one AP with the same SSID, and since cfg80211 has been updated and no longer supports "ieee80211_regdom" and "iw reg set" doesn't work yet, you're now stuck to channels 1-11 instead of 1-13.

Revision history for this message
WarrenTurkal (wturkal) wrote :

Are you using knetworkmanger? I believe the KDE 4.2 includes a plasma
applet for interacting with network manager. Try adding an applet and
seeing if you can find a network manager related one. Please keep in
mind that I am not running Jaunty and don't know if it includes this
functionality.

On Thu, Feb 19, 2009 at 8:04 AM, Jose Bernardo <email address hidden> wrote:
> Yes, this one is back in jaunty. But wireless in jaunty seems pretty bad
> right now. On my aspire one, besides knetwork manager no longer working
> (again) ath5k drivers will keep roaming away from the AP when there is
> more than one AP with the same SSID, and since cfg80211 has been updated
> and no longer supports "ieee80211_regdom" and "iw reg set" doesn't work
> yet, you're now stuck to channels 1-11 instead of 1-13.
>
> --
> knetworkmanager will no longer connect
> https://bugs.launchpad.net/bugs/259278
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Revision history for this message
mrvanes (mrvanes) wrote :

Yes, Jaunty has quite usable plasma-widget-network-manager some time now. I tried it a couple of weeks ago but wasn't impressed. It's actually usable now and fixes the problems with knetworkmanager most importantly!

Revision history for this message
charles.figura (charles-figura) wrote :

I've been running the network-manager plasmoid for about a week. I've found the following results:
1. WEP networks seem to work fine, whether they are DHCP or static-IP. I still need a few tests on the static IP, but it *appears* to be working.
2. LEAP and PEAP networks do NOT work at all. I've had ZERO success in these.
These results are the same as for knetworkmanager for me.

In all cases, nm-applet works fine, so the problem is clearly with the front-end (the plasmoid or knetworkmanager)

Revision history for this message
TGM (tommann.home) wrote :

Just today (8.30 GMT) I reinstalled Kubuntu Jaunty Alpha 4, and dist-upgraded to the current state.
The network manager plasmoid still shows a greyed out wlan0 with an enable switch, which will not turn on.

Am I missing something? - some people seem to have more luck than me.

I have tried "sudo iwlist wlan0 scan" and can see my access point, on WPA2 encryption. Can't quite figure how to bring it up manually.

Revision history for this message
mrvanes (mrvanes) wrote :

This might be related to a rf-kill switch bug in iwl3945. It should work if you start with rf-kill disabled (ie wireless enabled).

Revision history for this message
Jose Bernardo (bernardo-bandos) wrote :

Try adding "blacklist acer-wmi" to /etc/modprobe.d/blacklist, might fix the issue.

Revision history for this message
TGM (tommann.home) wrote :

Jose,

Blacklisting acer_wmi worked brilliantly, thanks :)
Can confirm as today my wireless (WPA2) connects.

Revision history for this message
DaveQB (david-dward) wrote :

I can confirm mrvanes comment

>This problem is still present in Jaunty, network-manager-kde 0.7svn864988-0ubuntu8. nm-applet works fine.

Trying with a Virgin Mobile Huawei E169 [detecting as a E620]

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

ii network-manager 0.7.1~rc4.1.cf199a964-0ubuntu network management framework daemon
ii network-manager-gnome 0.7.1~rc4.1-0ubuntu2 network management framework (GNOME frontend)
ii network-manager-kde 1:0.7svn864988-0ubuntu8 KDE systray applet for controlling NetworkManager

Revision history for this message
Iñaki Baz Castillo (ibc-aliax) wrote :

kubuntu jaunty 64 bits with KDE 4.3.2.

I had a WiFi router with no WPA/WEP security, just MAC access, and it worked perfectly for me with knetworkmanager v0.9.

I've changed my router but configured it in a similar way (MAC access and no more security). Now knetworkmanager doesn't connect to it, but of course it still can connect to the previous WiFi (the old router).

However if I use Gnome's nm-applet I can connect to the new WiFi.

ii network-manager 0.7.1~rc4.1.cf199a964-0ubuntu2
ii network-manager-gnome 0.7.1~rc4.1-0ubuntu2
rc network-manager-kde 1:0.7svn864988-0ubuntu8
ii plasma-widget-network-manager 0.9~svn1029786-0ubuntu2.1~jaunty1

Note that I've installed plasma-widget-network-manager and not network-manager-kde.

Revision history for this message
Iñaki Baz Castillo (ibc-aliax) wrote :

In fact, if I install network-manager-kde it can connect to the new WiFi.

Revision history for this message
Iñaki Baz Castillo (ibc-aliax) wrote :

And after it, I've reinstalled plasma-widget-network-manager again and now it works ¿?¿?

tags: added: iso-testing
Changed in knetworkmanager:
status: Confirmed → Won't Fix
savasten (savasten)
Changed in knetworkmanager (openSUSE):
status: New → Fix Released
Revision history for this message
TGM (tommann.home) wrote :
Revision history for this message
TGM (tommann.home) wrote : [URGENT] Please ignore previous emails from my address today

Today my email account was broken into and I have evidence of someone
spamming. you should ignore any previous emails from me today.

Tom

Revision history for this message
TGM (tommann.home) wrote :

Apologies. I've had my email hacked. Please remove the above.

Revision history for this message
TGM (tommann.home) wrote :
Revision history for this message
TGM (tommann.home) wrote :

Apologies again... This works for me so I'll unsubscribe.

Changed in knetworkmanager:
importance: Unknown → Medium
Displaying first 40 and last 40 comments. View all 126 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.