Unable to make any changes in Date / Time kcontrol

Bug #312569 reported by Johann MacDonagh on 2008-12-31
108
This bug affects 10 people
Affects Status Importance Assigned to Milestone
KdeSudo
Undecided
Anthony Mercatante
kdesudo (Ubuntu)
Critical
Anthony Mercatante
Declined for Jaunty by Harald Sitter
Declined for Karmic by Harald Sitter
Declined for Lucid by Harald Sitter

Bug Description

Binary package hint: systemsettings-kde4

I'm running the KDE 4.2 Beta 2 packages in Kubuntu 8.10.

The "Date & Time" systemsettings module does not properly call kdesudo so any operations it tries (such as changing the time, utilizing NTP, or changing the time zone), fail.

When I enter the Date & Time module and make any change and click Apply the following message boxes pop up:
"Unable to contact time server: ."
"Can not set date."
"Error setting new time zone."

If I run systemsettings from a terminal, I get the following output:
systemsettings(15442) Dtime::save: Set date QDateTime("Tue Dec 23 22:32:42 2008")
kdesu: Unknown option 'attach'.
kdesu: Use --help to get a list of available command line options.

I have also tried running systemsettings using kdesudo and sudo with the same result. It appears that the applet attempts to run the commands using kdesudo regardless of whether it is running as root or not.

Related branches

Harald Sitter (apachelogger) wrote :

Actually.
It appears that kdesudo is incompatible with kdesu as of KDE 4.2.

kdesu now got --attach to attach the dialog to a parent window, while kdesudo doesn't have this option. Moving bug to kdesudo package. Critical Importance since the only way kdesudo can replace kdesu is maintaining option compability.

Changed in kdebase-workspace:
importance: Undecided → Critical
milestone: none → ubuntu-9.04
status: New → Confirmed
Changed in kdesudo:
assignee: nobody → tonio
assignee: nobody → tonio
salim (salim-h007) on 2009-02-16
Changed in kdesudo:
status: Confirmed → Fix Released
Jo (16303-gmx) wrote :

Same problem here with kubuntu 8.10 and KDE 4.2

So is it true that during the last 30 days no kubuntu intrepid ibex user has been able to change date or time from within KDE??

Rup.Xamqon (rupxamqon) wrote :

Confirmed.
I found this bug only now, and had to use CL to change timezone (sudo dpkg-reconfigure tzdata).

pjina3 (pjina3) wrote :

I found this bug also
but I change the time and date by using date command

for example,
to set "Mar 1 14:07:00 2009"
you type this command in Terminal (Konsole)
    sudo date 030114072009

Hope this bug is solved soon :)

Leon Maurer (leon-n-maurer) wrote :

Any idea how to use the command line to change it to set the date and time automatically?

Rup.Xamqon (rupxamqon) wrote :

I found in http://kubuntuforums.net/forums/index.php?topic=3101221 this command:
      sudo ntpdate pool.ntp.org
In my case no need to kill ntpd, as the first poster wrote.

I fear it is a one time command (no permanent time update).

Jonathan Thomas (echidnaman) wrote :

Not fixed. I still experience this with an updated Jaunty.

Changed in kdesudo:
status: Fix Released → Triaged
Jonathan Thomas (echidnaman) wrote :

I believe the root of the problem is that kdesudo thinks that all the flags that may be passed to an application are his, when they may be directed towards the program is running.

I've got the same error in Kubuntu 9.04. I tried to use 'kdesudo systemsettings' to change time, but it restores previous values in a second.

kwilliam++ (kwilliam++) wrote :

Helpful tip: For those who want to change their timezone NOW, rather than wait for a fix, try running "sudo dpkg-reconfigure tzdata" from the command line.

auxbuss (launchpad-auxbuss) wrote :

This was marked critical in January and it's still broken. Makes things unusable for a traveller with laptop that doesn't speak geek.

Anthony Mercatante (tonio) wrote :

I'll have a look at this one toonight...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdesudo - 3.4.1-0ubuntu1

---------------
kdesudo (3.4.1-0ubuntu1) jaunty; urgency=low

  * New upstream release:
    - Closes LP: #351238
    - Closes LP: #312569

 -- Anthony Mercatante <email address hidden> Wed, 08 Apr 2009 23:06:38 +0200

Changed in kdesudo (Ubuntu):
status: Triaged → Fix Released
Didier Raboud (odyx) on 2009-05-01
Changed in kdesudo:
status: New → Fix Released
Changed in kdesudo:
status: Fix Released → Fix Committed
status: Fix Committed → Confirmed
Changed in kdesudo (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Confirmed
Changed in kdesudo (Ubuntu):
status: Confirmed → Fix Released
Changed in kdesudo:
status: Confirmed → Fix Released
Tomas Gustavsson (tomplast) wrote :

This was fixed over half a year ago? I really hope that this ain't my bug. Me neither can change the time/date settings in systemsettings. All I get is "You are not allowed to save the configuration".

Mark Schmidt (schmidtm) wrote :

This is not fixed in Lucid on amd64. I can not activate the option "set date and time automatically". I get an error on applying. The error message is the following "Authentifizierung nicht möglich, Aktion kann nicht ausgeführt werden: 4, " - which means that there is a problem with the authentication and the action cannot performed for that reason.

Changed in kdesudo (Ubuntu):
status: Fix Released → Confirmed
Changed in kdesudo:
status: Fix Released → Confirmed
Jonathan Thomas (echidnaman) wrote :

Different issue, which should also be fixed by now.

Changed in kdesudo:
status: Confirmed → Fix Released
Changed in kdesudo (Ubuntu):
status: Confirmed → Fix Released
TrReardon (tr-reardon) wrote :

How is this fixed? Still not able to "Set Date and Time Automatically".

I suppose "cannot make any changes" is fixed, but "cannot make some changes" is not fixed.

Liviu Beraru (beraru-liviu) wrote :

Kubuntu Lucid Beta 1, last updates, as of April, 7 2010, running on a Lenovo S12 and Toshiba Satellite L40.
If I click on "Set date and time automatically" I am prompted for password which I enter and then I get the message: "Unable to contact time server: de.pool.ntp.org."
Runing sudo ntpdate -u de.pool.ntp.org works so there is no problem with the ntp client or the server.

Also, running Lucid Beta somehow slows down the clock on the Lenovo machine so that after just one hour of uptime the system clock runs half an hour after. If I boot XP and just let it run, the system clock is correct even after 2 hours of running. I experience the same runnig the live cd.

OrionVII (orionxvii) wrote :

exact the same problem with kubuntu 9.10 KDE 4.4.2

Stan (brusco) wrote :

Still not fixed on Kubuntu 10.10 KDE 4.5.1.

When I try to change time servers from the settings panel, I get "unable to contact time server". I need to hack the ntpd and ntpdate config files to make any changes.

Curtis Grote (cgrote) wrote :

Using Kubuntu 10.10 and have upgraded to KDE 4.6

I am also still running into the same issue trying to update time servers from the settings panel. I get "unable to contact time server". I then need to stop the ntp deamon and run ntpdate xxx.xxx.xxx.xxx from the command line to correct the time on my PC.

Paul Abrahams (abrahams) wrote :

Running Natty under VirtualBox, the problem does not occur. I set the time manually to a different date and time and then did the automatic setting. It worked. However, the fact that I was running Natty in a virtual environment might be relevant -- I don't know.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers