kdegraphics-thumbnailers 4:15.12.3-0ubuntu1 uses the wrong path for plugin libraries

Bug #1574049 reported by Stéphane on 2016-04-23
74
This bug affects 17 people
Affects Status Importance Assigned to Milestone
KDE Graphics
Fix Released
High
Kubuntu PPA
Undecided
Unassigned
kdegraphics-thumbnailers (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

kdegraphics-thumbnailers 4:15.12.3-0ubuntu1 puts gsthumbnail.so and rawthumbnail.so under /usr/lib/x86_64-linux-gnu/plugins/ (see http://packages.ubuntu.com/xenial/amd64/kdegraphics-thumbnailers/filelist for the newest package file listing).
Dolphin looks for plugins under /usr/lib/x86_64-linux-gnu/qt5/plugins/ (see http://packages.ubuntu.com/xenial/amd64/dolphin/filelist for the newest package file listing).
Because of the discrepancy between the two pathes Dolphin is unable to invoke kdegraphics-thumbnailers.

This can be reproduced with the Kubuntu 16.04 LTS live image. After installing kdegraphics-thumbnailers and activating it under the Dolphin preferences no thumbnails are generated for PDF files.

There is a workaround until the package is fixed. This command will link all the files from /usr/lib/x86_64-linux-gnu/plugins/ to /usr/lib/x86_64-linux-gnu/qt5/plugins/:

sudo ln -s /usr/lib/x86_64-linux-gnu/plugins/* /usr/lib/x86_64-linux-gnu/qt5/plugins/

The installation routine of the package should be fixed to unpack gsthumbnail.so and rawthumbnail.so under /usr/lib/x86_64-linux-gnu/qt5/plugins/.

Dolphin preferences dialog, Previews tab has a list of file types to preview, but since version 15.08 the list shortened a lot, some file types disappeared (pdf, for instance).

Reproducible: Always

Steps to Reproduce:
1. Open a folder with pdf in its contents.
2. Change view mode to icons (Ctrl + 1)
3.

Actual Results:
No pdf and some other file types previews.

Expected Results:
Show the file previews

Thanks for the bug report, but this is most likely not a Dolphin issue (unless you get these previews in the file dialog of, e.g., KWrite, and in Folder View). Dolphin itself cannot create thumbnails for anything at all, it relies on external preview plugins for this. It seems that the necessary plugins are not installed on your system. It could be that the plugins were not ported to Qt5/KF5 yet, but I do not now where to find the source for the PDF plugin at the moment, so I cannot check that, but maybe someone else has an idea.

Probably related to this:
https://bbs.archlinux.org/viewtopic.php?id=201484

It looks like you're on Arch too. I installed the ffmpegthumbs-git package from the AUR, and then a new option became available in the list under Dolphin's preview preferences (which you referred to): "Video files (ffmpegthumbs)".
I still don't have PDF thumbnails again either, but getting video thumbnails back (in addition to the picture thumbnails I still have) is a start. This happened after I updated to the most recent KDE available in the testing repos.

The PDF plugin for the KF5 is available: https://projects.kde.org/projects/kde/kdegraphics/kdegraphics-thumbnailers -> https://projects.kde.org/projects/kde/kdegraphics/kdegraphics-thumbnailers/repository/show?rev=frameworks

Before. With the Archlinux/Dolphin - no plugin for the PDF: http://imgur.com/VjtpkMF

After. Downloading the kdegraphics-thumbnailers KF5 git source, building, installing it. There is plugin for the http://imgur.com/7Tjsk41 .

Same kind of (missing plugins): https://bugs.kde.org/show_bug.cgi?id=351894

And the thumbnailing is working

(In reply to Rog131 from comment #3)
> The PDF plugin for the KF5 is available:
> https://projects.kde.org/projects/kde/kdegraphics/kdegraphics-thumbnailers
> ->
> https://projects.kde.org/projects/kde/kdegraphics/kdegraphics-thumbnailers/
> repository/show?rev=frameworks
>
> Before. With the Archlinux/Dolphin - no plugin for the PDF:
> http://imgur.com/VjtpkMF
>
> After. Downloading the kdegraphics-thumbnailers KF5 git source, building,
> installing it. There is plugin for the http://imgur.com/7Tjsk41 .
>
> Same kind of (missing plugins): https://bugs.kde.org/show_bug.cgi?id=351894
>
> And the thumbnailing is working

Didn't work for me. At least this command sequence din't work:

# pacman -R kdegraphics-thumbnailers
$ git clone http://anongit.kde.org/kdegraphics-thumbnailers
$ cd kdegraphics-thumbnailers
$ cmake .
$ make
# cmake -P cmake_install.cmake

Messages say all is correct built and correct installed but still I get no pdf in the list of previews. What's wrong?

At here:

Installing:
libkexiv2-frameworks-git: https://aur.archlinux.org/packages/libkexiv2-frameworks-git/
libkdcraw-frameworks-git: https://aur.archlinux.org/packages/libkdcraw-frameworks-git/

Downloading/compiling/Installing:
$ git clone git://anongit.kde.org/kdegraphics-thumbnailers
$ cd kdegraphics-thumbnailers
$ git checkout origin/frameworks
$ mkdir -p builddir
$ cd builddir && cmake .. -DCMAKE_INSTALL_PREFIX=$(kf5-config --prefix) -DCMAKE_BUILD_TYPE=Release -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
$ su
# make install

Full - input/output: http://pastebin.com/stX7Qg2Q

Enabling the plugins: Dolphin -> Settings -> General/Previews

Working at here: http://imgur.com/kZawTZ1

Thank you Rog131 and austin.hoppe7. Now I got pdf and video thumbnails back.

I lost ability to see previews for JPEGs in 15.08. I've heard that in 15.08 package responsible for generating thumbnails is kio-extras, which I have installed (15.08.0), but… I still don't get any thumbnails for images. Anyone have a clue?

(In reply to Michał from comment #7)
> I lost ability to see previews for JPEGs in 15.08. I've heard that in 15.08
> package responsible for generating thumbnails is kio-extras, which I have
> installed (15.08.0), but… I still don't get any thumbnails for images.
> Anyone have a clue?

It appears to me that the fix is sitting in the origin/frameworks branch and hasn't been merged into the master yet.

*** Bug 353714 has been marked as a duplicate of this bug. ***

I too have experienced this problem on debian/testing for a fortnight.
Why is this bug still "unconfirmed"?

marking confirmed, probably should be triaged to kdegraphics-thumbnailers though (not sure where that is in bugzilla)

(In reply to Rex Dieter from comment #11)
> marking confirmed, probably should be triaged to kdegraphics-thumbnailers
> though (not sure where that is in bugzilla)

It might not have a bugzilla component at all. Maybe kio/thumbnail is the closest match.

*** Bug 354426 has been marked as a duplicate of this bug. ***

*** Bug 354504 has been marked as a duplicate of this bug. ***

Same error/bug in Kubuntu 15.10

kdegraphics-thumbnailers 4:15.08.2-0ubuntu1 :
usr/share/kde4/services/gsthumbnail.desktop
/usr/share/kde4/services/rawthumbnail.desktop
/usr/share/doc/kdegraphics-thumbnailers
/usr/share/doc/kdegraphics-thumbnailers/copyright
/usr/share/doc/kdegraphics-thumbnailers/changelog.Debian.gz
/usr/lib/kde4/rawthumbnail.so
/usr/lib/kde4/gsthumbnail.so

kio-extras 4:15.08.2-0ubuntu1 :
/usr/share/lintian/overrides/kio-extras
/usr/share/doc/kio-extras/copyright
/usr/share/doc/kio-extras/changelog.Debian.gz
/usr/lib/x86_64-linux-gnu/qt5/plugins
/usr/lib/x86_64-linux-gnu/qt5/plugins/kfileaudiopreview.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/man.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/filenamesearch.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/recentdocuments.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/mtp.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/nfs.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/sftp.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/info.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/bookmarks.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/fish.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/settings.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/smb.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/thumbnail.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/filter.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/archive.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/network.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/libkmanpart.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/jpegthumbnail.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/textthumbnail.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/svgthumbnail.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kded_networkwatcher.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/comicbookthumbnail.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kio_about.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/imagethumbnail.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/kded_recentdocumentsnotifier.so
/usr/lib/x86_64-linux-gnu/libmolletnetwork5.so.5.3.90
/usr/lib/x86_64-linux-gnu/libmolletnetwork5.so.5

This is a big problem to some users that we have in production :(

Both kdegraphics and ffmpeg thumbnailers will be released with a KF5 port together with KDE Applications 15.12. Thanks to Hrvoje Senjan from openSUSE KDE team for the porting.

*** Bug 358835 has been marked as a duplicate of this bug. ***

I see that this bug is resolved and from last comment I conclude that this should be fixed in kde-applications 15.12, is this correct?
I have version 15.12 and I still don't have any thumbnails. I rechecked that I have previews enabled in Dolphin's configuration. Is there anything else I need to do?

I use Arch Linux.

do you have kdegraphics-thumbnailers-15.12.x installed?

I have just installed it *and* I needed to enable previews in menu again (disable then enable) and it started to work. Thank you. :-)

Stéphane (stephane-treboux) wrote :

I just noticed that the proposed fix fails when the package kio-extras is not installed. Currently the package kdegraphics-thumbnailers does not depend on kio-extras. Could that be changed too? Thanks!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kdegraphics-thumbnailers (Ubuntu):
status: New → Confirmed

*** Bug 354504 has been marked as a duplicate of this bug. ***

I still seem to face problems with PDF files. I can now select them for preview, but the preview does not happen for PDFs. Only images and other files (text,fonts,etc.). It does not view them in the preview panel either. What am I missing ?

Kubuntu 16.04
KDE Frameworks 5.18.0
Qt 5.5.1
Dolphin 15.12.3
kdegraphcs-thumbnailers 15.12.3

Found the issue, as well as links to bugs and a temporary solution:
http://osdir.com/ml/ubuntu-bugs/2016-04/msg19852.html

Another workaround for video preview is to compile ffmpegthumbs from source:

sudo apt-get install git build-essential cmake extra-cmake-modules kio-dev pkg-config libavformat-dev libavcodec-dev libswscale-dev

git clone git://anongit.kde.org/ffmpegthumbs

cd ffmpegthumbs

git checkout origin/frameworks

mkdir -p builddir

cd builddir && cmake .. -DCMAKE_INSTALL_PREFIX=$(kf5-config --prefix) -DCMAKE_BUILD_TYPE=Release -DKDE_INSTALL_USE_QT_SYS_PATHS=ON

sudo make install

After executing the above commands, a "Video Files (ffmpegthumbs)" option should be available in the Control/Configure Dolphin/General/Previews tab.

The problem here is no longer the absence of the option (which is now there) but the fact that it has no effect.
Having the libs in the right place makes them work. The link goes to a post that lists 2 bugs files against the packaging for Ubuntu that will eventually solve the second problem.

I can confirm that
sudo ln -s /usr/lib/x86_64-linux-gnu/plugins/* /usr/lib/x86_64-linux-gnu/qt5/plugins/

fixes the problem.

I too can confirm that this bug is NOT fixed. After creating the symlinks as in Alexander's post video thumbs as well as PDF thumbs started to work.
Using Kubuntu 16.04 64-bit

I can also confirm that I had no PDF previews.

I had to:
1. Install kdegraphics-thumbnailers

2. Run sudo ln -s /usr/lib/x86_64-linux-gnu/plugins/* /usr/lib/x86_64-linux-gnu/qt5/plugins/

For PDF previews to start working.

(In reply to fleury from comment #22)
> I still seem to face problems with PDF files. I can now select them for
> preview, but the preview does not happen for PDFs. Only images and other
> files (text,fonts,etc.). It does not view them in the preview panel either.
> What am I missing ?
>
> Kubuntu 16.04
> KDE Frameworks 5.18.0
> Qt 5.5.1
> Dolphin 15.12.3
> kdegraphcs-thumbnailers 15.12.3

Ubuntu packaging bug: https://bugs.launchpad.net/ubuntu/+source/kdegraphics-thumbnailers/+bug/1574049

Should be fixed downstream.

(In reply to Fritigern from comment #27)
> I too can confirm that this bug is NOT fixed. After creating the symlinks as
> in Alexander's post video thumbs as well as PDF thumbs started to work.
> Using Kubuntu 16.04 64-bit

Another Ubuntu packaging bug: https://bugs.launchpad.net/ubuntu/+source/ffmpegthumbs/+bug/1574037

Should be fixed by Ubuntu packagers....

Changed in kdegraphics:
importance: Unknown → High
status: Unknown → Fix Released
tags: added: xenial
Changed in kubuntu-ppa:
status: New → Confirmed
Changed in kdegraphics-thumbnailers (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Philip Muškovac (yofel) on 2016-07-14
Changed in kdegraphics-thumbnailers (Ubuntu Xenial):
importance: Undecided → Medium
status: New → Triaged
Philip Muškovac (yofel) on 2016-07-14
tags: added: kubuntu

*** Bug 365972 has been marked as a duplicate of this bug. ***

Mahendra Tallur (mahen) wrote :

Hi ! I still have this bug under Xenial + official Kubuntu PPAs. Did you guys get the fix ? Thanks !

Mahendra Tallur (mahen) wrote :

(BTW, IMHO, LTS Kubuntu should be synced with LTS versions of Plasma...)

Stéphane (stephane-treboux) wrote :

Salut Mahendra,
Le paquet a été réparé dans Yakkety mais pas dans Xenial.
Tu peux t'en apercevoir en comparant les chemins de gsthumbnail.so et rawthumbnail.so dans la version actuelle de kdegraphics-thumbnailers:
Xenial, défectueux :
http://packages.ubuntu.com/xenial/amd64/kdegraphics-thumbnailers/filelist
Yakkety, correct :
http://packages.ubuntu.com/yakkety/amd64/kdegraphics-thumbnailers/filelist

Simon Quigley (tsimonq2) on 2018-07-07
Changed in kubuntu-ppa:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.