ffmpegthumbs 4:15.12.3-0ubuntu1 uses the wrong path for plugin libraries

Bug #1574037 reported by Stéphane on 2016-04-23
76
This bug affects 16 people
Affects Status Importance Assigned to Milestone
ffmpegthumbs (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

ffmpegthumbs 4:15.12.3-0ubuntu1 puts ffmpegthumbs.so under /usr/lib/x86_64-linux-gnu/plugins/ (see http://packages.ubuntu.com/xenial/amd64/ffmpegthumbs/filelist for the newest package file listing).
Dolphin looks for plugins under /usr/lib/x86_64-linux-gnu/qt5/plugins/ (see http://packages.ubuntu.com/xenial/amd64/dolphin/filelist for the newest package file listing).
Because of the discrepancy between the two pathes Dolphin is unable to invoke ffmpegthumbs.

This can be reproduced with the Kubuntu 16.04 LTS live image. After installing ffmpegthumbs and activating it under the Dolphin preferences no thumbnails are generated for videos.

There is a workaround until the package is fixed. This command will link all the files from /usr/lib/x86_64-linux-gnu/plugins/ to /usr/lib/x86_64-linux-gnu/qt5/plugins/:

sudo ln -s /usr/lib/x86_64-linux-gnu/plugins/* /usr/lib/x86_64-linux-gnu/qt5/plugins/

The installation routine of the package should be fixed to unpack ffmpegthumbs.so under /usr/lib/x86_64-linux-gnu/qt5/plugins/.

description: updated
description: updated
description: updated
description: updated
description: updated
summary: - ffmpegthumbs 4:15.12.3-0ubuntu1 uses the location for plugin libraries
+ ffmpegthumbs 4:15.12.3-0ubuntu1 uses the wrong path for plugin libraries
Stéphane (stephane-treboux) wrote :

I just noticed that the proposed fix fails when the package kio-extras is not installed. Currently the package ffmpegthumbs does not depend on kio-extras. Could that be changed too? Thanks!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ffmpegthumbs (Ubuntu):
status: New → Confirmed
賴家亨 (laichiaheng) wrote :

Please release the bug fixes!!

tags: added: xenial

This is also related to

bug# 1574049 (kdegraphics-thumbnailers 4:15.12.3-0ubuntu1 uses the wrong path for plugin libraries)

beeing reported 23.04.2016 here. Upstream bug-report exists.

Hex GuyS (Apologies for not refering to the Ladies)

would just be nice, if such a simple fix could scratch into 16.04.1

Not a lot of time left....

Changed in ffmpegthumbs (Ubuntu):
importance: Undecided → Medium
Philip Muškovac (yofel) on 2016-07-22
Changed in ffmpegthumbs (Ubuntu Xenial):
importance: Undecided → Medium
status: New → Triaged
Changed in ffmpegthumbs (Ubuntu):
status: Confirmed → Fix Committed
tags: added: kubuntu
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ffmpegthumbs - 4:16.04.3-0ubuntu1

---------------
ffmpegthumbs (4:16.04.3-0ubuntu1) yakkety; urgency=medium

  [ Scarlett Clark ]
  * New upstream release.

  [ Philip Muškovac ]
  * Update the Vcs URLs now that the repositories are hosted on
    Launchpad

  [ Scarlett Clark ]
  * New upstream bugfix release

  [ Clive Johnston ]
  * New upstream release (16.04.2)
  * Removing patch ffmpeg_2.9.patch
  * New upstream release (16.04.3)

  [ José Manuel Santamaría Lema ]
  * Merge with debian, fixing a FTBFS. (LP: #1574037)

 -- Philip Muškovac <email address hidden> Fri, 22 Jul 2016 12:15:35 +0000

Changed in ffmpegthumbs (Ubuntu):
status: Fix Committed → Fix Released
Dany (wonder) wrote :

Hi,
I confirm this bug in Linux Mint 18 KDE (based in ubuntu 16.04 with Plasma).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers