battery widget does not show current status as it changes

Bug #1028591 reported by Jonathan Riddell
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KDE Base
Invalid
Medium
kdebase-workspace (Ubuntu)
Undecided
Unassigned
Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

When removing the battery (e.g. after fully charged), the applet still says that battery is present. Restarting plasma-desktop is needed to correct the display.

The reverse is also true and worse. When I had plasma started without battery, inserting it does not update the display, so I cannot see battery state until I kill plasma again.

Revision history for this message
In , Thijs (thijs22nospam) wrote :

I assume you did check how upower and solid report this? And is this a new 4.9beta regression, or was it already present in 4.8?

Revision history for this message
In , Tommy_CZ (t-kijas) wrote :

Hi, I try KDE4,9 and I fond it cannot read my battery state. It can read it after I login to KDE and can read (un)plugging AC, but cannot read the change of battery state.

Revision history for this message
In , Tommy_CZ (t-kijas) wrote :

It seems the detection just stops to work after some time....
output from "qdbus --system org.freedesktop.UPower /org/freedesktop/UPower/devices/battery_BAT0 org.freedesktop.UPower.Device.Percentage" when the detection is OK:
97.7599738391105

And the detections stops just right in the moment I plugin AC power.:

96.3374754741661... etc.

stats in /proc/acpi/battery/BAT0/state are changing...:
tomas@tom-MacBookAir:~/Dokumenty$ cat /proc/acpi/battery/BAT0/state
present: yes
capacity state: ok
charging state: discharging
present rate: 28787 mW
remaining capacity: 58760 mWh
present voltage: 8091 mV
tomas@tom-MacBookAir:~/Dokumenty$ cat /proc/acpi/battery/BAT0/state
present: yes
capacity state: ok
charging state: charged
present rate: 0 mW
remaining capacity: 58700 mWh
present voltage: 8252 mV

Revision history for this message
In , Jonathan Riddell (jr) wrote :

I can confirm this in kubuntu quantal using alpha 3 candidate images

Revision history for this message
In , Jonathan Riddell (jr) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1028591

tags: added: iso-testing
Changed in kde-baseapps:
importance: Unknown → High
status: Unknown → Confirmed
Revision history for this message
In , KAMiKAZOW (kamikazow) wrote :

*** This bug has been marked as a duplicate of bug 302310 ***

Revision history for this message
In , KAMiKAZOW (kamikazow) wrote :

*** Bug 303812 has been marked as a duplicate of this bug. ***

Revision history for this message
In , KAMiKAZOW (kamikazow) wrote :

(In reply to comment #1)
> is this a new
> 4.9beta regression, or was it already present in 4.8?

Just upgraded to RC2 from 4.8.4: Same here. It's a new regression.

Changed in kde-baseapps:
status: Confirmed → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kdebase-workspace (Ubuntu):
status: New → Confirmed
Revision history for this message
Tommy_CZ (t-kijas) wrote :

Why invalid?

Revision history for this message
In , KAMiKAZOW (kamikazow) wrote :

Could this be a Solid bug and not the Plasmoid's?

Logan Rosen (logan)
Changed in kde-baseapps:
importance: High → Unknown
status: Invalid → Unknown
Changed in kde-baseapps:
importance: Unknown → Medium
status: Unknown → Confirmed
Revision history for this message
In , Viranch Mehta (viranch-mehta) wrote :

This is the plasmoid's bug.

Revision history for this message
In , Viranch Mehta (viranch-mehta) wrote :
Changed in kde-baseapps:
status: Confirmed → Fix Released
Revision history for this message
In , KAMiKAZOW (kamikazow) wrote :

Not fixed, at least not fully. I used my laptop without battery, then put it into standby, inserted the battery, unplugged the power cord, and switched my laptop on. Plasmaapplet claims that no battery is present (no cord is correctly detected).

Changed in kde-baseapps:
status: Fix Released → Confirmed
Revision history for this message
In , csslayer (wengxt) wrote :
Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

It still does not work correctly on today's master. Starting the computer without a battery, I correctly see the red X on the battery in systray. Inserting the battery, however, does not remove this X indicator. I have to restart plasma-desktop, to get it to recognize the battery.

Revision history for this message
In , U26 (u26) wrote :

*** Bug 312227 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Eyalyoli (eyalyoli) wrote :

Hello,
I'm a also a user of plasma desktop version 4.10.
I found out that removing the battery and reinserting it while the user is logged in actually works as expected (shows that the battery was removed and reinserted).
the problem appears when logging in without the battery (with AC plugged only) and then trying to reinsert the battery back to the computer actually does NOTHING to the battery monitor and it doesn't recognize that the battery was inserted - though the computer uses the battery as usual (when unplugging AC).
As a result the system doesn't warn about critical battery charge and, well, after a while the whole work will be lost because of sudden shutdown.

I tried working this bug around by inserting the battery, logging out, logging in again, and here it is the battery monitor is back and fully functional.

Hope that helps solving the bug ;-)
And btw I've worked with lower versions of KDE and didn't have that bug...
Thnx

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

*** Bug 315483 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

*** Bug 317196 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

*** This bug has been marked as a duplicate of bug 316213 ***

Changed in kde-baseapps:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.