Translation of kdelibs: untranslatable % placeholder

Bug #510616 reported by Sveinn í Felli on 2010-01-21
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned
Ubuntu Translations
Medium
Unassigned
kde4libs (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

In the icelandic kdelibs4 (karmic), string number 2541 - "% of View Width" has no Current Icelandic string, but a couple of suggestions (one of wich is correct). Either selecting the suggestion or inserting a new string results in:
"There is an error in a translation you provided. Please correct it before continuing."

I thought I'd seen this before in a bugreport, but I'm unable to find anything similar. Is this a known bug?

Sveinn í Felli (sveinki) wrote :

Sorry, wrong package chosen - corrected

affects: update-manager (Ubuntu) → kde4libs (Ubuntu)
David Planella (dpm) wrote :

Hi Sveinn,

Thanks for reporting this bug.

Could you please provide a link to the string so it is easier for those triaging it to identify it? Thanks!

I'm moving the bug to Launchpad Translations, since it seems to affect the tool to do Ubuntu Translations, not the translations of the distro themselves.

Changed in kde4libs (Ubuntu):
status: New → Invalid
affects: ubuntu-translations → rosetta

Here it is:

<https://translations.launchpad.net/ubuntu/karmic/+source/kde4libs/+pots/kdelibs4/is/+translate?show=untranslated>

This has been hunting me since Jaunty.

Sveinn

Þann fös 22.jan 2010 10:10, David Planella skrifaði:
> Hi Sveinn,
>
> Thanks for reporting this bug.
>
> Could you please provide a link to the string so it is easier for those triaging it to identify it? Thanks!
>
> I'm moving the bug to Launchpad Translations, since it seems to affect
> the tool to do Ubuntu Translations, not the translations of the distro
> themselves.
>
> ** Changed in: kde4libs (Ubuntu)
> Status: New => Invalid
>
> ** Project changed: ubuntu-translations => rosetta
>

This is a common problem where "no-c-format" (note the "no") tag is missing on what xgettext automatically recognizes as C-format string. Translation: it's a broken POT file, which has a message:

#, c-format
msgid "% of View Width"
msgstr ""

This should be fixed in the source code and POT file.

Changed in rosetta:
status: New → Invalid
Sveinn í Felli (sveinki) wrote :

Þann lau 23.jan 2010 14:15, Данило Шеган skrifaði:
> This is a common problem where "no-c-format" (note the "no") tag is
> missing on what xgettext automatically recognizes as C-format string.
> Translation: it's a broken POT file, which has a message:
>
> #, c-format
> msgid "% of View Width"
> msgstr ""
>
> This should be fixed in the source code and POT file.
>
> ** Changed in: rosetta
> Status: New => Invalid
>
> ** Also affects: ubuntu-translations
> Importance: Undecided
> Status: New
>
That's curious, searching a fresh SVN checkout of KDE3 and
KDE4 .po files, gives no results containing this string. Not
even my old backups give anything similar.
There is a "View Width" in katepart4.po and kdevelop.po but
nothing in kdelibs4.po.

Is this maybe an obsolete string?

Sveinn í Felli

David Planella (dpm) wrote :

I checked this our for a few other languages (Catalan, Italian, Spanish, German) and in all cases it appears untranslated (apart from Spanish, in which they used a bit of a hack by joining the % sign with the o). Here's the string in question from the template exported from Launchpad:

#: obj-arm-linux-gnueabi/kate/ui_appearanceconfigwidget.h:200
#, c-format
msgid "% of View Width"
msgstr ""

(note the wrong c-format flag as Danilo pointed out)

I do not quite understand how this template made it into Launchpad, since I cannot find it in KDE's svn, either. I'll keep investigating. Here's what I've found out so far:

Imported translations:

* The latest kde4libs/kdelibs4 template update was on 2009-12-11 03:24:53.606343+00:00 and it does not contain this string. However, looking through the changelogs at https://launchpad.net/ubuntu/karmic/+source/kde-l10n-is and https://launchpad.net/ubuntu/lucid/+source/kde-l10n-is I cannot see any uploads on (or near) that date.

* The latest Karmic upload for Icelandic was https://launchpadlibrarian.net/33073668/kde-l10n-is_4.3.2-0ubuntu1_i386_translations.tar.gz on the 05 Oct 2009

* There seems to have been a security upload on the 11th Dec for kdelibs, which would match the update date of the template and which seemed to import translations from kdelibs directly instead of the usual kde-l10n-* packages. So far I haven't been able to access that file: https://lplibrarian.internal/36636679/kde4libs_4.3.2-0ubuntu7.2_i386_translations.tar.gz, but for one I do not quite understand why the uploaded package contained translations, since as far as I know KDE upstream separate translations from the packages, that's why we additionally import the kde-l10n-* packages.

More information:
* There seems to be reference to something related here -> https://lists.ubuntu.com/archives/ubuntu-translators/2009-April/002353.html
* Description of the lifecycle and handling of KDE translations in Kubuntu: https://wiki.ubuntu.com/Translations/Upstream/KDE/KubuntuTranslationsLifecycle

David Planella (dpm) on 2010-01-24
Changed in ubuntu-translations:
status: New → Confirmed
importance: Undecided → Medium
status: Confirmed → Triaged

David, if this can help, POT files are imported from actual packages, even for KDE. Only translations come from kde-l10n-*. However, these packages were *copied* from a PPA and that may be something that caused some problems (stripping doesn't happen in PPAs).

Gabor Kelemen (kelemeng) wrote :

I just exported the katepart4 file from Natty kdelibs, where this string currently can be found:

$ grep -C3 "View Width" /tmp/po_katepart4-hu.po
#. i18n: ectx: property (suffix), widget (KIntSpinBox, sbDynamicWordWrapDepth)
#: rc.cpp:421
#, no-c-format
msgid "% of View Width"
msgstr "A nézet szélességének százaléka"

I think we can consider this fixed.

Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers