KDEInit could not launch XXXX

Bug #184337 reported by Soroosh on 2008-01-19
162
This bug affects 4 people
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
Medium
kde4libs (Mandriva)
New
Undecided
Unassigned
kde4libs (Ubuntu)
Low
Unassigned

Bug Description

I have installed KDE4 in kubuntu
when i want to open an archive (ex. .gz , ,zip) with ark,it shows this error "KDEInit could not launch '/usr/bin/ark' " and opens.
error title is "Sorry - plasma workspace"
in other programms i see this error too.
(just in KDE4)

James (james-ellis-gmail) wrote :

I get this as well with the latest PPA packages but with Konsole so it doesn't look to be application specific.. and it happens quite a bit (but not every app launch)

Reproduce:
1. Alt+F2
2. type konsole
3. Hit enter or select entry from list
4. error dialogue appears "Sorry - Run Command" - KDEInit could not launch /usr/bin/konsole-kde4
5. konsole-kde4 launches and works

$ ls -l /usr/bin/konsole*
-rwxr-xr-x 1 root root 3012 Dec 11 04:04 /usr/bin/konsole
-rwxr-xr-x 1 root root 170 Jan 15 07:45 /usr/bin/konsole-kde4

This is my ~/.xsession-errors log part from around the time of the message:

Task added, isActive = false
kdeinit4: PID 6321 terminated.
karm: WARNING: KLocale: trying to look up "" in catalog. Fix the program
Task added, isActive = false
krunner(6153) Interface::exec: match list has 2 items
kdeinit4: Got EXT_EXEC '/usr/bin/konsole-kde4' from launcher.
kdeinit4: preparing to launch /usr/bin/konsole-kde4
kdeinit4: PID 6358 terminated.
Task added, isActive = false
Task added, isActive = false
karm: WARNING: KLocale: trying to look up "" in catalog. Fix the program
plasma(6155) Plasma::Containment::emitLaunchActivated:
QPainter::end: Painter ended with 2 saved states
QPainter::end: Painter ended with 2 saved states
QPainter::end: Painter ended with 2 saved states
QPainter::end: Painter ended with 2 saved states

What should happen:
1. Don't show message as app launches ok.

Björn Streicher (bstreicher) wrote :

I've got the same issue.

James (james-ellis-gmail) wrote :

Is anything being done about this? It occurs nearly every time an application gets launched in 4.0

James (james-ellis-gmail) wrote :

This seems to be fixed in 4.0.1

integr8e (integr8e) wrote :

I still receive this error when I open a document with Kate-kde4 from a file browser, and close it. I opens fine - no errors - but when I exit Kate, this message pops up. It used to do the same thing whenever I opened a picture with Gwenview-kde4, but that seems to have been fixed with the release of KDE 4.0.1.

Ralph Janke (txwikinger) wrote :

I try to reproduce the problem.. How did you try to open the .gz files? I opened them in dolphin without any problems.

James (james-ellis-gmail) wrote :

i tell a lie, I can duplicate integr8e's kate issue in KDE 4.0.1 - same thing happens. The message appears after quitting Kate.

Does "not in Ubuntu" mean that this is for bugs.kde.org ?

Onlinelli (cornelius-maihoefer) wrote :

[Kubuntu-KDE4- Hardy] I get the same message when launching KDE 3.x apps. e.g. knetworkmanager or kpowersave.

VladBlanton (vblanton) wrote :

I can duplicate this on kde 4.0.2 when launching some apps from kde4's krunner (alt+f2)

It always occurs with the same apps. One of them is knetworkmanager

Che Guevara (che-guevara-3) wrote :

I get this on 4.0.3 with kwrite, ark, ktorrent and others

Changed in kdebase-kde4:
status: Incomplete → Confirmed
Ralph Janke (txwikinger) wrote :

It is clear that there are several different issues are mixed up here. I have just re-tested Soroosh's original problem and cannot reproduce it with the steps explained. None of the other descriptions have been in line with these original steps.

Therefore, I am closing this report. If anybody can reproduce it using the original description, please feel free to re-open this report. Any other problems that are not directly related as the ALT-F2 issue or kate, please address in the corresponding reports that are already existing (I know their is another at least another report about the ALT-F2 issue) or please create another new report.

Thanks

James (james-ellis-gmail) wrote :

I was just able to reproduce the original behaviour using the following steps (note, not using Krunner alt+f2)

1. Open Dolphin
2. Find a file that you can open in Kate - log, text etc
3. Open the file: Right Click -> Open With -> Kate
4. Close the file
5. The pop up appears

I've attached a screenshot.

Thanks

sl1pkn07 (sl1pkn07) wrote :

i agree . same error on kde4 4.0.3

VladBlanton (vblanton) wrote :

I think I have narrowed it down a bit. When you type a full command into krunner (alt+f2) the first option will be "Default: Run your_command (Command)" and this will work, but if your run ANY kde 3 application specifically by double clicking it's entry on the list (in other words, any kde 3 app listed as an app, not as a direct command) then you will recieve the error:

KDEInit could not launch '/usr/bin/the_app'.

but the application will still launch without a problem.

Hope this helps narrow the bug down!

James (james-ellis-gmail) wrote :

This (the steps carried out in my comment #12) is still occurring in KDE4.04/Kubuntu 8.04.

Still happening for me in KDE 4.0.4 with Ktorrent.

Thomas Kluyver (takluyver) wrote :

Seeing the same thing in KDE 4.0.4 for kmail--again, only when selecting the "application" not the "command". But it also affects launching the program from a plasma quicklaunch tray (something I got separately off KDE-look).

Having just tested, the same thing happens with kaddressbook and knotes--presumably it affects any KDE3 application.

Jahshan Bhatti (jabhatti91) wrote :

this is a dbus problem... kde3 apps of course don't use dbus... to fix it for a specific app, edit your icon settings and goto Application => Advanced Options => DBus Registration => none... perhaps all the kde3 app desktop files need to be updated?

Jahshan Bhatti (jabhatti91) wrote :

so a real fix would be to add the line X-DBUS-StartupType=none to all the kde3 desktop files in /usr/share/applications/kde/

Jahshan Bhatti (jabhatti91) wrote :

actually this has been fixed in kde trunk... revision 805921
in the 4.0 branch... revision 805923

this code was removed

 //Compatibility
       if( dbusStartupType.isEmpty() && desktopGroup.hasKey("X-DCOP-ServiceType"))
       {
           dbusStartupType = desktopGroup.readEntry("X-DCOP-ServiceType").toLower();
           entryMap.remove("X-DCOP-ServiceType");
       }

obviously you can see the problem... it shouldn't be waiting for it on DBUS if X-DCOP-ServiceType is true

going to close bug...

Changed in kdebase-kde4:
status: Confirmed → Fix Committed
Changed in kdebase:
status: Unknown → Fix Released

Setting back to confirmed.
Ralph do you think you can backport that fix?

Changed in kdebase-kde4:
status: Fix Committed → Confirmed
Jahshan Bhatti (jabhatti91) wrote :

sorry didn't know the bug closing policy...

@Jashan: No big problem. Just remember it for next time :)

James (james-ellis-gmail) wrote :

Just catching up on this, I should add that the steps followed in my Comment #12 are using KDE4 versions of Dolphin and Kate, no KDE3 programs in use to reproduce this bug. I'm not sure if the fix mentioned would then apply to these steps ?
I'm also not sure where "edit your icon settings" is, exactly.

Thanks!

Ralph Janke (txwikinger) on 2008-06-06
Changed in kde4libs:
importance: Undecided → Medium
James (james-ellis-gmail) wrote :

This (https://bugs.launchpad.net/ubuntu/+source/kde4libs/+bug/184337/comments/12) is still occurring in KDE 4.05 on Kubuntu 8.04.

This is also a fresh new install on a new laptop.

Changing the remote watch as I think this is the better report.

Changed in kdebase:
status: Unknown → Confirmed
Soroosh (sorset) wrote :

hi
recently i receive "KDEInit could not launch 'kate'." in KDE3 when i want to open a txt file , using kate or kwrite.
just when im using "kdesu konqueror" for browsing!!

Olivier (olivier-lacroix) wrote :

Hi !

I am using KDE4 in an up-to-date intrepid and I get the issue already described by James in https://bugs.launchpad.net/ubuntu/+source/kde4libs/+bug/184337/comments/7

That is, whithin dolphin, clicking on a text file opens kate fine. closing kate leads to the dolphin error message

KDEInit could not launch '/usr/bin/kate'.

I doubt the issue is a dcop/Dbus issue since both are KDE4 apps. Should we move this to a new bug report ?

Götz Christ (g-christ) wrote :

I have the same issue in Hardy with the PPA for KDE 4.1 (now in RC1).

If it is already in trunk, when will a release with the fix be released?

Andreas Zitzelsberger (az82) wrote :

Same issue as Olivier reported here with the KDE 4.1 release PPA.
Setting X-DBUS-StartupType=none in /usr/share/applications/kde4/kate.desktop works, but there is another issue: Apparently kate does not terminate properly, if I close the kate window the process stays alive. So when I want to open another text file kate won't start up again.

I really think the importance should be higher than medium. The default file manager not being able to open text files properly with the default editor is kind of a showstopper.

Javier Jardón (jjardon) wrote :

Same issue as Olivier reported here with the KDE 4.1 release.

But now the error message is:

"KLauncher could not be reached via D-Bus. Error when calling start_service_by_desktop_path:
empty"

Fabien Bodard (gambas-fr) wrote :

On Hardy, kde 4.1 dblClick on a text document give me : Impossible pour KDEInit de lancer « /usr/lib/kde4/bin/kate ».

Sorryt it's french !
It say that KDEInit can't launch "....."... Like Olivier so

Ralph Janke (txwikinger) on 2008-08-05
Changed in kde4libs:
assignee: txwikinger → nobody
Johnny Levai (digistyl3) wrote :

Still happening with KTorrent 3.1.1 and KDE 4.1 in Hardy.
When I open a torrent file, KTorrent opens without a problem, but I get this error message: "KDEInit could not launch '/usr/lib/kde4/bin/ktorrent'"

@ Johnny Levai

I have the exact same issue with the same prog, DE, and distro. Anything happening to fix this?

Harald Sitter (apachelogger) wrote :

Lowering importance since this bug now only affects a small fraction of KDE apps (in fact I have only seen it in KTorrent recently).

Changed in kde4libs:
importance: Medium → Low
Private Huff (privatehuff) wrote :

Bug # 205513 looks like a KTorrent-only version of this, but says it is the dupe...

Confirming this

I have Kubuntu 8.10 with KDE 4.1.2 and KTorrent 3.1.2, and was getting this whenever I double-clicked .torrent files. They opened file, but the message popup came up like this:

--- Sorry - Plasma workspace ----------------------------------
-
- KDEInit could not launch '/usr/bin/ktorrent'
-
------------------------------------------------------------------------

I resolved this by using a suggestion posted above:

In file /usr/share/applications/kde4/ktorrent.desktop

changed the line

"X-DBUS-StartupType=Unique"

to

"X-DBUS-StartupType=None"

Haven't had any other apps do this except ktorrent, but if any other do I will try the same thing.

Thanks!
Huff

Harri Pasanen (bugsbyhp) wrote :

I'm seeing this with konsole in KDE 4.2 on Kubuntu 8.10 amd64.

It doesn't matter if I start konsole from Alt-F2 or panel icon, the end result is the same.
konsole starts up ok, but "Sorry - Plasma Workspace" modal message box comes up as well.

.xsession-errors shows:

kdeinit4: preparing to launch /usr/bin/konsole
konsole(7114): Attempt to use QAction "change-profile" with KXMLGUIFactory!
kwin: X Error (error: <unknown>[DAMAGE+0], request: XDamageDestroy[DAMAGE+2], resource: 0x14256e0)

Harri Pasanen (bugsbyhp) wrote :

Testing further the problem seemed to be something in konsole settings. I've been in the habit of hiding the menu bar, and there has been some bug with respect to that as well. Now after few trials back and forth I managed to make the menu bar stay hidden in new terminal, and the KDEinit error disappeared as well.

DGMcCloud (duncan-doyle) wrote :

I'm having the same problem on 8.10 with KDE 4.2. This happens when launching Konsole using Alt-F2 (KRunner) or when copying the launch icon from the Application Launcher to the Panel and starting Konsole from the Panel.

When setting 'DBUS registration' is set to 'None' on the Panel icon (instead of 'Single Instance'), the error does not occur.

Terrell Prude' Jr. (microman) wrote :

Confirmed on Intrepid (8.10) with KDE 4.2. I was getting the same exact error under the same exact circumstances. I tried setting the DBUS registration to 'None" in the Konsole icon (desktop and Taskbar), and sure enough, the problem went away. Thanks, DGMcCloud, for the workaround.

But this shouldn't be happening in the first place, of course.

--TP

Daniel Eckl (daniel-eckl) wrote :

For me up to KDE 4.2 RC1 it was all fine, but the problem started with KDE 4.2 release.
Using Kubuntu 8.10 with kubuntu-experimental PPA

Reproduced on 3 different machines.

Tho it's not always. Right after login it's all fine and stays fine from some minutes to multiple hours. Then, suddently, it starts giving this message when launching konsole. Can only be temporarily fixed by logout and back in as far as I tried

Barrakketh (barrakketh) wrote :

I'm using 8.10 with KDE 4.2, and DGMcCloud's workaround fixed the problem for me.

When hunting to see if anyone else had this problem I noticed this thread on the kde.org forums (http://forum.kde.org/plasma-says-that-cant-launch-konsole-it-actually-t-29221.html)

A developer said "It is a not-yet-hunted-and-killed bug in kdelibs. (IIRC, it used to show up every now and then even before 4.0) "

Tom Helner (duffman) wrote :

I am seeing this behavior when launching the second (and all subsequent files) in kate, from both Dolphin and Konqueror.

My setup: Kubuntu 8.10 KDE 4.2 from kubuntu-experimental PPA.

Using Dolphin or Konqueror open text file with kate.
  --> works fine
Leaving Kate open, open second text file from Dolphin or Konqueror.
  --> Receive error "KDEInit could not launch '/usr/bin/kate'.
  --> But the file opens as expected (as second open document in kate)

Daniel Eckl (daniel-eckl) wrote :

interesting... I implemented the dirty workaround with setting the DBUS registration to 'None", and it worked fine for days now.

But today, I got the error message nevertheless. Tho I can't reproduce after a logout and login anymore...

marty123 (unconnected) wrote :

I have ubuntu 8.1, running a gnome desktop. I use konqueror 4:4.1.2-0ubuntu4 and kate 4:4.1.2-0ubuntu1

By default in this setup, konqueror launches a new instance of kate when you open a text file. To fix this, you can modify the command line the konqueror executes to:
kate -u %U
Which forces kate to open the file in the existing instance. I'm guessing that because the new instance of kate opens and then sends a message to the currently open instance and returns instantly, which konqueror treats as an execution failure?
This is all conjecture, and I have no idea what I'm talking about.
anyway, it gives me the:
KDEInit could not launch '/usr/bin/kate'
message TWICE.
(And of course, everything works fine, it opens the document in the current instance)
My xsession error log has nothing in it. Is there another log I can look in?

Cheers,
Marty

Jonathan Thomas (echidnaman) wrote :

This has been fixed in the KDE 4.2 packages in Kubuntu 9.04 and Kubuntu 8.10's backports.

Changed in kde4libs:
status: Confirmed → Fix Released

Hi Jonathan,
Has this been fixed in ubuntu? (Is there any plan to fix this)

Cheers,
MArty

2009/2/24 Jonathan Thomas <email address hidden>

> This has been fixed in the KDE 4.2 packages in Kubuntu 9.04 and Kubuntu
> 8.10's backports.
>
> ** Changed in: kde4libs (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> KDEInit could not launch XXXX
> https://bugs.launchpad.net/bugs/184337
> You received this bug notification because you are a direct subscriber
> of the bug.
>

mobiusNZ (mobiusnz) wrote :

I'm still getting this error message in Kubuntu 9.04 (KDE 4.2)

Jens Bremmekamp (nem75) wrote :

This is NOT fixed. If use use e.g. kate the way it maks sense (with the --use option) you will still get this error. See marty's posts.

Harald Sitter (apachelogger) wrote :

Please add your comments to the KDE bug http://bugs.kde.org/show_bug.cgi?id=75492 these issues need to be resolved in KDE itself rather than Kubuntu inspecific, so adding your comments here will not have much use.
Thanks.

Bob Willson (jeremywillson) wrote :

This page says that to fix the error you need to:

open terminal session as user and execute the following at the prompt:
xhost +local:0

http://www.linux-noob.com/forums/index.php?showtopic=2940

It worked for me

I was getting this error every time I tried running Kate from the launcher. In my case, it was searching for kate in the wrong place (/usr/lib/kde4/bin instead of /usr/bin).

What I did to fix it was to create a symbolic link inside /usr/lib/kde4/bin like so:

$ cd /usr/lib/kde4/
$ sudo mkdir bin
$ sudo ln -s /usr/bin/kate kate

BTW, I am running KDE 4.3.0 amd64 from the PPA, which I installed a couple of days ago (and the problem seems to have started as soon as I did that... It worked fine before).

Hope that helps somebody!

Changed in kdebase:
status: Confirmed → Fix Released
Changed in kdebase:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.