[natty] text does not display in plymouth (disk check, passphrase prompts)

Bug #728611 reported by Botond Szász on 2011-03-03
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Binary package hint: plymouth

During boot, if there is a disk check due, fsck starts checking the disk but there is no visual feedback at all shown by plymouth. Somebody who does not know that disks are being checked will think that the boot-up process takes tens of minutes in case of a larger disk.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: plymouth 0.8.2-2ubuntu5.1
ProcVersionSignature: Ubuntu 2.6.35-28.49-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic x86_64
Architecture: amd64
Date: Thu Mar 3 18:25:59 2011
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: Dell Inc. Inspiron 1525
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-28-generic root=UUID=b5e018f7-3a9d-43f5-8e0a-dfde7fd93665 ro quiet splash
ProcEnviron:
 LANG=en_IE.utf8
 SHELL=/bin/bash
ProcFB:
 0 inteldrmfb
 1 VESA VGA
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
dmi.bios.date: 10/16/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A16
dmi.board.name: 0U990C
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA16:bd10/16/2008:svnDellInc.:pnInspiron1525:pvr:rvnDellInc.:rn0U990C:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Inspiron 1525
dmi.sys.vendor: Dell Inc.

Botond Szász (boteeka) wrote :
Steve Langasek (vorlon) wrote :

This is also reported to affect cryptsetup passphrase prompts (bug #727925, marked as duplicate), so clearly there's a regression here in the use of plymouth-label for text display at boot time that needs to be sorted out.

Changed in plymouth (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-11.04-beta-1
status: New → Confirmed
summary: - Disk check message is completely missing
+ [natty] text does not display in plymouth (disk check, passphrase
+ prompts)
Niclas Andersson (niclasa) wrote :

I've hit the issue with the missing cryptsetup text.

I originally installed alpha-1 of natty, which displayed the text. Currently, no text is displayed for the password prompt for me. This has been the case for at least one or two weeks now, and I haven't upgraded any packages since then.

On Thu, Mar 03, 2011 at 07:05:38PM -0000, Niclas Andersson wrote:
> I've hit the issue with the missing cryptsetup text.

> I originally installed alpha-1 of natty, which displayed the text.
> Currently, no text is displayed for the password prompt for me. This has
> been the case for at least one or two weeks now, and I haven't upgraded
> any packages since then.

freetype in natty was updated to a new upstream version a week and a half
ago, and since then, I've seen one very small corner case regression from
freetype. Can you try downgrading to the previous version of libfreetype6
and regenerating your initramfs, to see if that corrects the issue for you?

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Daniel Manrique (roadmr) wrote :

Hi Steve,

I hope I did this correctly.

My system had libfreetype6-2.4.4-1. I downgraded to 2.4.2-2ubuntu0.1. (I downgraded libfreetype6 ONLY, no other packages). I then rebuilt initrd by:

sudo update-initramfs -u -k all

upon rebooting, I still don't get a text message for the encryption password.

Please let me know if I did something wrong or you need me to run some other test on this system.

Steve Langasek (vorlon) wrote :

On Thu, Mar 03, 2011 at 08:35:36PM -0000, Daniel Manrique wrote:
> I hope I did this correctly.

Yes, that sounds exactly correct, thanks.

> My system had libfreetype6-2.4.4-1. I downgraded to 2.4.2-2ubuntu0.1. (I
> downgraded libfreetype6 ONLY, no other packages). I then rebuilt initrd
> by:

> sudo update-initramfs -u -k all

> upon rebooting, I still don't get a text message for the encryption
> password.

Ok, then the bug lies elsewhere.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Oliver Grawert (ogra) wrote :

Bug #728335 might be related here, i see the text if i use the left/right cursor keys in my case.

Daniel Manrique (roadmr) wrote :

I tried using the cursor keys, and what it does is switch me to a text console, where I see a message about unlocking the disk and a prompt for the passphrase. Not much of an improvement as there is still no clue to the user that this might work.

John Lenton (chipaca) wrote :

I have this issue when using linux 2.6.38-6, but rebooting into 2.6.36-rc5 (not that many versions in between gave me a working panel on this latitude e6510) with no other change gives me the prompt back.

Robbie Williamson (robbiew) wrote :

I'm running with the latest updates, and am not able to reproduce this bug. Can someone please run "sudo touch /forcefsck" and reboot to confirm that plymouth is still not displaying the filesystem check info?

Changed in plymouth (Ubuntu Natty):
status: Confirmed → Incomplete
John Lenton (chipaca) wrote :

Just updated, dist-upgraded, touched, rebooted, and got no text around the password prompt and no progress meter during fsck.

Changed in plymouth (Ubuntu Natty):
status: Incomplete → Confirmed
Carl Milette (carl-milette) wrote :

I reinstall the old maverick version of plymouth and the bug still there
I used this version of the branch
bzr branch lp:ubuntu/maverick/plymouth
revision number : 1339

Changed in plymouth (Ubuntu Natty):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Robbie Williamson (robbiew) wrote :

@John Lenton: What type of graphics card do you have? The output from `lspci` should be good enough.

Daniel Manrique (roadmr) wrote :
Download full text (4.7 KiB)

One of the systems where we were able to replicate this problem was an HP ProBook 6550b with Intel graphics, lspci outputs this:

00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:19.0 Ethernet controller: Intel Corporation 82577LC Gigabit Network Connection (rev 05)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
43:00.0 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller (rev 01)
43:00.1 System peripheral: Ricoh Co Ltd Memory Stick Host Controller (rev 01)
43:00.2 System peripheral: Ricoh Co Ltd Device e852 (rev 01)
43:00.3 FireWire (IEEE 1394): Ricoh Co Ltd FireWire Host Controller (rev 01)
44:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

Another one was a Toshiba Tecra A11, also with Intel graphics, lspci as follows:

00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:19.0 Ethernet controller: Intel Corporation 82577LC Gigabit Network Connection (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI ...

Read more...

Robbie Williamson (robbiew) wrote :

Thanks for the fast feedback. Next question, are you seeing the "Ubuntu" splash screen or nothing at all, i.e. a blank screen?

John Lenton (chipaca) wrote :

This is a Dell E6510 with intel graphics and a 1080p panel:
$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:16.3 Serial controller: Intel Corporation 5 Series/3400 Series Chipset KT Controller (rev 06)
00:19.0 Ethernet controller: Intel Corporation 82577LM Gigabit Network Connection (rev 05)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
03:00.0 CardBus bridge: Ricoh Co Ltd Device e476 (rev 02)
03:00.1 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller (rev 03)
03:00.4 FireWire (IEEE 1394): Ricoh Co Ltd FireWire Host Controller (rev 03)
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

I get the ubuntu logo, the moving dots, the password box and the password dots, but none of the text.

Daniel Manrique (roadmr) wrote :

Same behavior as John Lenton re: the Ubuntu logo, dots and box.

A screenshot of what we got on the ProBook 6550b is here:

http://launchpadlibrarian.net/65470075/IMG_1827.JPG

it's attached to bug 727925 (which is duped to this one).

tags: added: natty regression-release
tags: added: iso-testing
Colin Watson (cjwatson) wrote :

Steve Langasek supplied a vital clue: this happens only when plymouth is in the initramfs. I'm investigating.

Changed in plymouth (Ubuntu Natty):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
status: Confirmed → Triaged
Colin Watson (cjwatson) wrote :

The problem is that /lib/plymouth/label.so now transitively links to libGL, which lives in /usr/lib/mesa/libGL.so.1 or some other subdirectory of /usr/lib depending on the GL implementation in use (fglrx, nvidia, etc.). This directory isn't on the linker's default search path; instead, it relies on /etc/ld.so.cache having been built appropriately from a configuration including /etc/ld.so.conf.d/GL.conf, which is managed by update-alternatives. The thing that's going wrong here is that /usr/lib/mesa/libGL.so.1 is copied into the initramfs, but it isn't on the linker's search path so /lib/plymouth/label.so fails to load.

I looked at fixing this by copying in /etc/ld.so.conf* and running ldconfig, but this turned out to be very difficult due to the way mkinitramfs symlinks libraries during initramfs creation. I think it's better to have copy_exec check whether the target directory name is only on the linker search path by virtue of /etc/ld.so.conf*, and if so, install to /lib or /usr/lib as appropriate instead.

affects: plymouth (Ubuntu Natty) → initramfs-tools (Ubuntu Natty)
Changed in initramfs-tools (Ubuntu Natty):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.98.8ubuntu3

---------------
initramfs-tools (0.98.8ubuntu3) natty; urgency=low

  * If copy_exec finds libraries to copy which are only accessible to the
    runtime linker by virtue of being listed in /etc/ld.so.conf*, then
    install those libraries to /lib or /usr/lib as appropriate instead
    (LP: #728611).
 -- Colin Watson <email address hidden> Sat, 26 Mar 2011 01:12:48 +0000

Changed in initramfs-tools (Ubuntu Natty):
status: In Progress → Fix Released
Michael Neuffer (neuffer) wrote :

Even with natty as of this morning (initramfs-tools 0.98.8ubuntu3, plymouth 0.8.2-2ubuntu20)
the problem persists and no text is beeing displayed on the first boot just a blank screen.

On the second boot (after Ctrl-Alt-Del'ing the first attempt), I get a text console after
less then 5sec which works just fine, lets me enter my cryptsetup passphrase and continues
the boot process.

Typing the passphrase blindly on the first boot doesn't let the boot process continue so
I gather the system must get stuck before reaching cryptsetup.

Isn't there a possibility to completely disable plymouth? Especially on a server it only gets into the way.

John Lenton (chipaca) wrote :

I confirm this fixed it for me.

Etienne (etn) wrote :

I have the same issue than Michale Neuffer and initramfs-tools (0.98.8ubuntu3) doesn't resolve the issue.
This regression occur with :

ii plymouth 0.8.2-2ubuntu22
linux-image-2.6.38-8-generic 2.6.38-8.42

Is there a way to disable properly plymouth from initramfs?

Matthias Schmidt (mschmidt) wrote :

Can confirm this bug with three different machines running natty amd64 and LUKS disc encryption. No password prompt is visible. I can either enter the pass phrase blindly or disable the splash mode in /etc/default/grub. To whom it may concern, I set LINUX_GFXPAYLOAD="text".

I have plymouth Version 0.8.2-2ubuntu23.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers