sound applet volume slider has no effect if pulseaudio is restarted

Bug #662296 reported by Victor Zamanian on 2010-10-17
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Medium
Conor Curran
indicator-sound (Ubuntu)
Medium
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: indicator-sound

If I run

$ pulseaudio --kill

and then restart pulseaudio using the Run dialog (ALT+F2) or from the terminal (I just type in "pulseaudio" without extra parameters), then the sound applet's volume slider has no effect.

The "Output volume" slider in the Sound Preferences does still have an effect on the sound, but not the indicator applet's volume lider.

Logging in and out does fix the issue, and presumably also restarting gnome-panel but I haven't tried that.

PS: Hopefully indicator-sound was the right package. It's kind of difficult since you can't right-click on indicators to find out any info about them. :P

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: indicator-sound 0.4.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sun Oct 17 19:51:07 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: indicator-sound

Victor Zamanian (victorz) wrote :
description: updated
Conor Curran (cjcurran) wrote :

Hi there,
Thanks for reporting this. I cannot reproduce this from this end. The indicator-sound-service should be sensitive to pulseaudio going up and down. Is this reproducible every time ?

Conor Curran (cjcurran) on 2010-10-20
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
Victor Zamanian (victorz) wrote :

Hi Conor,

This is reproducible every time for me.

While I have your attention, do you know of a way to "restart" the sound indicator to test this more efficiently? As it is now, I have to log out and back in again to get the volume control back into the indicator slider.

Conor Curran (cjcurran) wrote :

If you do a 'killall indicator-sound-service' from terminal this will restart the sound service which drives the sound indicator.

Can you tell me if when pulse is down if the indicator icon is hollowed out ? And when you restart pulse does this icon change to one which reflects the current volume of the system ?

Victor Zamanian (victorz) wrote :

Ah, okay! Cool, that worked great. Thanks!

No the indicator icon is not hollowed out. (If I understand what you mean.) When I restart pulse, the indicator icon only reflects the indicator slider. If I drag the indicator slider, the icon changes with it, but the volume is unchanged.

When I run 'killall indicator-sound-service' however, the indicator icon changes to reflect the volume of the system if that was different than that of the slider.

By the way, I just found out that pulseaudio is restarted immediately when I kill it.

$ pkill pulseaudio && pgrep -l pulse
31854 pulseaudio
$ pkill pulseaudio && pgrep -l pulse
31857 pulseaudio
$ pkill pulseaudio && pgrep -l pulse
31871 pulseaudio

So if I run pulseaudio in the terminal after killing it, it tells me the following.

$ pulseaudio
E: pid.c: Daemon already running.
E: main.c: pa_pid_file_create() failed.

Maybe that's normal, I'm unsure. I just thought I'd mention it.

Conor Curran (cjcurran) wrote :

Hi,
Okay firstly Pulseaudio will try to restart automatically if it dies for any reason. You can disable this by setting the autospawn = no in /etc/pulse/client.conf. You should not really want to do this.

So what you are telling me it seems the indicator thinks it has a valid sink when pulse is restarted . Can you,

- recreate the bug
- open sound volume preferences and go to the output tab.

Can you tell me what output device is selected as the default output device and what other options are in this list ?

Conor

Victor Zamanian (victorz) wrote :

Yeah. I didn't realize I was telling you that, but that does seem like a fair assumption now that you say it. :)

Before recreating the bug, the output tab has one device in the list of available devices:

"Internal Audio Analog Stereo", which is also selected obviously.

[closing sound preferences dialog to recreate bug]

[recreating bug and reopening sound preferences dialog]

The same device as before is listed there now, and selected. The sound preferences dialog's slider, as mentioned, *does* work and correctly adjusts the volume.

Conor Curran (cjcurran) wrote :

And at this point the indicator-sound slider has no effect ?

Sorry I cannot reproduce this and have not had any other similar bug reports since I got the basic volume stuff working in Lucid.

to reproduce open terminal and type 'pkill pulseaudio'

On Fri, Oct 22, 2010 at 7:41 PM, Conor Curran <email address hidden>wrote:

> And at this point the indicator-sound slider has no effect ?
>
> Sorry I cannot reproduce this and have not had any other similar bug
> reports since I got the basic volume stuff working in Lucid.
>
> --
> sound applet volume slider has no effect if pulseaudio is restarted
> https://bugs.launchpad.net/bugs/662296
> You received this bug notification because you are subscribed to
> indicator-sound in ubuntu.
>
> Status in Sound Menu: New
> Status in “indicator-sound” package in Ubuntu: New
>
> Bug description:
> Binary package hint: indicator-sound
>
> If I run
>
> $ pulseaudio --kill
>
> and then restart pulseaudio using the Run dialog (ALT+F2) or from the
> terminal (I just type in "pulseaudio" without extra parameters), then the
> sound applet's volume slider has no effect.
>
> The "Output volume" slider in the Sound Preferences does still have an
> effect on the sound, but not the indicator applet's volume lider.
>
> Logging in and out does fix the issue, and presumably also restarting
> gnome-panel but I haven't tried that.
>
> PS: Hopefully indicator-sound was the right package. It's kind of difficult
> since you can't right-click on indicators to find out any info about them.
> :P
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: indicator-sound 0.4.8-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> NonfreeKernelModules: nvidia
> Architecture: i386
> Date: Sun Oct 17 19:51:07 2010
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386
> (20101007)
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> SourcePackage: indicator-sound
>
>
>
>
>

Victor Zamanian (victorz) wrote :

Yes at that point the indicator-sound slider has no effect.

This is reproducible for me 100 % of the times attempted, between restarts, updates, etc.

Someone has to be the first, right? :)

Dan Jones (dr-daniel-l-jones) wrote :

I also have this problem (on x64 version).

If I do pulseaudio -k then the indicator volume slider has no effect on sources connected via module-loopback (like my digital tv card) even tho pulseaudio automatically restarts. The sound preferences dialog volume slider continues to work and do the right thing, etc. just as reported in #7.

Doing a killall indicator-sound-service does indeed right the ship until the next time one kills pulseaudio.

Dan Jones (dr-daniel-l-jones) wrote :

BTW, I am running version 0.4.9-0ubuntu1

Victor Zamanian (victorz) wrote :

I too have upgraded to 0.4.9-0ubuntu1 since reporting this bug and I am still experiencing the behavior in my original description.

Conor Curran (cjcurran) on 2010-10-25
Changed in indicator-sound:
status: New → In Progress
milestone: none → 0.5.0
Conor Curran (cjcurran) on 2010-10-26
Changed in indicator-sound:
importance: Undecided → Medium
Ken VanDine (ken-vandine) wrote :

Please test this build of the package to see if it fixes the problem.

Ken VanDine (ken-vandine) wrote :

And an i386 build as well

Omer Akram (om26er) wrote :

yes the test package works fine.

On Tue, Oct 26, 2010 at 8:43 PM, Ken VanDine <email address hidden>wrote:

> And an i386 build as well
>
> ** Attachment added: "indicator-sound_0.4.9-0ubuntu2~test1_i386.deb"
>
> https://bugs.launchpad.net/ubuntu/+source/indicator-sound/+bug/662296/+attachment/1711904/+files/indicator-sound_0.4.9-0ubuntu2%7Etest1_i386.deb
>
> --
> sound applet volume slider has no effect if pulseaudio is restarted
> https://bugs.launchpad.net/bugs/662296
> You received this bug notification because you are subscribed to
> indicator-sound in ubuntu.
>
> Status in Sound Menu: In Progress
> Status in “indicator-sound” package in Ubuntu: New
>
> Bug description:
> Binary package hint: indicator-sound
>
> If I run
>
> $ pulseaudio --kill
>
> and then restart pulseaudio using the Run dialog (ALT+F2) or from the
> terminal (I just type in "pulseaudio" without extra parameters), then the
> sound applet's volume slider has no effect.
>
> The "Output volume" slider in the Sound Preferences does still have an
> effect on the sound, but not the indicator applet's volume lider.
>
> Logging in and out does fix the issue, and presumably also restarting
> gnome-panel but I haven't tried that.
>
> PS: Hopefully indicator-sound was the right package. It's kind of difficult
> since you can't right-click on indicators to find out any info about them.
> :P
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: indicator-sound 0.4.8-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> NonfreeKernelModules: nvidia
> Architecture: i386
> Date: Sun Oct 17 19:51:07 2010
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386
> (20101007)
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> SourcePackage: indicator-sound
>
>
>
>
>

Dan Jones (dr-daniel-l-jones) wrote :

Yes, the problem is fixed for me with the test1_amd64 version.

Installing the test version and restarting made it do the expected thing - i.e. work.

Thanks!

Conor Curran (cjcurran) wrote :

Excellent,

Thanks Dan, just waiting to hear back from some other people with
regards a regression this fix may cause. Once it gets the all clear a
SRU will go out straight away.

Conor

On 26/10/10 13:14, Dan Jones wrote:
> Yes, the problem is fixed for me with the test1_amd64 version.
>
> Installing the test version and restarting made it do the expected thing
> - i.e. work.
>
> Thanks!
>

Hi Connor,

I can reproduce the regression, and the build by Ken van dine fixes it
for me.

Thanks,
David

On 10/26/2010 12:43 PM, Conor Curran wrote:
> Hi David,
>
> I am the developer for the indicator-sound on Ubuntu. I was wondering if
> you could help me test a proposed fix for Maverick as I cannot reproduce
> the initial problem. Basically the fix I did for this bug
>
> https://bugs.launchpad.net/ubuntu/+source/indicator-sound/+bug/581173
>
> Caused this regression:
>
> https://bugs.launchpad.net/ubuntu/+source/indicator-sound/+bug/662296
>
> Ken van dine has made .debs available on the current bug for both
> architectures.
>
> i386:
>
> https://bugs.launchpad.net/ubuntu/+source/indicator-sound/+bug/662296/+attachment/1711904/+files/indicator-sound_0.4.9-0ubuntu2%7Etest1_i386.deb
>
>
>
> and AMD64
>
> https://bugs.launchpad.net/ubuntu/+source/indicator-sound/+bug/662296/+attachment/1711903/+files/indicator-sound_0.4.9-0ubuntu2%7Etest1_amd64.deb
>
>
> If this is too much trouble that is no problem. I'm sure I will find
> someone else.
> Thanks for your time.
>
> Conor
>
> --
> Sound Architect
> Desktop Experience Team
> Product Strategy
> Canonical
>
>

Conor Curran (cjcurran) wrote :

Thanks David. Dan,
Will get a release out this week.

Conor

Conor Curran (cjcurran) on 2010-11-03
Changed in indicator-sound:
status: In Progress → Fix Committed
Changed in indicator-sound (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Conor Curran (cjcurran) on 2010-11-05
Changed in indicator-sound (Ubuntu):
status: Triaged → Fix Released
Changed in indicator-sound:
status: Fix Committed → Fix Released
Changed in indicator-sound (Ubuntu):
status: Fix Released → Triaged

Accepted indicator-sound into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-sound (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted indicator-sound into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-sound (Ubuntu Maverick):
status: New → Fix Committed
David Tombs (dgtombs) wrote :

Update works for me in Maverick.

indicator-sound:
  Installed: 0.5.0-0ubuntu1
  Candidate: 0.5.0-0ubuntu1
  Version table:
 *** 0.5.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.4.9-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main amd64 Packages
     0.4.7-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages

Victor Zamanian (victorz) wrote :

Works for me too. I'm on 32-bit.

Dan Jones (dr-daniel-l-jones) wrote :

Update works for me in Maverick as well. 64-bit.

Confirmed. Lucid 64-bit.

Martin Pitt (pitti) on 2010-11-11
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.5.0.1-0ubuntu1

---------------
indicator-sound (0.5.0.1-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release.
    - Fixed a regression, which would show the metadata widget when the
      player has no current track (LP: #674016)

indicator-sound (0.5.0-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release.
    - Buttons' hover image stays after dragging (LP: #643395)
    - Sound indicator works incorrect with playing status (LP: #656947)
    - sound applet volume slider has no effect if pulseaudio is
      restarted (LP: #662296)
    - Default music player should be present in the menu from a clean
      install (LP: #664743)
 -- Ken VanDine <email address hidden> Fri, 12 Nov 2010 09:40:47 -0500

Changed in indicator-sound (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Natty has a newer version, assuming it's fixed there.

Changed in indicator-sound (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.2.6-0ubuntu1

---------------
indicator-sound (0.2.6-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release.
    - More fixes for pulse re-connection problems (LP: #662296)
 -- Ken VanDine <email address hidden> Thu, 04 Nov 2010 17:04:14 -0400

Changed in indicator-sound (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers