indicator-sound-service eating CPU on second user login

Bug #581173 reported by David Tombs on 2010-05-16
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
PulseAudio
Invalid
Undecided
Unassigned
The Sound Menu
Fix Released
Medium
Conor Curran
indicator-sound (Ubuntu)
Low
Conor Curran
Lucid
Undecided
Unassigned
Maverick
Low
Conor Curran

Bug Description

Binary package hint: indicator-sound

I am not sure if this is reproducible (I'm reporting this the first time I see it, with an active process), but here goes.

1) Log in to any user.
2) Do a user switch to another user.
3) See high CPU usage from indicator-sound-service. Note also that the indicator applet shows a muted speaker icon (dashed lines).

It seems that pulseaudio is not running in the second session.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: indicator-sound 0.2.3-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun May 16 00:22:33 2010
ExecutablePath: /usr/lib/indicator-sound/indicator-sound-service
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
SourcePackage: indicator-sound

David Tombs (dgtombs) wrote :
David Tombs (dgtombs) wrote :

Yes, it's reproducible--at least in this session.

Per Buer (perbu) wrote :

This affects me as well. Here is what strace says:

open("/dev/shm/pulse-shm-87918442", O_RDONLY|O_NOFOLLOW|O_CLOEXEC) = 10
fstat(10, {st_mode=S_IFREG|0400, st_size=67108904, ...}) = 0
mmap(NULL, 67112960, PROT_READ, MAP_SHARED, 10, 0) = 0x7dd86cb71000
close(10) = 0
kill(5289, SIG_0) = 0
munmap(0x7dd86cb71000, 67112960) = 0
open("/dev/shm/pulse-shm-4214229396", O_RDONLY|O_NOFOLLOW|O_CLOEXEC) = 10
fstat(10, {st_mode=S_IFREG|0400, st_size=67108904, ...}) = 0
mmap(NULL, 67112960, PROT_READ, MAP_SHARED, 10, 0) = 0x7dd86cb71000
close(10) = 0
kill(5289, SIG_0) = 0
munmap(0x7dd86cb71000, 67112960) = 0

Also, the process as allocated 500M of physical memory (1.7TB virtual) and is spinning on one CPU. The problem *might* be related to the gmail checker plugin in Chrome. At least I didn't notice the problem before installing that extension.

David Tombs (dgtombs) wrote :

I don't have Chrome installed, myself. Confirming due to second report.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Christopher (captain-c) wrote :

I am also experiencing this problem using nx client/server. It happened multiple times in 1 session.

Jeremy Boden (jeremyboden) wrote :

It affects me - on a dual processor it causes about roughly full use on one processor and causes indicator-applet to use most of the remaining CPU!

Note that signing out of the second user and returning to the first user "cures" the problem...

Jeremy Boden (jeremyboden) wrote :

PS I don't have anything else but the calendar,date/time, wireless and pulse-audio in indicator.
(No gmail etc)

Killing the looping processes does not help.

I also tried re-installing the indicator-applet, which didn't help.

Jeremy

Conor Curran (cjcurran) wrote :

Okay i cannot reproduce this but I have heard about this issue since Lucid. Whereby when indicator-sound-service attempt to connect the pulse daemon and for whatever reason the daemon is not running but it should be, the respawn behaviour of pulse goes into overdrive and cripples a CPU. I am going to assign this also to pulse because indicator-sound does not do anything unorthodox there.

David Tombs (dgtombs) wrote :

There's already a task for indicator-sound.

Changed in indicator-sound:
status: New → Invalid
David Tombs (dgtombs) wrote :

If it is a problem with pulseaudio, we should confirm before making an upstream task.

Connor: if you can't reproduce, how do you know what the underlying problem is? Do you have a source for this?

Changed in pulseaudio:
status: New → Incomplete
Conor Curran (cjcurran) wrote :

Sorry David,

My mistake.

The service was trying to recreate a pulse connection again if it had failed even though the initial attempt had the reconnect flag. Will be fixed in 0.4.8.

Changed in indicator-sound:
status: Invalid → Confirmed
status: Confirmed → Fix Committed
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → Medium
milestone: none → 0.4.8
Conor Curran (cjcurran) on 2010-10-01
Changed in indicator-sound (Ubuntu):
assignee: nobody → Conor Curran (cjcurran)
Conor Curran (cjcurran) on 2010-10-04
Changed in pulseaudio:
status: Incomplete → Invalid
Conor Curran (cjcurran) wrote :

Will be released in lucid as part of 0.2.4

Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
importance: Medium → Low
David Tombs (dgtombs) wrote :

Cool, thanks! Sorry about invalidating your upstream task, didn't realize that you _were_ upstream. :)

Martin Pitt (pitti) wrote :

Please provide an SRU for maverick as well, so that this can be moved to -updates after verification.

Changed in indicator-sound (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed

Accepted indicator-sound into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Conor Curran (cjcurran) on 2010-10-07
Changed in indicator-sound:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted indicator-sound into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-sound (Ubuntu Maverick):
status: Confirmed → Fix Committed
David Tombs (dgtombs) wrote :

@Martin: maverick-proposed update fixes it for me, thank you!

verification done for maverick
verification needed for lucid

tags: added: verification-done
Alkis Georgopoulos (alkisg) wrote :

Verifying for Lucid.

I've been seeing this in LTSP thin client labs, where all user sessions run on the server. Sometimes there were more than 10 indicator-sound processes (one for each user) eating all the CPU.

I've not been able to reproduce it after upgrading to the version in lucid-proposed.

Thanks for testing. Marking as verification-done for lucid.

tags: removed: verification-needed
Gary M (garym) on 2010-10-17
tags: added: i386 maverick
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.2.5-0ubuntu1

---------------
indicator-sound (0.2.5-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release.
    - Fixed high CPU load when there is problems connecting to
      pulse (LP: #581173)
 -- Ken VanDine <email address hidden> Tue, 05 Oct 2010 10:18:07 -0400

Changed in indicator-sound (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.4.9-0ubuntu1

---------------
indicator-sound (0.4.9-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release.
    - fixes tranlation mpris name regression (LP: #654140)

indicator-sound (0.4.8-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release.
    - indicator-sound-service eating CPU on second user login (LP: #581173)
    - Right border of transport control is different colour while using
      Ambiance (LP: #632774)
    - Incorrect ellipsing (LP: #637580)
    - always show unmuted at startup (LP: #648238)
    - click or enter on metadata widget does not copy contents to
      clipboard (LP: #651246)
    - Sound menu has two Rhythmbox elements when using
      translations (LP: #654140)
 -- Ken VanDine <email address hidden> Thu, 14 Oct 2010 10:40:13 -0400

Changed in indicator-sound (Ubuntu Maverick):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2010-12-04
Changed in indicator-sound (Ubuntu):
status: Fix Committed → Fix Released
MarcRandolph (mrand) wrote :

Least we think this is completely resolved, this just occurred on my up-to-date 10.04/Lucid system.

David Tombs (dgtombs) wrote :

Marc, the bug is fixed for me so please submit a new report for yourself.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers