Ubuntu

[SRU]Update indicator-sound-gtk2 with patch

Reported by TK on 2013-08-04
This bug affects 239 people
Affects Status Importance Assigned to Milestone
Ubuntu Studio
Undecided
Unassigned
indicator-sound-gtk2 (Ubuntu)
High
Dick Seaman
Saucy
High
Unassigned

Bug Description

[Impact]

 * The indicator menu for sound not displaying is a major user interface failure.

 * The justification for making this upload is that the number of workarounds proposed are actually damaging to system integrity as well as allowing for shifts between desktop environment.

 * This patch resolves a conflict that will allow the menu to display.

[Test Case]

 * Install stock Xubuntu 13.10. The indicator menu for sound should fail to display when clicking on the sound icon.

[Regression Potential]

 * There is a risk of further conflict between the gtk2 and gtk3 sound indicators. In previous releases the two versions were almost identical but this changed in Saucy (this is also the reason -gtk2 broke). In particular, there is a potential for the two indicators to use gsettings configuration keys in different ways which may lead to problems. Testing should be done on systems with both Unity and Xubuntu installed.

 * While Xubuntu is working on landing gtk3 indicators for 14.04 the landing of such for 13.10 now would be a massive change requiring approval by potentially the Technical Board.

[Other Info]

 * In general Xubuntu users have been distressed over not having the indicator sound menu available which makes this an issue we would like to resolve expeditiously.

 * Xubuntu will need to adjust its website documentation slightly to note that users must select "Download updates while installing" during an installation from the LiveCD to ensure this fix is picked up to avoid a broken interface experience.

TK (tkrishan) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1208204

tags: added: iso-testing
Sean Davis (smd-seandavis) wrote :

I can confirm that this bug does exist.

I have also found that if you kill the currently running indicator-sound-service and run /usr/lib/indicator-sound-gtk2/indicator-sound-service it starts working again.

Since the running process in both 13.04 and 13.10 is /usr/lib/x86_64-linux-gnu/indicator-sound-service, does this mean the latest version does not fall back on /usr/lib/indicator-sound-gtk2/indicator-sound-service? I haven't dove into the code yet, but maybe this is a simple fix?

Daniel Letzeisen (dtl131) wrote :

Thanks, Sean
For those looking for a temporary workaround, look at /usr/share/dbus-1/services/indicator-sound.service and change the Exec line

Exec=/usr/lib/indicator-sound-gtk2/indicator-sound-service

Elfy (elfy) wrote :

that appears to work

TK (tkrishan) wrote :

Editing indicator-sound.service file works for me.

Also, falling back to using the Raring's binary also works.
indicator-sound_12.10.2daily13.04.12-0ubuntu1_amd64.deb

TK (tkrishan) wrote :

Still experiencing the issue with “indicator-sound” 12.10.2+13.10.20130812.1-0ubuntu1.

Daniel Letzeisen (dtl131) wrote :

Marking 'Low' right now since easy workarounds exist.

Changed in indicator-sound (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
TK (tkrishan) wrote :

Will the importance be raised as 13.10 nears release? The reason I ask is whether easy workarounds should include having users search through bug reports to find the "easy workarounds" that require editing system files?

I can understand that there are probably far more important issues to work on right now; I'm just trying to understand what an easy workaround includes. From a non-technical user's perspective who just wants something to work, I would rate this as medium.

https://wiki.ubuntu.com/Bugs/Importance

Daniel Letzeisen (dtl131) wrote :

Yes, I planned to raise the importance as release nears. I'm hoping it gets solved long before that, though.

Daniel Hollocher (chogydan) wrote :

I think technically, this bug is of high importance: https://wiki.ubuntu.com/Bugs/Importance
You can't adjust sound, which is core functionality.

The workaround is easy only if you happen to be looking at this bug report. I suspect that by easy, the guide means that an uneducated user could find a workaround, just by playing around.

Please don't change the importance as the release nears. Please just set it correctly. Low means ignore potentially forever. High means, fix at least before release. Changing it will just confuse or surprise the dev.

Richard Elkins (texadactyl) wrote :

I have been running with the patch that dtl131 described in message #5 for the last 3 days - when he alerted me to the fact that https://bugs.launchpad.net/ubuntu/+source/xfce4-indicator-plugin/+bug/1215852 is a duplicate of this report. Since applying the patch, I have rebooted around 20 times for various other reasons and I no longer experience xfce4-indicator-plugin crashes (https://bugs.launchpad.net/ubuntu/+source/xfce4-indicator-plugin/+bug/1181134) nor do I ever lose my volume control on Panel 0 (this report). Saucy Alpha-2 has become my everyday system - very stable.

So, could anyone who has access please fix the package 'indicator-sound' with the one liner as described in the patch? I'll be happy to volunteer for QA duty. I can run tests and/or collect specified logs.

Richard

Richard Elkins (texadactyl) wrote :

I just looked at my 13.04 server. Interestingly enough, after applying the above patch to /usr/share/dbus-1/services/indicator-sound.service, then the 13.04 and 13.10 versions of that file are identical in content.

Changed in indicator-sound (Ubuntu):
importance: Low → High
Richard Elkins (texadactyl) wrote :

Note that the indicator-sound package containing the file needing the patch of message #5 was just re-released yesterday without the patch (scheduling issue?). I had to re-apply the patch.

Daniel Letzeisen (dtl131) wrote :

The bluetooth indicator is also affected (see duplicate bug 1219938). Maybe the problem lies in the xfce4-indicator itself?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-bluetooth (Ubuntu):
status: New → Confirmed
Alistair Buxton (a-j-buxton) wrote :

@daniel: I don't think it is directly related to the xfce4 indicator applet - I'm testing gtk3/indicator-ng support from upstream, and with it the sound menu works fine, but bluetooth menu is still broken. So it is either unrelated bugs, or something fixed in indicator-sound and not indicator-sound-gtk2 and indicator-bluetooth (which has no gtk2 version).

Alistair Buxton (a-j-buxton) wrote :

Actually, I'm not sure how the reporter of bug 1219938 even got the bluetooth indicator to appear in Xubuntu given that is has no gtk2 version.

Simon Steinbeiß (ochosi) wrote :

I assume that it uses indicator-application-gtk2.

Alistair Buxton (a-j-buxton) wrote :

Weird. In 13.10 bluetooth is a Unity service/indicator-ng, but it still uses appindicator APIs, but it doesn't use the library version of them, so it must have it's own.

TK (tkrishan) wrote :

The bluetooth applet I use in XFCE is blueman-applet. It appears as an indicator but also does not display any options when clicked on. Only a small empty box appears under the indicator.

Here's the error message when I click on the indicator:
(blueman-applet:27228): LIBDBUSMENU-GLIB-WARNING **: About to Show called on an item wihtout submenus. We're ignoring it.

Alistair Buxton (a-j-buxton) wrote :

Ok - there's two things going on here.

First, when you get the bluetooth icon with an empty menu, that isn't indicator-bluetooth. It is blueman, which uses appindicator. Something is wrong there so it sends an empty menu.

Second, indicator-bluetooth is also broken - but in this case it's so broken it doesn't appear at all. It is trying to create a menu of com.canonical.indicator.switch, but this menu model cannot be found. It isn't part of IDO, and I don't know where it is supposed to come from.

Daniel Letzeisen (dtl131) wrote :

@a-j-buxton: so I take it the bluetooth indicators should be separate bugs split off from this one?

Alistair Buxton (a-j-buxton) wrote :

@dtl131 https://bugs.launchpad.net/ubuntu/+source/glipper/+bug/1203888/ covers blueman-applet - that bug also affects glipper.

indicator-bluetooth and indicator-sound I am not sure of - they could be the same bug or they could be different.

Alistair Buxton (a-j-buxton) wrote :

indicator-bluetooth is now working for me. It still produces the error about com.canonical.indicator.switch, but it is showing up on the panel, including the menu. The blueman-applet is right next to it and is still broken. This is after i've been playing around all day killing services and so on, so there may be some logic which normally prevents both loading at the same time.

Without comment #5 i would not have this possible fix
Possible solution:
Replace the Exec= line in /usr/share/dbus-1/services/indicator-sound.service with this line
Exec=/bin/sh -c 'if [ -n "$(pidof xfce4-session)" ]; then /usr/lib/indicator-sound-gtk2/indicator-sound-service;else /usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service;fi'

This will make the change only affect the XFCE desktop environment so it will not effect the Unity/KDE/Gnome/Lubuntu DEs for example

no longer affects: indicator-bluetooth (Ubuntu)
Richard Elkins (texadactyl) wrote :

The indicator-sound package was just re-released with the same bug. I had to use the patch in message #5 above to re-apply the work-around.

Version from dpkg = 12.10.2+13.10.20130913-0ubuntu1

Daniel Letzeisen (dtl131) wrote :

@Richard: Every time there's an update, it's going to overwrite the change. Put the package on hold to prevent updates:
echo "indicator-sound hold" | sudo dpkg --set-selections

Daniel

I realise that. Not trying to be a pest.

I just want the indicator-sound maintainer to understand that the package
is being rereleased for other reasons but unfixed w.r.t. to this bug and
the fix would be so simple. I don't mind reapplying the patch until a fix
is permanent.
On Sep 14, 2013 12:11 PM, "Daniel Letzeisen" <email address hidden>
wrote:

> @Richard: Every time there's an update, it's going to overwrite the
> change. Put the package on hold to prevent updates:
> echo "indicator-sound hold" | sudo dpkg --set-selections
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1215852).
> https://bugs.launchpad.net/bugs/1208204
>
> Title:
> indicator-sound no longer functions with xfce4-indicator-plugin
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/indicator-sound/+bug/1208204/+subscriptions
>

Richard, the suggestion in comment #5 is a workaround/hack for xfce users to use the old gtk2 sound indicator until this gets sorted out. It is not a suitable patch or fix by any means, since users of other desktop environments would be forced to use the old gtk2 indicator as well.

Seeing as how the icon shows up, but doesn't reflect the sound status or respond to sound changes, I've got a gut feeling it's not connecting to pulseaudio properly (but I could be way off base).

Alistair Buxton (a-j-buxton) wrote :

Hmm... what you've written here doesn't really make sense. You can only use the gtk2 indicator in the current xfce packages. There is absolutely no way to load gtk3 indicators without installing a custom version of several xfce components.

So whatever the problem is, it's a problem with the gtk2 indicator (because the gtk3 indicator works fine if you install those patches). Therefore your workaround is actually what needs to be done for the real fix. It just needs to be implemented in a way that does not impact other desktops.

Alistair Buxton (a-j-buxton) wrote :

So this is my final analysis:

The sound indicator has two parts: there is the part which gets loaded to the panel and displays the icons and menus, and then there is the dbus service which coordinates between the indicator and all the audio players. Both these parts exist in both the gtk2 and gtk3 version of the plugin. However, the gtk2 dbus backend is not normally used. The package does not include a service activation script so it can never get loaded automatically. The gtk2 package depends on the gtk3 package which installs a service activation script to start the gtk3 dbus backend.

In raring this worked fine: the two different dbus backends were interchangable so it did not matter which one was running. However, in saucy, the gtk3 indicator backend has been rewritten and the gtk2 one has not changed, so they are now out of sync. That is why it doesn't work.

The changes in the backend are very big - I think it would be difficult to port them over to the gtk2 indicator. The easy alternative is the workaround from comment 27, and a harder but more permanent fix is to bring xfce to gtk3 indicator support and dump the gtk2 one entirely.

Daniel Hollocher (chogydan) wrote :

I do think the issue is that the xfce4 panel is in gtk2, and the gtk2 sound indicator was written specifically to support xfce. see: https://bugs.launchpad.net/ubuntu/+bug/1048217

Given what's in 1048217, I think comment #27 needs to be adjusted to work for lubuntu as well, and then it can be a proper fix. And it should also probably check against pidof xfce4-panel, since that is the relevant program, right?

If lubuntu is also affected this adjustment will handle it:
Exec=/bin/sh -c 'if [ -n "$(pidof xfce4-session)$(pidof lxsession)" ]; then /usr/lib/indicator-sound-gtk2/indicator-sound-service;else /usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service;fi'

about using xfce4-penel with pid does the panel start before the file is called that launches the sound indicator? or does the panel launch the sound indicator?
if the panel or the indicator applet is what calls sound indicator that would work fine

Alistair Buxton (a-j-buxton) wrote :

The part that matters (the dbus service) is launched using dbus activation. That means that when any program tries to access the dbus service at namespace "com.canonical.indicator.sound", the dbus daemon will run the activation script (the bit you want to patch). In theory this should never happen when the panel is not running but there is no guarantee of this.

Alistair Buxton (a-j-buxton) wrote :

Also, checking for the PID isn't the greatest idea if there are multiple user sessions. It might be better to check the XDG_CURRENT_DESKTOP environment variable.

true but "$XDG_CURRENT_DESKTOP" is null when it runs

using xfce4-panel pid would only effect someone using multiple sessions and different DEs which would be limited to certain combinations for example Xubuntu and Lubuntu DEs would get along with each other but they would not get along with the others, but all the others would get along with the others

perhaps this will solve that issue with the workaround:
Exec=/bin/sh -c 'if [ -n "$(ps -U $USER | grep xfce4-panel) ]; then /usr/lib/indicator-sound-gtk2/indicator-sound-service;else /usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service;fi'

Changed in indicator-sound (Ubuntu):
status: Triaged → Fix Released
Pasi Lallinaho (knome) on 2013-10-10
Changed in indicator-sound (Ubuntu):
status: Fix Released → Triaged
description: updated
55 comments hidden view all 135 comments
Denis Štogl (denisstogl) wrote :

#5 worked for me also, but #85 doesn't for bluetoot with Headset. I found out that 'pulseaudio-module-bluetooth' is not instaled by default. After instalation and executing 'pulseaudio -k' I got working my headset with 'blueman' from ubuntu repository.

Maybe you will need to call 'pulseaudio -k' command after every restart.

Gaspar (gaspar-ag) wrote :

#5 STOP WORKING after a "sudo apt-get update; sudo apt-get upgrade".

Bluetooth is working but, who cares when you cannot get a sound out of your laptop?

Cannot figure out how to downgrade to Raring applet.

So I will reinstall the hole system with Precise (or fedora xfce spin). The great "feature" they both have? You can listen to music and see a film !

you have to reapply #5
if the sound indicator packages updates w/out a fix you have to reapply it

there is another solution in #75 it should work better with multiple desktop environments installed and you have multiple users/sessions

Richard Elkins (texadactyl) wrote :

Gaspar (#97),

You shouldn't have to do this but I would suggest either re-apply #5 manually or use the automation in #69. Do you really want to re-install and go through re-customizing your laptop all over again? Personally, I am using the automation route.

All,

Why is this major annoyance "unassigned" still? Shouldn't this be assigned to the indicator-sound package maintainer? The XFCE desktop *bunutu distributions are losing users without a fix.

Gaspar (gaspar-ag) wrote :

Thank you very much for your quick response guys, really appreciated.

Of course I reapplied #5, the result was the same I used to have: The applet starts to work, but you have no sound. The funny thing is that when you open the sound preferences, the graphic shows you the sound bars going up and down with the music, you can "see" your music, but you cannot hear anything.

This is the output of the "automated" patch:

 ./status.1208204.sh
status.1208204.sh: Patch/Unpatch status follows
status.1208204.sh: Patched
-rw-r--r-- 1 root root 369 nov 23 14:21 indicator-sound.service
-rw-r--r-- 1 root root 110 nov 23 14:21 indicator-sound.service.ORIGINAL
status.1208204.sh: End

Yes, reinstalling is anoying but I cannot see another solution. On the "good" side: I made a full backup on 2013-11-19 to clean install xubuntu Saucy, so this time, for me, it is not a big deal.

Hi guys!

Better safe then sorry, so i thought i might remind that the sound
preferences for pulse are now under:

main menu => Audio Production => Mixer And Card Control

Perhaps your sound is routed to another device in the pulse control? It
sort of make sens if you can see the sound in the "VU" meter :)

yours,
Set

On 2013-11-23 14:34, Gaspar wrote:
> Thank you very much for your quick response guys, really appreciated.
>
> Of course I reapplied #5, the result was the same I used to have: The
> applet starts to work, but you have no sound. The funny thing is that
> when you open the sound preferences, the graphic shows you the sound
> bars going up and down with the music, you can "see" your music, but you
> cannot hear anything.
>
> This is the output of the "automated" patch:
>
> ./status.1208204.sh
> status.1208204.sh: Patch/Unpatch status follows
> status.1208204.sh: Patched
> -rw-r--r-- 1 root root 369 nov 23 14:21 indicator-sound.service
> -rw-r--r-- 1 root root 110 nov 23 14:21 indicator-sound.service.ORIGINAL
> status.1208204.sh: End
>
> Yes, reinstalling is anoying but I cannot see another solution. On the
> "good" side: I made a full backup on 2013-11-19 to clean install xubuntu
> Saucy, so this time, for me, it is not a big deal.
>

--
Set Hallstrom
AKA Sakrecoer
http://sakrecoer.com

WARNING: Remember clear-text email is subject to mass surveillance
systems. Alone this information is useless. Our summed communications
are worth humanity.

Please keep in mind Internet is a boulevard in a crowded virtual city.
Privacy is found under the cloaks.

In response to comment #90:

I still observe the same issue on a fresh Xubuntu 14.04 amd64.
The difference to the Saucy release is that I can't apply the fix from comment #5, because I don't have /usr/share/dbus-1/services/indicator-sound.service. Where is the file now? Is it dynamically generated, or has something in the package changed?

Eric Walker (eqwalker) wrote :

Just wanted to add to the list of people having this same issue. All three of my machines (two Xubuntu and one Ubuntu Studio) that I updated now don't have a functioning indicator on the sound. I am not keen to having to install a "workaround" that includes "holding" updates to keep the workaround in place. Much rather this be fixed permanently. Two of my friends that I got to switch from Windows to Xubuntu also now have the same problem and now they are doubting their decision. I can't see how this is remaining a low priority since this is so visual. I am very new to the Ubuntu world and have been most pleased with Xubuntu and Ubuntu Studio and so have my friends but this is not giving a good impression to them. Just saying.

@eqwalker
This is a high priority bug, you can see it at the top of this page
This command will implement the workaround
sudo wget http://pastebin.com/raw.php?i=4HHup7ZF -O /usr/share/dbus-1/services/indicator-sound.service
then logout and login
to verify it worked run this
md5sum /usr/share/dbus-1/services/indicator-sound.service
it should give you this:
ece5a3e0ad8dc32c00d6aec49c2017bf /usr/share/dbus-1/services/indicator-sound.service

Eric Walker (eqwalker) wrote :

Thank you for your quick response. That has worked. I will pass this command on to my friends for them to run in a terminal window. Glad to see the priority is high. As I have mentioned I am new to the linux world and quite leery of messing around with commands in a terminal window but simply copying and pasting from your command made it simple. Look forward to the permanent fix. With the release of Windows 8 and how many of my friends do not like it, now is the time to get people to switch. That is why I switched and am so far pleased. I hope to learn more as time goes. Thanks again.

Renzo Bagnati (renbag) wrote :

In reply to comments #71, #72, #74 and #104:
The variable $(arch) on 32-bit systems returns the value "i686", not "i386", so the workarounds using it do not work if you are in 32-bit unity.

in that case lets make this long line another 25% longer
Exec=/bin/sh -c 'if [ -n "$(ps -U $USER | grep xfce4-panel)" ]; then /usr/lib/indicator-sound-gtk2/indicator-sound-service;else /usr/lib/$(if [ $(arch) == "i686" ];then echo i386;else arch;fi)-linux-gnu/indicator-sound/indicator-sound-service;fi'

@eqwalker updated for 32bit compatibility
sudo wget http://pastebin.com/raw.php?i=iUnRRuA6 -O /usr/share/dbus-1/services/indicator-sound.service
verify with this
md5sum /usr/share/dbus-1/services/indicator-sound.service
3555d649a4fbd10fbb13c8a17a7977dd /tmp/tmpfile

I tested this on both a 64bit and 32bit live disk of 13.10

i have tried all of these and none return i386 or x86_64, so if anyone knows a command that does i would like to know, i wanted to keep that Exec line simple but it is getting ridiculous
$(arch), $(uname -m) and $(dpkg --print-architecture)

EricDHH (ericdhh) wrote :

Have rollbacked 3 computers to mint 15 (ubuntu 13.04) and get rid of this bug, it's a 13.10 feature. So my suggestion is a rollback of the affected packages to the 13.04 state. What has happened to the ubuntu quality, are we back into the "never change a running system" timeline?

This bug is on the agenda for discussion at the Xubuntu meeting to be held on Thursday, December 5 at 19:00 UTC on #xubuntu-devel in the Freenode IRC network (chat.freenode.net).

affects: indicator-sound (Ubuntu) → indicator-sound-gtk2 (Ubuntu)

PPA with fixed package:

https://launchpad.net/~a-j-buxton/+archive/indicator-sound-gtk2
ppa:a-j-buxton/indicator-sound-gtk2

This doesn't use the workaround from the bug report. It fixes it in a
way which is hopefully compatible with other desktops. It needs
testing though, on systems with both Xubuntu and Unity installed.

Richard Elkins (texadactyl) wrote :

Alistair,

I can confirm that this indicator-sound-gtk2 package update SUCCEEDS on 2 different Xubuntu Saucy machines in my house: one with an Intel i915 kernel module and one with a gma500_gfx kernel module (Modesetting Xorg video driver).

Thank you. Now I can start psychedelik.com radio without pissing off my cats! (-:

Hey Ubuntu Studio folks - please try this out, okay?

1. Make sure that the patch from message #5 (above), #69 (above), or wherever is *not* in effect.
E.g. With synaptic, re-install indicator-sound and indicator-sound-gtk from the repositories.
2. Verify that the audio widget in the upper-right corner isn't functioning as it ought to.
3. sudo add-apt-repository ppa:a-j-buxton/indicator-sound-gtk2
4. sudo apt-get -y update
5. sudo apt-get -y dist-upgrade
6. Restart the desktop (E.g. sudo reboot)

Richard

description: updated
tags: added: sru stable-release-update
summary: - indicator-sound no longer functions with xfce4-indicator-plugin
+ [SRU]Update indicator-sound-gtk2 with patch
Alistair Buxton (a-j-buxton) wrote :

This is a debdiff for the fix. It doesn't quite match what's on my ppa because I've edited the changelogs a bit. Version numbers/changelog will probably require further fixing anyway.

The attachment "Debdiff for the fix" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch

I just added Volti, an indicator for volume/sound and using alsamixer directly instead of the pulseaudio.
I like the volti "indicator" much better, as it is a classic volume (sound) icon with a very simple up/down bar, yet can be changed easily by simply hovering over it and rolling the mouse wheel.
Alsamixer is proven, Pulseaudio seems to have problems. I like to stick with what works. (Call me old-fashioned.)
Something this elementary (using sound on a system) shouldn't have any bugs, by the way.

Brian Murray (brian-murray) wrote :

I've uploaded this to the Saucy -proposed queue for review and also the same changes with a different version number to Trusty.

Changed in indicator-sound-gtk2 (Ubuntu Saucy):
status: New → In Progress
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound-gtk2 - 12.10.0.1-0ubuntu3

---------------
indicator-sound-gtk2 (12.10.0.1-0ubuntu3) trusty; urgency=low

  * Make this actually work. (LP: #1208204)
    - Make the Gtk2 indicator use a different DBus name, so that the
      indicator-sound-service from this package is loaded instead of
      the Gtk3 one which is incompatible.
 -- Alistair Buxton <email address hidden> Wed, 11 Dec 2013 13:33:19 -0800

Changed in indicator-sound-gtk2 (Ubuntu):
status: Triaged → Fix Released

Hello TK, or anyone else affected,

Accepted indicator-sound-gtk2 into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/indicator-sound-gtk2/12.10.0.1-0ubuntu2.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in indicator-sound-gtk2 (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
Arek (arek75) wrote :

Was hit by this bug on 2 xubuntu systems. One got pulseaudio yanked for various reasons, so the bug no longer applies to it. On the other one I just updated to the saucy-proposed version, which fixes the bug for me.

--Arek

tags: added: verification-done
removed: verification-needed
pioruns (pioruns) wrote :

I am confirming that patch is working.

Freshly installed Xubuntu 13.10 AMD64 on desktop. Enabled saucy-proposed repo, installed only 1 package:

Package: indicator-sound-gtk2
Version: 12.10.0.1-0ubuntu2.3

PC rebooted, sound is working now.

Richard Elkins (texadactyl) wrote :

I removed the temporary PPAs provided in #110, added Saucy Proposed, reinstalled sound-indicator-gtk and sound-indicator, and rebooted. I can confirm that the patch is working.

Nikolay Morozov (nmorozov) wrote :

work for me

quantumfoam (lmunchpad) wrote :

Updating from saucy-proposed fixed the printing indicator on my machine (Xubuntu 13.10 amd64).

Valentin (a0003719) wrote :

I enabled the saucy-proposed repo and installed 'indicator-sound-gtk2'. Fixed the sound indicator on xubuntu 13.10 (64).

Is this also going into Ubuntu Studio? They have XFCE, and the same problem.

Henrik Karlsson (hkarlsson) wrote :

I installed indicator-sound-gtk2_12.10.0.1-0ubuntu2.3_amd64.deb and sound indicator works fine now, thank you.

Okay, this has marinated for 7 days. Can we promote the fix or not?

Kenneth Wrede (kennethwrede) wrote :

The patch works for me too.

Does it NOT work för somebody?

openfred (openfred) wrote :

Tested today on a new installation. Indicator now works great.
Unmute is working using menu, using keyboard specific keys (Thinkpad T500), using pavucontrol.
Regular users (not using proposed-updates) may use it now.
Never too late for a Xmas present :-)
Thx for the fix

grundair (grundair) wrote :

Tested today on Ubuntu Studio and it did not work. I then appplied the action in comment 104 and then it displayed. I use Studio to broad cast 3 web shows and it is vital that it works since Jack will not work correctly and IDJC will cease

Changed in indicator-sound-gtk2 (Ubuntu Saucy):
status: Fix Committed → Invalid
status: Invalid → Fix Committed
openfred (openfred) wrote :

@grundair

The file provided by the package in proposed-updates is the same you can get after what is described in comment #4 and #104.
Hard to believe it is not working on your particular case, as anybody else seems ok.

As you said, you are using you PC to broadcast web shows, I was wondering if you logged off and on again ?
Indeed, it is mandatory to get the applet behaviour to become OK. I had to log off after updating the package.

You may be able to test without logging off, by simply adding a new Indicator applet, but I haven't tested it.

Alistair Buxton (a-j-buxton) wrote :

@openfred

no. the proposed fix has nothing to do with the workarounds described in #4 and #104 which are harmful.

Petri Piira (petri-piira) wrote :

Just upgraded from Xubuntu 13.04 to Xubuntu 13.10, and got the issue of the sound indicator not working. (64bit system.)

I did the workaround described in http://askubuntu.com/questions/360806/volume-indicator-issue-after-xubuntu-13-10-upgrade

It worked.

Just posted to point out that the upgrade from 13.04 to 13.10 is still broken for this.

Stephen Warren (srwarren) wrote :

I installed indicator-sound-gtk2_12.10.0.1-0ubuntu2.3_amd64.deb, and it fixed the issue for me. Is there a good place to indicate test results for proposed packages?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound-gtk2 - 12.10.0.1-0ubuntu2.3

---------------
indicator-sound-gtk2 (12.10.0.1-0ubuntu2.3) saucy; urgency=low

  * Make this actually work. (LP: #1208204)
    - Make the Gtk2 indicator use a different DBus name, so that the
      indicator-sound-service from this package is loaded instead of
      the Gtk3 one which is incompatible.
 -- Alistair Buxton <email address hidden> Wed, 11 Dec 2013 13:33:19 -0800

Changed in indicator-sound-gtk2 (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in indicator-sound-gtk2 (Ubuntu Saucy):
assignee: nobody → Ross Parker (rossco-parker)
assignee: Ross Parker (rossco-parker) → nobody
fpaz (it-fpaz) on 2014-03-16
Changed in indicator-sound-gtk2 (Ubuntu):
assignee: nobody → fpaz (it-fpaz)
assignee: fpaz (it-fpaz) → nobody
Changed in indicator-sound-gtk2 (Ubuntu):
assignee: nobody → Dick Seaman (swankthecyborg)
Lars Uebernickel (larsu) on 2014-04-11
no longer affects: indicator-sound
Displaying first 40 and last 40 comments. View all 135 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers