restart is missing from SessionMenu

Bug #815077 reported by Omer Akram on 2011-07-23
434
This bug affects 83 people
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
Undecided
Conor Curran
indicator-session (Ubuntu)
Medium
Conor Curran
Oneiric
Medium
Conor Curran

Bug Description

With the latest update to indicator-session there is no 'restart' menu item available to restart the system

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: indicator-session 0.3.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-6.7-generic 3.0.0-rc7
Uname: Linux 3.0.0-6-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Sat Jul 23 19:08:33 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110721)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-session
UpgradeStatus: No upgrade log present (probably fresh install)

Omer Akram (om26er) wrote :
Changed in indicator-session (Ubuntu):
assignee: nobody → Conor Curran (cjcurran)
Changed in indicator-session (Ubuntu):
status: New → Confirmed
Changed in indicator-session (Ubuntu):
importance: Undecided → Medium
Eric Appleman (erappleman) wrote :

Can we expand this bug to include a lack of user switching and guest sessions?

tags: added: iso-testing
Erick Brunzell (lbsolost) wrote :

Just noticed that this effects both the live desktop and the installed version of the 20110801-i386 iso-testing image.

Even selecting logout and then selecting restart from the login screen fails to restart the machine and even Alt + SysReq + B seems not to work, but reboot from terminal does work.

Erick Brunzell (lbsolost) wrote :

Post install there were 25 updates. After applying those updates I can now select logout and restart from the login screen does now work.

I recall seeing similar behavior with earlier versions of gnome3 so maybe it's an upstream thing?

Erick Brunzell (lbsolost) wrote :

With the 20110802-i386 iso-testing image you can restart the live desktop by clicking on logout, confirming, and then clicking on restart in the upper right-hand corner of the login screen.

IMHO just something for the release notes as is bug 819609.

Erick Brunzell (lbsolost) wrote :

Regarding the above comment. Logout is also missing due to bug 750140.

Some mention needs to be made in the release notes about how to reboot the live CD :^)

I just Alt + SysReq + K and then select restart from the upper right hand corner of the login screen.

Erick Brunzell (lbsolost) wrote :

The reason I opened bug 820666 was because of a change between 20110803 and 20110803.1 (both i386).

What I said in comment #6 worked with 20110803 but it does not work with 20110803.1.

With 20110803.1-i386 the logout option is there in the live session but selecting logout and then selecting restart from the upper right hand corner of the login screen fails ............ it just brings back the ability to log back into a desktop session.

So we need a consistent and coherent set of instructions for rebooting the live CD/DVD/USB included in the release notes.

Something like Ctrl + Alt + F1 and type sudo reboot :^)

Erick Brunzell (lbsolost) wrote :

I just double checked on a test install from the 20110803.1-i386 image with no updates applied and post-installation the newly installed Ubuntu can be successfully rebooted using the instructions in comment #6, that is restart is successful from the login screen.

It's only in the live session that restart is unsuccessful from the upper right hand corner of the login screen.

Changed in indicator-session:
status: New → Confirmed
Jeff Lane (bladernr) wrote :

I opened a bug that was marked as a duplicate of this... on an install of Alpha 3 with all updates applied as of today (Aug 9) the restart option is still not available.

I verifed this on 4 different machines that were installed and updated in the same manner.

Stephen Cradock (s-cradock) wrote :

I note that selecting "logout" from the SessionMenu after certain updates gives a dialog box that asks if I am sure I want to logout, and offers the alternative of a restart. Selecting that option gives a restart as expected.

This surely means that the restart script is in place and working; all that is missing is the menu entry.

Could someone fix this, please? It's getting really old...

Vladimir Scherbaev (zemik) wrote :

I apply this patch to source from bzr branch lp:indicator-session and build package. This fix bug for me. But I don't understand why for some item added three dots.

Conor Curran (cjcurran) wrote :

Hi,

Thanks for the patch !
I intend to put this in the gtkdialog as opposed to the menu only because we are trying to limit the length of that menu. Thanks for the patch though.

Conor

Vladimir Scherbaev (zemik) wrote :

Conor, can you explain me about three dots? What that means?

And I think what better remove Bluetooth from menu, but not reboot... :)

Vladimir

Conor Curran (cjcurran) on 2011-08-10
Changed in indicator-session:
status: Confirmed → Fix Committed
milestone: none → 0.3.1
Conor Curran (cjcurran) on 2011-08-10
Changed in indicator-session:
assignee: nobody → Conor Curran (cjcurran)
Conor Curran (cjcurran) on 2011-08-10
Changed in indicator-session:
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) wrote :

Vladimir, the three dots is an "ellipsis" and you can read about it at http://developer.gnome.org/hig-book/unstable/controls-buttons.html . Note that Ubuntu status menus do add an ellipsis to Settings items.

Vladimir Scherbaev (zemik) wrote :

Thank you, Jeremy!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.1-0ubuntu1

---------------
indicator-session (0.3.1-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - restart is missing from SessionMenu (LP: #815077)
    - Don't allow starting programs via the greeter indicators (LP: #811853)
    - Printer menu item should launch system-config-printer (LP: #818602)
    - gudev integration
    - apt restart required awareness
  * debian/control
    - Added build depends on libgudev-1.0-dev
 -- Ken VanDine <email address hidden> Wed, 10 Aug 2011 16:23:33 -0400

Changed in indicator-session (Ubuntu Oneiric):
status: Confirmed → Fix Released

I installed 0.3.1-0ubuntu2 but restart is still missing in the SessionMenu. Maybe you should call the menu entry "Shut Down/Restart" now.

Xavier Guillot (valeryan-24) wrote :

The "restart" option is now in a button in bottom left on the window appearing when you click on "Shutdown" in SessionMenu, this is well because it allows to restart easily without putting too many commands in the menu.

Stephen Cradock (s-cradock) wrote :

That's good, but Eduard's suggestion is to show in the menu that "Shutdown" also allows "Restart".

I think that would be appropriate - it is clear and informative, rather than obscure, as at present.

Vladimir Scherbaev (zemik) wrote :

And maybe better move left "cancel" button in dialog.

thomas (thomas-heuer) wrote :

Still no restart option in the finished release…

Vladimir Scherbaev (zemik) wrote :

You may see it if pressed to Shut Down...

Jacopo Moronato (jmoronat) wrote :

See comment #18

I disabled the confirmation dialogues, because I know what I am doing. However sometimes I have to restart the machine, so I would like to see it in the system menu. Is there a possibility to have a dconf option whether to include it in the menu or not (defaulting the later one).

pablomme (pablomme) wrote :

Or even better, setting apps.indicator-session.suppress-logout-restart-shutdown restores the "Restart" entry automatically.

That said, pressing the power button does offer you the option to restart.

Matthew Paul Thomas (mpt) wrote :

(This bug regressed in Raring, bug 1156566.)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers