Time and Date Settings don't load

Bug #751175 reported by Martin Eve on 2011-04-05
390
This bug affects 81 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Medium
Unassigned
gnome-control-center (Ubuntu)
Undecided
Unassigned
indicator-datetime (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: indicator-datetime

Clicking the time in the indicator gives the option "Time and Date Settings..."

Clicking this menu option has no effect; time and date settings do not appear.

The same result is apparent if attempting to launch time and date settings from the System Settings app.

Expected result: time and date settings appear.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: indicator-datetime 0.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Tue Apr 5 10:31:22 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100831.2)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-datetime
UpgradeStatus: Upgraded to natty on 2011-04-05 (0 days ago)

Martin Eve (martineve) wrote :

I can confirm exactly the same bug with the 64bit ubuntu - bug 751396. I marked it as a duplicate.

jorge cob (jorgecs10) wrote :

I can confirm this

Running it from the command line, after some seconds, shows this message:

(indicator-datetime-preferences:3106): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Martin Eve (martineve) wrote :

After today's updates (standard repos and unity daily ppa), this seems to be fixed.

Agreed, problem appears solved :)

Sebastien Bacher (seb128) wrote :

thanks, closing the bug then

Changed in indicator-datetime (Ubuntu):
status: Incomplete → Invalid
Simon (simon-west-family) wrote :

Clean install of Beta 1 when it came out, this bug is still not fixed for me (just did update which included indicator and time-date applet updates, and I have restarted). Settings in applet does nothing, in main control centre I get egg-timer mouse cursor for a few seconds then nothing.

Simon (simon-west-family) wrote :

This bug is definitely not fixed for me

Changed in indicator-datetime (Ubuntu):
status: Invalid → Incomplete

I hate to say it, but...bug's back lol

Latest version is now 0.2.2-0ubuntu1

I would obtain a backtrace but i'm unsure about the procedure since i can't find mention of a "indicator-datetime-dbg" package?

Karl Lattimer (karl-qdh) on 2011-04-08
Changed in indicator-datetime (Ubuntu):
status: Incomplete → In Progress
Sebastien Bacher (seb128) wrote :

the wiki page indicated explains how to enable the ddeb source which should give you access to indicator-datetime-dbgsym to install

Karl Lattimer (karl-qdh) wrote :

@Simon, Antonius; could you run "ps ax | grep indiator-datetime-preferences" the next time you can reproduce it, I think it's a problem with the application still running at least in some way behind the scenes.

Originally it was:

ant@ant-laptop:~$ ps ax | grep indicator-datetime-preferences
 5414 ? Sl 0:00 indicator-datetime-preferences
13645 pts/0 S+ 0:00 grep --color=auto indicator-datetime-preferences

then, after clicking "Time and Date Settings..."

ant@ant-laptop:~$ ps ax | grep indicator-datetime-preferences
 5414 ? Sl 0:00 indicator-datetime-preferences
13647 ? S 0:00 indicator-datetime-preferences
13652 pts/0 S+ 0:00 grep --color=auto indicator-datetime-preferences

then, after a few seconds (with nothing happening), back to:

ant@ant-laptop:~$ ps ax | grep indicator-datetime-preferences
 5414 ? Sl 0:00 indicator-datetime-preferences
13655 pts/0 S+ 0:00 grep --color=auto indicator-datetime-preferences

Karl Lattimer (karl-qdh) wrote :

so you have a zombie process which is blocking because of libunique :/

sure would be nice to find out what makes it block, any hints at reproducing this? I'm assuming that it launches properly after reboot but any subsequent attempts are blocked?

Dennis Baudys (thecondordb) wrote :

I can confirm the date/time settings dialog not to be opening with all updates installed as of now (in Ubuntu Natty Beta 2!). It seems to opening some days, some other days not. Some users are affected, some are not. See also comments on bug 729631 [1].

I'm using:

- Ubuntu 11.04 (Natty) Beta 2 (32-.Bit) with Kernel 2.6.38-8-generic # 42
- Unity 2D
- indicator-datetime 0.2.2-0ubuntu1
… inside VirtualBox as a guest system.

The dialog doesn't appear either, when entering »indicator-datetime-preferences« in a terminal window. After waiting for many seconds/some minutes, following output is printed - or nothing happens at all:

"(indicator-datetime-preferences:1807): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible cause include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

Restarting Ubuntu in the virtual machine did not help.

Thanks for fixing this in time! It causes major trouble testing the (complicated) date/time strings (see comments on [1]) and the deadline for translations is coming very soon.

[1] https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/729631

Regards,

Dennis Baudys
(Ubuntu German Translator)

Dennis Baudys (thecondordb) wrote :

Addendum: NOW, after a restart AND wating forever in the terminal window after entering »indicator-datetime-preferences« (where nothing happend) the dialog appeas when clicking on the menu entry of the date/time indicator in the panel.

What a strangeness.

Karl Lattimer (karl-qdh) wrote :

@Dennis, the indicator-datetime-preferences is obviously having some trouble communicating over dbus, mostly this is out of our hands as we simply use libunique to do the communication and determine if the application is already running.

If you're having trouble launching it, please try killing it first.

Changed in indicator-datetime (Ubuntu):
assignee: nobody → Karl Lattimer (karl-qdh)
fishears (johnnyp-ntlworld) wrote :

After being logged in for a few hours today, I just checked the indicator-datetime-process with
> ps ax | grep indicator-datetime-preferences

and got the following (showing that the process is not running) :
> 3287 pts/0 S+ 0:00 grep --color=auto indicator-datetime-preferences

then I clicked on indicator-datetime, "Time & Date Settings" and no settings appeared so I repeat the process check and get:
> 3289 ? Sl 0:00 indicator-datetime-preferences
 3292 pts/0 S+ 0:00 grep --color=auto indicator-datetime-preferences

Which shows that it is now running even though there is no GUI...

So I do:
> kill 3289

and then click on indicator-datetime, "Time & Date Settings" and this time the settings appear as expected and indeed continue to do so throughout the current session. So could it be just the first launch that is the problem?

Simon (simon-west-family) wrote :

fishears #19 post - same is true for me (at least I can now get my clock displaying the way I want!)

Karl Lattimer (karl-qdh) wrote :

hmm, this is interesting - there seems to be some link to dbus not working correctly in libunique which might cause the first failure, then after killing it it'll restart fine.

I can't reproduce this unfortunately, which is making it harder to find a fix. Any other hints? could someone do a gdb attach to the process and back trace it from there perhaps?

joopbraak (joopbraak) wrote :

With me, it works the first time I open preferences.

After opening and subsequently closing the preferences the first time I have a sh zombie process (parent process gvfsd-http) which prevents the preferences from opening correctly after that.

I have to wait longer, until the zombie process is gone (can take a few minutes or forever), before it works again.

fishears (johnnyp-ntlworld) wrote :

@Karl Lattimer: I've got the debug symbols already installed so I can do this but it will be later today - unless someone else provides it before then.

Karl Lattimer (karl-qdh) wrote :

Thanks fishears :)

Karl Lattimer (karl-qdh) wrote :

@joopbraak: the preferences shouldn't be related to gvfsd-http maybe you're experiencing a different bug that's causing similar symptoms?

fishears (johnnyp-ntlworld) wrote :

backtrace from indicator-datetime-preferences - this is a first-run after login so the GUI did not appear. HTH. Let me know if I can help further.

Daniel Hermanns (d-hermanns1) wrote :

I have the same problem. I use the Beta 2. The version of the "indicator-datetime" is indicator-datetime_0.2.3-0ubuntu2.

I get the error message:

indicator-datetime-preferences

(indicator-datetime-preferences:2092): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Karl Lattimer (karl-qdh) wrote :

@fishears, it seems to be related to policy kit, do you have policy kit installed and up to date?

Try a dist-upgrade if you haven't already.

fishears (johnnyp-ntlworld) wrote :

by Policy Kit, do you mean:

policykit-1:
  Installed: 0.101-1
  Candidate: 0.101-1
  Version table:
 *** 0.101-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
and:

policykit-1-gnome:
  Installed: 0.99-1ubuntu4
  Candidate: 0.99-1ubuntu4
  Version table:
 *** 0.99-1ubuntu4 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

All packages on my system are up to date...

Lex Ross (lross) wrote :

I have the same problem with zombie process. Each time I close the Date & Time preferences dialogue I end up with the process blocking the subsequent opening of Date & Time preferences.

$ ps ax | grep indicator-datetime-preferences
 2007 ? Sl 0:00 indicator-datetime-preferences

I have to kill that process whenever I need to launch Date & Time preferences, otherwise it fails with the message

(indicator-datetime-preferences:5032): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

The important thing is, that I only get this problem when using clock applet Date and Time preferences. If I use Unity launcher or the terminal, everything is working fine.

fishears (johnnyp-ntlworld) wrote :

As of today, this appears to be fixed for me. Three consecutive reboots and indicator-datetime-preferences has run correctly when invoked from indicator-datetime and gnome-control-center

Let me know if any new information from me will help you further. I'll let you know if the bug reappears!

indicator-datetime:
  Installed: 0.2.3-0ubuntu3
  Candidate: 0.2.3-0ubuntu3
  Version table:
 *** 0.2.3-0ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

Karl Lattimer (karl-qdh) wrote :

@fishears thanks for all your testing. Did you update, any particular packages of interest appear in the update?

Can we confirm this is gone?

I can't reproduce it.

Daniel Hermanns (d-hermanns1) wrote :

Sunday I installed the updates: libdbusmenu-glib3; gir1.2-dbusmenu-glib-0.4; libdbusmenu-gtk3.
Since that day the indicator-datetime works for me.

Today there was an update for the indicator. And now it doesn't work....

Daniel Hermanns (d-hermanns1) wrote :

I installed the package manually and now it works.

indicator-datetime_0.2.3-0ubuntu3_i386.deb

fishears (johnnyp-ntlworld) wrote :

Haha - spoke too soon. Just logged in to post here and thought I'd better check it one last time.... it failed. There was the usual process running but no GUI appeared, I killed it and now it works again so, no, this hasn't gone away.

Feel free to ask for any help on this - I'll happily sit here running backtraces and installing patches ;)

Daniel Hermanns (d-hermanns1) wrote :

I become crazy. Sometimes it works and sometimes it doesn't.

Otus (jan-varho) wrote :

Not fixed as of today and 0.2.3-0ubuntu3. Shouldn't the priority be higher as there is currently no way to change time or to 24h format?

I seem to be able to reproduce every time so I can debug if someone gives directions.

sacha@ubuntu (sacha-b77) wrote :

Hello!

I'm running on a fresh upgrade of Natty (this day).

On my first session (created on intall), hiting preferences of date/time applet does'nt work. I've deleted gconfd, gconf and gnome, none!

I have tested sudo dpkg-reconfigure tzdata, none!

I have tested with another session. And, on this session, it works!

It's strange that we must switch to another session to modify preferences of date/time.

So, anybody had tested with a new session?

Daniel Hermanns (d-hermanns1) wrote :

Yes, I can confirm this. When I switch to a Guest-Session I can change date and time.

yanick (yanick76) wrote :

It's strange, 'indicator-datetime-preferences' appears in my process list after reboot and login. Everything works after I kill process 'indicator-datetime-preferences'.

sacha@ubuntu (sacha-b77) wrote :

I confirm that, when i kill the processus indicator-datetime-preferences, the applet works fine after.

But, i haven'nt this processus after boot and login. The fisrt time after i hit the preference option, then, the pocessus appears once. I kill it, i restart the preferences and it works fine.

If i reboot, the bug appears....

It seems to be a lot of problems with the root permissions, when i've checked my sourcelists for example, without message and after few minutes, the screen freezes and hard reset is needed. It would be linked?

Karl Lattimer (karl-qdh) wrote :

@sacha it seems what's happening is the application fails to load the first time because of a failure possibly in policy kit but it hangs. The subsequent attempts are blocked by libunique.

sacha@ubuntu (sacha-b77) wrote :

Why people doesn't suffer of this bug?

On ubuntu-fr.org, some users doesn't have this bug on natty beta2. Why?

It's strange! If it's a bug of policykit, why some users don't have this bug too?

Why it's works with another session and not on the first session?

Michal Predotka (mpredotka) wrote :

Just updated to Ubuntu 11.04 from 10.10 and I have this bug.

Bob-El (boblanctot) wrote :

Feeling the need to add my 2 cents worth, I am also experiencing this bug. I installed 11.04 a couple of days ago and this issue has been bugging me. Finding and killing the indicator-datetime-preferences process allowed me to access the settings.

Patrick Dawkins (pjcdawkins) wrote :

I have the same problem. This might be a simpler explanation of the solution:

1. Press ALT+F2 (to bring up the "Run a command" dialog)
2. Type killall indicator-datetime-preferences and press Enter
3. Try to open Time & Date Settings again

Otus (jan-varho) wrote :

@Patrick Dawkins,

Nope, that doesn't help for me. When it fails the process gets left running, but killing it doesn't help. I.e. launching it again still fails and produces another running process.

I can reproduce this, but after booting and trying it the first time it sometimes works. Closing the window and retrying usually fails.

summary: - Time and Date Settings don't load (Natty Beta 1)
+ Time and Date Settings don't load
Alfas (alfonsasstonis) wrote :

I also have the same problem: Time settings indicator does not start. If I start from command line I get error message:
indicator-datetime-preferences

(indicator-datetime-preferences:2387): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Barry Rueger (barry-rueger) wrote :

Just tried Patrick Dawkins' killall suggestion, and it worked for me. Natty 2.6.38-8-generic Gnome 2.32.1

Zaph0d (nertberble) wrote :

I am also experiencing this bug and have also found a simple workaround. The problem appears to be with elevation - ie the date and time settings app fails to request it. Running from terminal the above quoted command works if you ask for elevation. So:

   $ sudo /usr/bin/indicator-datetime-preferences

works fine for me.

This problem has come and gone with me, mostly come in the last month or so.

I used the ps ax | grep indicator-datetime-preferences and then kill the first job method (i.e. proposed by https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/751175/comments/19). Obviously, this is not an optimum approach to the problem!

I think it is a pretty high bug: changing date and time is a common user action and the solution to this at the moment is not for the people for whom "just works" is important. These kinds of issues have a major effect on user opinions.

grelbar (grelbar) wrote :

Fresh install of 11.04 today. Initially i set the time and date options using indicator-datetime-preferences, like i normally would. Later i noticed i wanted to change something through the GUI, but couldn't. Attempting to start it from the terminal results in:

(indicator-datetime-preferences:18310): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Killing the process from the terminal, and then attempting to restart it through the GUI worked fine, and has worked fine several subsequent tries. Also starting it from the terminal (as non-root user) works fine after killing it first.

Version is 0.2.3-0ubuntu3.

grelbar (grelbar) wrote :

Some additional information: Ubuntu 64-bit, kernel 2.6.38-10-generic, Gnome version 2.32.1. Everything apt-get upgraded.

Huubb (huub-van-baal) wrote :
Download full text (3.1 KiB)

Earlier this week a dbus patch came through. After rebooting I thought the behavior with indicator-datetime-preferences had disappeared. However after some reboots the problems still exists. First time launch causes a hang in de application. Killing it manually the application does work.

Dbus-monitor still gives this in its results (along other things):
method call sender=:1.81 -> dest=org.freedesktop.DBus serial=11683 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=AddMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/datetime/'"
method call sender=:1.81 -> dest=org.freedesktop.DBus serial=11684 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=RemoveMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/datetime/'"
method call sender=:1.81 -> dest=org.freedesktop.DBus serial=11685 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=AddMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/datetime/'"
method call sender=:1.81 -> dest=org.freedesktop.DBus serial=11686 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=RemoveMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/datetime/'"
method call sender=:1.81 -> dest=org.freedesktop.DBus serial=11687 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=AddMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/datetime/'"
method call sender=:1.81 -> dest=org.freedesktop.DBus serial=11688 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=RemoveMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/datetime/'"
method call sender=:1.81 -> dest=org.freedesktop.DBus serial=11689 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=AddMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/datetime/'"
method call sender=:1.81 -> dest=org.freedesktop.DBus serial=11690 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=RemoveMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/datetime/'"
method call sender=:1.81 -> dest=org.freedesktop.DBus serial=11691 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=AddMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/datetime/'"
method call sender=:1.81 -> dest=org.freedesktop.DBus serial=11692 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=RemoveMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/...

Read more...

Almaz (almazworks) wrote :

My solution:
1) open Performance Monitor;
2) kill the process "indicator-datetime-preferences" (if you tried to open the preferences it should be there);
3) click again on "Time & Date Settings ...".
I hope this helps.

Massimo Forti (slackwarelife) wrote :

I can confirm this bug. new installation of Ubuntu on hp 11.04 made ​​today. Updated kernel to version 2.6.38-11 and installed Unity 2d. After all, the applet does not work. I must kill the process whenever i need to use it. Many thanks.

Ted Gould (ted) on 2011-08-31
Changed in indicator-datetime (Ubuntu):
status: In Progress → Confirmed
assignee: Karl Lattimer (karl-qdh) → nobody
importance: Low → Medium
Changed in indicator-datetime:
status: New → Confirmed
importance: Undecided → Medium
Javier Jardón (jjardon) wrote :

The current code fails here:

http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/oneiric/gnome-control-center/oneiric/view/head:/shell/gnome-control-center.c#L862

So seems that the indicator-datetime is not correctly introduced in the control-center data model.
Seems to be related with the change to the new gnome-menus api in the cc_shell_model_add_item() function:

http://git.gnome.org/browse/gnome-control-center/commit/?id=c635d8e875713c697ba9a9b13f5d7a4cc6ced432

affects: gnome-control-center → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Javier Jardón (jjardon) wrote :

After cleanup the libraries on my system, the panel loads again without problems with the current indicator code. Leave the bug open as seems that this bug only affect the pre-oneiric Ubuntu packages

Changed in gnome-control-center (Ubuntu):
status: New → Invalid
Changed in indicator-datetime:
status: Confirmed → Fix Released
Sam_ (and-sam) wrote :

Unable to reproduce, settings open here with:
indicator-datetime:
  Installed: 0.2.3-0ubuntu3
  Candidate: 0.2.3-0ubuntu3
  Version table:
 *** 0.2.3-0ubuntu3 0

Linux 2.6.38-11-generic #48-Ubuntu

Ben Hearsum (bhearsum) wrote :

I just hit this with the dbus message:
[] bhearsum@voot:$ indicator-datetime-preferences

(indicator-datetime-preferences:5764): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

ii indicator-datetime 0.2.3-0ubuntu3 A very, very simple clock

Javier Jardón (jjardon) on 2011-10-09
Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers