Date label on the indicator is partially untranslated

Bug #729631 reported by David Planella on 2011-03-05
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Low
Unassigned
Unity Foundations
Low
Karl Lattimer
indicator-datetime (Ubuntu)
Low
Karl Lattimer

Bug Description

Binary package hint: indicator-datetime

I've got the indicator set to show the day if the week, day and month and time.

For some reason the day of the week appears untranslated, whereas the day and month appear half translated as "5 de Mar" ('de' is in Catalan, 'Mar' in English). See the attached screenshot.

I'm not sure where this translation is supposed to come from, from indicator-datetime or somewhere else.

David Planella (dpm) wrote :
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Karl Lattimer (karl-qdh)
importance: Undecided → Low
status: New → Confirmed
Changed in indicator-datetime:
importance: Undecided → Low
status: New → Triaged
Changed in indicator-datetime (Ubuntu):
status: Confirmed → Triaged
David Barth (dbarth) on 2011-03-09
Changed in unity-foundations:
assignee: nobody → Karl Lattimer (karl-qdh)
importance: Undecided → Low
milestone: none → ubuntu-11.04-beta-1
status: New → Triaged
Karl Lattimer (karl-qdh) wrote :

Line 166 to 173 of indicator-datetime/src/utils.c

--
 if (show_date && show_day) {
  /* TRANSLATORS: This is a format string passed to strftime to represent
     the day of the week, the month and the day of the month. */
  date_string = T_("%a %b %e");
 } else if (show_date) {
  /* TRANSLATORS: This is a format string passed to strftime to represent
     the month and the day of the month. */
  date_string = T_("%b %e");
--

So the text for the date are translatable, maybe this is a missing translation?

David Barth (dbarth) on 2011-03-14
Changed in unity-foundations:
milestone: unity-3.8.0-beta → unity-3.6.6

El dl 14 de 03 de 2011 a les 11:23 +0000, en/na Karl Lattimer va
escriure:
> So the text for the date are translatable, maybe this is a missing
> translation?

The string is translated in Launchpad and its translation shipped in
language packs, but it seems that the translations for the strftime
placeholders are not being loaded. If I'm not mistaken, these should be
read from the locale definition.

$ gettext -d indicator-datetime "%a %b %e"
%a, %e de %b

So here you can see that the string itself is translated in the
shipped .mo file, but looking at the indicator %a should be been "ds"
instead of "Sat" and %b should have been "mar" instead of "Mar".

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Ted Gould (ted) on 2011-03-16
Changed in indicator-datetime:
status: Triaged → Fix Released
milestone: none → 0.1.98
Changed in unity-foundations:
status: Triaged → Fix Released
Sebastien Bacher (seb128) wrote :

it's fixed today in natty

Changed in indicator-datetime (Ubuntu):
status: Triaged → Fix Released
Dennis Baudys (thecondordb) wrote :

Hi!

I'm from the German translation team.

It does NOT seem to be fixed. In a fully updated Natty inside VirtualBox I have very similar problems with indicator-datetime too. It appears to be 'half way' translated though gettext displays the strings from launchpad translations correctly. And also: the date & time settings dialog can not be opened - nothing happens. I assume, it's crashing.

I checked the strings in launchpad [1]. They should be correct. Something strange ist happening with indicator-datetime. And why can't I open the date & time settings dialog?

See the attached screenshot for proof of the bug being still in place.

[1] https://translations.launchpad.net/ubuntu/natty/+source/indicator-datetime/+pots/indicator-datetime/de/+translate?batch=10&show=all&search=%25A

Thanks.

Dennis Baudys (thecondordb) wrote :

I'm not quite sure at the moment, if I was correct in my last comment. Maybe the bug is not fixed, maybe it is. I've made some minor adjustments regarding these date and time strings [1] [2] as a test but also with best intentions. As soon as these new strings are released in the Natty Beta, I'll check the displayed date and time combinations again and I'll then report back here.

By the way … the date & time settings dialog can be opened again. Additionally to the strangenesses mentioned before, I wonder why this dialog doesnt appear translated (in German) though these strings for the dialog were already translated a while ago.

PS: FYI: Just made another update after writing this text – and now, the date & time settings dialog cannot be opened again. *sigh

David Planella (dpm) wrote :

Karl, Ted, could you help us debugging this?

I'll be happy to open a new bug, as it seems to be fixed for some languages, such as French. In others (Catalan, German, Spanish(*)) it does not seem to, but I don't know where to start, as I don't know where the string and translation shown in the indicator is supposed to come from.

Any pointer would help.

Thanks!

(*) In the case of Spanish the string appears translated but not following the capitalization rules for the locale, so this might be a separate issue, though

Xhacker Liu (xhacker) wrote :

I'm affected by it too, indicator-datetime behaves strange in my computer.
My locale is zh_CN. When I switch my session language to English, it still uses the Chinese translation string on the panel, while the translations in the menu are correct.

And there are another strange thing. When I let it display date and month, it displays nothing! I'll upload a screenshot to describe it.

Thanks.

Xhacker Liu (xhacker) wrote :
Dennis Baudys (thecondordb) wrote :

Hi!

I've just updated Natty Beta and was trying to test the date and time displayed in the panel. Now – the German translation seem to be released (because I can see a change, that we, German translators made in the relevant strings [1] [2]) but real testing can NOT be done because the date & time settings dialog can NOT be opened – again. So at the moment, I can only 'test' the standard display method, that is the combination of weekday and time.

By the way, I think I have figured out, *how* these date and time strings [1] [2] are meant to be used. The date/time displayed in the panel is a combination of two parts, the date part and the time part. These parts are put together by a special string like this: %s %s (see string number 19 [3]). Because Germans like the date and time to be separated by a comma, we put the comma in this string number 19, which - as it turns out - was good! But sadly we made some appending commas to the strings that are relevant for the date part, too. So that causes two commas to be displayed there, now. However that is a translation bug, that I'm going to fix now.

I'd like YOU to fix the problem with the non-launchable date/time settings dialog - therefore I'll open a new bug for that issue, now. However I realise that not everybody seems to be affected by this.

[1] https://translations.launchpad.net/ubuntu/natty/+source/indicator-datetime/+pots/indicator-datetime/de/+translate?batch=10&show=all&search=%25a
[2] https://translations.launchpad.net/ubuntu/natty/+source/indicator-datetime/+pots/indicator-datetime/de/+translate?batch=10&show=all&search=%25h
[3] https://translations.launchpad.net/ubuntu/natty/+source/indicator-datetime/+pots/indicator-datetime/de/19/+translate

Regards,

Dennis

Dennis Baudys (thecondordb) wrote :

Addendum: the bug regarding the preferences dialog (indicator-datetime-preferences) not opening (sometimes!) was already reported in bug 743047 here [1] and bug 751175 here [2].

[1] https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/743047
[2] https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/751175

AJenbo (ajenbo) wrote :

Thanks Dennis Baudys this helped me improve the Danish transaltions that should in most parts be the same as the german.

My locale is set to German de_DE.
Two commata are shown in the panel and the weekday is half translated. On Language support applet In the example it shows the right - in the indicator panel the wrong weekday (see screenshot).

Karl Lattimer (karl-qdh) wrote :

I think what might have happened here is that the comma was changed in the code. Originally there was a comma in the untranslated string, this was pointed out by mpt to be incorrect. It's highly probable that this change has caused a bunch of the translations to go out of whack.

David Planella (dpm) wrote :

El dv 15 de 04 de 2011 a les 13:49 +0000, en/na Karl Lattimer va
escriure:
> I think what might have happened here is that the comma was changed in
> the code. Originally there was a comma in the untranslated string, this
> was pointed out by mpt to be incorrect. It's highly probable that this
> change has caused a bunch of the translations to go out of whack.
>

I don't know if there was an upload that fixed this, or the latest
langpacks, but in my system it is now fixed (i.e. the date is now fully
translated).

Unless some of the other commenters are still experiencing the bug, I
believe this could be closed

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Dennis Baudys (thecondordb) wrote :

Seems to be 'fix released' for Natty now. And the 'two commas in the German translation' are also 'fix released' now.

Aleksi Liimatainen (aleksil79) wrote :

This bug seems to still be present in the Finnish locale. The date currently reads "17. Juneta", a mix of the English month name and a Finnish suffix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers