Ubuntu

biarch alsa-lib path problem with Skype

Reported by Patrice DUROUX on 2008-09-23
132
This bug affects 8 people
Affects Status Importance Assigned to Milestone
alsa-lib (Ubuntu)
Undecided
Unassigned
alsa-plugins (Ubuntu)
Undecided
Unassigned
ia32-libs (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ia32-libs

Hy!

Since last libasound2-plugins (or PulseAudio) upgrade to version 1.0.17-0ubuntu2, it seems that it breaks the 32bits Skype with the following message:
ALSA lib ../../src/conf.c:2700:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib ../../../src/pcm/pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM default

Does this can be solved by an adequate upgrade of the 32bits libasound/pulseaudio provided by ia32-libs?

Regards,
Patrice.

Related branches

Coran21 (coran) wrote :

I have the same problem

Tomasz Grzegurzko (tomasz89) wrote :

I've now got the same problem also.

...Max... (max-motovilov) wrote :

Ditto. The problem is not limited to Skype either -- I have first run into it trying this game: http://www.wegroup.org/games/arkanoid-games/arkanoid-space-ball.html
which worked perfectly well before yesterday's update.

Mingming Ren (portis25) wrote :

I also have this problem with a little different error message:

ALSA lib ../../src/conf.c:2700:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib ../../../src/control/control.c:909:(snd_ctl_open_noupdate) Invalid CTL hw:0
Aborted (core dumped)

Dmitry Pankratov (dremon) wrote :

Temporary workaround: in the /usr/share/alsa/alsa.conf comment out the line that says:
"/usr/share/alsa/pulse.conf"

Dmitry Pankratov (dremon) wrote :

Another workaround that works for me:
1. Create /etc/ld.so.conf.d/alsa32.conf with the following contents:
/usr/lib32/alsa-lib

2. Create /etc/ld.so.conf.d/alsa64.conf with the following contents:
/usr/lib/alsa-lib

3. sudo ldconfig

4. Open /usr/share/alsa/pulse.conf in the editor and remove the "/usr/lib/alsa-lib/" prefix from the libasound_module_conf_pulse.so file.

Steve Beattie (sbeattie) wrote :

Given multiple reporters, marking as confirmed.

Changed in ia32-libs:
status: New → Confirmed
David Vonka (vonkad) wrote :

After recent updates I get
--------------------
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi

RtApiAlsa: callback thread error (RtApiAlsa: audio read error for device (pulse): Input/output error.) ... closing stream.
-----------------

when trying to call. When making the test call, sound works ok, but I have no capture.

Confirmed, now I have no capture too.

David Vonka (vonkad) wrote :

Ignore my previous message. It is a pulse audio problem on a 32bit system ... sorry ...

I can confirm that dmitry's workaround #2 (the /etc/ld.so.conf.d/alsa{32,64}.conf changes)
work perfectly for me.

I would recommend that this change go into the ALSA packages.

Mingming Ren (portis25) wrote :

The 2nd workaround works for me too. Great. Thanks.

bendis (bendis) wrote :

Thanks, the 2nd workaround fixed it! IMHO this "workaround" should be renamed to "solution" :-)

ktp420 (ktp420) wrote :

Thanks, worked for me too...I was having issues with flash audio and this fixed it.

Dimitrios Symeonidis (azimout) wrote :

confirming that dmitry's 2nd workaround solved the problem for me, on intrepid on an amd64

captive (salvo-schifani) wrote :

I can confirm 2nd workaround works perfectly on amd64 / intrepid

Dmitry Pankratov (dremon) wrote :

The solution can be a bit simplified:
A single file "/etc/ld.so.conf.d/alsa-lib.conf" is enough, with 2 lines in it:
/usr/lib/alsa-lib
/usr/lib32/alsa-lib

I suggest to include it into both 64-bit and 32-bit "pulseaudio" package, for 64-bit systems the second line is not needed.

kulight (kulight) wrote :

i had this error:
desktop:~$ skype
ALSA lib ../../src/conf.c:2700:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib ../../../src/control/control.c:909:(snd_ctl_open_noupdate) Invalid CTL hw:0
Aborted (core dumped)

and this workaround worked for also

1. Create /etc/ld.so.conf.d/alsa32.conf with the following contents:
/usr/lib32/alsa-lib

2. Create /etc/ld.so.conf.d/alsa64.conf with the following contents:
/usr/lib/alsa-lib

3. sudo ldconfig

4. Open /usr/share/alsa/pulse.conf in the editor and remove the "/usr/lib/alsa-lib/" prefix from the libasound_module_conf_pulse.so file.

thank you dimitry

Dimitrios Symeonidis (azimout) wrote :

PROBLEM:

the above fix (2nd workaround) fixed the skype problem, and now audio works in skype, but while skype is running, no other application can take control of the sound sink. if i close skype, everything works again...

Dimitrios Symeonidis (azimout) wrote :

and the latest (simplified) solution by dmitry does not fix the skype crash for me. i'm on amd64/intrepid

Dimitrios Symeonidis (azimout) wrote :

correction on the last comment: dmitry's latest fix works, as long as you also execute steps 3 and 4 of the previous fix (sudo ldconfig + edit /usr/share/alsa/pulse.conf)

also note that my error messages where:
ALSA lib ../../src/conf.c:2700:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib ../../../src/control/control.c:909:(snd_ctl_open_noupdate) Invalid CTL hw:0

Tomasz Grzegurzko (tomasz89) wrote :

Doesn't work for me:
I've created the file in /etc/ld.so.conf.d/alsa-lib:
/usr/lib32/alsa-lib
/usr/lib/alsa-lib

Changed /usr/share/alsa/pulse.conf:
Instead of
lib "/usr/lib/alsa-lib/libasound_module_conf_pulse.so"
Modified to
lib "libasound_module_conf_pulse.so"

Run sudo ldconfig -v and saw that alsa libs were being read in.

And skype still crashes. Or it starts up and says problem with audio, can't make a test call, etc..

Hello,

Are we trying to find out a workaround that we should try in our machines individually and at our own risk?

Or are we trying to report a bug so that "somebody" at Ubuntu will fix the package for a new update?

I mean, should I try what you are discussing on my computer or just wait for an update? I am not in a rush, but I just want to know whether the update is coming or not...

 affects ubuntu/alsa-plugins
 status invalid

 affects ubuntu/alsa-lib
 status inprogress

Changed in alsa-plugins:
status: New → Invalid
Dmitry Pankratov (dremon) wrote :

Tomasz Grzegurzko: did you miss the .conf extension of the /etc/ld.so.conf.d/alsa-lib.conf file?

Changed in alsa-lib:
assignee: nobody → themuso
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.0.17a-0ubuntu4

---------------
alsa-lib (1.0.17a-0ubuntu4) intrepid; urgency=low

  [ Mario Limonciello ]
  * debian/patches/bluetooth_configuration.patch:
    - Adds a pointer to the bluetooth configuration file.
      If a user has bluez-audio installed and a heaset paired
      this will allow them to use a headset by the name of
      "headset" (LP: #274950)

  [ Luke Yelavich ]
  * Add files to /etc/ld.so.conf.d for libasound2 and libasound2 bi-arch
    packages. This Allows for alsa plugins to be referred to in alsa
    configuration files without the need for absolute paths, the pulseaudio
    runtime check is one such example. (LP: #273693)

 -- Luke Yelavich <email address hidden> Tue, 07 Oct 2008 17:49:28 +1100

Changed in alsa-lib:
status: In Progress → Fix Released
Changed in ia32-libs:
status: Confirmed → Invalid
omvsj (omvsj) wrote :

I have Intrepid amd64 up-to-date and Skype form Medibuntu.
Alsa-base 1.0.17.dfsg-2ubuntu1. There is no alsa-lib package in the repositories.
Skype runs but no sound.

# ldconfig
# ldconfig -v | grep alsa
/usr/lib32/alsa-lib:
/usr/lib/alsa-lib:
 libalsatoss.so.0 -> libalsatoss.so.0.0.0

1) Changed "Default device" to "pulse", in Skype options: it has sound but no capture

2) Dimitry's workaround 1: everything's right on Skype, but if there's a call in progress, no other application can take control of the sound sink, or mix the sound. Or vice-versa, if other application is playing a sound, Skype can't use the sound sink.

3) Dimitry's workaround 2 (with its variants: alsa*.conf): sound but no capture. Here's the output of ldconfig:
    # ldconfig
    # ldconfig -v | grep alsa
    /sbin/ldconfig.real: Ruta '/usr/lib32/alsa-lib' establecida más de una vez
    /sbin/ldconfig.real: Ruta '/usr/lib/alsa-lib' establecida más de una vez
    /usr/lib/alsa-lib:
    /usr/lib32/alsa-lib:
     libalsatoss.so.0 -> libalsatoss.so.0.0.0
    (I have the spanish version. It says something like: /sbin/ldconfig.Real: Path xxx is set more tan once)

Hope this is helpfull for you.

Luke Yelavich (themuso) wrote :

What version of libasound2 and libasound2-plugins are you running? On a standard Ubuntu install, skype + alsa on an amd64 works fine, including other aplications being able to use the sound device. Note pulseaudio wasn't running, as skype does not work very well with it at times, at least for me.

omvsj (omvsj) wrote :

libasound2 1.0.17a-0ubuntu4
libasound2-plugins 1.0.17-0ubuntu4
skype 2.0.0.72-0medibuntu3

kulight (kulight) wrote :

i found that using skype-static-oss package from medibuntu of skype make everyone play nice with each other as it uses its own sound libs

acimmarusti (andrescimmarusti) wrote :

Hello,

When running either skype_2.0.0.72-0medibuntu4 or skype-
static_2.0.0.72-0medibuntu4 from the terminal I get the following
statements.

ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)

The sound doesn't work at all in skype. I cannot make calls. I don't
understand what's happening, as I'm not trying to use a bluetooth.
Although this has happened to me (without the bluetooth issue) while
running skype on hardy heron 8.04, it didn't happen all the time. My
real problems with skype began when I installed a fresh copy of Intrepid
Ibex (8.10).

I tried skype-static-oss 2.0.0.72-0medibuntu4 and the sound works, but
my usb microphone doesn't seem to be supported (usb microphone embedded
in a logitech quickcam pro for Notebooks).

When I got everything to work while running skype on hardy heron 8.04,
even then If I used the microphone in conjunction with the video, the
mic would screw up the video image. I had to use a separate mic or not
use the cam at all!

I've checked that I have all the apparent fixes and I have everything up to date, but my problem is not solved!

lhomla (brice-pelle) wrote :

installing gnome alsa mixer fixed the problem (at least my version of the problem). dont know why

Dario Trevisan (papanonno) wrote :

Hi, I confirm the same problem as acimmarusti. Skype worked well on hardy heron 8.04, but on Ibex there is no sound at all.

Jon Arnold (jonarnoldsemail) wrote :

I can also confirm the same problem as acimmarusti. I'm probably gonna file a separate bug report...

Tomasz Grzegurzko (tomasz89) wrote :

Do you actually get the same results as the original bug report?

ALSA lib ../../src/conf.c:2700:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib ../../../src/pcm/pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM default

If not it would be better to file a different report, though I don't know how well Skype is supported as it is proprietary. I've fought long and hard to get it to work and suggest playing around with Skype's sound devices settings, try the different sound in/out/ring devices listed there with making test sounds until you hear something.

lamapper (lamapper) wrote :

I am running Ubuntu 8.10 on Pentium D (amd64; x86_64). Since there is no 64 bit Skype (and probably will not be anytime soon), you have little choice but to -force the install which of course brings with it many dependencies. (getlibs is a must have, see attached file for skype .deb and getlibs usage)

In my case Skype runs, no error messages, however no sound either. I run Amarok, I can see that it is playing (GUI and text messages displayed as it goes from one song to the next); however no sound.

I attempted Dimtry's workaround #2, however it did not work for me. Thanks for the effort Dimitry!

I also attempted to load the Gnome Alsa Mixer as someone suggested it worked for them, again, no joy for me.

Attached file has the following information: versions of libasound*; skype and alsa* files via dpkg; ldconfig on alsa; comment on necessity for 32 bit dependencies to run Skype required; for those whose skype is broken the specific skype....i386.deb file that worked for me; getlibs works like a champ at getting all the needed files; The specific lib32 files that getlib retrieved from the intrepid repositories; ldd /usr/bin/skype, showing all files; mention of error messages that others are seeing when running skype that I do NOT see; mention of speaker-test -li -c6 -twav which does not work for me as I do not hear anything on either speaker plugged in rear or headphones plugged into front of system.

I hope this information helps you to resolve this issue.

Somewhere I read that a reader removed pulse files and reinstalled alsa to get Skype working, I will give that a go and report back on success or failure.

No sound, no joy, let me know if you need anything else (i.e. mention the command & parms that will give you the results you need in order to avoid confusion)

Thank you for all you are doing to resolve this problem.

Bug is there also in jaunty.

ALSA lib ../../src/conf.c:2700:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib ../../../src/control/control.c:909:(snd_ctl_open_noupdate) Invalid CTL hw:0
Aborted

Program received signal SIGSEGV, Segmentation fault.
0xf7ef430a in snd_ctl_close () from /usr/lib32/libasound.so.2

skype 2.0.0.72-0medibuntu4
ia32-libs 2.7ubuntu2

Dimitry's workaround worked till today, no more working with ia32-libs update to 2.7ubuntu2. Even forcing path /usr/lib32/alsa-lib/libasound_module_conf_pulse.so in /usr/share/alsa/pulse.conf does'nt work.

Bogdan Butnaru (bogdanb) wrote :

I'm reopening this because I have the same problem as Graziano: it's happening again in Jaunty. I've looked at all mentioned work-arounds, I can't seem to find anything helpful.

In my case, it's with Skype from Medibuntu:
~ skype
ALSA lib ../../src/conf.c:2700:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib ../../../src/control/control.c:909:(snd_ctl_open_noupdate) Invalid CTL hw:0
Aborted

Changed in alsa-lib:
assignee: themuso → nobody
status: Fix Released → Confirmed

+1 - same problem, Doom 3, ETQW, Quake 4 and Skype do not have sound, Prey however works somehow... I'm using 64Bit Jaunty.

Doom and the others:

------ Alsa Sound Initialization -----
ALSA lib ../../src/conf.c:2700:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib ../../../src/pcm/pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM default
snd_pcm_open SND_PCM_STREAM_PLAYBACK 'default' failed: No such file or directory
dlclose
--------------------------------------
----------- Alsa Shutdown ------------
--------------------------------------

Prey:

------ SDL Sound Initialization ------
ALSA lib ../../src/conf.c:2700:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib ../../../src/pcm/pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM default
SDL is using audio backend 'esd'.
allocated a mix buffer of 32768 bytes
SDL_AudioSpec: 44100 freq, S16LSB, 2 channels, 512 samples.
Opening audio device...
Audio device is ready.
--------------------------------------

Thanks everybody for workarounds. Now skype works. Big thanks :)

Mingming Ren (portis25) wrote :

The workaround no longer works. I'm in Jaunty.

ALSA lib ../../src/conf.c:2700:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib ../../../src/control/control.c:909:(snd_ctl_open_noupdate) Invalid CTL hw:0
Aborted

Ok, new workaround for people like me using jaunty: problem is libgdbm3 missing in lib32.

What to to as superuser

wget http://archive.ubuntu.com/ubuntu/pool/main/g/gdbm/libgdbm3_1.8.3-4_i386.deb
dpkg -x libgdbm3_1.8.3-4_i386.deb libgdbm32
cp -a libgdbm32/usr/lib/* /usr/lib32/

Workaround used before now working again. Enjoy.

Mingming Ren (portis25) wrote :

Great! Thanks, it works.

2009/1/12 Graziano <email address hidden>

> Ok, new workaround for people like me using jaunty: problem is libgdbm3
> missing in lib32.
>
> What to to as superuser
>
> wget
> http://archive.ubuntu.com/ubuntu/pool/main/g/gdbm/libgdbm3_1.8.3-4_i386.deb
> dpkg -x libgdbm3_1.8.3-4_i386.deb libgdbm32
> cp -a libgdbm32/usr/lib/* /usr/lib32/
>
> Workaround used before now working again. Enjoy.
>
> --
> biarch alsa-lib path problem with Skype
> https://bugs.launchpad.net/bugs/273693
> You received this bug notification because you are a direct subscriber
> of the bug.
>

lib32 meta package now should be updated, because this workaround works excelent. This is off topic but I also get:

ALSA lib ../../../src/pcm/pcm.c:2162:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_bluetooth.so

This maybe is also smth with this problem. But I don't use bluetooth pcm device so I don't feel something not working.

Daniel T Chen (crimsun) on 2009-01-23
Changed in ia32-libs:
status: Invalid → Confirmed
Changed in alsa-lib:
status: Confirmed → Fix Released
pricey (pricey) wrote :

Had the same problems as everybody else on this page regarding the sound. However, after reading through peoples response, I have Skype working now in Linux on my USB mass storage device. Many thanks.

Timo Aaltonen (tjaalton) wrote :

looks like it's fixed, libgdbm3 is now included.

Changed in ia32-libs:
status: Confirmed → Fix Released
dvo (mueller8) wrote :

Neither of the above workarounds worked for me, using Ubuntu 8.04 on both 32bit and 64bit, but the following did:
* close any running VirtualBox
* sudo alsa reload snd-hda-intel
* restart skype

garvin timmann (emailgarvin) wrote :

I still have the problem that when skype is running, no other program can have sound.

Will skype launch a 64 bit version soon, as that would solve all the problems?

If anyone knows how to solve this in 8.10 then please help.

David Kohen (kohen-d) wrote :

I still get this:
ALSA lib ../../../src/pcm/pcm.c:2156:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_bluetooth.so
In intrepid on amd64, a new packaged that contains the contents of bluez-alsa for 32 bit should be added to the repository. just like alsa libs, or maybe it should be added to alsa libs...

Yohumbus (yohumbus) wrote :

Using 64bit jaunty I was getting this. I erased my old config files and it fixed everything. The configs were from hardy versions.

Skype static, karmic amd64

After libasound2/ lib32asound2 update i have this warnings here and skype does not run..

Daniel T Chen (crimsun) wrote :

On Mon, Aug 10, 2009 at 12:14 AM, Raphael
Gradenwitz<email address hidden> wrote:
> Skype static, karmic amd64
>
> After libasound2/ lib32asound2 update i have this warnings here and
> skype does not run..

See bug 408615.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers