PPDs for HP's PostScript printers not installed in default installation

Bug #1014478 reported by Lixin Chin on 2012-06-18
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Ubuntu)
Medium
Unassigned
Precise
Medium
Till Kamppeter

Bug Description

The HP LaserJet Enterprise 500 Color m551dn printer is claimed to be fully supported using HPLIP 3.11.10 (http://hplipopensource.com/hplip-web/models/color_laserjet/hp_laserjet_500_color_m551.html), so it should be supported under the 3.12.2 version shipped with Ubuntu 12.04.

Installing the printer using KDE's print setup interface to CUPS defaults to using the HP DesignJet 500 Foomatic/cdnj500 driver, which works, but doesn't allow duplex printing, at least when trying from okular.

Installing the printer using hplip-gui (hp-setup) spits out a warning message about

warning: No PPD found for model laserjet_500_color_m551 using new algorithm. Trying old algorithm...

And the PPD field is defaulted to
foomatic-db-compressed-ppds:0/ppd/foomatic-ppd/HP-LaserJet_5100-pxlmono.ppd

Which *does* allow duplex printing from okular, but fails to print in colour.

NOTE: Due to the Quantal alpha 2 soft freeze the fixed package for Quantal is prepared but not uploaded yet. The Quantal fix is exactly the same as for Precise.

[Impact] There is no package which has printer-driver-postscript-hp in its dependencies, which makes this package not getting installed automatically. The package contains the PPD files for all PostScript printers from HP. Without it, these printers get set up with inferior generic PostScript PPDs, PCL PPDs, or even completely wrong drivers, causing lots of problems with principally perfectly supported printers. HP's PostScript printers are one of the most common classes of laser printers.

[Test Case] To reproduce without having the appropriate printer:

apt-cache rdepends printer-driver-postscript-hp

These command gives no output after "Reverse Depends:". With the fixed package "hplip" appears after "Reverse Depends:".

[Regression Potential] None, the fixed HPLIP causes an additional package (printer-driver-postscript-hp) to be installed during the update, this will not break anything.

Lixin Chin (wstfgl) wrote :

The printer appears to work perfectly if assigned the "Generic PCL 6/PCL XL Printer foomatic/pxlcolor" ppd (/usr/share/ppd/ghostscript/model/pxlcolor.ppd).

Till Kamppeter (till-kamppeter) wrote :

Can domeone of the HPLIP developers at HP look into this? Seems that there are some PostScript PPDs missing in the current HPLIP.

Till Kamppeter (till-kamppeter) wrote :

Lixin, this printer most probably also supports PostScript and PDF natively. So you can also try the "Generic PostScript printer" and the "Generic PDF printer".

Till Kamppeter (till-kamppeter) wrote :

Support for the HP LaserJet Enterprise 500 color M551 got introduced in HPLIP 3.11.10. Problem is that the PPD does not contain "Enterprise" in the printer name. You can find the corrrect PPD when changing the driver and choosing the "HP LaserJet 500 color M551" from the list.

Please run the following commands so that we know how the printer identifies itself:

sudo /usr/lib/cups/backend/dnssd
sudo /usr/lib/cups/backend/snmp
sudo /usr/lib/cups/backend/usb

and post the output here.

If the printer reports "Enterprise" in its name, this is clearly a bug in HPLIP.

Changed in hplip (Ubuntu):
status: New → Incomplete
Changed in hplip:
status: New → Incomplete
Changed in hplip (Ubuntu):
importance: Undecided → Medium
  • dnssd.txt Edit (905 bytes, text/plain; charset=UTF-8; name="dnssd.txt")
  • snmp.txt Edit (257 bytes, text/plain; charset=UTF-8; name="snmp.txt")
  • usb.txt Edit (52 bytes, text/plain; charset=UTF-8; name="usb.txt")

Attached the output files requested. There are several printers on the
work network, so I've edited out the lines directly related the the M551.

As far as I can tell looking through the CUPS driver selection dialog
using the web interface http://localhost:631, and use the KDE printer
configuration dialog, there is no printer driver called "HP Laserjet 500
color M551"

The HP LaserJet series goes from 2 -> 4 -> 5 -> 6 -> 1000 ... 9000 ->
cmXXX -> cpXXX -> Foomatic -> m100X ... -> p100X -> Profession XXX ->
"HP Color LaserJet Series PCL 6 CUPS," which is the one I'm currently
using (switched to it from the generic PCL 6 driver), and seems to work.

Can you run the commands

dpkg -l | grep hplip
dpkg -l | grep printer-driver
dpkg -l | grep -i postscript
lpinfo -m | grep -i laserjet | grep 500

and post the output here? Thanks.

Till Kamppeter (till-kamppeter) wrote :

On Precise I get

till@till:~$ lpinfo -m | grep -i 'laserjet 500\b'
postscript-hp:0/ppd/hplip/HP/hp-laserjet_500_color_m551-ps.ppd HP LaserJet 500 color M551 Postscript (recommended)
till@till:~$

This matches the model name in your attached files. So at least on Precise this printer should get identified. system-config-printer also lists this model for me on Precise.

Sanjay Kumar (sanjay-kumar14) wrote :

Hello Lixin,

Thanks for reporting the issue in HPLIP. To help us understand and analyze the issue please follow following things.
=> Download and install the latest HPLIP release from http://hplipopensource.com/hplip-web/install/install/index.html

=> Reconfigure print queue with the commands in the terminal mentioned below.
       => system-config-printer (remove all print queues)
       => hp-setup -g > /tmp/hpsetup.log (It should not be run in a root mode. This command is for adding print queue.Please make sure you select ppd name having "-ps" or "hpcups" substring)
=>Try printing now.

If problem persistes then please pastee the output of /tmp/hpsetup.log

Attached

On 25/06/12 17:21, Till Kamppeter wrote:
> Can you run the commands
>
> dpkg -l | grep hplip
> dpkg -l | grep printer-driver
> dpkg -l | grep -i postscript
> lpinfo -m | grep -i laserjet | grep 500
>
> and post the output here? Thanks.
>

Installing the 'printer-driver-postscript-hp' package has solved my problem.

It could be because my system has been upgraded continuously without a fresh install since 10.04, but the 'printer-driver-postscript-hp' doesn't seem to be installed by default.

A brief search using synaptic, and it seems this package isn't recommended or even suggested by anything, certainly not cups or hplip.

Lixin Chin (wstfgl) wrote :

Thank you very much for your help, initial tests with the driver from the 'printer-driver-postscript-hp' package went well, and everything seems to be working perfectly now.

Thank you very much, I will look into it to add a recommends for printer-driver-postscript-hp.

Changed in hplip:
status: Incomplete → Invalid
Changed in hplip (Ubuntu):
status: Incomplete → Confirmed
Changed in hplip (Ubuntu):
status: Confirmed → In Progress

Package for Quantal prepared, will be uploaded after the Alpha 2 release.

Changed in hplip (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
milestone: none → ubuntu-12.04.1

Uploaded fixed package to precise-proposed. As soon as the package gets approved it will get available for testing and we post instructions in another comment here. Please test the package then and give us feedback here, as this is needed to make the package an official update.

To the SRU team: debdiff attached.

description: updated
Changed in hplip (Ubuntu Precise):
status: Triaged → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.12.6-3ubuntu1

---------------
hplip (3.12.6-3ubuntu1) quantal; urgency=low

  * debian/control: Let hplip recommend printer-driver-postscript-hp
    (LP: #1014478).
 -- Till Kamppeter <email address hidden> Tue, 26 Jun 2012 20:55:00 +0200

Changed in hplip (Ubuntu):
status: In Progress → Fix Released
summary: - No PPD available for HP LaserJet Enterprise 500 Color m551
+ PPDs for HP's PostScript printers not installed in default installation

printer-driver-postscript-hp needs to be moved from Universe to Main. It seems that it got demoted accidentally, probably on the renaming to printer-driver-... following Debian's printer driver packaging policy. It is essentially important in a default installation as it provides the support for all PostScript printers from HP and these are very common printers.

Reuploaded the rejected SRU package as the rejection reason was printer-driver-postscript-hp being in Universe. printer-driver-postscript-hp will get moved back into main as it got demoted in error (see previous comment).

The printer-driver-postscript-hp package got moved back into Main for Quantal but not yet for Precise. Can it also get moved back into Main for Precise so that we can complete this SRU and have HP PostScript PPDs in Precise systems by default? Thank you.

Hello Lixin, or anyone else affected,

Accepted hplip into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/hplip/3.12.2-1ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Lixin Chin (wstfgl) wrote :

Testing:
-- Enabled precise-proposed repository as in https://wiki.ubuntu.com/Testing/EnableProposed.
-- Installed hplip and dependencies from the proposed repository (log attached)
-- Verified that printer-driver-postscript-hp is now recommend by hplip.
-- Verified that printing to the M551 printer still works using the version of hplip from the proposed repository.

tags: added: verification-done
removed: verification-needed
Changed in hplip (Ubuntu Precise):
assignee: nobody → Till Kamppeter (till-kamppeter)
Colin Watson (cjwatson) wrote :

I've moved printer-driver-postscript-hp to main in precise-proposed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.12.2-1ubuntu3.1

---------------
hplip (3.12.2-1ubuntu3.1) precise-proposed; urgency=low

  * debian/control: Let hplip recommend printer-driver-postscript-hp
    (LP: #1014478).
 -- Till Kamppeter <email address hidden> Tue, 26 Jun 2012 20:55:00 +0200

Changed in hplip (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers