Screen brightness buttons don't work properly on Thinkpad Z61T

Bug #61184 reported by stbaker on 2006-09-18
106
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: acpi-support

When you press Fn + Home/End to adjust screen brightness, it either goes to the darkest or the brightest setting. To get to a setting somewhere in the middle, you have to click the buttons to start the transition from one extreme to the other, then click it again to stop the transition somewhere in the middle.

Matthew Garrett (mjg59) wrote :

gnome-power-manager

Matthew Garrett (mjg59) wrote :

Nngh. Possibly actually a hal bug - all Thinkpads have the same screen behaviour, whereas hal only seems to flag the X31.

stbaker (sean-t-baker) wrote :

I've also noticed that in the latest Edgy (beta release, plus updates), the brightness slider in gnome-power-manager doesn't work properly. You have to slide it back and forth a few times before it will allow you step between the different brightness settings.

zdzichu (zdzichu-gmail) wrote :

Confirmed on Thinkpad z61t, attached patch for HAL's .fdi file fixes it for me. Remarks:
1) OSD popup showing current brightness level do not appear (gnome-power-manager bug?)
2) match should be probably extended to all Lenovo Thinkpads, or even wider.
3) there are many more quirks in HAL's cvs -- http://cvsweb.freedesktop.org/hal/hal/fdi/policy/10osvendor/10-laptop-panel-mgmt-policy.fdi?view=log
they are probably safe to include in Edgy's HAL package, as they only add or change some keys.

zdzichu (zdzichu-gmail) wrote :

It IS a HAL bug.

Changed in gnome-power-manager:
status: Unconfirmed → Confirmed
zdzichu (zdzichu-gmail) wrote :

Sean, could you replace /usr/share/hal/fdi/policy/10osvendor/10-laptop-panel-mgmt-policy.fdi with attached file, do "/etc/dbus-1/event.d/20hal restart" (or reboot your computer) and check if brightness control works?

Simon Law (sfllaw) wrote :

zdzichu, your patch works on the T60p.

Simon Law (sfllaw) wrote :

Ah, I forgot to mention that the side-effect is that the on-screen display for brightness disappears. But this seems to be a problem with gnome-power-manager, and I've filed a bug upstream about it.

zdzichu (zdzichu-gmail) wrote :

Great, I will send this patch upstream. To Ubuntu HAL maintainers: could you please add it to package?

Martin Pitt (pitti) wrote :

Easy fix for edgy.

Changed in hal:
assignee: nobody → pitti
importance: Undecided → Medium
status: Confirmed → In Progress
Martin Pitt (pitti) on 2006-10-09
Changed in hal:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

 hal (0.5.7.1-0ubuntu15) edgy; urgency=low
 .
   * Add debian/patches/00upstream-05-fix-stale_nfs_handle_block.patch:
     - Do not stat NFS mounts when preparing for suspend to fix hang.
     - Patch taken from upstream git.
     - Closes: LP#64266
   * Add debian/patches/20_laptop-panel-fixes.patch: ThinkPad T60 controls
     screen brightness in hardware, so set the appropriate flag in
     10-laptop-panel-mgmt-policy.fdi. Closes: LP#61184
   * Add debian/patches/21_smartcard_drivetype.patch: Recognize 'Storage-SDC'
     as smart card drive type. Closes: LP#61834
   * Add debian/patches/22-prefer-pmi-over-powersave.patch: Prefer pmi over
     powersave in the suspend/hibernate scripts. Closes: LP#61920
   * debian/patches/17-mp3-player-fdi.patch: Add information about Sandisk
     Corp. Sansa e270. Closes: LP#64300
   * debian/patches/02_ignored_volumes.patch: Ignore Apple bootstrap partitions
     on removable devices, too. Closes: LP#61767
   * Add debian/patches/00upstream-06-stat-dev-not-mountpoint.patch:
     - hald/linux/blockdev.c, blockdev_refresh_mount_state(): Stat the special
       device file, not the mount point's underlying device. This makes hal
       correctly recognize fuse mounts.
     - Patch ported from upstream GIT, thanks to Florent Mertens!
       http://gitweb.freedesktop.org/?p=hal.git;a=commit;h=2ea340399bf8cf3d2bb6bd1b5c4ecbc2042e93d4
     - Closes: LP#35354

Changed in hal:
status: Fix Committed → Fix Released
zdzichu (zdzichu-gmail) wrote :

Z61t need similar patch.

Martin Pitt (pitti) wrote :

Reopening for z61t.

Changed in hal:
status: Fix Released → In Progress
Ross Burton (ross) wrote :

This is also required for the X60 and I imagine the X60s.

  smbios.system.version = 'ThinkPad X60' (string)

Might be best to match on "ThinkPad .6[0-9]s?"...

This is also needed for the ThinkPad X41 (and I suspect the rest of the X4x series)

Martin Pitt (pitti) wrote :

mdz is fine with fixing that for edgy.

Martin Pitt (pitti) wrote :

 hal (0.5.7.1-0ubuntu16) edgy; urgency=low
 .
   * debian/patches/20_laptop-panel-fixes.patch: Extend match to all LENOVO
     ThinkPad models from the T, Z, and X series to fix brightness keys for
     those, too. Closes: LP#61184

Please urgently report regressions, and also improvements. Thanks!

Changed in hal:
status: In Progress → Fix Released
Hubert Figuiere (hub) wrote :

problem still happen with hal 0.5.7.1-0ubuntu16 on a Z60t

Jarmo Ilonen (trewas) wrote :

Problem still here with Thinkpad X41 and hal 0.5.7.1-0ubuntu16.

  smbios.system.manufacturer = 'IBM' (string)
  smbios.system.version = 'ThinkPad X41' (string)

Confirming Jarmo's problem. The X series is IBM, not LENOVO.

zdzichu (zdzichu-gmail) wrote :

X series are both IBM and LENOVO. Generalyy "60" and higher are Lenovo, except z60. See: http://thinkwiki.org/wiki/List_of_DMI_IDs#X_series

Martin Pitt (pitti) wrote :

Right, the current hal patch only fixes this for the LENOVO series, since I had no other data from the bug trail. On the other hand, Adam Conrad has an IBM T43 without hardware brightness buttons, and current edgy works fine for him.

So I am reopening this for edgy+1. Everybody: Please check if this affects you, and give me the output of

  lshal|grep smbios.system

Changed in hal:
status: Fix Released → Needs Info
Ross Burton (ross) wrote :

From a Lenovo Thinkpad X60 that has broken brightness:

lshal|grep smbios.system
  smbios.system.uuid = '0A7CB481-4866-11CB-A0AF-B3B7A2FEB98C' (string)
  smbios.system.serial = 'L3B9444' (string)
  smbios.system.version = 'ThinkPad X60' (string)
  smbios.system.product = '17068GG' (string)
  smbios.system.manufacturer = 'LENOVO' (string)

zdzichu (zdzichu-gmail) wrote :

Thinkpad Z61t with broken brightness:

$ lshal|grep smbios.system
  smbios.system.uuid = 'C9ED4E80-4805-11CB-8D26-9E116E5DF32C' (string)
  smbios.system.serial = 'L3A0534' (string)
  smbios.system.version = 'ThinkPad Z61t' (string)
  smbios.system.product = '94402CU' (string)
  smbios.system.manufacturer = 'LENOVO' (string)

Hubert Figuiere (hub) wrote :

Thinkpad Z60t

  smbios.system.uuid = '0060A481-47D9-11CB-93CB-84973E2CA408' (string)
  smbios.system.serial = 'LR05635' (string)
  smbios.system.version = 'ThinkPad Z60t' (string)
  smbios.system.product = '2511E5U' (string)
  smbios.system.manufacturer = 'IBM' (string)

Michael Helmling (supermihi) wrote :

# lshal|grep smbios.system
  smbios.system.uuid = '1A59C001-4889-11CB-8F62-CA0B2CFB0EE4' (string)
  smbios.system.serial = 'L3A3846' (string)
  smbios.system.version = 'ThinkPad Z60t' (string)
  smbios.system.product = '2511FFG' (string)
  smbios.system.manufacturer = 'IBM' (string)

with hal 0.5.7.1-0ubuntu17, on a LENOVO Z60t bought in February 2006 in Germany.

Sassur (sassur) wrote :

smbios.system.uuid = '8B6D7A81-4798-11CB-8138-90DAB17F9A76' (string)
smbios.system.serial = 'L3GC141' (string)
smbios.system.version = 'ThinkPad X41' (string)
smbios.system.product = '252563G' (string)
smbios.system.manufacturer = 'IBM' (string)

Martin Pitt (pitti) on 2006-12-12
Changed in hal:
status: Needs Info → Confirmed
status: Confirmed → In Progress
rdschouw (robert-schouwenburg) wrote :

Thinkpad Z60m

  smbios.system.uuid = 'B0FD8280-479E-11CB-9FB8-D47BECB7F7E4' (string)
  smbios.system.serial = 'L3A2352' (string)
  smbios.system.version = 'ThinkPad Z60m' (string)
  smbios.system.product = '2529FKG' (string)
  smbios.system.manufacturer = 'IBM' (string)

Default Edgy install still has the brightness issue.

Downloaded and installed "10-laptop-panel-mgmt-policy.fdi" and did "/etc/dbus-1/event.d/20hal restart". Brightness works ok now.

Indeed the Gnome OSD is gone.

Jarmo Ilonen (trewas) wrote :

I triaged a bit for duplicates of this bug. Hopefully the bugs I marked are truly duplicates and not some other issues. There are also other thinkpad & brightness bugs which may be related to this, but I did not mark them as duplicates: bugs #67805, #69624, #70073, #76061 at least.

Troels Faber (troelsfaber) wrote :

In feisty on a T42:
  smbios.system.uuid = 'C389A481-4729-11CB-A373-DBC117FBD34F' (string)
  smbios.system.serial = '999DMWN' (string)
  smbios.system.version = 'ThinkPad T42' (string)
  smbios.system.product = '2374VSG' (string)
  smbios.system.manufacturer = 'IBM' (string)

Patch not working here either.

Troels

Bug # 84968 similar?

Dr D J Clark (djc-online) wrote :

Seems this bug is same as 71204, 87028, 61184, 90925, 8i585, I append my case here to save opening yet another report.

Thinkpad R60e, Kubuntu 7.04 (installed as herd4 updated to 2007-03-25 ie = 7.04 beta)

Fn+Home and Fn+End Brightness buttons don't work properly on Thinkpad R60e. Screen goes blank, pressing button multiple times does get a response eventually and screen is dimmed. This feature does work ok on 6.06.

Svenny (sven-ndwun) wrote :

Patch works for Debian etch on R60e, too. I added the following to
/usr/share/hal/fdi/policy/10osvendor/10-laptop-panel-mgmt-policy.fdi

  <device>
    <match key="info.category" string="laptop_panel">
      <match key="/org/freedesktop/Hal/devices/computer:smbios.system.manufacturer" string="LENOVO">
        <match key="/org/freedesktop/Hal/devices/computer:smbios.system.version" string="ThinkPad R60e">
          <merge key="laptop_panel.brightness_in_hardware" type="bool">true</merge>
        </match>
      </match>
    </match>
  </device>

Also occurring in Feisty 64-bit, installed fresh from final release Live CD.

Thinkpad T60. Here is my lshal output:

 $ lshal |grep smbios.system
  smbios.system.uuid = '6F76FE01-497D-11CB-ACEA-F7E3726C1877' (string)
  smbios.system.serial = 'L3AR247' (string)
  smbios.system.version = 'ThinkPad T60' (string)
  smbios.system.product = '63716NU' (string)
  smbios.system.manufacturer = 'LENOVO' (string)

While I was experiencing the same symptoms, Feisty has this bug fixed. The .fdi patches in this thread are already incorporated into Feisty.

What I am experiencing is outlined here: http://www.thinkwiki.org/wiki/Installing_Kubuntu_6.10_on_a_ThinkPad_X60s_2 and also here: https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/87028

Current workaround is to blacklist video.ko module (echo blacklist video >> /etc/modules.d/blacklist). Brightness controls now work, but gnome-power-manager OSD does not know the brightness (it thinks it's always full).

Interestingly enough, using 'echo "level 4" >> /proc/acpi/ibm/brightness' does work and gnome-power-manager's OSD does report the right brightness. Something should be probably done here.

The patch above (Svenny said on 2007-04-14:) did work for R60e with Fiesty (Fiesty had code in /usr/share/hal/fdi/policy/10osvendor/10-laptop-panel-mgmt-policy.fdi for Lenovo X, T and Z series but nothing for R)
But a few days ago there was an update to hal which changed /usr/share/hal/fdi/policy/10osvendor/10-laptop-panel-mgmt-policy.fdi and removed the
<device>
    <match key="info.category" string="laptop_panel">
      <match key="/org/freedesktop/Hal/devices/computer:smbios.system.manufacturer" string="LENOVO">
...
code completely. I am not sure if the changed hal now tries to fix this problem elsewhere, in which case model R had been overlooked again, or if the whole Lenovo laptop fix which was in the original Fiesty release has been dropped with the updated version.

Reapplying the patch works.

zdzichu (zdzichu-gmail) wrote :

I still doesn't work in after recent HAL upgrades in Feisty.
Come on, why don't you just include this patch now? It's confirmed to work.

idle (th-casalogic) wrote :

I found (I think) the answer to whats going wrong, on a HAL discussion list. Looks like the patch have not reached the public yet, or at least not ubuntu.
http://www.nabble.com/Matching-problems-t3873229.html

Philipp Kern (pkern) wrote :

Tries to modify the backlight on Gutsy soon-to-be-beta result in the backlight being set to zero. Resetting it to 7 via `/sys/class/backlight/thinkpad_screen/brightness' works. Setting HAL to let the BIOS manage backlight completely (i.e. brightness_in_hardware) deactivates the OSD and the set-to-zero, but does not allow me to control the backlight via the keys.

  smbios.system.manufacturer = 'LENOVO' (string)
  smbios.system.product = '9452KLG' (string)
  smbios.system.serial = 'L3AR817' (string)
  smbios.system.uuid = '272EF001-492B-11CB-9244-FACED8D2CCBB' (string)
  smbios.system.version = 'ThinkPad Z61m' (string)

gagarine (gagarine) wrote :

Bug #132887 marked as duplicate.

The patch to resolve the matching problem is committed now (see comment <a href='https://bugs.launchpad.net/ubuntu/+source/hal/+bug/61184/comments/38'>38</a>) , It's ok to integrate it for Gusty? Because the patch for 10-laptop-panel-mgmt-policy.fdi is great and work but it's a work around....

For a t60p (but seem work with the t60 patch)
 #lshal|grep smbios.system
  smbios.system.manufacturer = 'LENOVO' (string)
  smbios.system.product = '20078JG' (string)
  smbios.system.serial = 'L36X52K' (string)
  smbios.system.uuid = '33E22281-48F0-11CB-927F-FF4063E02A77' (string)
  smbios.system.version = 'ThinkPad T60p' (string)

Craig Huffstetler (xq) wrote :

Please see:

https://bugs.launchpad.net/ubuntu/+bug/191161

I believe these are related on some fronts. This is still existing. I confirmed it on another model Thinkpad today.

Martin Pitt (pitti) wrote :

The upstream patch http://gitweb.freedesktop.org/?p=hal.git;a=commitdiff;h=3734b53bafd98672db52ce55678f80136a5af84c which was supposed to fix this is already in Hardy. So it seems there needs to be done something else?

xq, "still existing" -> did you test it on latest Hardy or on Gutsy?

Changed in hal:
status: In Progress → Incomplete
Craig Huffstetler (xq) wrote :

Latest Hardy still existing... (Alpha 4 ---> now alpha 5).

Gutsy - it is not a bug...

- xq

Troels Faber (troelsfaber) wrote :

It works on my T42 since some time ago i Hardy.

./Troels

Martin Pitt (pitti) wrote :

Can you please

 - upgrade hal-info to latest hardy
 - try the hal package from my PPA: https://launchpad.net/~pitti/+archive

and check whether that fixes the issue? Thank you!

Paweł (paff) wrote :

I added a comment on bug 191161 that I think is the same like this one.

https://bugs.launchpad.net/ubuntu/+bug/191161/comments/5

Martin Pitt (pitti) wrote :

Can anyone please test this on latest hardy? With hal 0.5.10+git20080301-1ubuntu2?

Craig Huffstetler (xq) wrote :

@Martin Pitt

RE: hal 0.5.10+git20080301-1ubuntu2

It is not working on my Lenovo T61p 14" with an NVIDIA 128MB card nor is it working my Lenovo Z60M.

Any other Lenovo T61p or Z60 users out there who care to share there experiences with this?

(Manual screen adjust / on screen adjuster via gnome applet panel)

I even tried via a fresh install of Alpha 5 on my T61p. Same result even after a full update.

Dr D J Clark (djc-online) wrote :

Lenovo R60e with hal 0.5.10+git20080301-1ubuntu2

Screen brightness Fn+Home and Fn+End do work though there are only 5 levels in the range.

Martin Pitt (pitti) on 2008-03-19
Changed in hal:
status: Incomplete → New
status: New → Confirmed
Craig Huffstetler (xq) wrote :

@ Martin

What can I do to assist with this? What system information do you need? Files? Anything? I would like to give you as much detailed information as
possible to get this fix released.

Martin Pitt (pitti) wrote :

xq: The most efficient way would certainly be to directly contact upstream with your hardware data and the problem description on the ML: http://lists.freedesktop.org/mailman/listinfo/hal. (You have to subscribe before you post.) Although we repeatedly tried to fix it for this kind of hardware, we apparently missed some corner cases, and without having this hardware ourselves it's quite hard to fix. Thank you!

Fredrik Wendt (fredrik-wendt) wrote :

I had similar problems on my T61 (things worked under Gutsy but not with Hardy alpha 6) - my actual bugs are bug #198476 or bug #172985.

The same trouble at Lenovo Thinkpad X61s. Hardy Beta.

Craig Huffstetler (xq) wrote :

I have been subscribed to the HAL mailing list for about 3 - 4 weeks. I haven't seen much activity on this particular topic. I am monitoring the issue and seeing if any fixes are released on quite a frequent basis; but to my knowledge, none have been released that have fixed either Lenovo laptop of mine (or the referenced on above apparently). Just an update. I am watching the list and watching for fixes to no degree of luck.

lil_kreen (littlekreen) wrote :

I have the same problem on my everex va2001t. The brightness buttons do not work except just after grub has loaded.

Phil Sung (psung) wrote :

Works for me now with an X61s on the latest Intrepid (hal 0.5.11-3~ubuntu8). Can someone else confirm?

Martin Pitt (pitti) wrote :

Closing as per last report. If you still have problems, please report a bug against hal-info.

Changed in hal:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers