Thinkpad X60s (also T60, R60): changing the screen brightness blanks screen

Bug #87028 reported by Timo Aaltonen on 2007-02-22
76
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-source-2.6.20

Changing the screen brightness with Fn+Home/End on a Thinkpad X60s makes the screen go blank, and you need to restart X to get it back (console works).

a workaround is to blacklist 'video.o' from loading and reboot:

http://www.thinkwiki.org/wiki/Installing_Kubuntu_6.10_on_a_ThinkPad_X60s_2
http://<email address hidden>/msg00092.html

and it seems to be a kernel bug.

Timo Aaltonen (tjaalton) wrote :
Kyle McMartin (kyle) wrote :

Saw something about this on LKML, will track and update status.

Changed in linux-source-2.6.20:
assignee: nobody → kyle
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Ben Collins (ben-collins) wrote :

Confirmed bugs need to be assigned to ubuntu-kernel-team.

Changed in linux-source-2.6.20:
assignee: kyle → ubuntu-kernel-team
Ben Epstein (superbenny) wrote :

confirmed here too

Ian Redfern (ian-redfern) wrote :

Still present in Gutsy with linux-generic_2.6.22.6.5_i386.deb, but blacklisting video now disables gnome-brightness-applet, which it didn't in Feisty.

grenness (christopher-grenness) wrote :

Confirmed in Gutsy with 2.6.22-7-generic kernel (Lenovo Thinkpad X60s).
Sometimes (like today) I forget about this bug and try to increase the brightness in meetings etc (the brightness is set to decrase on battery power) and the screen blanks. But plugging the laptop to an external monitor gives me the display there and I am able to save my work and restart X.
This however only works after the following lines has been added to the section "Device" in xorg.conf:

 Option "MonitorLayout" "CRT,LFP"
 Option "Clone" "true"
 Option "DevicePresence" "true"

(this clones your monitor output, great to hotplug a projector, for instance)

Sebastian Heinlein (glatzor) wrote :

Blacklisting the video module is a better and cleaner approach to workaround this bug.

Nathan Collins (ntc2) wrote :

For me the buttons (Fn+Home and Fn+End) actually do adjust the brightness, but need to be pressed *three* times. I can wait a long time a long time between presses and the screen just stays black until the third press.

Feisty on an x60s.

Nathan Collins wrote:
> For me the buttons (Fn+Home and Fn+End) actually do adjust the
> brightness, but need to be pressed *three* times. I can wait a long
> time a long time between presses and the screen just stays black until
> the third press.
>
> Feisty on an x60s.
>
>
Yes, confirmed on my R60 (Feisty also).

Gregory Oschwald (osch0001) wrote :

My machine is still experiencing this using an up-to-date Gutsy install with linux-image-2.6.22-9-generic.

Ante Karamatić (ivoks) wrote :

Looks like this is resolved with latest xserver-xorg-core package in gutsy.

Ian Redfern (ian-redfern) wrote :

I can confirm the brightness keys work now correctly on my ThinkPad X60 with the latest gutsy without blacklisting.

The brightness applet also controls brightness again, but doesn't reflect changes made with Fn-Home/End.

Matthew Garrett (mjg59) wrote :

Yeah, turns out Xorg was being utterly insane. I've sent a patch upstream.

Changed in linux-source-2.6.20:
status: Confirmed → Invalid
Changed in xorg:
status: New → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers